Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/01/2017, à 12:02

boomerang

Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Bonjour, étant complètement novice sur Linux je n'arrive pas a installer " fpv freerider " qui est un simulateur (pour drones) prévu dans une version Linux, je vous mets le lien ; https://fpv-freerider.itch.io/fpv-freerider
Donc après maints essais infructueux via le terminal si vous pouviez me donner la marche à suivre pour installer " ces paquets " ce serait sympa, merci d'avance.

Hors ligne

#2 Le 17/01/2017, à 12:15

Killian.Fr

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Bonjour !

Normalement tu as juste à faire ça dans le terminal

sudo apt-get update
sudo apt-get install fpv freerider

Si le paquet se nomme bien fpv freerider smile


Amateur Linux
Etudiant en administration système et réseau

Hors ligne

#3 Le 17/01/2017, à 12:52

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Merci pour ta réponse expresse, c'est pourtant bien ce que je frappe dans la commande mais ça ne marche pas chez moi et j'ai cette réponse, idem avec la deuxième frappe ;

 bertrand@BP-PC:~/Documents/logiciels décompréssés/FPVFreerider_Recharged_linux_2
016-10-27/FPVFreerider_Recharged_linux_Data$ sudo apt-get update
[sudo] Mot de passe de bertrand : 
Réception de:1 [url]http://security.ubuntu.com/ubuntu[/url] yakkety-security InRelease [102 kB]
Atteint:2 [url]http://fr.archive.ubuntu.com/ubuntu[/url] yakkety InRelease     
Atteint:3 [url]http://fr.archive.ubuntu.com/ubuntu[/url] yakkety-updates InRelease
Réception de:4 [url]http://fr.archive.ubuntu.com/ubuntu[/url] yakkety-backports InRelease [102 kB]
204 ko réceptionnés en 1s (168 ko/s)                                           
Lecture des listes de paquets... Fait
N: « 20auto-upgrades.ucf-old » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
bertrand@BP-PC:~/Documents/logiciels décompréssés/FPVFreerider_Recharged_linux_2
016-10-27/FPVFreerider_Recharged_linux_Data$

Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 17/01/2017, à 15:20)

Hors ligne

#4 Le 17/01/2017, à 14:46

Killian.Fr

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Je peux avoir le retour de cette commande sous balises code ? Merci !

lsb_release -a

Amateur Linux
Etudiant en administration système et réseau

Hors ligne

#5 Le 17/01/2017, à 16:47

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Désolé je n'ai pas lu toutes les marches à suivre avant de poster neutral big_smile
voilà le retour de commande :

bertrand@BP-PC:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.10
Release:	16.10
Codename:	yakkety
bertrand@BP-PC:~$ 

Hors ligne

#6 Le 17/01/2017, à 23:55

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Tu peux commencer par supprimer le fichier d'upgrade foireux (même si ça n'a rien à voir avec ton problème) :

sudo rm /etc/apt/apt.conf.d/20auto-upgrades.ucf-old

Ensuite, ton soft n'est pas du tout un paquet, il ne sera pas installé via APT (il n'est pas dans les dépôts). Il se présente sous forme d'une archive, qu'il te suffit de décompresser où tu veux puis de lancer l'exécutable manuellement dans le dossier obtenu, ou en créant un lanceur pour qu'il apparaisse dans le menu Applications.
Étant donné qu'il est payant, je ne peux pas le télécharger pour te dire ce qu'il faut lancer mais la démo a deux exécutables : FPVFreerider_demo.x86 (32 bits) et FPVFreerider_demo.x86_64 (64 bits). Je suppose que dans la version complète tu as FPVFreerider.x86 et FPVFreerider.x86_64.

Killian.Fr : même si le soft était dans les dépôts, le paquet ne pourrait pas se nommer "fpv freerider" : un nom de paquet ne peut pas contenir d'espaces. La commande que tu as donnée installerait deux paquets hypothétiques : "fpv" et "freerider".

Dernière modification par abelthorne (Le 17/01/2017, à 23:59)

Hors ligne

#7 Le 18/01/2017, à 09:26

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Alors pour commencer je vous remercie pour votre aide !!
Avant de demander un coup de mains ici j'ai fait quelques recherches sur le net, donc comme Linux est tout nouveau pour moi, j'ai essayé plusieurs choses comme de simplement décompresser le soft et aller dans " propriété/permission " pour cocher " autoriser l'exécution " de l'exécutable correspondant à ma version mais rien ne se passe ! 
J'ai également tenté de le déplacer dans le fichier " bin " du système d'exploitation mais j'ai eu un refus.
Je pense que mon problème est lié aux droits d'accès car les divers permissions sont nombreuses big_smile !!

Hors ligne

#8 Le 18/01/2017, à 09:54

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Abelthorne si ça te tente de faire un essai en le téléchargent c'est possible car il y a des versions démo gratuites afin de pouvoir tester si la configuration de son ordi est viable avec ce simulateur !
En bas de la page tu as la démo gratuite ici pour la version basic :
https://fpv-freerider.itch.io/fpv-freerider

Où ici pour la version Recharged un peu plus gourmande au niveau configuration :
https://fpv-freerider.itch.io/fpv-freerider-recharged

Hors ligne

#9 Le 18/01/2017, à 11:07

Killian.Fr

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

J'avais un doute justement à ce niveau là ^^ @abelthorne
Thanks dude !


Amateur Linux
Etudiant en administration système et réseau

Hors ligne

#10 Le 18/01/2017, à 11:19

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

boomerang a écrit :

Avant de demander un coup de mains ici j'ai fait quelques recherches sur le net, donc comme Linux est tout nouveau pour moi, j'ai essayé plusieurs choses comme de simplement décompresser le soft et aller dans " propriété/permission " pour cocher " autoriser l'exécution " de l'exécutable correspondant à ma version mais rien ne se passe !

C'est bien ce qu'il faut faire mais peut-être que le soft a besoin de biblis spécifiques qu'il faut installer avant. Et comme en graphique tu n'as pas de retour d'erreurs de ce genre, il faudrait plutôt le lancer depuis un terminal. En partant du principe que tu vas garder FPV Freerider installé dans ton dossier perso, commence par déplacer le dossier où tu veux (par exemple directement dans ton dossier perso, ou dans un dossier "Applis" que tu y crées ou ce que tu veux d'autre de façon à le ranger où tu préfères). Ensuite, place-toi dans le dossier en question via un terminal (commande cd nom du dossier) et donne-moi la liste des fichiers (commande ls -l).

J'ai également tenté de le déplacer dans le fichier " bin " du système d'exploitation mais j'ai eu un refus.

C'est normal, il te faut les droits admin. Même si c'est possible de les obtenir, je te déconseille d'installer un logiciel manuellement au niveau système, ou alors il ne faut pas le faire n'importe comment et pas placer les fichiers n'importe où. On va d'abord s'en occuper dans ton dossier perso puis, une fois que le problème de lancement sera réglé, on pourra voir pour le déplacer au niveau système si tu préfères.

Hors ligne

#11 Le 19/01/2017, à 12:20

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Alors je te donne le retour de commande avec les deux frappes que tu m'as recommandé :

bertrand@BP-PC:~$ cd  FPVFreerider_demo_Data
bash: cd: FPVFreerider_demo_Data: Aucun fichier ou dossier de ce type
bertrand@BP-PC:~$  ls -l
total 672
-rw-r--r--  1 bertrand bertrand 417792 janv.  5 05:59 bp : logiciel (prise de note).ctb~
-rw-r--r--  1 bertrand bertrand 225280 janv.  5 02:24 bp : logiciel (prise de note).ctb~~
drwxr-xr-x  2 bertrand bertrand   4096 janv. 18 11:26 Bureau
drwxr-xr-x  6 bertrand bertrand   4096 janv. 19 10:39 Documents
-rw-r--r--  1 bertrand bertrand   8980 janv.  3 07:48 examples.desktop
drwxr-xr-x 17 bertrand bertrand   4096 janv. 19 09:24 Images
drwxr-xr-x  2 bertrand bertrand   4096 janv.  3 08:00 Modèles
drwxr-xr-x  3 bertrand bertrand   4096 janv. 19 09:23 Musique
drwxr-xr-x  2 bertrand bertrand   4096 janv.  3 08:00 Public
drwxr-xr-x  2 bertrand bertrand   4096 janv. 18 17:49 Téléchargements
drwxr-xr-x  2 bertrand bertrand   4096 janv.  7 21:53 Vidéos
bertrand@BP-PC:~$ 

Et je rajoute ce retour de commande fait à partir du fichier (complet) en faisant un clic gauche :

bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$  ls -l
total 50364
drwxrwxrwx 7 bertrand bertrand     4096 janv. 19 09:53 FPVFreerider_demo_Data
-rw-r--r-- 1 bertrand bertrand 25644176 sept.  1 12:13 FPVFreerider_demo.x86
-rwxrwxrwx 1 bertrand bertrand 25923152 sept.  1 12:13 FPVFreerider_demo.x86_64
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ 

BON visiblement au niveau droits d'accès c'est OK.

Hors ligne

#12 Le 19/01/2017, à 16:53

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

En ce qui concerne le fichier d'upgrade  « /etc/apt/apt.conf.d/ » c'est dans mon système d'exploitation qu'il se trouve, donc je ne peut pas mettre dans la corbeille ce fichier *casse-bonbon (propriètaire root) afin de faire un essai sans !
Lors d'une tentative le terminal m'avait indiqué qu'il avait installé des paquets mais en mentionnant " 0 nouvellement installés, 0 à enlever et 0 non mis à jour " donc j'ai supprimé hmm mais peut-être que je devrais faire un petit nettoyage avec l'une de ces trois commandes :
    -sudo apt-get autoclean
    -sudo apt-get clean
    -sudo apt-get autoremove

Dans le doute je vais attendre la confirmation big_smile

Hors ligne

#13 Le 19/01/2017, à 19:58

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Pour supprimer le fichier, il fallait juste taper la commande que j'avais donnée et surtout pas tenter de supprimer tout le dossier /etc/apt/apt.conf.d si c'est ce que tu as tenté de faire :

sudo rm /etc/apt/apt.conf.d/20auto-upgrades.ucf-old

Après, tu peux lancer tes commandes apt-get si tu veux mais de toute façon le fichier n'empêche pas d'utiliser APT, il n'y a pas de raison que tu ne sois pas à jour ou que ton système nécessite un nettoyage.

Pour ce qui est de FPV Freerider, la première commande que tu as tapée a le mauvaus nom de dossier, donc tu m'as donné le contenu de ton dossier perso. Mais bref. Les droits sont un peu bizarres et le binaire 32 bits n'est pas exécutable. Ce n'est pas très gênant mais autant nettoyer un peu ça :

cd ~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06
chmod 755 FPVFreerider_demo.x86 FPVFreerider_demo.x86_64

Ensuite, lance l'exécutable (en restant dans ce dossier) :

./FPVFreerider_demo.x86_64

Là, tu verras ce qui cloche s'il ne se lance pas.

Hors ligne

#14 Le 20/01/2017, à 13:20

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

J'ai simplement regardé si je pouvais mettre le fichier en question dans la corbeille par facilité car il m'aurait été facile de faire une restauration, alors que via la terminal je patauge un peu smile avec les divers commandes mais j'éviterai à l'avenir !
Peut-être que j'aurais dû commencé par préciser que j'ai remplacé ma carte graphique suite à l'installation d'Ubuntu ainsi que l'ajout de deux barrettes de RAM !
Voilà ce que donne le retour de commande suite à tes instructions après la suppression du fichier  « /etc/apt/apt.conf.d/ » :

bertrand@BP-PC:~$ cd ~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ chmod 755 FPVFreerider_demo.x86 FPVFreerider_demo.x86_64
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ ./FPVFreerider_demo.x86_64
Instruction non permise (core dumped)
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ 

En même temps une petite fenêtre c'est ouverte mentionnant " ? problème logiciel détecté " donc je referai des essais ce soir avec la version complète FPVFreerider !
Encore merci pour ton aide smile

Hors ligne

#15 Le 20/01/2017, à 14:18

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Un coredump, c'est assez embêtant pour déterminer le problème, étant donné que ça dit juste que le soft a planté, sans plus de précisions. J'espérais qu'il te dise simplement qu'il manque des biblis.

Peut-être en essayant la version 32 bits :

cd ~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06
./FPVFreerider_demo.x86

À tout hasard, donne aussi le retour (en restant placé dans le dossier du jeu) de :

ldd FPVFreerider_demo.x86_64

Ça va afficher la liste des biblis dont l'exécutable a besoin.

Hors ligne

#16 Le 20/01/2017, à 14:49

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Le point positif est que mon terminal ne me parle plus du fichier  « /etc/apt/apt.conf.d/ » big_smile !!
voilà le retour de commande :

bertrand@BP-PC:~$ cd ~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ ./FPVFreerider_demo.x86
./FPVFreerider_demo.x86: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ ldd FPVFreerider_demo.x86_64
	linux-vdso.so.1 =>  (0x00007ffced58f000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f818db70000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f818d952000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f818d74a000)
	libGL.so.1 => /usr/lib/nvidia-367/libGL.so.1 (0x00007f818d4bb000)
	libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f818d182000)
	libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f818cf76000)
	libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f818cd6b000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f818c9e3000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f818c6da000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f818c4c3000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f818c0fc000)
	/lib64/ld-linux-x86-64.so.2 (0x000055b5a5f79000)
	libGLX.so.0 => /usr/lib/nvidia-367/libGLX.so.0 (0x00007f818bec9000)
	libGLdispatch.so.0 => /usr/lib/nvidia-367/libGLdispatch.so.0 (0x00007f818bbe0000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f818b9be000)
	libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f818b7b4000)
	libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f818b5ae000)
	libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f818b39c000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f818b196000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f818af90000)
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ 

Je vais faire quelques recherches sur ces fameux biblis car pour l'instant c'est du chinois pour moi hmm !

Hors ligne

#17 Le 20/01/2017, à 14:52

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Pas de bibli manquante pour la version 64 bits (tu aurais un message du genre "not found" sur certaines lignes si c'était le cas).

Pour la version 32 bits, tu peux commencer par installer libX11 et réessayer :

sudo apt-get install libx11-6:i386

Il y aura peut-être d'autres biblis à installer, donne aussi le ldd pour cette version :

ldd FPVFreerider_demo.x86

Dernière modification par abelthorne (Le 20/01/2017, à 14:53)

Hors ligne

#18 Le 20/01/2017, à 15:04

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

bon voilà ce que ça donne :

bertrand@BP-PC:~$ sudo apt-get install libx11-6:i386
[sudo] Mot de passe de bertrand : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  gcc-6-base:i386 libc6:i386 libgcc1:i386 libxau6:i386 libxcb1:i386
  libxdmcp6:i386
Paquets suggérés :
  glibc-doc:i386 locales:i386
Les NOUVEAUX paquets suivants seront installés :
  gcc-6-base:i386 libc6:i386 libgcc1:i386 libx11-6:i386 libxau6:i386
  libxcb1:i386 libxdmcp6:i386
0 mis à jour, 7 nouvellement installés, 0 à enlever et 13 non mis à jour.
Il est nécessaire de prendre 3 000 ko dans les archives.
Après cette opération, 11,8 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu yakkety/main i386 gcc-6-base i386 6.2.0-5ubuntu12 [17,0 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu yakkety/main i386 libgcc1 i386 1:6.2.0-5ubuntu12 [48,0 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu yakkety-updates/main i386 libc6 i386 2.24-3ubuntu2 [2 278 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu yakkety/main i386 libxau6 i386 1:1.0.8-1 [8 352 B]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu yakkety/main i386 libxdmcp6 i386 1:1.1.2-1.1 [11,4 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu yakkety/main i386 libxcb1 i386 1.11.1-1ubuntu1 [44,1 kB]
Réception de:7 http://fr.archive.ubuntu.com/ubuntu yakkety/main i386 libx11-6 i386 2:1.6.3-1ubuntu3 [593 kB]
3 000 ko réceptionnés en 16s (184 ko/s)                                        
Préconfiguration des paquets...
Sélection du paquet gcc-6-base:i386 précédemment désélectionné.
(Lecture de la base de données... 249292 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-gcc-6-base_6.2.0-5ubuntu12_i386.deb ...
Dépaquetage de gcc-6-base:i386 (6.2.0-5ubuntu12) ...
Sélection du paquet libgcc1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../1-libgcc1_1%3a6.2.0-5ubuntu12_i386.deb ...
Dépaquetage de libgcc1:i386 (1:6.2.0-5ubuntu12) ...
Sélection du paquet libc6:i386 précédemment désélectionné.
Préparation du dépaquetage de .../2-libc6_2.24-3ubuntu2_i386.deb ...
Dépaquetage de libc6:i386 (2.24-3ubuntu2) ...
Remplacement de fichiers dans l'ancien paquet libc6-i386 (2.24-3ubuntu2) ...
Sélection du paquet libxau6:i386 précédemment désélectionné.
Préparation du dépaquetage de .../3-libxau6_1%3a1.0.8-1_i386.deb ...
Dépaquetage de libxau6:i386 (1:1.0.8-1) ...
Sélection du paquet libxdmcp6:i386 précédemment désélectionné.
Préparation du dépaquetage de .../4-libxdmcp6_1%3a1.1.2-1.1_i386.deb ...
Dépaquetage de libxdmcp6:i386 (1:1.1.2-1.1) ...
Sélection du paquet libxcb1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../5-libxcb1_1.11.1-1ubuntu1_i386.deb ...
Dépaquetage de libxcb1:i386 (1.11.1-1ubuntu1) ...
Sélection du paquet libx11-6:i386 précédemment désélectionné.
Préparation du dépaquetage de .../6-libx11-6_2%3a1.6.3-1ubuntu3_i386.deb ...
Dépaquetage de libx11-6:i386 (2:1.6.3-1ubuntu3) ...
Paramétrage de gcc-6-base:i386 (6.2.0-5ubuntu12) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...
Paramétrage de libc6:i386 (2.24-3ubuntu2) ...
Paramétrage de libxdmcp6:i386 (1:1.1.2-1.1) ...
Paramétrage de libxau6:i386 (1:1.0.8-1) ...
Paramétrage de libgcc1:i386 (1:6.2.0-5ubuntu12) ...
Paramétrage de libxcb1:i386 (1.11.1-1ubuntu1) ...
Paramétrage de libx11-6:i386 (2:1.6.3-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...
bertrand@BP-PC:~$ ldd FPVFreerider_demo.x86
ldd: ./FPVFreerider_demo.x86: Aucun fichier ou dossier de ce type
bertrand@BP-PC:~$ 

je recommence la deuxième commande :

bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ ldd FPVFreerider_demo.x86
	linux-gate.so.1 =>  (0xf774e000)
	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7725000)
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7708000)
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf76fd000)
	libGL.so.1 => /usr/lib32/nvidia-367/libGL.so.1 (0xf7690000)
	libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7545000)
	libXcursor.so.1 => not found
	libXrandr.so.2 => not found
	libstdc++.so.6 => not found
	libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf74ef000)
	libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf74d1000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7317000)
	/lib/ld-linux.so.2 (0x565e8000)
	libGLX.so.0 => /usr/lib32/nvidia-367/libGLX.so.0 (0xf72f7000)
	libGLdispatch.so.0 => /usr/lib32/nvidia-367/libGLdispatch.so.0 (0xf7261000)
	libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf7239000)
	libXext.so.6 => not found
	libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf7235000)
	libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf722e000)
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ 

Hors ligne

#19 Le 20/01/2017, à 15:17

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

j'ai tenté un nouvel essai d'installation et les mises à jour ont bien étaient prises en compte smile

bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ sudo apt-get install
[sudo] Mot de passe de bertrand : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de bertrand : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 13 non mis à jour.
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ 

Sinon aucun des exécutables ne veut se lancer !

Hors ligne

#20 Le 20/01/2017, à 15:21

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Ah ben non elles ne sont mises a jour lol hmm

Hors ligne

#21 Le 20/01/2017, à 15:35

cqfd93

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Bonjour,

Ça serait peut-être bien de faire les mises à jour avant de tenter à nouveau l'installation.

sudo apt update
sudo apt full-upgrade

cqfd93

Hors ligne

#22 Le 20/01/2017, à 15:37

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Euh ben oui big_smile lol
Merci !!

Hors ligne

#23 Le 20/01/2017, à 17:50

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Quand tu tapes sudo apt-get install tout court, ça ne fait rien.

Pour la version 32 bits de FPV Freerider, essaie d'installer les biblis manquantes pointées par ldd :

sudo apt-get install libxcursor1:i386 libxrandr2:i386 libstdc++6:i386 libxext6:i386

Hors ligne

#24 Le 20/01/2017, à 23:07

boomerang

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Les paquets de biblis manquants sont installés, les mises à jour faites mais l'installation ne se fait toujours pas :

bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ sudo apt-get install
[sudo] Mot de passe de bertrand : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
bertrand@BP-PC:~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06$ 
bertrand@BP-PC:~$ sudo apt-get install
[sudo] Mot de passe de bertrand : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
bertrand@BP-PC:~$ sudo apt-get install FPVFreerider_linux_demo_2016-10-06
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet FPVFreerider_linux_demo_2016-10-06
bertrand@BP-PC:~$ 

Par contre quand je tente de lancer l'exécutable 32 bits j'ai un écran noir quelques secondes comme si il se lancé, puis retour de la petite fenêtre " ? problème logiciel détecté ".

Hors ligne

#25 Le 21/01/2017, à 02:16

abelthorne

Re : Besoin d'aide pour installer " FPV Freerider " sur Ubuntu

Je ne comprends pas ce que tu cherches à faire : sudo apt-get install est une commande qui ne fait rien. Elle sert à installer des paquets depuis les dépôts, en lui donnant une liste de paquets : sans rien lui indiquer derrière, elle ne fait tout simplement rien.

Si tu cherches à installer ton jeu, il faut bien comprendre qu'APT (commandes apt-get) sert uniquement à gérer des paquets qui sont dans les dépôts (ceux fournis par Ubuntu ou d'autres que tu peux ajouter). Ton jeu n'étant pas dans les dépôts et n'ayant pas non plus d'installeur tiers, il va falloir l'installer manuellement, càd placer son dossier quelque part et éventuellement faire un lanceur pour le démarrer plus facilement (enfin, si on arrive à le lancer). C'est pour ça que je t'ai suggéré de créer un dossier Applis ou similaire quelque part dans ton dossier perso, ça te permettra de ranger ensemble les softs installés manuellement.

Pour ce qui est de tester la version 32 bits maintenant que les biblis sont installées, place-toi dans le dossier avant de lancer l'exécutable :

cd ~/Documents/Applis/FPVFreerider_linux_demo_2016-10-06
./FPVFreerider_demo.x86

Hors ligne