Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 01/03/2017, à 00:19

ninaw

[RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Bonjour!
Je n'avais pas de problèmes... jusqu'à très récemment. Est-ce le passage de 14.09 à 16.04, ou une simple mise à jour (je n'ai pas tout de suite tenté de lire des fichier .wma)
Le fait est qu'avec VLC y a pas de soucis, mais Rhythmbox ne parvient plus à lire les fichiers WMA... or venant très lointainement de windows, une bonne partie de ma musique est encore dans ce format sad et mes playlists sont sur Rhythmbox...
J'ai déjà fait quelques forum, installé et réinstallé divers plugin de gstreamer... sans résultat. Comme je ne trouve pas de discussion liée à ubuntu 16.04 je me dis qu'il y a peut-être une subtilité que j'ai zappé. Il est donc possible que j'ai modifié la config de base en chipotant...
Voici une ou l'autre commande que j'ai vue demander sur d'autres posts:

ninette@ninordinateur:~$  dpkg -l |grep gstreamer1.0
ii  gstreamer1.0-alsa:amd64                       1.8.3-1ubuntu0.1                              amd64        GStreamer plugin for ALSA
ii  gstreamer1.0-clutter-3.0                      3.0.18-1                                      amd64        Clutter PLugin for GStreamer 1.0
ii  gstreamer1.0-fluendo-mp3:amd64                0.10.32.debian-1                              amd64        Fluendo mp3 decoder GStreamer 1.0 plugin
ii  gstreamer1.0-libav:amd64                      1.8.3-1ubuntu0.1                              amd64        libav plugin for GStreamer
ii  gstreamer1.0-plugins-bad:amd64                1.8.3-1ubuntu0.2                              amd64        GStreamer plugins from the "bad" set
ii  gstreamer1.0-plugins-bad-faad:amd64           1.8.3-1ubuntu0.2                              amd64        GStreamer faad plugin from the "bad" set
ii  gstreamer1.0-plugins-bad-videoparsers:amd64   1.8.3-1ubuntu0.2                              amd64        GStreamer videoparsers plugin from the "bad" set
ii  gstreamer1.0-plugins-base:amd64               1.8.3-1ubuntu0.1                              amd64        GStreamer plugins from the "base" set
ii  gstreamer1.0-plugins-base-apps                1.8.3-1ubuntu0.1                              amd64        GStreamer helper programs from the "base" set
ii  gstreamer1.0-plugins-good:amd64               1.8.3-1ubuntu0.3                              amd64        GStreamer plugins from the "good" set
ii  gstreamer1.0-plugins-ugly:amd64               1.8.3-1ubuntu0.1                              amd64        GStreamer plugins from the "ugly" set
ii  gstreamer1.0-plugins-ugly-amr:amd64           1.8.3-1ubuntu0.1                              amd64        GStreamer plugins from the "ugly" set
ii  gstreamer1.0-pulseaudio:amd64                 1.8.3-1ubuntu0.3                              amd64        GStreamer plugin for PulseAudio
ii  gstreamer1.0-tools                            1.8.3-1~ubuntu0.1                             amd64        Tools for use with GStreamer
ii  gstreamer1.0-x:amd64                          1.8.3-1ubuntu0.1                              amd64        GStreamer plugins for X11 and Pango
ii  libgstreamer1.0-0:amd64                       1.8.3-1~ubuntu0.1                             amd64        Core GStreamer libraries and elements

et

ninette@ninordinateur:~$ dpkg -l | grep libasoun*
ii  libasound2:amd64                              1.1.0-0ubuntu1                                amd64        shared library for ALSA applications
ii  libasound2:i386                               1.1.0-0ubuntu1                                i386         shared library for ALSA applications
ii  libasound2-data                               1.1.0-0ubuntu1                                all          Configuration files and profiles for ALSA drivers
ii  libasound2-plugins:amd64                      1.1.0-0ubuntu1                                amd64        ALSA library additional plugins
ii  libasound2-plugins:i386                       1.1.0-0ubuntu1                                i386         ALSA library additional plugins

D'avance merci à ceux qui se pencheront sur la question !

Dernière modification par ninaw (Le 04/03/2017, à 17:38)

Hors ligne

#2 Le 01/03/2017, à 00:25

charrier63

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Une reponse ici, en esperant que ca marche pour toi :

https://forum.ubuntu-fr.org/viewtopic.php?id=1991544

Hors ligne

#3 Le 01/03/2017, à 01:17

Coeur Noir

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Installer le paquet ubuntu-restricted-extras → bonne suggestion.

Je ne dis pas que c'est la même situation mais lors d'une mise à niveau précédente ( entre 13.10 et 14.04 ) mon rhythmbox avait perdu certaines de ses fonctionnalités.
Pour le purger j'avais fini par trouver cette liste de paquets à supprimer ( sur les pages fossfreedom je crois ) :

sudo apt-get purge rhythmbox gir1.2-rb-3.0 librhythmbox-core5 rhythmbox-mozilla rhythmbox-data rhythmbox-plugin-zeitgeist rhythmbox-plugin-magnatune rhythmbox-plugin-cdrecorder librhythmbox-core6 rhythmbox-plugins

Puis réinstaller rhythmbox, fonctionnel.

https://forum.ubuntu-fr.org/viewtopic.php?id=1632611

Hors ligne

#4 Le 02/03/2017, à 17:37

ninaw

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Bonjour et merci pour vos réponses!
@ Charrrier63: j'avais déjà trouvé ça aussi, mais sans résultat! j'ai déjà les "extras" en question installés.
@ Coeur Noir: J'ai testé ta commande, ce à quoi il me dit juste:

E: Impossible de trouver le paquet librhythmbox-core5
E: Impossible de trouver le paquet librhythmbox-core6

Il n'a pas l'air d'avoir désinstallé Rhythmbox du coup;.. donc je ne peux pas le "réinstaller" wink
Zut! !

Hors ligne

#5 Le 03/03/2017, à 02:27

Coeur Noir

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Essaie

sudo apt-get purge librhythmbox-core*

pour voir ?

Hors ligne

#6 Le 03/03/2017, à 12:49

ninaw

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

ça a bien désinstallé rhythmbox ce coup-ci,
alors j'ai réinstallé via le  terminal...et je reviens au même problème qu'avant.
Puis j'ai suivi ce qui était indiqué dans la page que tu donne au post #3:

sudo add-apt-repository ppa:fossfreedom/rhythmbox
sudo apt-get update
sudo apt full-upgrade

et réinstallé normalement.
ça marche!! smile
Merci beaucoup!

Edit: Ah non, j'ai crié victoire trop vite en lisant juste un morceau que j'essayais de lire depuis le début et qui buggait.
Le problème a changé: maintenant Rhythmbox ne voit simplement pas la musique dans la plupart de mes dossiers, et ne sait plus l'importer. Ce qu'il importe par contre, est lu sans soucis.
Il a entre autre importé sans problème tous les morceaux qui étaient dans mes playlistes. Mais à part ça environ qu'une heure de musique (alors que je dois en avoir une centaine en tout...).
??

Dernière modification par ninaw (Le 03/03/2017, à 13:24)

Hors ligne

#7 Le 03/03/2017, à 20:10

Coeur Noir

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Est-ce que le paquet

ubuntu-restricted-extras

est installé sur ton système ?

Hors ligne

#8 Le 04/03/2017, à 17:37

ninaw

Re : [RESOLU] Rhythmbox ne lit plus les WMA sur ubuntu 16.04

Oui il est installé et en fait je devais avoir fait une fausse manoeuvre, tout fonctionne! Encore merci pour ton aide!
N.

Hors ligne