Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/03/2017, à 15:55

rwlas01

[RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

Bonjour,

je viens d'installer ubuntu  16.04.2 LTS en cote à  cote avec W10 préinstall après quelques semaine d'essai sur la live usb.
L'installation c'est bien avec deux messages d'erreur à la fin :

erreur lors de l'installation de /target/var/cache/apt/archives/snapd_2.23.1_
trying to overwrite  '/etc/apparmor.d/usr.lib.snapd-confine' , which is also in package snap-confine 2.23.1


une erreur est survenue lors de l’installation des paquets :
E:Sub-process/usr/bin/dpkg returned an error code (1)
snap-confine, snapd, linux-image-generic-hwe-16.04, ubuntu-core-launcher

ici url boot-in
http://paste2.org/j7n22x3C

j'ai changer plusieurs fois les paramètres du bios en jouant entre le legacy mode/uefi et le sécure boot.

Impossible de demarrer ubuntu, il demarre a tout les coup sur windows... pas de choix..

Je reste à votre dispo si vous avez des questions

et vous remercie d'avance pour le coup de pouce

Romain

Dernière modification par rwlas01 (Le 18/03/2017, à 07:36)

Hors ligne

#2 Le 18/03/2017, à 00:05

Bougron

Re : [RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

Bonsoir
Arrêtes de jongler avec les options LEGACY / EFI
Ton windows est installé en EFI. Donc restes une bonne fois pour toutes en EFI.

Ton installation a été ratée (comme un certain nombre depuis quelques jours).

Tu n'as aucune structure de boot en LEGACY

 => No boot loader is installed in the MBR of /dev/sda.

Tu n'as pas les fichiers de boot de ubuntu en EFI!

sda1: __________________________________________________________________________
    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bootx64.efi /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgr.efi 
/EFI/Microsoft/Boot/memtest.efi

et tu n'as même pas de fichier de grub de généré (/boot/grub/grub.cfg
pourtant quelques fichiers de boot sont bien installés ( boot/vmlinuz-4.8.0-36-generic.efi.signed )  La description du fichier FSTAB n'est pas alarmiste

=============================== sda8/etc/fstab: ================================
--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda8 during installation
UUID=0df3cb85-87d4-4b19-b136-cdc078b3777d /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=2213-9907  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda9 during installation
UUID=2e70f2e3-3fc6-462c-a46d-c7d87326f1d9 none swap sw 0 0

Je te propose la réparation recommandée de boot-repair... Mais j'y crois très peu. Cependant cela pourrait sortir un nouveau message d'erreur plus parlant que les deux que tu as signalés.

=================== Suggested repair
The default repair of the Boot-Repair utility would purge (in order to fix packages sign-grub) and reinstall the grub-efi-amd64-signed of sda8, using the following options:     kernel-purge   sda1/boot/efi,

Et si cela ne marche pas, tu pourrais  au choix
A) Recommencer l'installation en disant de ne pas faire les mises à jour pendant l'installation.
B) Changer d'OS en prenant la version 16.04.1  à télécharger  http://old-releases.ubuntu.com/releases … so.torrent

Dernière modification par Bougron (Le 18/03/2017, à 00:14)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#3 Le 18/03/2017, à 04:57

rwlas01

Re : [RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

Bonjour,

Merci de ton aide

voici le rapport de la réparation :

apt-error detected. Please open a terminal then type (or copy-paste) the following command:

sudo chroot "/mnt/boot-sav/sda8" apt-get -f install




ensuite j'ai relancer boot repair et suivi les instruction :

Boot successfully repaired.

Please write on a paper the following URL:
http://paste2.org/EmGwAUBf


In case you still experience boot problem, indicate this URL to:
boot.repair@gmail.com or to your favorite support forum.

You can now reboot your computer.


If your computer reboots directly into Windows, try to change the boot order in your BIOS.
If your BIOS does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi



Voila...
je peux demarrer sur ubuntu...
j'ouvre ma session ...

PB j'ai le fond du bureau mais rien d'autre

j'ai refait une boot in
http://paste2.org/Jj8vOMeG

Dois je commencer "pour ce probleme une nouvelle discussion ou continuer sur celle-ci?
en attendant que tu me réponde je vais chercher les différentes solutions

Merci pour le pb du boot

Hors ligne

#4 Le 18/03/2017, à 07:35

rwlas01

Re : [RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

Re-bonjour,

Je viens de réinstaller Ubuntu 16.04. et tout fonctionne parfaitement...

Merci encore

Hors ligne

#5 Le 18/03/2017, à 11:53

Bougron

Re : [RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

Bonjour.

rwlas01 a écrit :

Bonjour,

voici le rapport de la réparation :

apt-error detected. Please open a terminal then type (or copy-paste) the following command:

sudo chroot "/mnt/boot-sav/sda8" apt-get -f install

Donc boot-repair t'a proposé de finir l'installation qui était pour le moins incomplète.
Il a certainement fait quelques montages pour te permettre de faire une simple commande.

rwlas01 a écrit :

ensuite j'ai relancé boot repair et suivi les instructions :
Boot successfully repaired.
Please write on a paper the following URL:
http://paste2.org/EmGwAUBf
You can now reboot your computer.
...
Voila...
je peux demarrer sur ubuntu...
j'ouvre ma session ...
PB j'ai le fond du bureau mais rien d'autre
j'ai refait une boot info
http://paste2.org/Jj8vOMeG

Dans cette réparation et dans le boot-info qui suit, je ne vois absolument rien d'anormal pour la partie démarrage.

Et  je "visualise mal" ce que tu veux dire par "j'ai le fond de bureau".

Mon sentiment est qu'il manque encore quelques logiciels   qui n'ont pas été détectés comme ayant été commencés à s'installer et donc pas finalisés.

rwlas01 a écrit :

Dois je commencer "pour ce probleme une nouvelle discussion ou continuer sur celle-ci?
en attendant que tu me réponde je vais chercher les différentes solutions
Merci pour le pb du boot

La suite montre que tu as eu raison de tout recommencer.  C'est très souvent plus rapide lorsqu'on sait ce qu'il faut éviter de faire.


ATTENTION.   A l'avenir, il faut que tu prennes l'habitude de stopper windows en cliquant sur la fonctionnalité REDEMARRER    et pas sur celle qui vient naturellement à l'idée: ARRETER
Tu n'auras plus ce message d'erreur au moment ou tu voudras accéder aux partitions NTFS

mount -t ntfs-3g -o remove_hiberfile /dev/sda4 /mnt/boot-sav/sda4
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Dernière modification par Bougron (Le 18/03/2017, à 11:58)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#6 Le 18/03/2017, à 18:16

malbo

Re : [RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

rwlas01 a écrit :

Re-bonjour,

Je viens de réinstaller Ubuntu 16.04. et tout fonctionne parfaitement...

Merci encore

Puisque tu as réinstallé, je te prie de démarrer une session sur ton Ubuntu 16.04 réinstallé, de faire un Boot-Info depuis cette session et de donner l'URL de ce Boot-Info dans ta réponse.

En ligne

#7 Le 18/03/2017, à 22:56

Bougron

Re : [RÉSOLU] PB dual-boot Lenovo Yoga 700 14ISK

Bonsoir
En effet, ton portable n'est pas encore référencé dans la doc  https://doc.ubuntu-fr.org/liste_portables_lenovo

Dernière modification par Bougron (Le 18/03/2017, à 22:58)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne