Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 19/03/2017, à 21:36

lamnair

[RESOLU] manque libgcrypt11

Bonjour j'ai voulu installer StarUml, mais il manque la dependance libgcrypt11.
Pourtant dans les dépôts je ne la trouve pas. libgcrypt11 doit être obsolète.
Je trouve libgcrypt11-dev que j'ai installé, ça ne fonctionne toujours pas. L'installation ne se passe pas bien.
Quelqu'un a une idée ?

sudo dpkg -i StarUML-v2.8.0-64-bit.deb (Lecture de la base de données... 241307 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de StarUML-v2.8.0-64-bit.deb ...
Dépaquetage de staruml (2.8.0) sur (2.8.0) ...
dpkg: des problèmes de dépendances empêchent la configuration de staruml :
 staruml dépend de libgcrypt11 (>= 1.4.5) ; cependant :
  Le paquet libgcrypt11 n'est pas installé.

dpkg: erreur de traitement du paquet staruml (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour menu (2.1.47ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 staruml

__________________________________________________

C'est bon j'ai trouvé la solution sur
http://stackoverflow.com/quest/37095617/cant-install-staruml-in-ubuntu-16-04

    Download libgcrypt11_1.5.3 from: https://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb

    Install lib with dpkg
    sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb

    Install StarUML with dpkg
    sudo dpkg -i StarUML-v2.7.0-64-bit.deb

Dernière modification par lamnair (Le 20/03/2017, à 00:06)

Hors ligne

#2 Le 19/03/2017, à 23:58

abelthorne

Re : [RESOLU] manque libgcrypt11

Libgcrypt11 est dispo dans les dépôts Trusty (14.04). Sur les versions plus récentes, elle a été remplacée par libgcrypt20.

Tu peux toujours essayer de récupérer et d'installer la version pour Trusty, ça devrait fonctionner.

Pour ce qui est de libgcrypt11-dev, c'est normal que ça ne change rien : les paquets -dev sont les paquets de développement, ils ne sont utiles que pour la compilation.

Hors ligne

#3 Le 20/03/2017, à 00:03

lamnair

Re : [RESOLU] manque libgcrypt11

Merci pour ta réponse abelthorne. Je viens juste de trouver où télécharger le paquet libgcrypt11 et ça fonctionne smile :
http://stackoverflow.com/quest/37095617/cant-install-staruml-in-ubuntu-16-04

    Download libgcrypt11_1.5.3 from: https://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb

    Install lib with dpkg
    sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb

    Install StarUML with dpkg
    sudo dpkg -i StarUML-v2.7.0-64-bit.deb

Hors ligne