Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 27/04/2017, à 16:33

FrancisFDZ

grub et "_" [Resolu]

Bonjour,
J'essaie de booter à partir d'un fichier iso en utilisant les fonctionnalités de grub. Il se trouve que le fichier "vmlinuz" sur l'iso se trouve dans le répertoire x86_64, mais grub bute sur le caractère "_" et me dit qu'il n'existe pas de commande "x86". Je pourrais modifier le fichier iso pour remplacer "_" par "-", mais les conséquences pourraient rendre cet iso inutilisable ...
L'iso en question est prévu pour l'installation de archlinux. D'après ce post d'un forum arch, la commande devrait être

  linux (loop)/arch/boot/x86_64/vmlinuz img_dev=/dev/sda1 img_loop=$isofile archisobasedir=arch archisolabel=ARCH_201509

(avec bien sur des corrections sur les noms de fichier, je ne vais pas m'installer une version de 2015 !).

[Edit] Le message d'erreur est plus précisément

La commande (loop)/arch/boot/x86 n'existe pas

[/Edit]

Edit2] La doc ubuntu est pratiquement identique [/Edit2]

Dernière modification par FrancisFDZ (Le 16/05/2017, à 16:20)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#2 Le 27/04/2017, à 17:56

Caerroff

Re : grub et "_" [Resolu]

Alors ma question est la suivante:

Pourquoi tu veux l'installer depuis le grub alors que rentrer dans le bios et booter de la serrait certainement plus facile ?

Hors ligne

#3 Le 27/04/2017, à 18:27

FrancisFDZ

Re : grub et "_" [Resolu]

Pour le principe ! Ça marche très bien avec ubuntu, mais pour les autres isos, c'est plus problématique
Et d'ailleurs, je n'ai pas besoin de passer par le bios pour démarrer d'un cd, la touche f12 me donne le choix du périphérique de boot. Mais je n'ai pas envie de graver un cd alors que grub permet de booter directement depuis l'iso sur HDD

Dernière modification par FrancisFDZ (Le 27/04/2017, à 18:32)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#4 Le 30/04/2017, à 16:48

FrancisFDZ

Re : grub et "_" [Resolu]

Up ? sad


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#5 Le 30/04/2017, à 17:27

maxire

Re : grub et "_" [Resolu]

Salut,

Es-tu bien certain que le problème vienne du caractère _?
Grub reconnaît parfaitement ce caractère.

Ne te serais-tu pas loupé dans le montage loop?


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#6 Le 30/04/2017, à 17:42

FrancisFDZ

Re : grub et "_" [Resolu]

Vu d'une part la commande : 

linux (loop)/arch/boot/x86_64/vmlinuz

et d'autre part le message d'erreur :

La commande (loop)/arch/boot/x86 n'existe pas

l'hypothèse d'une mauvaise reconnaissance du caractère "_" semble plausible. J'ai isolé (dans une variable) le terme "/arch/boot/x86_64/" et en ai demandé l'affichage : le caractère "_" est bel et bien reconnu, alors comment expliquer le message d'erreur ? Je sèche.

[HS} J'ai aussi testé en gravant le fichier iso : ça n'avait pas fonctionné dans un premier temps, avec messages d'erreur mettant en cause /dev/sr0. J'ai gravé un autre CD : ça fonctionne ! Les messages d'erreur font penser à un problème au niveau du driver, mais il s'agit bien d'un CD (réinscriptible) fatigué. Mais le problème de grub n'en est pas résolu pour autant. [/HS]

Dernière modification par FrancisFDZ (Le 30/04/2017, à 17:50)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#7 Le 30/04/2017, à 17:43

Babdu89

Re : grub et "_" [Resolu]

Bonjour.

Au vu du post#1.

La commande (loop)/arch/boot/x86 n'existe pas

C'est x86, ou x86_64  ?.
Tu as mis quoi dans ton texte?

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#8 Le 30/04/2017, à 17:51

maxire

Re : grub et "_" [Resolu]

Je ne peux pas ni ne veux tester ton montage faute d'image iso de Archlinux, je n'utilise qu'une clef usb  obtenue par extraction de l'image ISO.

Un truc que tu pourrais essayer.

Une fois le montage loop réalisé, que donne la commande ls (loop)/ ?
Obtiens-tu l'arborescence de l'image iso, comme /arch /boot ....?

Si oui tu peux alors tenter:

grub> set root=loop
grub> chainloader +1
grub> boot

Normalement tu devrais obtenir le menu d'installation de Archlinux, ceci dit je n'ai pas testé cela récemment et je ne me souviens plus comment se termine ce lancement  exotique de Arch.

Si non, le montage loop a un problème.

Dernière modification par maxire (Le 30/04/2017, à 18:02)


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#9 Le 30/04/2017, à 17:56

FrancisFDZ

Re : grub et "_" [Resolu]

@Babdu89 : La commande est bien celle du post #1, le répertoire "/arch/boot/x86_64" est bien présent.
Je n'ai jamais lancé la commande

(loop)/arch/boot/x86

c'est pourquoi j'ai émis l'hypothèse d'une mauvaise reconnaissance du caractère "_", hypothèse bien fragile (je n'en ai pas d'autre)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#10 Le 30/04/2017, à 17:59

maxire

Re : grub et "_" [Resolu]

Pour information je n'ai aucun problème avec:

grub> linux /arch/boot/x86_64/vmlinuz

J'attaque une extraction de l'image iso de Archlinux et mon clavier est un qwerty canadien.

Quelle touche du clavier utilises-tu pour _?
En qwerty us c'est la position majuscule ) du clavier azerty français, je crois me souvenir qu'il existe 2 codages de _ donc _ correspond à 2 caractères différents.

Dernière modification par maxire (Le 30/04/2017, à 18:06)


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#11 Le 30/04/2017, à 18:01

FrancisFDZ

Re : grub et "_" [Resolu]

@maxire : J'ai plusieurs isos de live cd, il me semble avoir déjà essayé la méthode que tu préconise, j'avais peut-être une petite erreur de syntaxe, je vais vérifier.


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#12 Le 30/04/2017, à 18:05

FrancisFDZ

Re : grub et "_" [Resolu]

@maxire : je suis sur un clavier AZERTY français, le caractère "_" est sur la même touche que 6 (mais en minuscule : sur ce clavier, les chiffres sont en majuscule).

Dernière modification par FrancisFDZ (Le 30/04/2017, à 18:06)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#13 Le 30/04/2017, à 18:11

maxire

Re : grub et "_" [Resolu]

Non 6 c'est - et non _ sur un azerty latin9-Euro, mais peu importe sous Grub c'est un qwerty us qui est actif; à moins que tu n'aies mis en place un clavier azerty sous Grub ce qui est parfaitement possible (non sans mal).


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#14 Le 30/04/2017, à 18:11

Babdu89

Re : grub et "_" [Resolu]

Et avec un copier/coller du texte donné dans les liens du post#1, çà ne donnerait pas la syntaxe qui convient pour "x86_64"? avant de modifier la suite de la ligne;
linux (loop)......?

@+.   Babdu89  .

Dernière modification par Babdu89 (Le 30/04/2017, à 18:12)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#15 Le 30/04/2017, à 18:18

maxire

Re : grub et "_" [Resolu]

Euh, Babdu89, un copier-coller en console Grub, non, pas possible.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#16 Le 30/04/2017, à 18:18

FrancisFDZ

Re : grub et "_" [Resolu]

@maxire : exact, il s'agit bien du 8 et non du 6. Par contre, le clavier azerty sous grub, ça m'intéresse, il me semble bien que c'est possible (je vais creuser ça plus tard)
@Babdu89 : je ne vois pas comment faire un copier-coller quand je suis sous le grub-shell !


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#17 Le 30/04/2017, à 18:22

maxire

Re : grub et "_" [Resolu]

FrancisFDZ a écrit :

il me semble bien que c'est possible (je vais creuser ça plus tard)

Si si, c'est possible je l'ai fait et je l'utilise, mais je ne me souviens plus vraiment comment j'ai généré le  clavier azerty de grub.
Je me contente de copier le dit clavier d'une installation à l'autre.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#18 Le 30/04/2017, à 18:30

FrancisFDZ

Re : grub et "_" [Resolu]

@maxire : merci du renseignement, sachant que ça existe, je le trouverais, mais on s'égare ...


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#19 Le 30/04/2017, à 18:40

maxire

Re : grub et "_" [Resolu]

Le plus dur c'est de générer le clavier , une fois généré tu ajoutes cette ligne dans /etc /grub.d/40_custom:

keymap /usr/local/share/kbd/keymaps/fr.gkb

Le clavier est ici fr.gkb et tu le mets où tu veux, ici il est en /usr/local/share/kbd/keymaps.

Effectivement nous nous égarons, as-tu tenté ce que j'ai conseillé?


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#20 Le 30/04/2017, à 18:44

Babdu89

Re : grub et "_" [Resolu]

@maxire.

Si si, c'est possible je l'ai fait et je l'utilise, mais je ne me souviens plus vraiment comment j'ai généré le  clavier azerty de grub.

Ce n'est pas çà que tu cherches?

setxkbmap    fr   ### qu'il  faudra frapper  "setxkb,qp    fr"

Voir ici;

https://forum.ubuntu-fr.org/viewtopic.p … #p21720249

@+.    Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#21 Le 30/04/2017, à 18:45

FrancisFDZ

Re : grub et "_" [Resolu]

@maxire : je suis actuellement sur mon portable sous win7 (pas taper !! sad ) Mais dès que je rallume mon fixe, je tente !


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#22 Le 30/04/2017, à 18:59

maxire

Re : grub et "_" [Resolu]

Non Babdu89, nous parlons de grub et la gestion du clavier est alors toute autre que celle du serveur graphique Xorg et de la console virtuelle.
Il est nécessaire de convertir les formats de claviers en des formats gkb (je ne me souviens plus de la dénomination exacte de ce truc).
J'ai retrouvé un script qui fait peut-être le boulot, ckbcomp.

FrancisFDZ, je pensais que tu étais sur le problème, tiens-nous au courant alors.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#23 Le 30/04/2017, à 19:20

FrancisFDZ

Re : grub et "_" [Resolu]

grub et azerty : j'ai googlisé et trouvé ça. Reste à tester.


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#24 Le 30/04/2017, à 19:46

maxire

Re : grub et "_" [Resolu]

Non surtout pas ça, tu vas griller ta définition de clavier AT.
Il faut effectivement dans /etc/default/grub installer le clavier AT via cette directive,

GRUB_TERMINAL_INPUT=at_keyboard

Puis générer un clavier français à un format compatible AT (mon fr.gkb) qui sera référencé par la commande keymap dans /etc/grub.d/40_custom
Le problème est que je ne sais plus quel programme de conversion j'ai utilisé ni quel format source j'ai utilisé.

En tout cas j'ai bien un clavier azerty partiellement couvert, les lettres accentuées ne sont pas supportées ce serait beaucoup trop demander au niveau du programme firmware + une bizarrerie le zéro du pavé numérique n'est pas reconnu.

Bien évidemment un update-grub est nécessaire pour prendre en compte tout ceci.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#25 Le 30/04/2017, à 20:35

maxire

Re : grub et "_" [Resolu]

En fait c'est très simple pour générer un clavier utilisable par grub.
Tu installes le script perl ckbcomp via le dépôt AUR  sous Archlinux, je suppose qu'il existe un paquet debian qui fait la même chose puis par exemple:

aspire7730z@asus-arch ~]$ grub-kbdcomp fr-latin9 -o toto.gkb
Code de touche 0x54 inconnu
Code de touche 0x65 inconnu
Code de touche 0x7f inconnu
[aspire7730z@asus-arch ~]$

Tu installes le fichier toto.gkb où cela t'arrange  (pourquoi pas sous /boot/grub/kbd), tu paramètres correctement /etc/default/grub et /etc/grub.d/40_custom, un update-grub et c'est fini.

Beaucoup plus simple que voici quelques années lorsque j'ai généré mon fr.gkb.


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

Hors ligne