Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/09/2017, à 21:51

klintiswood

Manque un écran dans Nvidia X Server

Hello tout le monde,

J'ai une config avec 10 GPU tournant sous Ubuntu et j'ai configuré xorg.conf afin de pouvoir overclocker chaque carte individuellement (via coolbits).
Tout fonctionne sauf que je me suis rendu compte qu'une carte dans la liste (la dernière) n'est pas overclockée et pas moyen de changer sa vitesse d'horloge.

Je pense pourtant avoir correctement configuré xorg.conf et je ne vois pas où se trouve l'erreur:

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "screen1" 0 0
    Screen      1  "screen2" 0 0
    Screen      2  "screen3" 0 0
    Screen      3  "screen4" 0 0
    Screen      4  "screen5" 0 0
    Screen      5  "screen6" 0 0
    Screen      6  "screen7" 0 0
    Screen      7  "screen8" 0 0
    Screen      8  "screen9" 0 0
    Screen      9  "screen10" 0 0
    Inactive       "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"

#Driver "intel"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "None"
#Option "AccelMethod" "sna"
    BusID          "PCI:0@0:2:0"
EndSection

Section "Device"
    Identifier     "nvidia1"
    Driver         "nvidia"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "nvidia2"
    Driver         "nvidia"
    BusID          "PCI:2:0:0"
EndSection

Section "Device"
    Identifier     "nvidia3"
    Driver         "nvidia"
    BusID          "PCI:3:0:00"
EndSection

Section "Device"
    Identifier     "nvidia4"
    Driver         "nvidia"
    BusID          "PCI:4:0:0"
EndSection

Section "Device"
    Identifier     "nvidia5"
    Driver         "nvidia"
    BusID          "PCI:5:0:0"
EndSection

Section "Device"
    Identifier     "nvidia6"
    Driver         "nvidia"
    BusID          "PCI:8:0:0"
EndSection

Section "Device"
    Identifier     "nvidia7"
    Driver         "nvidia"
    BusID          "PCI:10:0:0"
EndSection

Section "Device"
    Identifier     "nvidia8"
    Driver         "nvidia"
    BusID          "PCI:11:0:0"
EndSection

Section "Device"
    Identifier     "nvidia9"
    Driver         "nvidia"
    BusID          "PCI:12:0:0"

EndSection

Section "Device"
    Identifier     "nvidia10"
    Driver         "nvidia"
    BusID          "PCI:13:0:0"

EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
    Monitor        "Monitor0"
EndSection

Section "Screen"
    Identifier     "screen1"
    Device         "nvidia1"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen2"
    Device         "nvidia2"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen3"
    Device         "nvidia3"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen4"
    Device         "nvidia4"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen5"
    Device         "nvidia5"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen6"
    Device         "nvidia6"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen7"
    Device         "nvidia7"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen8"
    Device         "nvidia8"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen9"
    Device         "nvidia9"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "screen10"
    Device         "nvidia10"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    Option         "Coolbits" "12"
    Option         "MultiGPU" "on"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Dans Nvidia X Server je ne vois pas de screen 9 apparaitre, le GPU 9 (c'est le dixième vu qu'on commence à 0) apparait mais pas d'option pour changer la vitesse.

Quelqu'un a une idée?

Merci!


Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 10/09/2017, à 22:39)

Hors ligne