Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 10/11/2017, à 16:58

rob1

Clavier virtuel OnBoard par défaut, ou désactiver celui de Gnome

Bonjour,
j'ai un problème pour utiliser le clavier virtuel OnBoard convenablement sous Ubuntu 17.10 (donc sous Gnome 3). Apparemment Gnome 3 intègre son propre clavier virtuel, très basique et pas du tout paramétrable, ni même désactivable.
J'arrive à installer OnBoard mais même quand il est lancé, le clavier par défaut de Gnome continue à s'afficher. Apparemment il détecte automatiquement l'écran tactile (sur un pc sans écran tactile il ne réapparaît pas toutes les 5 secondes). Et le clavier de Gnome empêche d'utiliser OnBoard.

J'aimerais donc savoir s'il est possible soit de définir OnBoard comme clavier par défaut, soit, ce qui pourrait être plus simple, de forcer la désactivation du clavier virtuel par défaut de Gnome 3 (même quand "clavier visuel" est désactivé dans les paramètres d'accessibilité, il continue à appraître). J'ai déjà essayé l'extension gnome "onboard-integration" mais elle ne fonctionne pas (elle a l'air d'être prévue pour des versions plus anciennes de Gnome).

Merci!

Hors ligne

#2 Le 10/11/2017, à 17:27

alexarnaud

Re : Clavier virtuel OnBoard par défaut, ou désactiver celui de Gnome

Bonjour,

C'est le comportement par défaut de GNOME visiblement : https://help.gnome.org/users/gnome-help … sk.html.fr

Est-ce que c'était mieux sur la version 17.04 ? Il est toujours possible basculer sur le bureau Unity pour retrouver l'ancien comportement.

N'utilisant pas GNOME moi-même je ne pourrais vous en dire plus.

Bien à vous.


Hypra.fr - Accessibilité et logiciel libre

Hors ligne

#3 Le 10/11/2017, à 18:02

cqfd93

Re : Clavier virtuel OnBoard par défaut, ou désactiver celui de Gnome

Modération : merci de respecter les règles du forum : les doublons sont interdits.

En ligne

#4 Le 14/11/2017, à 00:18

rob1

Re : Clavier virtuel OnBoard par défaut, ou désactiver celui de Gnome

Merci pour votre réponse.
Finalement j'ai trouvé une solution pour bloquer le clavier de Gnome (qui s'appelle Caribou) grâce à une extension: Block Caribou
Elle fonctionne, caribou arrête bien de s'afficher automatiquement. Mais maintenant il y a un autre problème: dans certaines situations, comme lors de l'affichage des "Activités", du menu des applications ou encore quand il faut saisir le mot de passe root, l'interface de Gnome se superpose à toutes les autres fenêtres, et il est alors impossible d'avoir accès à OnBoard. Et donc aucun moyen de saisir du texte sans clavier (vu que même caribou ne s'affiche plus à cause de l'extension). Même problème sur l'écran de login pour saisir le mot de passe utilisateur.
Est-ce qu'il y a un moyen de remédier à ça?
(pour préciser la situation, l'ordinateur est destiné à une personne en situation de handicap qui ne peut utiliser ni clavier ni souris, mais un écran tactile. et le clavier virtuel par défaut de gnome-shell (caribou) ne dispose pas des options nécessaires, contrairement à OnBoard (notamment le redimensionnement, la personnalisation de l'agencement, de la police de caractère, etc). mais mis à part ce gros problème de clavier virtuel, gnome-shell est clairement l'environnement le plus optimisé pour écran tactile, le seul qui pourrait vraiment permettre de se passer de la souris et du clavier en fait)
Merci!

Dernière modification par rob1 (Le 14/11/2017, à 00:29)

Hors ligne