Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 23/07/2018, à 19:25

Emmanuel Billette

[résolu] Bibliothèques Python

Bonjour,

J'ai installé le logiciel IDLE avec Python 3.7, et tout marche correctement... sauf que je n'ai pas toutes les bibliothèques dont j'ai besoin (numpy, matplotlib, ... finalité enseignement) et j'ai le plus grand mal à trouver comment on les installe. En furetant un peu, j'ai trouvé l'utilitaire pip que j'ai installé, mais qui ne semble pas reconnu par le shell :

emmanuel@PC-E:~$ pip install numpy
bash: /home/emmanuel/.local/bin/pip : /usr/bin/python3.5 : mauvais interpréteur: Aucun fichier ou dossier de ce type

ou encore

emmanuel@PC-E:~$ python -m pip install --emmanuel numpy matplotlib
/usr/bin/python: No module named pip

Je précise que j'ai aussi installé le paquet matplotlib... Bref je me sens un peu démuni.

Merci pour votre aide !

Emmanuel


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par Emmanuel Billette (Le 26/07/2018, à 06:33)

Hors ligne

#2 Le 23/07/2018, à 19:48

toitoinebzh

Re : [résolu] Bibliothèques Python

salut

passe plutôt par apt

sudo apt install python3-numpy  python3-matplotlib

pour pip (que je n'utilise pas), je pense qu'il est dédié à la version 2 de python
pour python3.x, je pense qu'il faut pip3

sudo apt install python3-pip

Dernière modification par toitoinebzh (Le 23/07/2018, à 19:48)

Hors ligne

#3 Le 24/07/2018, à 16:03

Emmanuel Billette

Re : [résolu] Bibliothèques Python

Bonjour,

Merci pour cette réponse rapide. Il y a du progrès car lorsque je lance Python dans un terminal, l'import des bibliothèques marche !

En revanche dans IDLE qui est l'interface que j'utilise (et recommandée pour mes étudiants), les bibliothèques ne sont pas inconnues mais j'ai le messsage d'erreur suivant, dont l'interprétation ne me semble pas évidente :

>>> import matplotlib.pyplot as pypl
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/numpy/core/__init__.py", line 16, in <module>
    from . import multiarray
ImportError: cannot import name 'multiarray' from 'numpy.core' (/usr/lib/python3/dist-packages/numpy/core/__init__.py)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "<pyshell#0>", line 1, in <module>
    import matplotlib.pyplot as pypl
  File "/usr/lib/python3/dist-packages/matplotlib/__init__.py", line 123, in <module>
    from . import cbook
  File "/usr/lib/python3/dist-packages/matplotlib/cbook/__init__.py", line 36, in <module>
    import numpy as np
  File "/usr/lib/python3/dist-packages/numpy/__init__.py", line 142, in <module>
    from . import add_newdocs
  File "/usr/lib/python3/dist-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/usr/lib/python3/dist-packages/numpy/lib/__init__.py", line 8, in <module>
    from .type_check import *
  File "/usr/lib/python3/dist-packages/numpy/lib/type_check.py", line 11, in <module>
    import numpy.core.numeric as _nx
  File "/usr/lib/python3/dist-packages/numpy/core/__init__.py", line 26, in <module>
    raise ImportError(msg)
ImportError:
Importing the multiarray numpy extension module failed.  Most
likely you are trying to import a failed build of numpy.
If you're working with a numpy git repo, try `git clean -xdf` (removes all
files not under version control).  Otherwise reinstall numpy.

Original error was: cannot import name 'multiarray' from 'numpy.core' (/usr/lib/python3/dist-packages/numpy/core/__init__.py)

Des idées  ?

Emmanuel

Hors ligne

#4 Le 24/07/2018, à 18:14

toitoinebzh

Re : [résolu] Bibliothèques Python

bonjour

je n'ai pas ce comportement chez moi (matplotlib via apt)
as tu installer matplotlib via apt ou pip ?

comment as tu installé python, normalement c'est la version 3.6 sous ubuntu 18.04 ?

Hors ligne

#5 Le 25/07/2018, à 06:27

Emmanuel Billette

Re : [résolu] Bibliothèques Python

J'ai abandonné (temporairement ?) l'usage de pip qui ne semple pas reconnu par le shell - il s'agissait bien de la version Python 3. Sinon, j'ai installé python3 avec le gestionnaire de paquets synaptic, mais apparemment j'ai deux versions installées (pas délibéré de ma part), je ne sais pas si ça peut poser problème ?

emmanuel@PC-E:~$ python -V
Python 2.7.15rc1
emmanuel@PC-E:~$ python3 -V
Python 3.6.5

Le problème qui subsiste semble plutôt être une bonne compréhension entre les bibliothèques installées (qui sont bien reconnues) et le logiciel IDLE.

Emmanuel

Hors ligne

#6 Le 25/07/2018, à 06:28

Emmanuel Billette

Re : [résolu] Bibliothèques Python

et pour finir, IDLE semble utiliser encore une autre version car il commence par

Python 3.7.0b3 (default, Mar 30 2018, 04:35:22)
[GCC 7.3.0] on linux
Type "copyright", "credits" or "license()" for more information.
>>>

Emmanuel

Hors ligne

#7 Le 25/07/2018, à 18:11

toitoinebzh

Re : [résolu] Bibliothèques Python

salut

c'est normal d'avoir python 2 et 3 sous ubuntu, il faut juste faire attention à la version que l'on utilise

est ce que tu as le même message d'erreur quand tu lance matplotlib sous python3 (en terminal) ?

Dernière modification par toitoinebzh (Le 25/07/2018, à 18:11)

Hors ligne

#8 Le 25/07/2018, à 21:59

Emmanuel Billette

Re : [résolu] Bibliothèques Python

Non, comme mentionné plus haut, ça marche dans le terminal, c'est juste IDLE qui a un problème. En relisant dans le détail le long message d'erreur, il semble qu'il n'arrive pas à charger une "extension multiarray"... Je n'ai pas trouvé comment y remédier.

Emmanuel

Hors ligne

#9 Le 25/07/2018, à 22:04

toitoinebzh

Re : [résolu] Bibliothèques Python

salut

essaye d'installer la version 3.6 d'idle

sudo apt install idle-python3.6

Hors ligne

#10 Le 26/07/2018, à 06:32

Emmanuel Billette

Re : [résolu] Bibliothèques Python

Ça marche ! C'était donc un problème de compatibilité entre versions de Python.
Un grand merci pour ton aide.

Emmanuel

Hors ligne

#11 Le 26/07/2018, à 17:30

toitoinebzh

Hors ligne