Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/09/2018, à 19:06

philo_neo

[résolu] installer xfce4 sur ubuntu 18.04.1 server

Bonjour,
je cherche a installer "xfce4" sur un AMD64 quad core, LTS 18.04.1 server...
J'ai installé mon serveur mais lors de la commande

apt-get install xfce4

, ce dernier ne trouve pas le packet!
idem pour la commande

tasksel install xfce4,

sans retour !
comment installer un bureu légé sur un serveur ?

Salutations
philippe

Dernière modification par philo_neo (Le 22/09/2018, à 23:35)

Hors ligne

#2 Le 18/09/2018, à 19:17

inbox

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Salut,

Que donnent ces commandes ?

sudo apt-get update
sudo apt-get install xfce4

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 18/09/2018, à 19:40

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

rien déja essayé !

Hors ligne

#4 Le 18/09/2018, à 19:41

inbox

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Comment veux-tu obtenir de l'aide sans donner les retours de commandes ?


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#5 Le 18/09/2018, à 19:50

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

bien c'est simple le dépot "xfce4" n'est pas activé !
pour les retours de commande il ne trouve pas le paquet !

Hors ligne

#6 Le 19/09/2018, à 10:01

choops

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Pour commencer, il n'y a pas de 'dépot "xfce4"', xfce4 est dans les dépots de base de ubuntu toutes variantes confondues, y compris ubuntu-server.

Donne ici le retour réel de tes commandes, pas "il ne se passe rien" qui ne permet pas de t'aider.

Pour résumer il t'a été demandé jusqu'ici le retour de:

sudo apt-get update

et:

sudo apt-get install xfce4

Ajoute à ça le retour des commandes suivantes:

cat /etc/apt/sources.list

et:

ls /etc/apt/sources.list.d

Sans les retours réels de ces 4 commandes, personne ne pourra te fournir une réponse sachant qu'il ne se passe jamais "rien" : il y a toujours un retour, même négatif avec message d'erreur, pour ces commandes.

Dernière modification par choops (Le 19/09/2018, à 11:16)

En ligne

#7 Le 20/09/2018, à 15:18

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

sudo apt-get update

Last login: Thu Sep 20 13:11:51 2018
root@dct-arthemis:~# sudo apt-get update
Atteint:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Atteint:2 http://archive.ubuntu.com/ubuntu bionic-security InRelease
Atteint:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Lecture des listes de paquets... Fait
root@dct-arthemis:~#

et:

sudo apt-get install xfce4

root@dct-arthemis:~# apt-get install xfce4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet xfce4
root@dct-arthemis:~#

Ajoute à ça le retour des commandes suivantes:

cat /etc/apt/sources.list

root@dct-arthemis:~# cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu bionic main
deb http://archive.ubuntu.com/ubuntu bionic-security main
deb http://archive.ubuntu.com/ubuntu bionic-updates main
root@dct-arthemis:~#

et:

ls /etc/apt/sources.list.d

root@dct-arthemis:~# ls /etc/apt/sources.list.d
root@dct-arthemis:~#

Hors ligne

#8 Le 20/09/2018, à 15:29

inbox

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Ton sources.list est incomplet. Pour installer Xfce4, il te faut ajouter le dépôt universe.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#9 Le 20/09/2018, à 15:34

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

comment je fait pour ajouter le dépot universe

Hors ligne

#10 Le 20/09/2018, à 16:15

Caribou22

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Bonjour smile

Tu dois éditer ton sources.list et ajouter ces lignes et en remplaçant xenial par bionic :
https://doc.ubuntu-fr.org/depots_xenial … multiverse

Mais si tu veux une interface graphique Xfce, pourquoi ne pas avoir directement installé Xubuntu ? (Ou Lubuntu qui est la plus légère.)

Hors ligne

#11 Le 20/09/2018, à 17:43

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

merci j'ai installé xfce4 mais comment lancer automatiquement xfce4 GUI ?

Hors ligne

#12 Le 20/09/2018, à 17:48

Caribou22

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Il faut aussi installer un gestionnaire de session : une interface graphique qui te permet de t'identifier et de choisir de démarrer une session graphique.
LightDM est l'un des plus répandus et c'est celui qui est utilisé pour Xubuntu donc c'est celui que je te conseille : https://doc.ubuntu-fr.org/lightdm

Pour l'installer :

sudo apt install lightdm

Hors ligne

#13 Le 20/09/2018, à 18:10

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

j'ai installé lightdm mais le login ne reconnait pas mon mot de passe d'utilisateur non root!
j'ai essayé en azerty et en qwerty !

que faire ?

Hors ligne

#14 Le 21/09/2018, à 08:35

choops

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

philo_neo a écrit :
cat /etc/apt/sources.list
root@dct-arthemis:~# cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu bionic main
deb http://archive.ubuntu.com/ubuntu bionic-security main
deb http://archive.ubuntu.com/ubuntu bionic-updates main
root@dct-arthemis:~# 

Comment se fait-il que tu aies un sources.list si restreint ?
De base ubuntu server 18.04 était livré avec un sources.list comprenant les dépots main, restricted, universe et multiverse activés, ça a changé pour 18.04.1 en base d'install ?
J'installe à partir de l'image minimale netboot 18.04 que j'ai inclue dans mon serveur PXE fin avril en restreignant l'installation à "basic ubuntu server" et ça me donne ce sources.list (install fraiche refaite à l'instant pour être sûr de ce que je raconte) :

choops@new-host-2:~$ cat /etc/apt/sources.list
# deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted

# deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb http://security.ubuntu.com/ubuntu bionic-security main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic universe
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse
choops@new-host-2:~$ 

Etant donné que tu n'as pas la totalité des dépots par défaut il va sans doute te manquer des accès à certains paquets. Je te suggère donc de reprendre un sources.list complet tel que celui que je te montre ci-dessus pour être sûr de bien pouvoir installer correctement ce que tu veux

Dernière modification par choops (Le 21/09/2018, à 08:46)

En ligne

#15 Le 21/09/2018, à 14:37

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

bonjour choops,
j'ai refais une installation complet !
avec ton  /etc/apt/sources.list .
Le mot de passe est failed, impossible d'ouvrir une session sous lightdm !
Je crois que le mot de passe est crypté mais il me manque des paramétres,
pour configurer lightdm !
/var/log/lightdm/lightdm.log

root@dct-arthemis:~# cat /var/log/lightdm/lightdm.log
[+0.07s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.07s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=704
[+0.07s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.07s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
[+0.07s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
[+0.07s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.07s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.07s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
[+0.07s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.07s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.07s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.07s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.07s] DEBUG: Registered seat module local
[+0.07s] DEBUG: Registered seat module xremote
[+0.07s] DEBUG: Registered seat module unity
[+0.07s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.08s] DEBUG: Monitoring logind for seats
[+0.08s] DEBUG: New seat added from logind: seat0
[+0.08s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.08s] DEBUG: Seat seat0: Starting
[+0.08s] DEBUG: Seat seat0: Creating greeter session
[+0.29s] DEBUG: Seat seat0: Creating display server of type x
[+0.29s] DEBUG: Using VT 7
[+0.29s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.29s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.29s] DEBUG: XServer 0: Writing X server authority to /var/run/lightdm/root/:0
[+0.29s] DEBUG: XServer 0: Launching X Server
[+0.29s] DEBUG: Launching process 713: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.29s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.29s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.29s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.38s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.38s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+7.29s] DEBUG: Got signal 10 from process 713
[+7.29s] DEBUG: XServer 0: Got signal from X server :0
[+7.29s] DEBUG: XServer 0: Connecting to XServer :0
[+7.29s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+7.29s] DEBUG: Session pid=735: Started with service 'lightdm-greeter', username 'lightdm'
[+7.53s] DEBUG: Session pid=735: Authentication complete with return value 0: Success
[+7.53s] DEBUG: Seat seat0: Session authenticated, running command
[+7.53s] DEBUG: Session pid=735: Running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/unity-greeter
[+7.53s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+7.54s] DEBUG: Session pid=735: Logging to /var/log/lightdm/seat0-greeter.log
[+8.35s] DEBUG: Activating VT 7
[+8.35s] DEBUG: Activating login1 session c1
[+8.35s] DEBUG: Seat seat0 changes active session to c1
[+8.35s] DEBUG: Session c1 is already active
[+11.79s] DEBUG: Greeter connected version=1.26.0 api=1 resettable=false
[+19.70s] DEBUG: Greeter start authentication for phipo
[+19.70s] DEBUG: Session pid=883: Started with service 'lightdm', username 'phipo'
[+20.27s] DEBUG: Session pid=883: Got 1 message(s) from PAM
[+20.27s] DEBUG: Prompt greeter with 1 message(s)
[+20.85s] DEBUG: User /org/freedesktop/Accounts/User116 added
[+34.92s] DEBUG: Continue authentication
[+34.95s] DEBUG: Session pid=883: Authentication complete with return value 0: Success
[+34.95s] DEBUG: Authenticate result for user phipo: Success
[+34.95s] DEBUG: User phipo authorized
[+34.96s] DEBUG: Greeter requests default session
[+35.05s] DEBUG: Writing /home/phipo/.dmrc
[+35.08s] DEBUG: Seat seat0: Failed to find session configuration ubuntu
[+35.08s] DEBUG: Seat seat0: Can't find session 'ubuntu'
[+35.09s] DEBUG: Greeter start authentication for phipo
[+35.09s] DEBUG: Session pid=900: Started with service 'lightdm', username 'phipo'
[+35.10s] DEBUG: Session pid=900: Got 1 message(s) from PAM
[+35.10s] DEBUG: Prompt greeter with 1 message(s)
[+51.63s] DEBUG: Continue authentication
[+53.55s] DEBUG: Session pid=900: Authentication complete with return value 7: Authentication failure
[+53.55s] DEBUG: Authenticate result for user phipo: Authentication failure
[+53.55s] DEBUG: Session pid=900: Exited with return value 1
[+53.55s] DEBUG: Seat seat0: Session stopped
[+53.55s] DEBUG: Greeter start authentication for phipo
[+53.55s] DEBUG: Session pid=906: Started with service 'lightdm', username 'phipo'
[+53.56s] DEBUG: Session pid=906: Got 1 message(s) from PAM
[+53.56s] DEBUG: Prompt greeter with 1 message(s)
[+1285.60s] DEBUG: Seat seat0 changes active session to 
[+1287.96s] DEBUG: Seat seat0 changes active session to c1
[+1287.96s] DEBUG: Session c1 is already active
root@dct-arthemis:~# 


que faire ?

Dernière modification par philo_neo (Le 21/09/2018, à 15:19)

Hors ligne

#16 Le 21/09/2018, à 23:24

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

bonjour,
j'ai modifié le fichier suivant : /etc/lightdm/lightdm.conf

[SeatDefaults]
autologin-user=phipo
autologin-guest=false
autologin-user-timeout=0
autologin-session=xfce

mon probléme est que la session s'ouvre automatiquement sans demander de mot de passe.
j'aimerais pouvoir activer le login de lightdm .

comment activer le login ?

Hors ligne

#17 Le 21/09/2018, à 23:29

choops

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Salut

ce n'est pas ton mot de passe qui n'est pas reconnu, c'est le type de session que tu veux ouvrir:
- ton authentification passe:

[+34.95s] DEBUG: Session pid=883: Authentication complete with return value 0: Success
[+34.95s] DEBUG: Authenticate result for user phipo: Success
[+34.95s] DEBUG: User phipo authorized
[+34.96s] DEBUG: Greeter requests default session
[+35.05s] DEBUG: Writing /home/phipo/.dmrc

- le type de session qui semble vouloir s'ouvrir est alors 'ubuntu' et ce type de session n'est pas reconnu:

[+35.08s] DEBUG: Seat seat0: Failed to find session configuration ubuntu
[+35.08s] DEBUG: Seat seat0: Can't find session 'ubuntu'

Au moment de saisir ton mot de passe il doit y avoir un endroit dans l'écran (c'est variable suivant les configurations de lightm-greeter) où tu peux choisir le type de session. En général, c'est une icone en forme d'engrenage.
Tu cliques dessus et tu choisis "Xfce session" dans le menu déroulant qui va s'afficher.
Normalement, ça te permettra d'accéder à un environnement de bureau xfce.

En ligne

#18 Le 21/09/2018, à 23:32

choops

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

philo_neo a écrit :

bonjour,
j'ai modifié le fichier suivant : /etc/lightdm/lightdm.conf

[SeatDefaults]
autologin-user=phipo
autologin-guest=false
autologin-user-timeout=0
autologin-session=xfce

mon probléme est que la session s'ouvre automatiquement sans demander de mot de passe.
j'aimerais pouvoir activer le login de lightdm .

comment activer le login ?

En même temps, éditer les fichiers de conf avant de voir ce qui peut fonctionner en l'état ça n'aide pas...

et oui ça te log automatiquement puisque tu le demandes dans ton fichier de conf :

autologin-user=phipo

Lis la doc avant de toucher à tes fichiers de conf et gardes toujours une copie des originaux. Pour la doc, Caribou22 t'avais envoyé vers quelque chose de très détaillé et clair : https://doc.ubuntu-fr.org/lightdm

Dernière modification par choops (Le 21/09/2018, à 23:38)

En ligne

#19 Le 22/09/2018, à 23:34

philo_neo

Re : [résolu] installer xfce4 sur ubuntu 18.04.1 server

Merci a tous !
Je maitrise mieux XFCE4 sur Ubuntu.

Post/threads RESOLU

Hors ligne