Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 23/10/2018, à 21:36

maximeay

Ubuntu 18 LTS démarre après 10 secondes...

Bonjour,

J'ai actuellement ubuntu 18 LTS depuis quelques mois sur mon DELL avec une configuration tels que : 16go de RAM, intel core i7 dernière génération, SSD...
Cependant, mon ordinateur met énormément de temps à démarrer, j'avais windows avant et il s'allumait beaucoup plus rapidement.

Je vous remercie,
Maxime.

Hors ligne

#2 Le 23/10/2018, à 21:39

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Salut,

Que donne la commande systemd-analyze blame ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#3 Le 23/10/2018, à 21:53

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

 2min 40.782s apt-daily.service
          9.537s NetworkManager-wait-online.service
          5.363s snapd.seeded.service
          3.305s plymouth-quit-wait.service
          1.536s plymouth-start.service
          1.357s apparmor.service
          1.309s plymouth-read-write.service
           833ms dev-sda5.device
           773ms systemd-journal-flush.service
           756ms fwupd.service
           705ms keyboard-setup.service
           493ms vboxdrv.service
           492ms mysql.service
           333ms systemd-logind.service
           296ms udisks2.service
           240ms rtkit-daemon.service
           193ms phpsessionclean.service
           178ms networkd-dispatcher.service
           174ms NetworkManager.service
           162ms apport-autoreport.service
           139ms systemd-resolved.service
           127ms ModemManager.service
           117ms upower.service
           117ms snapd.service
           116ms systemd-rfkill.service
           112ms apache2.service
            98ms systemd-udevd.service
            90ms systemd-fsck@dev-disk-by\x2duuid-EEF5\x2d6002.service
            87ms grub-common.service
            86ms avahi-daemon.service
            84ms bluetooth.service
            82ms apport.service
            77ms accounts-daemon.service
            74ms systemd-udev-trigger.service
            73ms networking.service
            73ms speech-dispatcher.service
            73ms gpu-manager.service
            73ms thermald.service
            65ms alsa-restore.service
            62ms swapfile.swap
            59ms rsyslog.service
            58ms bolt.service
            54ms pppd-dns.service
            46ms systemd-journald.service
            46ms teamviewerd.service
            43ms packagekit.service
            41ms wpa_supplicant.service
            37ms user@1000.service
            35ms user@121.service
            30ms systemd-tmpfiles-setup-dev.service
            30ms systemd-modules-load.service
            28ms polkit.service
            24ms gdm.service
            23ms systemd-sysctl.service
            20ms systemd-tmpfiles-clean.service
            17ms systemd-tmpfiles-setup.service
            16ms tmp.mount
            15ms boot-efi.mount
            15ms kerneloops.service
            14ms console-setup.service
            14ms ureadahead-stop.service
            14ms dev-hugepages.mount
            14ms vboxballoonctrl-service.service
            13ms systemd-update-utmp.service
            13ms dns-clean.service
            13ms sys-kernel-debug.mount
            11ms kmod-static-nodes.service
            11ms colord.service
            11ms systemd-user-sessions.service
            10ms ufw.service
            10ms systemd-remount-fs.service
             8ms dev-mqueue.mount
             7ms vboxautostart-service.service
             7ms sys-kernel-config.mount
             6ms systemd-backlight@backlight:intel_backlight.service
             5ms systemd-random-seed.service
             5ms sys-fs-fuse-connections.mount
             4ms systemd-update-utmp-runlevel.service
             4ms vboxweb-service.service
             1ms setvtrgb.service
           608us snapd.socket
           430us systemd-timesyncd.service

Hors ligne

#4 Le 23/10/2018, à 21:55

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Tu peux désactiver NetworkManager-wait-online.service qui est inutile si tu te connectes classiquement à Internet (via modem/routeur et câble ou wi-fi) : sudo systemctl disable NetworkManager-wait-online.service

Est-ce que tu utilises Snap ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#5 Le 23/10/2018, à 21:56

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Non je n'utilise pas snap, à mon école il y a une interface de connexion lorsque je me connecte en wifi, mais c'est sur le navigateur, donc si je peux quand même y accéder, je désactive NetworkManager-wait-online.service

Hors ligne

#6 Le 23/10/2018, à 22:01

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Dans ce cas, tu peux supprimer le paquet Snap : sudo apt remove snapd

Et pour être sûr que le service lié soit désactivé, des fois qu'il resterait des morceaux sur ton installation : sudo systemctl disable snapd.seeded.service
sudo systemctl disable snapd.service

Ensuite, redémarre et refais systemd-analyze blame pour voir si c'est mieux.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#7 Le 23/10/2018, à 22:02

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

J'ai désactivé NetworkManager... et j'ai ça maintenant (et le temps reste le même)

8.793s NetworkManager-wait-online.service
          3.234s plymouth-quit-wait.service
          1.491s plymouth-start.service
          1.389s apparmor.service
          1.342s plymouth-read-write.service
          1.203s apache2.service
           830ms systemd-journal-flush.service
           645ms keyboard-setup.service
           503ms mysql.service
           466ms dev-sda5.device
           407ms vboxdrv.service
           316ms systemd-logind.service
           289ms rtkit-daemon.service
           273ms udisks2.service
           221ms NetworkManager.service
           207ms apport-autoreport.service
           177ms networkd-dispatcher.service
           149ms upower.service
           145ms accounts-daemon.service
           136ms systemd-resolved.service
           136ms systemd-fsck@dev-disk-by\x2duuid-EEF5\x2d6002.service
           136ms systemd-udevd.service
           132ms networking.service

Hors ligne

#8 Le 23/10/2018, à 22:03

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Tu as bien redémarré entre-temps ? Bizarre que le service reste affiché alors qu'il devrait être désactivé.

Tu as bien copié-collé la commande que je t'ai indiquée ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#9 Le 23/10/2018, à 22:05

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Oui exact, je viens de la refaire et toujours pareil.

Hors ligne

#10 Le 23/10/2018, à 22:08

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Que donne systemctl status NetworkManager-wait-online.service ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#11 Le 23/10/2018, à 22:10

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Il dit qu'il est actif.

NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/lib/systemd/system/NetworkManager-wait-online.service; disab
   Active: active (exited) since Tue 2018-10-23 23:07:03 CEST; 2min 48s ago
     Docs: man:nm-online(1)
  Process: 836 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, sta
 Main PID: 836 (code=exited, status=0/SUCCESS)

oct. 23 23:06:53 inspiron-5567 systemd[1]: Starting Network Manager Wait Online.
oct. 23 23:07:03 inspiron-5567 systemd[1]: Started Network Manager Wait Online.

Hors ligne

#12 Le 23/10/2018, à 22:13

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Peux-tu mettre ton terminal en plein écran et refaire la commande ? Le résultat est coupé en partie et je me demande ce qui manque dans la réponse smile


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#13 Le 23/10/2018, à 22:13

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

J'ai regardé dans un forum, j'ai fais ça:

systemctl mask NetworkManager-wait-online.service

cela à désactivé le service, mais le temps de démarrage est le même
https://forums.fedora-fr.org/viewtopic.php?id=67185

Dernière modification par maximeay (Le 23/10/2018, à 22:14)

Hors ligne

#14 Le 23/10/2018, à 22:15

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Voici maintenant ce que cela me donne:

3.321s plymouth-quit-wait.service
          1.479s plymouth-start.service
          1.345s apparmor.service
          1.299s plymouth-read-write.service
           790ms fwupd.service
           714ms systemd-journal-flush.service
           591ms keyboard-setup.service
           544ms dev-sda5.device
           512ms mysql.service
           412ms vboxdrv.service
           336ms systemd-logind.service
           283ms rtkit-daemon.service
           245ms apport-autoreport.service
           224ms udisks2.service
           192ms ModemManager.service
           189ms networkd-dispatcher.service
           173ms NetworkManager.service
           172ms networking.service
           157ms systemd-resolved.service
           147ms upower.service
           147ms thermald.service
           146ms avahi-daemon.service
           139ms apport.service

Hors ligne

#15 Le 23/10/2018, à 22:16

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Un autre truc à désactiver serait Plymouth. Il permet d'afficher le logo Ubuntu lors du démarrage plutôt qu'une succession de lignes de commande.

Là, c'est un peu différent, tu peux tester pour une session en redémarrant. Quand tu arrives dans GRUB, tu édites la ligne de démarrage d'Ubuntu avec la touche "e". Tu arrives sur le script de démarrage du système. Repère les termes quiet splash et efface-les. Tu démarres ensuite en appuyant sur la touche "F10".

Le changement est pour une seule session, il faut le pérenniser autrement. Mais ça permet de voir si ça améliore ton temps de démarrage.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#16 Le 23/10/2018, à 22:29

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Exact ! C'est hyper rapide maintenant ! Il faut que je trouve un moyen maintenant smile

Hors ligne

#17 Le 23/10/2018, à 23:01

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Pour enlever le logo ubuntu au démarrage :

sudo nano /etc/default/grub

On modifie ça :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

par ça :

GRUB_CMDLINE_LINUX_DEFAULT=""

Cependant, le temps est le même, ça ne change rien pour moi...

Hors ligne

#18 Le 24/10/2018, à 08:49

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Pour finaliser la modification que tu as faite dans /etc/default/grub, il faut lancer la commande sudo update-grub


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#19 Le 24/10/2018, à 10:24

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

J'avais fais sudo update-grub2, ça avait changé mais le temps était le même sauf que cette fois il n'y avait pas de logo ubuntu.

Hors ligne

#20 Le 24/10/2018, à 11:03

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

maximeay a écrit :

Exact ! C'est hyper rapide maintenant ! Il faut que je trouve un moyen maintenant smile

C'était rapide et ça ne l'est de nouveau plus ?

Que donne systemd-analyze blame, maintenant ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#21 Le 24/10/2018, à 11:26

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

C'était rapide avec la manipulation de grub, mais quand je démarre mon PC, on voit l'écran avec le logo de DELL, ensuite écran noir, ecran violet (ubuntu), ecran noir et ecran violet avec apparition du logo ubuntu.. mais c'est long.

Hors ligne

#22 Le 24/10/2018, à 11:28

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

Voici ce que me donne l'analyse

3.262s plymouth-quit-wait.service
          1.418s plymouth-start.service
          1.275s apparmor.service
          1.230s plymouth-read-write.service
           591ms keyboard-setup.service
           500ms upower.service
           426ms dev-sda5.device
           410ms vboxdrv.service
           314ms systemd-logind.service
           287ms udisks2.service
           257ms apport-autoreport.service
           220ms NetworkManager.service
           182ms systemd-fsck@dev-disk-by\x2duuid-EEF5\x2d6002.service
           173ms networkd-dispatcher.service
           167ms systemd-resolved.service
           154ms systemd-journal-flush.service
           148ms systemd-rfkill.service
           143ms accounts-daemon.service
           121ms ModemManager.service
           118ms systemd-hostnamed.service
           115ms thermald.service
           113ms apport.service
           112ms systemd-udevd.service

Hors ligne

#23 Le 24/10/2018, à 12:35

Mornagest

Re : Ubuntu 18 LTS démarre après 10 secondes...

Donne-nous le résultat de cat /etc/default/grub, s'il te plaît. Ça m'étonne que tu n'aies pas les lignes de démarrage du système qui apparaissent sur ton écran.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#24 Le 24/10/2018, à 13:21

grigouille

Re : Ubuntu 18 LTS démarre après 10 secondes...

Il faut avoir ceci :

$ grep noresume /etc/default/grub 
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noresume"

et ensuite

sudo update-grub

Xubuntu 18.04

Hors ligne

#25 Le 24/10/2018, à 17:45

maximeay

Re : Ubuntu 18 LTS démarre après 10 secondes...

(J'avais mis 2 au timeout)

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

J'ai rajouté "noresume" à coté de "quiet splash ICI"
ET voici mon analyze

3.264s plymouth-quit-wait.service
          1.411s plymouth-start.service
          1.269s apparmor.service
          1.220s plymouth-read-write.service
           574ms keyboard-setup.service
           529ms dev-sda5.device
           425ms vboxdrv.service
           365ms rtkit-daemon.service
           358ms systemd-logind.service
           339ms systemd-journal-flush.service
           246ms apport-autoreport.service
           214ms NetworkManager.service
           213ms udisks2.service
           149ms systemd-resolved.service
           146ms networking.service
           142ms systemd-fsck@dev-disk-by\x2duuid-EEF5\x2d6002.service
           132ms networkd-dispatcher.service
           131ms accounts-daemon.service
           120ms upower.service
           119ms systemd-localed.service
           116ms systemd-hostnamed.service
           111ms systemd-udevd.service
           109ms ModemManager.service

Dernière modification par maximeay (Le 24/10/2018, à 17:49)

Hors ligne