Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 08/11/2018, à 22:21

Gil2018

problème APT

Bonsoir
J'ai installé Lubuntu 18.04 il y a quelques jours déjà, à partir d'une Lubuntu 16.04.

Après des problèmes d'installation de skype j'ai tenté pas mal de manips pour finalement arriver à ne plus pouvoir utiliser APT.

quelque soit la commande suivant apt j'obtiens

$> /usr/bin/apt: 1: /usr/bin/apt: y
                                : not found
/usr/bin/apt: 1: /usr/bin/apt: 1: not found
/usr/bin/apt: 1: /usr/bin/apt: /: Permission denied
/usr/bin/apt: 1: /usr/bin/apt: ELF: not found
/usr/bin/apt: 3: /usr/bin/apt: Syntax error: "(" unexpected"

A part ça le système fonctionne plutôt bien pour l'instant, mais je ne peux plus faire d'update et encore moins d'upgrade, ni même installer de nouveaux logiciels.

J'ai tenté de réinstaller Lubuntu avec unetbootin

./unetbootin-linux64-661.bin 
bash: ./unetbootin-linux64-661.bin : impossible d'exécuter le fichier binaire : Erreur de format pour exec()

J'ai bien un clef avec unetBootin et Ubuntu 18.04 (et même 16.04) parfaitement lues mais qui refusent de booter sur cet ordinateur.

Bref je ne sais plus trop quoi faire et j'apprécierais beaucoup quelques suggestions et conseils.

Merci beaucoup d'avance.


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 08/11/2018, à 22:30)

Hors ligne

#2 Le 08/11/2018, à 22:25

Naziel

Re : problème APT

Peux tu donner les commandes exécutées qui ont permis d'arriver à cet état? (pour voir si c'est récupérable en fait). Tu peux taper la commande

history

pour voir précisément ce que tu as lancé

Hors ligne

#3 Le 08/11/2018, à 22:29

Gil2018

Re : problème APT

sudo apt install skype
wget [url]https://repo.skype.com/latest/skypeforlinux-64.deb[/url]
ls
sudo gdebi skypeforlinux-64.deb
/snap/bin/skype
skype
sudo apt update
sudo apt upgrade
sudo apt --fix-broken install
sudo apt autoclean
sudo apt clean
skype
sudo apt update
dpkg -l linux-* | awk '/^ii/{ print $2}' | grep -v -e `uname -r | cut -f1,2 -d"-"` | grep -e [0-9] | grep -E "(image|headers)"  | xargs sudo dpkg --dry-run --remove
dpkg -l linux-* | awk '/^ii/{ print $2}' | grep -v -e `uname -r | cut -f1,2 -d"-"` | grep -e [0-9] | grep -E "(image|headers)"  | xargs sudo dpkg --purge
df -h
sudo apt clean
sudo rm -r /var/cache/apt /var/lib/apt/lists
sudo apt-get update
sudo apt update
sudo rm -r /var/lib/apt/lists/
sudo apt update
sudo apt install skype
sudo rm /usr/bin/apt-get
apt
apt update
sudo apt update
ls /var/lib/apt/lists/
sudo mkdir  /var/lib/apt/lists/
sudo mkdir  /var/lib/apt/lists/partial
apt-get update
sudo apt update
sudo apt install apt

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 08/11/2018, à 22:30)

Hors ligne

#4 Le 08/11/2018, à 22:33

cqfd93

Re : problème APT

C'est sûr qu'avec une telle commande :

sudo rm /usr/bin/apt-get

apt doit marcher beaucoup moins bien…


cqfd93

Hors ligne

#5 Le 08/11/2018, à 22:33

Naziel

Re : problème APT

sudo rm /usr/bin/apt-get

Ah bah voilà

Edit: grillé smile

Vu qu'il n'y a "que" le binaire qui est supprimé, je proposerais bien de déinstaller apt-get puis le réinstaller via dpkg.

Dernière modification par Naziel (Le 08/11/2018, à 22:36)

Hors ligne

#6 Le 08/11/2018, à 22:38

Gil2018

Re : problème APT

apt a commencé à dysfonctionner avant le rm
c'était une commande de désespoir.


Pas de solution miracle ?

Hors ligne

#7 Le 08/11/2018, à 22:42

Naziel

Re : problème APT

Disons que tu as achevé apt avec cette commande.

C'était quoi le message d'erreur avant?

Je cherche le paquet

Hors ligne

#8 Le 08/11/2018, à 22:44

cqfd93

Re : problème APT

Il faudrait télécharger le paquet apt correspondant à la version d'Ubuntu installé et l'installer avec dpkg.

Pour savoir la version d'Ubuntu :

cat /etc/issue
uname -a
echo "${XDG_CURRENT_DESKTOP}"

cqfd93

Hors ligne

#9 Le 08/11/2018, à 22:46

Gil2018

Re : problème APT

honnêtement je ne sais plus exactement le premier message,
mais très vite j'ai eu

[quote]/usr/bin/apt: 1: /usr/bin/apt: y
                                : not found
/usr/bin/apt: 1: /usr/bin/apt: 1: not found
/usr/bin/apt: 1: /usr/bin/apt: /: Permission denied
/usr/bin/apt: 1: /usr/bin/apt: ELF: not found
/usr/bin/apt: 3: /usr/bin/apt: Syntax error: "(" unexpected[/quote]

Dernière modification par Gil2018 (Le 08/11/2018, à 23:00)

Hors ligne

#10 Le 08/11/2018, à 22:49

Gil2018

Re : problème APT

Ubuntu 18.04.1 LTS \n \l
686 i686 GNU/Linux
LXDE

Dernière modification par Gil2018 (Le 08/11/2018, à 23:00)

Hors ligne

#11 Le 08/11/2018, à 22:50

Naziel

Re : problème APT

Si je dis pas de bêtises un lien vers le paquet: http://security.ubuntu.com/ubuntu/pool/ … _amd64.deb
Tu peux le télécharger

Dernière modification par Naziel (Le 08/11/2018, à 22:51)

Hors ligne

#12 Le 08/11/2018, à 22:52

Gil2018

Re : problème APT

l'installateur de paquets m'indique
erreur une version plus récente est déjà installée

Hors ligne

#13 Le 08/11/2018, à 22:53

Naziel

Re : problème APT

Normal, il est pas désinstallé. Donne

dpkg -l | grep apt

Hors ligne

#14 Le 08/11/2018, à 22:53

cqfd93

Re : problème APT

Modération

Bonjour,

Pour ajouter toi-même les balises code à tes messages #9 et #10 :

  • Cliquer sur le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message
    1471986854.png


cqfd93

Hors ligne

#15 Le 08/11/2018, à 22:54

Gil2018

Re : problème APT

ii  apt:amd64                                                   1.6.6                                      amd64        commandline package manager
ii  apt-config-icons                                            0.12.0-3ubuntu1                            all          APT configuration snippet to enable icon downloads
ii  aptdaemon                                                   1.1.1+bzr982-0ubuntu19                     all          transaction based package management service
ii  aptdaemon-data                                              1.1.1+bzr982-0ubuntu19                     all          data files for clients
ii  apturl                                                      0.5.2ubuntu14.2                            i386         install packages using the apt protocol - GTK+ frontend
ii  apturl-common                                               0.5.2ubuntu14.2                            i386         install packages using the apt protocol - common data
ii  laptop-detect                                               0.16                                       all          system chassis type checker
rc  libapt-inst1.5:i386                                         1.0.1ubuntu2.17                            i386         deb package format runtime library
ii  libapt-inst2.0:i386                                         1.6.6                                      i386         deb package format runtime library
ii  libapt-pkg-perl                                             0.1.33build1                               i386         Perl interface to libapt-pkg
rc  libapt-pkg4.12:i386                                         1.0.1ubuntu2.17                            i386         package management runtime library
ii  libapt-pkg5.0:amd64                                         1.6.6                                      amd64        package management runtime library
ii  libapt-pkg5.0:i386                                          1.6.6                                      i386         package management runtime library

Dernière modification par Gil2018 (Le 08/11/2018, à 23:01)

Hors ligne

#16 Le 08/11/2018, à 23:02

Naziel

Re : problème APT

Nickel pour les balises code. Je me suis trompé, je t'ai fait télécharger apt en version 1.6.3 et non 1.6.6. Je vais chercher un lien

Et hop, le bon lien: http://fr.archive.ubuntu.com/ubuntu/poo … _amd64.deb

Je proposerais bien

sudo dpkg -r apt

(je me demande s'il faut aussi purger)

sudo dpkg -i Téléchargements/apt_1.6.6_amd64.deb

mais attends l'avis de cqfd93 sur ces 2 commandes

Dernière modification par Naziel (Le 08/11/2018, à 23:05)

Hors ligne

#17 Le 08/11/2018, à 23:08

Gil2018

Re : problème APT

j'en avais oublié quelques uns, désolé

ii  libmjpegutils-2.1-0                                         1:2.1.0+debian-5                           i386         MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libmpeg2encpp-2.1-0                                         1:2.1.0+debian-5                           i386         MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libmplex2-2.1-0                                             1:2.1.0+debian-5                           i386         MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libpcap0.8:i386                                             1.8.1-6ubuntu1                             i386         system interface for user-level packet capture
rc  libqapt2                                                    2.1.70-0ubuntu4.2                          i386         QApt library package
rc  libqapt2-runtime                                            2.1.70-0ubuntu4.2                          i386         Runtime components for the QApt library
rc  libqapt3-runtime                                            3.0.2-0ubuntu1.1                           i386         Runtime components for the QApt library
ii  libraptor2-0:i386                                           2.0.14-1build1                             i386         Raptor 2 RDF syntax library
ii  python-apt                                                  1.6.3                                      i386         Python interface to libapt-pkg
ii  python-apt-common                                           1.6.3                                      all          Python interface to libapt-pkg (locales)
ii  python-aptdaemon                                            1.1.1+bzr982-0ubuntu19                     all          Python 2 module for the server and client of aptdaemon
ii  python-aptdaemon.gtk3widgets                                1.1.1+bzr982-0ubuntu19                     all          Python 2 GTK+ 3 widgets to run an aptdaemon client
ii  python3-apt                                                 1.6.3                                      i386         Python 3 interface to libapt-pkg
ii  python3-aptdaemon                                           1.1.1+bzr982-0ubuntu19                     all          Python 3 module for the server and client of aptdaemon
ii  python3-aptdaemon.gtk3widgets                               1.1.1+bzr982-0ubuntu19                     all          Python 3 GTK+ 3 widgets to run an aptdaemon client
rc  python3-aptdaemon.pkcompat                                  1.1.1+bzr982-0ubuntu14                     all          PackageKit compatibilty for AptDaemon
ii  scrot                                                       0.8-18                                     i386         command line screen capture utility
ii  synaptic                                                    0.84.3ubuntu1                              i386         Graphical package manager
ii  wakeonlan                                                   0.41-11                                    all          Sends 'magic packets' to wake-on-LAN enabled ethernet adapters
ii  xserver-xorg-input-synaptics                                1.9.0-1ubuntu1                             i386         Synaptics TouchPad driver for X.Org server

Hors ligne

#18 Le 08/11/2018, à 23:10

Gil2018

Re : problème APT

l'installateur de paquets a bien voulu installer le dernier apt.
mais j'ai toujours la même erreur en faisant apt update par exemple.


par ailleurs j'ai toujours des tas de rc dans la liste des paquets.


ii  apt:amd64                                                   1.6.6                                      amd64        commandline package manager
ii  apt-config-icons                                            0.12.0-3ubuntu1                            all          APT configuration snippet to enable icon downloads
ii  aptdaemon                                                   1.1.1+bzr982-0ubuntu19                     all          transaction based package management service
ii  aptdaemon-data                                              1.1.1+bzr982-0ubuntu19                     all          data files for clients
ii  apturl                                                      0.5.2ubuntu14.2                            i386         install packages using the apt protocol - GTK+ frontend
ii  apturl-common                                               0.5.2ubuntu14.2                            i386         install packages using the apt protocol - common data
ii  laptop-detect                                               0.16                                       all          system chassis type checker
rc  libapt-inst1.5:i386                                         1.0.1ubuntu2.17                            i386         deb package format runtime library
ii  libapt-inst2.0:i386                                         1.6.6                                      i386         deb package format runtime library
ii  libapt-pkg-perl                                             0.1.33build1                               i386         Perl interface to libapt-pkg
rc  libapt-pkg4.12:i386                                         1.0.1ubuntu2.17                            i386         package management runtime library
ii  libapt-pkg5.0:amd64                                         1.6.6                                      amd64        package management runtime library
ii  libapt-pkg5.0:i386                                          1.6.6                                      i386         package management runtime library
ii  libmjpegutils-2.1-0                                         1:2.1.0+debian-5                           i386         MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libmpeg2encpp-2.1-0                                         1:2.1.0+debian-5                           i386         MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libmplex2-2.1-0                                             1:2.1.0+debian-5                           i386         MJPEG capture/editing/replay and MPEG encoding toolset (library)
ii  libpcap0.8:i386                                             1.8.1-6ubuntu1                             i386         system interface for user-level packet capture
rc  libqapt2                                                    2.1.70-0ubuntu4.2                          i386         QApt library package
rc  libqapt2-runtime                                            2.1.70-0ubuntu4.2                          i386         Runtime components for the QApt library
rc  libqapt3-runtime                                            3.0.2-0ubuntu1.1                           i386         Runtime components for the QApt library
ii  libraptor2-0:i386                                           2.0.14-1build1                             i386         Raptor 2 RDF syntax library
ii  python-apt                                                  1.6.3                                      i386         Python interface to libapt-pkg
ii  python-apt-common                                           1.6.3                                      all          Python interface to libapt-pkg (locales)
ii  python-aptdaemon                                            1.1.1+bzr982-0ubuntu19                     all          Python 2 module for the server and client of aptdaemon
ii  python-aptdaemon.gtk3widgets                                1.1.1+bzr982-0ubuntu19                     all          Python 2 GTK+ 3 widgets to run an aptdaemon client
ii  python3-apt                                                 1.6.3                                      i386         Python 3 interface to libapt-pkg
ii  python3-aptdaemon                                           1.1.1+bzr982-0ubuntu19                     all          Python 3 module for the server and client of aptdaemon
ii  python3-aptdaemon.gtk3widgets                               1.1.1+bzr982-0ubuntu19                     all          Python 3 GTK+ 3 widgets to run an aptdaemon client
rc  python3-aptdaemon.pkcompat                                  1.1.1+bzr982-0ubuntu14                     all          PackageKit compatibilty for AptDaemon
ii  scrot                                                       0.8-18                                     i386         command line screen capture utility
ii  synaptic                                                    0.84.3ubuntu1                              i386         Graphical package manager
ii  wakeonlan                                                   0.41-11                                    all          Sends 'magic packets' to wake-on-LAN enabled ethernet adapters
ii  xserver-xorg-input-synaptics                                1.9.0-1ubuntu1                             i386         Synaptics TouchPad driver for X.Org server

Hors ligne

#19 Le 08/11/2018, à 23:15

cqfd93

Re : problème APT

Donne les retours complets de :

sudo apt update
sudo apt full-upgrade

Un retour complet doit contenir toutes les lignes depuis celle de la commande jusqu'à la ligne attendant la commande suivante, exemple :

moi@lenovo:~$ uname -a
Linux moi-lenovo 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
moi@lenovo:~$

cqfd93

Hors ligne

#20 Le 08/11/2018, à 23:18

Gil2018

Re : problème APT

ok, désolé.

gil@ligil:~$sudo apt update
/usr/bin/apt: 1: /usr/bin/apt: y
                                : not found
/usr/bin/apt: 1: /usr/bin/apt: 1: not found
/usr/bin/apt: 1: /usr/bin/apt: /: Permission denied
/usr/bin/apt: 1: /usr/bin/apt: ELF: not found
/usr/bin/apt: 3: /usr/bin/apt: Syntax error: "(" unexpected


gil@ligil:~$sudo apt full-upgrade
/usr/bin/apt: 1: /usr/bin/apt: y
                                : not found
/usr/bin/apt: 1: /usr/bin/apt: 1: not found
/usr/bin/apt: 1: /usr/bin/apt: /: Permission denied
/usr/bin/apt: 1: /usr/bin/apt: ELF: not found
/usr/bin/apt: 3: /usr/bin/apt: Syntax error: "(" unexpected
gil@ligil:~$

Hors ligne

#21 Le 08/11/2018, à 23:28

Naziel

Re : problème APT

@cqfd93: est ce que les commandes du 16 sont bonnes ou faut il purger?

Hors ligne

#22 Le 08/11/2018, à 23:36

cqfd93

Re : problème APT

Naziel a écrit :

@cqfd93: est ce que les commandes du 16 sont bonnes ou faut il purger?

Pour supprimer un paquet avec dpkg, je fais plutôt

sudo dpkg -P lepaquet

Sinon, pour l'installation, si le nom du paquet est bon, la commande est bonne.

Mais on a :

686 i686 GNU/Linux

c'est donc un Lubuntu 32 bits ? Il faudrait donc installer la version 32 bits de apt.

Et on n'a pas eu les retours de tes commandes, on ne sait donc pas comment ça s'est passé.


cqfd93

Hors ligne

#23 Le 08/11/2018, à 23:37

Naziel

Re : problème APT

Ok, je crois que i686 c'est du 64 bits mais je connais pas la différence avec amd64
i386 c'est le 32 bits

Edit: effectivement, i686 j'ai trouvé pas mal de référence au 32 bits

Dernière modification par Naziel (Le 08/11/2018, à 23:40)

Hors ligne

#24 Le 08/11/2018, à 23:39

Gil2018

Re : problème APT

c'est bien un 64 bits.

Je lance les commandes de Naziel ?

dois-je rebooter ?

Hors ligne

#25 Le 08/11/2018, à 23:44

cqfd93

Re : problème APT

Donne les retours des commandes !


cqfd93

Hors ligne