Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/05/2019, à 18:30

mortim2

probléme sur le jeux league of legend

bonjours,
je vous demande a l'aide par ce que j'ai un probleme pour jouer a lol, j'ai regarder des sites mais je n'arrive pas a comprendre comment faire pour que mon jeu marche.
Voici le site que j'ai trouver : https://bugs.winehq.org/show_bug.cgi?id=47198
https://www.reddit.com/r/leagueoflinux/ … ine_46_w7/

merci de votre aider.

Hors ligne

#2 Le 28/05/2019, à 16:37

mortim2

Re : probléme sur le jeux league of legend

Bonjour, je ne sais pas comment faire pour faire une commande.

nathan@nathan-X556UQ:~$ sudo lxc-attach -n ubuntu32 -- apt install build-essential autotools-dev autoconf debhelper docbook-to-man  docbook-utils docbook-xsl fontforge libacl1-dev libasound2-dev libavcodec-dev libcapi20-dev libcups2-dev libdbus-1-dev libfontconfig1-dev libfreetype6-dev libgl1-mesa-dev libglu1-mesa-dev libgnutls28-dev libgphoto2-dev gcc-8 libgsm1-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgtk-3-dev libice-dev libkrb5-dev liblcms2-dev libldap2-dev libldap-dev libmpg123-dev libncurses5-dev libopenal-dev libosmesa6-dev libpcap-dev libpulse-dev libsane-dev libsdl2-dev libssl-dev libudev-dev libv4l-dev libva-dev libxcomposite-dev libxcursor-dev libxi-dev libxinerama-dev libxml2-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev prelink sharutils unixodbc-dev bison flex gawk quilt rdfind symlinks gperf systemtap-sdt-dev libaudit-dev libcap-dev libselinux-dev g++-7-multilib
[sudo] Mot de passe de nathan : 
lxc-attach: ubuntu32: attach.c: lxc_attach: 1095 Failed to get init pid

je vous presente les commandes que je souhaite faire :

# Install build dependencies for 64-bit
sudo apt update
sudo apt install -y build-essential autotools-dev autoconf debhelper docbook-to-man  docbook-utils docbook-xsl fontforge libacl1-dev libasound2-dev libavcodec-dev libcapi20-dev libcups2-dev libdbus-1-dev libfontconfig1-dev libfreetype6-dev libgl1-mesa-dev libglu1-mesa-dev libgnutls28-dev libgphoto2-dev gcc-8 libgsm1-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgtk-3-dev libice-dev libkrb5-dev liblcms2-dev libldap2-dev libldap-dev libmpg123-dev libncurses5-dev libopenal-dev libosmesa6-dev libpcap-dev libpulse-dev libsane-dev libsdl2-dev libssl-dev libudev-dev libv4l-dev libva-dev libxcomposite-dev libxcursor-dev libxi-dev libxinerama-dev libxml2-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev prelink sharutils unixodbc-dev bison flex gawk quilt rdfind symlinks gperf systemtap-sdt-dev libaudit-dev libcap-dev libselinux-dev g++-7-multilib

mkdir ~/build

# Download and build glibc
cd ~/build
wget [url]http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/glibc_2.27-3ubuntu1.dsc[/url]
wget [url]http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/glibc_2.27.orig.tar.xz[/url]
wget [url]http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/glibc_2.27-3ubuntu1.debian.tar.xz[/url]
dpkg-source -x glibc_2.27-3ubuntu1.dsc
cd glibc-2.27
curl '[url]https://bugs.winehq.org/attachment.cgi?id=64482[/url]' | patch -p1
DEB_BUILD_OPTIONS=nocheck dpkg-buildpackage -b -us -uc

# Download and build wine
cd ~/build
wget [url]https://dl.winehq.org/wine-builds/ubuntu/dists/bionic/main/source/wine-staging_4.8~bionic.dsc[/url]
wget [url]https://dl.winehq.org/wine-builds/ubuntu/dists/bionic/main/source/wine-staging_4.8~bionic.orig.tar.gz[/url]
wget [url]https://dl.winehq.org/wine-builds/ubuntu/dists/bionic/main/source/wine-staging_4.8~bionic.diff.gz[/url]
dpkg-source -x wine-staging_4.8~bionic.dsc
cd wine-staging-4.8~bionic
curl '[url]https://bugs.winehq.org/attachment.cgi?id=64481[/url]' | patch -p1
curl '[url]https://bugs.winehq.org/attachment.cgi?id=64496[/url]' | patch -p1
dpkg-buildpackage -b -us -uc

# Create 32-bit LXC container
sudo apt install -y lxc lxc-templates debootstrap
sudo lxc-create -t ubuntu -n ubuntu32 -- --bindhome $LOGNAME -a i386 -r bionic
sudo lxc-start -n ubuntu32

# Install build dependencies and build for 32-bit
sudo lxc-attach -n ubuntu32 -- apt install build-essential autotools-dev autoconf debhelper docbook-to-man  docbook-utils docbook-xsl fontforge libacl1-dev libasound2-dev libavcodec-dev libcapi20-dev libcups2-dev libdbus-1-dev libfontconfig1-dev libfreetype6-dev libgl1-mesa-dev libglu1-mesa-dev libgnutls28-dev libgphoto2-dev gcc-8 libgsm1-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgtk-3-dev libice-dev libkrb5-dev liblcms2-dev libldap2-dev libldap-dev libmpg123-dev libncurses5-dev libopenal-dev libosmesa6-dev libpcap-dev libpulse-dev libsane-dev libsdl2-dev libssl-dev libudev-dev libv4l-dev libva-dev libxcomposite-dev libxcursor-dev libxi-dev libxinerama-dev libxml2-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev prelink sharutils unixodbc-dev bison flex gawk quilt rdfind symlinks gperf systemtap-sdt-dev libaudit-dev libcap-dev libselinux-dev g++-7-multilib
sudo lxc-attach -n ubuntu32 -- sh -c 'cd ~/build/glibc-2.27; DEB_BUILD_OPTIONS=nocheck dpkg-buildpackage -b -us -uc'
sudo lxc-attach -n ubuntu32 -- sh -c 'cd ~/build/wine-staging-4.8~bionic; dpkg-buildpackage -b -us -uc'

# Install Wine packages and 32-bit libc packages
sudo dpkg -i --force-overwrite ~/build/libc6-i386_2.27-3ubuntu1_amd64.deb ~/build/libc6_2.27-3ubuntu1_i386.deb
sudo apt install -y ~/build/winehq-staging_4.8~bionic_amd64.deb ~/build/wine-staging_4.8~bionic_amd64.deb ~/build/wine-staging-amd64_4.8~bionic_amd64.deb ~/build/wine-staging-i386_4.8~bionic_i386.deb

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 28/05/2019, à 19:18)

Hors ligne

#3 Le 28/05/2019, à 17:13

nam1962

Re : probléme sur le jeux league of legend

Euhhh...
Quel est l'objectif ?
Où as-tu pêché ce gloubi boulga ?


[ Modéré ]

Hors ligne

#4 Le 28/05/2019, à 17:15

mortim2

Re : probléme sur le jeux league of legend

c'est pour refaire marcher mon lol
je l'ai trouver sur ce site : https://www.reddit.com/r/leagueoflinux/ … ld_script/

Hors ligne

#5 Le 28/05/2019, à 17:19

nam1962

Re : probléme sur le jeux league of legend

La doc Ubuntu est incomplète ? --> leagueoflegends


[ Modéré ]

Hors ligne

#6 Le 28/05/2019, à 17:40

mortim2

Re : probléme sur le jeux league of legend

Mais il faut faire quoi? en vrai je ne vois pas se que je dois faire

Hors ligne

#7 Le 28/05/2019, à 18:36

sergei_ruskof

Re : probléme sur le jeux league of legend

il y a une version qui marcherait sur lutris mais cela requiert un carte graphique compatible vulkan:

https://lutris.net/games/league-of-legends/

Hors ligne