Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/07/2019, à 19:59

kurnous

Gros problème Kdenlive

Hello tout le monde,
J'ai un énorme problème avec Kdenlive aujourd'hui.
Je bosse sur une vidéo depuis hier, un gros truc sur lequel j'ai déjà passé je ne sais combien d'heure.
Tout à l'heure kdenlive à merder et je l'ai fermé pour le réouvrir.
Depuis il m'est impossible d'ouvrir le projet, il m'annonce que des transitions ne sont pas valables et sont supprimées, j'appuie sur OK et le programme se ferme.
J'utilise l'appimage 18.12.1, même chose avec une en 19.04 et une installation via les dépot en 17.12. Le tout sous Ubuntu 18.04.
J'ai essayé d'aller supprimer manuellement les transitions dans le projet mais ça ne se lance pas non plus, le programme se ferme direct.
Si quelqu'un sait quoi faire.

Hors ligne

#2 Le 03/07/2019, à 20:58

JiPi_82

Re : Gros problème Kdenlive

J'utilise depuis longtemps KdenLive. Mon expérience c'est que l'appimage n'est pas la meilleure solution. J'ai testé et j'ai eu des surprises et pas des meilleures. Bref, j'ai installé Kdenlive depuis le dépôt de Ubuntu et j'ai complété l'installation en passant pas synaptic. En fait, il faut TOUJOURS compléter les applications développées pour KDE par les utilitaires et compléments kde. A commencer par les thèmes, les traductions.
Rien de tel que de passer par synaptic pour optimiser l'installation de kdenlive.
Ensuite, les fichiers générés par kdenlive sont des scripts qu'on peut corriger à la main par l'éditeur de texte (j'ai jamais fait, mais j'ai vu que c'est possible).
Mis à part quelques trucs étranges qui peuvent arrivés, je n'ai pas de bug.
Ne pas hésiter à faire des sauvegarde quand on manipule pendant trop longtemps des séquences. J'ai aussi remarqué, qu'il faut mieux couper son travail toutes les 3 heures en quittant proprement le logiciel. Prendre une bonne pause, puis relancer le montage.
Donc, pour te dépanner, je dirai : vire l'AppImage et installe kdenlive en propre, complète par les compléments KDE et ça devrait tourner.


UBUNTU 18.04.1 LTS 64 bits
Intel® Core™ i5-3570 | Mémoire : 16 Gio DDR3 1600 PC12800 | Chipset Z77
Disque : SSD 500 Go - HHD 2x1 To + 2 To | GForce 1050 HDMI 1920x1080 + DisplayPort 3840x2160
Chaîne YouTube : 82jipi

Hors ligne

#3 Le 03/07/2019, à 21:07

kurnous

Re : Gros problème Kdenlive

Cela ne change rien, j'ai essayé sur une installation propre sous une machine virtuelle kubuntu et le problème est le même.
Une fois j'avais pu corriger le fichier à la main mais là je ne trouve pas.

Hors ligne

#4 Le 03/07/2019, à 21:14

JiPi_82

Re : Gros problème Kdenlive

Le problème peut provenir d'un éventuel déplacement de fichiers source (je postule ça, mais j'ai des doutes).
J'ai eu, un jour ce type de soucis avec un problème de pilote vidéo. A priori, un conflit d'adressage mémoire.


UBUNTU 18.04.1 LTS 64 bits
Intel® Core™ i5-3570 | Mémoire : 16 Gio DDR3 1600 PC12800 | Chipset Z77
Disque : SSD 500 Go - HHD 2x1 To + 2 To | GForce 1050 HDMI 1920x1080 + DisplayPort 3840x2160
Chaîne YouTube : 82jipi

Hors ligne

#5 Le 03/07/2019, à 21:15

kurnous

Re : Gros problème Kdenlive

Non ce n'est pas ça. Les fichiers n'ont pas bougé.
J'ai aussi fait l'essai en copiant tout sur un dd externe pour tester sur mon portable, même résultat.

Hors ligne

#6 Le 04/07/2019, à 07:08

JiPi_82

Re : Gros problème Kdenlive

J'ai constaté aussi que les fichiers images en png trop volumineuses créent des plantages systématique. Il faut toujours resté en dessus de 800 ko en png avec une définition de 150 px/pouce. Ce problème est encore apparu hier. J'ai réduit et substitué les images à insérer, et plus de bug.


UBUNTU 18.04.1 LTS 64 bits
Intel® Core™ i5-3570 | Mémoire : 16 Gio DDR3 1600 PC12800 | Chipset Z77
Disque : SSD 500 Go - HHD 2x1 To + 2 To | GForce 1050 HDMI 1920x1080 + DisplayPort 3840x2160
Chaîne YouTube : 82jipi

Hors ligne

#7 Le 04/07/2019, à 07:18

kurnous

Re : Gros problème Kdenlive

Perso je n'ai jamais eu de problème avec les images et ici ce n'est pas la source du problème.

Hors ligne

#8 Le 04/07/2019, à 09:28

kurnous

Re : Gros problème Kdenlive

Je pense que c'est reparti !
Après avoir lancé le soft dans un terminal pour voir les erreur j'ai eu plusieurs choses dont la première ligne : WARNING, FOUND UNKNOWN PRODUDER:  "producer0"  ----------------
qui m'a donné un résultat dans Google : https://forum.kde.org/viewtopic.php?f=265&t=155982
J'ai par l'occasion découvert un outil pour analyser les fichiers de projet. Si je n'ai pas tout compris à l'analyse, j'ai tenté la correction que le gars à fait à savoir supprimer une ligne <track producer="overlay_track" hide="audio"/>
Le projet s'ouvre, quelques transitions ont disparus ou sont raccourcies, des images sont décalées mais ça s'ouvre. Plus qu'à tout remettre en ordre et espérer que ça ira ensuite smile

Hors ligne