Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/08/2019, à 13:19

Vincent_57

[RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonjour à tou-te-s,

J'ai modifié le grub sur mon ordi portable Toshiba Satellite C855-21Q après avoir fouillé sur les forums pour pouvoir régler le rétroéclairage - les touches au clavier ne font rien, rien non plus du côté des paramètres.
Sur la ligne finissant par « quiet splash nomodeset », j'ai remplacé « nomodeset » par « acpi_backlight=vendor », puis j'ai mis à jour le grub.

Bilan des courses :
- au démarrage, l'écran « constructeur » (« Toshiba »...) apparaît ;
- puis écran noir
- puis écran (presque) blanc
- puis écran genre patchwork pointilliste contemporain (de très mauvais goût) que l'ordi semble ne pas apprécier non plus : il disparaît, en passant par un écran très brièvement jaune, puis noir plus longtemps, avant de revenir, et ainsi plusieurs fois, avant de sembler se fixer sur l'écran « patchwork ».

Ordi inutilisable, donc. Par chance j'en ai un deuxième (même distri ; Samsung NC110), mais firefox beugue rapidement (un script le fait planter au bout d'un certain temps d'utilisation, surtout en utilisant gmail, mais c'est une autre histoire).

Dans les paramètres de mon FAI (media acces gateway), si j'allume le toshiba et le branche sur le modem par câble éthernet, je le vois apparaître. Mais je ne trouve pas de moyen de m'y connecter depuis le samsung (et ça m'soûle!), par ex. en SSH (j'ai découvert ça hier, je suis donc grand débutant!), pour remodifier le grub... C'est une bonne idée ?

Help! Je prends tout conseil - surtout s'il est bon ! ;o)

Merci d'avance, tout de bon à vous.
Vincent

Dernière modification par Vincent_57 (Le 14/09/2019, à 12:03)

Hors ligne

#2 Le 08/08/2019, à 15:15

geole

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonjour
Boote en mode recovery  https://doc.ubuntu-fr.org/recovery_mode   et rajoute nomodeset  puisque cela fonctionnait avec assez bien

Hors ligne

#3 Le 09/08/2019, à 09:23

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonjour et merci geole.

J'ai suivi ton conseil et lancé le démarrage en mode recovery.
Ensuite probablement du texte, en blanc, mais en mode « canal+ en crypté », illisible, défile sur un écran noir, sur la moitié supérieure de l'écran uniquement.

Apparaît ensuite un fond bleu (toujours sur la moitié sup de l'écran seulement) avec une sorte de tableau gris pâle ou blanc avec probablement du texte en noir et un bandeau rouge d'un demi-centimètre, placé vers le haut du tableau, qui descend ou remonte quand j'utilise les flèches du clavier. Totalement illisible. Cf. photo :

1565371355.jpg

Il paraît que la carte graphique a du plomb dans l'aile. :o/

En espérant que vous ayez encore des ressources pour m'aider. Cheers !
Vincent

Dernière modification par Vincent_57 (Le 09/08/2019, à 18:26)

Hors ligne

#4 Le 09/08/2019, à 09:26

xubu1957

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonjour,

Fournis le noyau actif :

uname -a

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 09/08/2019, à 09:54

inbox

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Salut,

Vu que depuis que tu enlevé l'option nomodeset, tu rencontres ces problèmes d'affichage, redémarre avec nomodeset et donne le retour de :

lspci
lsmod

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#6 Le 09/08/2019, à 10:07

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Merci xubu1957 & inbox.

J'ai dû manquer de clarté dans mon message précédent : l'affichage est absolument illisible, je ne peux donc rien faire, une fois passé l'écran écrit en blanc sur fond noir du grub. Voyez l'image du billet ci-dessus.

Donc pas accès à une console, rien, nada, tchipette, walou !

sad

Hors ligne

#7 Le 09/08/2019, à 10:19

geole

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonjour
Pour remettre l'option, Il faut  que tu  suives les consignes du paragraphe 7.3 de cette documentation. https://doc.ubuntu-fr.org/kernel#modifi … sur_disque

Dernière modification par geole (Le 09/08/2019, à 10:19)

Hors ligne

#8 Le 09/08/2019, à 10:58

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Oui, j'avais commencé à regarder pour faire une clé usb live.
Je viens d'en retrouver une déjà prête avec la version 17.04. 1er test : l'ordi ne boote pas sur la clé. Grmpf. « USB » figure en deuxième position après « ODD » pour le démarrage et avant HDD (à ce stade du grub - en appuyant sur echap au démarrage - l'affichage est ok). J'ai mis la surbrillance sur USB et appuyé sur Entrée... et il boote « normalement », càd. anormalement.

Voici une photo de l'écran d'accueil de Lubuntu (interface XFCE, mais à ce point, on s'en fout...), où je suis censé choisir la session :
1565370526.jpg

Youpi. sad

...

Dernière modification par Vincent_57 (Le 09/08/2019, à 17:48)

Hors ligne

#9 Le 09/08/2019, à 11:41

inbox

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Une chose que je viens de remarquer, tu utilises une iso de la 16.04. Il faudrait que tu essayes plutôt avec la version LTS actuelle, soit la 18.04.1.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#10 Le 09/08/2019, à 13:50

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Ok merci inbox, je suis en train de télécharger l'iso.

Du nouveau : dans le grub, après avoir appuyé sur echap au démarrage, j'ai placé la surbrillance sur démarrage normal puis j'ai appuyé sur e. J'ai trouvé la ligne que j'ai modifiée et ai remis « nomodeset » là où c'était, en supprimant mon ajout malencontreux.

Résultat peu satisfaisant... c'est un euphémisme.
C'est comme si l'affichage se faisait, toujours et encore, grosso modo sur la moitié sup de l'écran et si l'écran se répétait 4 ou 5 fois de gauche à droite. J'ai noté ça lors de l'affichage - indevinable par ailleurs, car le texte est illisible - de l'écran bleu avec le mot Lubuntu et les points blancs s'allumant successivement en dessous pendant le chargement. Ce sont précisément ces points qui m'ont mis la puce à l'oreille, ils apparaissent à plusieurs endroits.

Ça avance... mais l'ordi est toujours inutilisable. Dès que le téléchargement de l'iso sera fini (que c'est long !!! marre des ordi qui rament!), que la clé live sera créée et que j'aurai testé sur le toshiba, je reviens vers vous.

Hors ligne

#11 Le 09/08/2019, à 14:39

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

C'est fait. L'ordi ne boote pas sur la clé live. Comment faire pour l'y contraindre ?

Truc bizarre : je vous disais, l'écran tout bleu avec écrit Lubuntu et les points blancs du chargement s'affichait de manière erronée dans ma description précédente. Le grub n'a pas gardé ma rectification, puisque cet écran n'apparaît plus et je retrouve le « patchwork » du début.
En revanche, quand j'éteins l'ordi (une chance : j'avais paramétré le bouton on/off de telle manière que l'ordi s'éteigne lors d'une simple pression, sans demander de confirmation), l'écran Lubuntu aux points blancs s'affiche normalement, sans les stries, la démultiplication, le « cryptage canal+ »...

Ouate de phoque ?

Merci encore...

Hors ligne

#12 Le 09/08/2019, à 15:20

cqfd93

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Modération : merci de respecter les règles du forum : l'usage des liens raccourcis est interdit (donc modifier les liens des messages 3 et 8).

Et pour les images, utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).


cqfd93

Hors ligne

#13 Le 09/08/2019, à 15:50

inbox

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Il semble qu'il faille appuyer sur F12 au démarrage pour pouvoir booter sur USB.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#14 Le 09/08/2019, à 17:34

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

@cqfd93 : toutes mes excuses, je corrige.

@ inbox : je viens de tester F12... j'arrive au même écran du menu de démarrage qu'avec échap. À partir de là, je ne sais pas quoi faire. Voici ce qui apparaît (je mets de côté le descriptifs du matériel associé) :

1. ODD
2. USB
3. HDD/SSD
4. Réseau
<Entrée Setup>

Quand je fais entrée sur USB... il part sur le démarrage classique... vérolé.

Hors ligne

#15 Le 09/08/2019, à 17:40

mikedafunk

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonsoir,
Tu as désactivé le secure boot dans la bios ?


Lubuntu 14.04 sur Eeepc 2 Go.  Tu veux de l'aide physique ?
Pense à la  liste des GUL ou aux parrains linux | mon blog : http://mikedafunk.over-blog.org/
Mike, informaticien Bisontin dans un lycée à SLM en Guyane

Hors ligne

#16 Le 09/08/2019, à 18:28

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonsoir Mikedafunk,

Non, comment puis-je faire ça ? Merci !

Hors ligne

#17 Le 09/08/2019, à 18:32

mikedafunk

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Tu peux aussi chercher dans google avant de poser des questions...  wink
https://lecrabeinfo.net/desactiver-secu … -uefi.html


Lubuntu 14.04 sur Eeepc 2 Go.  Tu veux de l'aide physique ?
Pense à la  liste des GUL ou aux parrains linux | mon blog : http://mikedafunk.over-blog.org/
Mike, informaticien Bisontin dans un lycée à SLM en Guyane

Hors ligne

#18 Le 09/08/2019, à 18:36

ylag

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonsoir,

Concernant le commentaire #14, il se pourrait bien que la clé liveUSB soit répertoriée sous la rubrique HDD/SSD.

A+

Dernière modification par ylag (Le 09/08/2019, à 18:37)

Hors ligne

#19 Le 09/08/2019, à 18:41

mikedafunk

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Tout à fait, dans le bios certaines clés usb apparaissent comme des disques durs, il est possible de changer la priorité d'amorçage et d'enregistrer le changement pour que l'ordi démarre toujours sur la clé.
Si on démarre sans la clé, le bios remet le disque interne par défaut...


Lubuntu 14.04 sur Eeepc 2 Go.  Tu veux de l'aide physique ?
Pense à la  liste des GUL ou aux parrains linux | mon blog : http://mikedafunk.over-blog.org/
Mike, informaticien Bisontin dans un lycée à SLM en Guyane

Hors ligne

#20 Le 09/08/2019, à 18:45

ylag

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Salut,

Il devrait être possible de sélectionner la clé liveUSB directement dans le sous-menu HDD/SSD, sans avoir à changer la priorité d'amorçage dans la configuration du bios?
C'est ce que je fais sur ma machine, un ordinosaure datant de 2009 avec un bios très ancien: ça fonctionne au poil et les liveUSB y appararaîssent comme des HDD-USB, ou quelque chose de semblable.
Peut-être possible sur la machine de @Vincent_57 ?

A+

Dernière modification par ylag (Le 09/08/2019, à 18:52)

Hors ligne

#21 Le 09/08/2019, à 18:53

mikedafunk

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Probablement, mais mon message était en complément de ton premier message...


Lubuntu 14.04 sur Eeepc 2 Go.  Tu veux de l'aide physique ?
Pense à la  liste des GUL ou aux parrains linux | mon blog : http://mikedafunk.over-blog.org/
Mike, informaticien Bisontin dans un lycée à SLM en Guyane

Hors ligne

#22 Le 09/08/2019, à 19:37

ylag

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

Bonsoir,

mikedafunk a écrit :

Probablement, mais mon message était en complément de ton premier message...

Aucun problème smile
Il faudrait avoir un retour de @Vincent_57 pour voir s'il arrive à démarrer son liveUSB de cette façon.

A+

Hors ligne

#23 Le 09/08/2019, à 19:47

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

@mikedafunk : j'ai passé la journée sur les forums pour régler ce schmilblick, j'ai les yeux carrés... alors oui, j'ai opté (sans même y penser) pour le plus simple : y a des gens qui savent et qui ont déjà des bons plans. smile Merci les gars et les filles !

@ylag : j'y aurais pas pensé ! Je viens de faire un test, quand je clique sur HDD/SSD, il ouvre une petite fenêtre avec deux options : ubuntu (en minuscules) et Ubuntu (avec une maj.). Le second démarre sur le boot habituel. Le premier apporte une petite nuance : avant l'écran « patchwork » est apparu subrepticement un écran jaune (au lieu du bleu) avec écrit Lubuntu lisiblement, quoique avec un affichage (couleur notam.) très altéré...

Je regarde pour le bios, mais ne sais pas sur quelle touche je dois appuyer pendant le démarrage pour l'atteindre... Comme je boycotte gougueule, je vais demander à duckduckgo. wink

Hors ligne

#24 Le 09/08/2019, à 20:56

Vincent_57

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

F2 pour accéder au bios. Le démarrage sécurisé est déjà désactivé. J'ai remonté HDD/SSD en pole position. Rien de neuf, ne boote toujours pas sur la clé.

Ensuite, trouvé ça :
Désactiver secure boot sur toshiba
Dans l'onglet Avancés > Configuration du système, « Démarrage UEFI » modifié en « Démarrage CSM ». F10 pour sauver et quitter et... écran noir. Il n'affiche même plus « Toshiba » au démarrage. sad

Après plusieurs essais (impossible de revenir au bios), devant l'écran noir, j'ai appuyé sur échap : la DEL de la clé usb s'est mise à clignoter. Idem avec les touches F. Donc il semblerait qu'il a démarré sur la clé. Manque « juste » l'affichage, ou au moins le rétroéclairage.

Pas encore ça.

Si j'avais pu retourner dans le bios, j'aurais aussi essayé ça (même lien que plus haut) :

Allez dans l'onglet Avancés, désactivez l'option Technologie EDB (DEP)

Si vous voulez les images des différentes étapes, j'ai pris des photos. Sauf de mon reflet soupirant dans l'écran noir...

Allez, bonne nuit et merci encore.

Hors ligne

#25 Le 09/08/2019, à 21:09

mikedafunk

Re : [RÉSOLU][Lubuntu 16.04LTS] Gros pb d'affichage écran suite modif. grub

T'as pas un GUL qui pourrait t'aider près de chez toi ? cf ma signature..


Lubuntu 14.04 sur Eeepc 2 Go.  Tu veux de l'aide physique ?
Pense à la  liste des GUL ou aux parrains linux | mon blog : http://mikedafunk.over-blog.org/
Mike, informaticien Bisontin dans un lycée à SLM en Guyane

Hors ligne