Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 07/04/2008, à 12:06

Compte0

Pb ACPI démarrage

Je viens d'installé Hardy sur mon portable (sony vaio vgn-c2z). Au démarrage, j'ai:

[   15.024810] ACPI: EC: acpi_ec_wait timeout,status = 0,expect_event=1
[   15.024878] ACPI: EC:read timeout, command =128

Le mode recovery marche avec les mêmes noyaux. J'ai solutionné, en partie, le problème en ajoutant acpi=off, je peux donc démarré, mais l'ordinateur ne s'éteint plus, ce qui n'était pas le cas avec le mode recovery.

Quelqu'un a une idée ? merci d'avance.


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#2 Le 07/04/2008, à 17:50

Compte0

Re : Pb ACPI démarrage

Personne ?


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#3 Le 07/04/2008, à 18:30

Adhémar

Re : Pb ACPI démarrage

J'ai eu le même problème. Il était présent sur le noyau 2.6.24-13, résolu sur le 2.6.24-14, et il est de retour sur le 2.6.24-15. J'ai pas de fix sérieux à ce problème. J'ai juste remarqué que:
- si tu démarre ton ordi sur batterie, le problème ne se pose pas...
- si tu démarre en mode recovery, et qu'ensuite tu choisis un boot normal, le problème ne se pose plus.

Je crois que le bug est connu sur le launchpad.

Adhémar

Hors ligne

#4 Le 07/04/2008, à 20:55

Compte0

Re : Pb ACPI démarrage

ok, merci.

J'ai trouvé une autre solution en ajoutant apci=force dans les defoption de grub.lst.


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#5 Le 22/04/2008, à 22:18

bakurt

Re : Pb ACPI démarrage

Hep même pc, même problème.

En plus de ca, j'ai des problèmes de carte graphique. Je vais pouvoir m'amuser.
Si je trouve (autrement qu'en recompilant le noyau) je fais savoir wink

Hors ligne

#6 Le 23/04/2008, à 08:03

Jerjerod

Re : Pb ACPI démarrage

Salut,
Idem. Exactement le même problème au boot. je précise que le problème est identique que le portable soit sur batterie ou sur secteur.

#7 Le 24/04/2008, à 10:51

oswald-p

Re : Pb ACPI démarrage

+1

Sony VGN C2Z qui marche parfaitement bien sous Gutsy mad

On est mal...

O-p


Chuck Norris a terrassé Prince de Lu avec un cookie

Hors ligne

#8 Le 24/04/2008, à 11:01

Compte0

Re : Pb ACPI démarrage

J'ai plus ce pb récement, essaye avec acpi=force et globalement mes remarques sont le même que celles de Adhémar.

Vous avez le bug dans le launchpad???


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#9 Le 24/04/2008, à 16:50

korbé

Re : Pb ACPI démarrage

Même problème sur Vaio  VGN-FE48E + wifi qui fonctionne pas.

J'avait les même problème sous la beta ( sauf que le wifi fonctionnait mais sauf quand on fesait trop monter le debit) mais je retrouve plus mes deux topiques.

Du coup je retourne en 7.10 en attendan.


Fais ce que bon te semble, mais ne fais de mal à personne.
Défends toi, mais ne deviens pas ton agresseur.
La force aide la faiblesse, elle ne l'asservit pas.

Hors ligne

#10 Le 24/04/2008, à 18:11

Jouiedf

Re : Pb ACPI démarrage

tu peux me dire comment tu rajoutes apci=force dans grub.lst ?
je ne trouve même pas le fichier grub.lst !!

#11 Le 24/04/2008, à 20:21

javofra

Re : Pb ACPI démarrage

j'ai essayé acpi=force cela ne marche pas.
qu'est-ce que je peux faire ?

J'ai aussi un Vaio VGN-N38Z

Dernière modification par javofra (Le 24/04/2008, à 20:21)

Hors ligne

#12 Le 24/04/2008, à 22:30

Compte0

Re : Pb ACPI démarrage

@ jouiedf

tu édite le fichier de préférence de grub

sudo gedit /boot/grub/menu.lst

tu trouve la ligne qui contient

defoption

et tu ajoutes acpi=force, au pire du pire, acpi=off (mais là tu coupes toute gestion du la vitesse du proc, de la batterie... :-\ ) Puis tu mets à jour, grub

sudo update-grub

Normalement, c'est bon. Après il nous faudra attendre le noyaux .25 pour avoir une bonne gestion de l'acpi pour sony...


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#13 Le 25/04/2008, à 09:30

fredoche35

Re : Pb ACPI démarrage

Quand je fais le "update-grub", mon fichier "/boot/grub/menu.lst" ne contient plus le acpi=force ? Il revient à son état initial (option en commentaire)

Hors ligne

#14 Le 25/04/2008, à 09:47

fredoche35

Re : Pb ACPI démarrage

Au temps pour moi !
En fait, le "#" devant defoptions doit rester, ce n'est pas vraiment un commentaire !!!

Par contre, le "force" ne fonctionne pas pour moi (VAIO VGN-N21Z), je l'ai donc passé à "off" pour le moment.

Hors ligne

#15 Le 25/04/2008, à 09:47

Compte0

Re : Pb ACPI démarrage

Il ne faut pas retirer le commentaire devant defoption. Si ça marche tjrs pas vérifie qu'il ne s'est pas automatiquement mit en fin de ligne sur les systèmes présents


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#16 Le 25/04/2008, à 16:07

javofra

Re : Pb ACPI démarrage

c'est bien comme ceci qu'il faut faire ?

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash acpi=force

help !

Dernière modification par javofra (Le 25/04/2008, à 16:08)

Hors ligne

#17 Le 26/04/2008, à 22:35

Compte0

Re : Pb ACPI démarrage

oui, c'est ça.


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne

#18 Le 28/04/2008, à 18:09

chris.fox

Re : Pb ACPI démarrage

je n'ai pas argumenté avec acpi "force" ou "off" sur mon vaio vgn-c2z,
par contre suite à la lecture d'un forum sur le noyau 2.6.24,
j'ai lu qu'il fallait retirer "quiet" et "splash" à la fin de la ligne, et çà marche, à rien y comprendre.
hmm

#19 Le 29/04/2008, à 17:36

Adhémar

Re : Pb ACPI démarrage

D'après ce que j'ai compris, l'explication vient du fait que au démarrage, le kernel va réaliser interroger l'acpi sur l'état des batteries, puis peu de temps après il va utiliser des fonctions liées à de l'acpi. Le bug arrive quand tu lances la seconde tâche sans avoir fini la première. Si tu enlèves l'option quiet, tu vas ralentir ton démarrage (le temps d'afficher tous les logs à l'écran), et ce temps supplémentaire va permettre à la première tâche de se finir avant que la seconde ne démarre.

Bizarre, non ?

Sinon, pour javofra, moi, j'ai été enlever les options plus bas dans le grub. J'ai édité le fichier /boot/grub/menu.lst, pour changer les lignes


title           Ubuntu hardy (development branch), kernel 2.6.24-16-generic
root            (hd0,4)
kernel          /boot/vmlinuz-2.6.24-16-generic root=UUID=2042c97e-fddd-4ce0-999f-04ec0c7933c6 ro [b]quiet splash[/b]
initrd          /boot/initrd.img-2.6.24-16-generic
[b]quiet[/b]

en

title           Ubuntu hardy (development branch), kernel 2.6.24-16-generic
root            (hd0,4)
kernel          /boot/vmlinuz-2.6.24-16-generic root=UUID=2042c97e-fddd-4ce0-999f-04ec0c7933c6 ro
initrd          /boot/initrd.img-2.6.24-16-generic

Adhémar

Hors ligne

#20 Le 03/05/2008, à 13:04

jfalconnet

Re : Pb ACPI démarrage

Meme probleme pour moi sur le VAIO VGN-FE41M depuis que j'ai basculé sous HH. Par contre il me semble qu'il ne le fait pas toujours mais il le fait sur secteur et sur batterie, mais à première vue pas quand la batterie est pleine ET qu'il est sur secteur.

Pour le contourner, la meilleure solution que j'ai trouvée c'est de par un controle alt supr juste avant le lancement du système. Sur un reboot, ça marche... allez comprendre.

#21 Le 05/05/2008, à 09:44

oswald-p

Re : Pb ACPI démarrage

Adhémar a écrit :

D'après ce que j'ai compris, l'explication vient du fait que au démarrage, le kernel va réaliser interroger l'acpi sur l'état des batteries, puis peu de temps après il va utiliser des fonctions liées à de l'acpi. Le bug arrive quand tu lances la seconde tâche sans avoir fini la première. Si tu enlèves l'option quiet, tu vas ralentir ton démarrage (le temps d'afficher tous les logs à l'écran), et ce temps supplémentaire va permettre à la première tâche de se finir avant que la seconde ne démarre.

Bizarre, non ?

Sinon, pour javofra, moi, j'ai été enlever les options plus bas dans le grub. J'ai édité le fichier /boot/grub/menu.lst, pour changer les lignes


title           Ubuntu hardy (development branch), kernel 2.6.24-16-generic
root            (hd0,4)
kernel          /boot/vmlinuz-2.6.24-16-generic root=UUID=2042c97e-fddd-4ce0-999f-04ec0c7933c6 ro [b]quiet splash[/b]
initrd          /boot/initrd.img-2.6.24-16-generic
[b]quiet[/b]

en

title           Ubuntu hardy (development branch), kernel 2.6.24-16-generic
root            (hd0,4)
kernel          /boot/vmlinuz-2.6.24-16-generic root=UUID=2042c97e-fddd-4ce0-999f-04ec0c7933c6 ro
initrd          /boot/initrd.img-2.6.24-16-generic

Adhémar

J'ai du enlever l'option "quiet" de la ligne "defoption" pour que mon PC boot... j'ai eu un espoir avec la mise à jour du noyau de ce week end mais c'est toujours pareil :-(

J'espère que cela va s'améliorer avec les mises à jour mais j'en doute... snif!

O-p


Chuck Norris a terrassé Prince de Lu avec un cookie

Hors ligne

#22 Le 02/07/2008, à 16:25

Sososo

Re : Pb ACPI démarrage

Est-ce que ce problème sera résolu avec la 8.04.1 demain ?

#23 Le 03/07/2008, à 09:44

Compte0

Re : Pb ACPI démarrage

Hope and wait


Q-DOS ( Quick & Dirty Operating System) + MS (MicroSoft) = MS-DOS (MicroSoft Dirty Operating System)

Hors ligne