Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 19/04/2008, à 18:57

Zeekrom

Permission CdRom

Bonjour !!

Je souhaiterai installer Age Of Empire II sous Linux Ubuntu 7.10, alors petit tour sur un bon site...ubuntu.fr et la je trouve toute la doc, nikel smile
Petit problème, quand je lance ma commande "wine aoesetup.exe" là petit message d'erreur me disant que je n'ai pas la permission d'etre dans le dossier "/media/cdromO"

Donc pour eviter de passer en root, je souhaiterai installer le jeu avec mon compte "normal"...

Merci pour vos réponses wink

Dernière modification par Zeekrom (Le 19/04/2008, à 19:01)

Hors ligne

#2 Le 19/04/2008, à 19:20

azzurri

Re : Permission CdRom

as tu vérifiez que tu es bien dans le groupe cdrom ?

sinon fait  :

groups

et regardes si cdrom fait parti des groupes affichés

Hors ligne

#3 Le 19/04/2008, à 19:25

Zeekrom

Re : Permission CdRom

alors après avoir fait "groups" voilà ce qu'il affiche !

root adm dialout fax cdrom floppy tape audio dip video plugdev scanner netdev lpadmin powerdev admin fuse

Là je vois "cdrom" ca devrait etre bon ?

Merci pour ta réponse en tout cas ^^

Hors ligne

#4 Le 19/04/2008, à 19:29

azzurri

Re : Permission CdRom

de rien wink
peux tu me donner l'erreur qui s'affiche exactement ?

Hors ligne

#5 Le 19/04/2008, à 19:32

Zeekrom

Re : Permission CdRom

Voilà l'erreur...de base je te l'accorde hmm

zeek@ZuniK:~$ cd /media/cdrom0
bash: cd: /media/cdrom0: Permission non accordée
zeek@ZuniK:~$

Hors ligne

#6 Le 19/04/2008, à 19:32

azzurri

Re : Permission CdRom

sinon essayes la commande :

winecfg

et regardes si l'emplacement du cdrom est le bon perso je me rapelles qu'il pointait sur mon DD

Hors ligne

#7 Le 19/04/2008, à 19:34

azzurri

Re : Permission CdRom

donnes moi le resultat de la commande :

ls -l /media/cdrom

Hors ligne

#8 Le 19/04/2008, à 19:35

Zeekrom

Re : Permission CdRom

Là exactement pareil il pointe sur le DD et quand je vais sur le lecteur cd il ne met aucune arborescence !

Hors ligne

#9 Le 19/04/2008, à 19:36

azzurri

Re : Permission CdRom

changes déjà dans la config de wine.

ensuites fais moi un : ls -l dans le répertoire /media

Hors ligne

#10 Le 19/04/2008, à 19:37

Zeekrom

Re : Permission CdRom

Et voilà

zeek@ZuniK:~$ ls -l /media/cdrom
lrwxrwxrwx 1 root root 6 2008-03-16 20:16 /media/cdrom -> cdrom0

apparement il n'y a que root qui puisse utiliser le cdrom, la loose hmm

Hors ligne

#11 Le 19/04/2008, à 19:39

azzurri

Re : Permission CdRom

fais surtout le ls -l sur /media

Hors ligne

#12 Le 19/04/2008, à 19:41

Zeekrom

Re : Permission CdRom

Voilà voilà ^^

zeek@ZuniK:~$ ls -l /media
total 6
lrwxrwxrwx 1 root       root          6 2008-03-16 20:16 cdrom -> cdrom0
dr--r--r-- 7 4294967295 4294967295 1420 2005-12-12 20:53 cdrom0
lrwxrwxrwx 1 root       root          7 2008-03-16 20:16 floppy -> floppy0
drwxr-xr-x 2 root       root       4096 2008-03-16 20:16 floppy0

Hors ligne

#13 Le 19/04/2008, à 19:43

azzurri

Re : Permission CdRom

alors là tu me fais (dans l'ordre) :

sudo chown root:root /media/cdrom0
sudo chmod 755 /media/cdrom0

et tu me dis si ça marche wink

Dernière modification par azzurri (Le 19/04/2008, à 19:43)

Hors ligne

#14 Le 19/04/2008, à 19:45

Zeekrom

Re : Permission CdRom

Voilà les réponses en retour !

zeek@ZuniK:~$ sudo chown root:root /media/cdrom0
[sudo] password for zeek:
chown: changement de propriétaire pour `/media/cdrom0': Système de fichiers accessible en lecture seulement
zeek@ZuniK:~$ sudo chmod 755 /media/cdrom0
chmod: modification des permissions de `/media/cdrom0': Système de fichiers accessible en lecture seulement

Hors ligne

#15 Le 19/04/2008, à 19:49

azzurri

Re : Permission CdRom

arf lol

fais moi un :

cat /etc/fstab

stp

Hors ligne

#16 Le 19/04/2008, à 19:51

Zeekrom

Re : Permission CdRom

Pas de soucis wink

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/hda2
UUID=02fca48f-240d-435d-b08a-98125e36792c /               ext3    defaults,errors=remount-ro 0       1
# /dev/hda1
UUID=24059e73-7484-4450-a4d6-436c8fab659d none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

Hors ligne

#17 Le 19/04/2008, à 19:53

azzurri

Re : Permission CdRom

enlève le udf de la ligne /media/cdrom0, reboot et dis moi si c'est bon ?

Hors ligne

#18 Le 19/04/2008, à 19:55

Zeekrom

Re : Permission CdRom

euh, le coeur y est, je veux bien....mais comment fait on ? :x

Hors ligne

#19 Le 19/04/2008, à 19:57

azzurri

Re : Permission CdRom

tu fais :

sudo gedit /etc/fstab

ensuite tu supprimes "udf,"

tu redémarres et tu me dis quoi wink

Hors ligne

#20 Le 19/04/2008, à 19:59

Zeekrom

Re : Permission CdRom

Ouki ouki je reboot, encore merci smile

Hors ligne

#21 Le 19/04/2008, à 20:05

Zeekrom

Re : Permission CdRom

Impec, après redémarrage, je peux accéder au cdrom et donc faire fonctionner wine !
un grand merci ! wink;)

Hors ligne

#22 Le 19/04/2008, à 20:07

azzurri

Re : Permission CdRom

Je dois y aller si cela ne marche pas remets le udf et ajoute "exec" :

udf,...,exec

redémarres et dis moi quoi

Hors ligne

#23 Le 19/04/2008, à 20:09

Zeekrom

Re : Permission CdRom

Ok ok, enfin pour le moment aucun soucis, je te remercie encore !! bonne soirée wink

Hors ligne

Haut de page ↑