Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 01/05/2008, à 09:27

novotni31

internet lent - livebox-dns

Bonjour,

Je rencontre une lenteur anormale dans la resolution des sites internet (pas d'impact sur le debit). Après avoir fait quelques tests et navigué dans differents forums il semble que le problème vienne de la configuration des adresses des serveurs dns. Avant de me lancer dans des manips qui risquerait de me priver completement d'internet je souhaiterai avoir quelques éclaircissements.

ma config :
ubuntu edgy
livebox sagem
connexion ethernet
ip allouée par dhcp

Je suis allé verifier les adresses dns dans ubuntu :  c'est l'adresse de la livebox (192.168.1.1)

Dans l'interface livebox il y a aussi des adresses dns definies : primaire 192.168.1.1 ( c'est l'adresse de la livebox), secondaire ( 0.0.0.0)

Mes questions

-quels sont les adresses utilisées,par exemples si je modifie les dns dans ubuntu, lequels seront utilisés, ceux de la box ou celle d'ubuntu.
- y a -t-il un lien entre les adresses definies dans la box et celle defini dans ubuntu ?

- j'ai une livebox sagem 6164 , d'après la doc il y a un menu reseau qui permet de modifier les dns mais je ne le trouve pas dans la mienne ( il y a une menu different à la place).

- les adresses dns fournies par orange sont 80.10.246.2 et 80.10.246.129 pour ces adresses sont elles differentes de ce que je trouve dans ubuntu ou ma livebox ??


Vos réponses sont les bienvenues


Merci par avance

Dernière modification par novotni31 (Le 01/05/2008, à 09:31)

Hors ligne

#2 Le 02/05/2008, à 16:25

Ryogi

Re : internet lent - livebox-dns

Même problème ici, le débit est très bon à partir du moment oú le DNS a été résolu. Ma config : Ubuntu 8

#3 Le 02/05/2008, à 16:45

Elios

Re : internet lent - livebox-dns

J'ai ce problème aussi, en plus de tout un tas d'autres. Hardy a beaucoup de problèmes avec le réseau je pense... attendre une maj hmm !

#4 Le 03/05/2008, à 17:51

novotni31

Re : internet lent - livebox-dns

Bonjour,

J'ai resolu mon problème de la façon suivante :

paramètrage d'une adresse IP static au lieu de DHCP + suppression du dns "livebox" ( en fait l'adresse de la box) et ajout des dns orange. Le passage à une adresse ip fixe permet de garder les dns saisis sinon je crois qu'ils sont ecrasés par celui (ceux ) envoyé par la box en l'occurence son adresse.

Je me pose néenmoins quelques questions :

- pourquoi la resolution des nom des sites marchait bien avant , en mode DHCP et plus maintenant ?
- comment fait on pour changer les DNS de la livebox ( le menu "relai dns " ne semble pas exister et est remplacé par un autre menu upNP je crois).

Si avez des idées ...

Hors ligne

#5 Le 18/05/2008, à 13:32

Pierre Valiron

Re : internet lent - livebox-dns

Bonjour,

J'ai le même problème avec une distrib Fedora Core 8 depuis fin avril. Je suppose que quelque chose a changé dans la gestion du DNS/wifi par la Livebox qui pose problème avec Linux en général, indépendamment d'Ubuntu en particulier.

Une solution simple est d'éditer le fichier /etc/resolv.conf après établissement de la liaison wifi pour remplacer l'adresse de la livebox par l'adresse d'un serveur DNS d'Orange dans la ligne

nameserver 192.168.1.1

qui est générée automatiquement par le gestionaire réseau de Linux.

Pour automatiser un peu, il est facile de créer un alias pour une commande
sudo cp /etc/resolv.conf.livebox /etc/resolv.conf

après avoir préparé un fichier /etc/resolv.conf.livebox contenant

# generated by NetworkManager, do not edit!

search home

#nameserver 192.168.1.1
nameserver 80.10.246.2
nameserver 80.10.246.129

C'est pas une solution très élégante, mais ça marche smile

#6 Le 19/05/2008, à 15:07

Pierre Valiron

Re : internet lent - livebox-dns

Si la livebox a fait l'objet de la dernière mise à jour 3202_26014A (indiqué dans le menu web d'accès à la livebox), les lenteurs du DNS sont provoquées par une incompatibilité avec le service IPV6 de Linux.

La solution est facile, cf. http://www.forum-orange.com/forums/view … ?pid=38025, il faut inhiber le service IPV6. Pour éviter de créer un trou de sécurité avec le pare-feu réseau, la solution la plus sûre est la suivante:

- Créer un fichier sous /etc/modprobe.d contenant la ligne "install ipv6 /bin/true", par ex:

sudo gedit /etc/modprobe.d/disable-ipv6

# To completely disable IPv6 in the system even if it is required
# by a service:
install ipv6 /bin/true

- puis rebooter la machine Linux.

Avec cette modif, les performances du dns et du réseau sont à nouveau excellentes, sans besoin de patcher le fichier resolv.conf.

wink

#7 Le 21/05/2008, à 14:36

yvan78

Re : internet lent - livebox-dns

Pierre Valiron a écrit :

- Créer un fichier sous /etc/modprobe.d contenant la ligne "install ipv6 /bin/true", par ex:

sudo gedit /etc/modprobe.d/disable-ipv6

# To completely disable IPv6 in the system even if it is required
# by a service:
install ipv6 /bin/true

- puis rebooter la machine Linux.

Avec cette modif, les performances du dns et du réseau sont à nouveau excellentes, sans besoin de patcher le fichier resolv.conf.

Sous une derivée debian (qui n'a pas le /etc/modprobe des RH/Fedora/mandriva...), il faut plus simplement mettre "ipv6" dans /etc/modprobe.d/blacklist

Mais en fait, on s'aperçoit que seul cela ne résoud rien. on reste obligé de modifier les DNS car la libc est conforme au rec et pile réseau IPV6 => requêtes DNS AAAA d'abord, puis, si timeout, A.

Peut-être la modif propre a firefox faite par certains peut-elle tromper (sur la seule navigation web), mais ipv6 blackliste, si on fait:

dig A yahoo.fr

OK

dig AAAA yahoo.fr

KO tant que l'on ne mets pas les DNS Orange en direct (et non l'adresse locale de la LB afin de passer par son relais DNS merdique).

Bref, c'est pas vraiment un problème IPV6... mais un problème que le relais DNS de la box filtre ces requêtes, ce qui pose pb a tous les systèmes nativement IPV6.

#8 Le 16/09/2008, à 11:13

Dopey

Re : internet lent - livebox-dns

Merci beaucoup, j'ai pu résoudre mon problème graçe à vous smile

Après une maj récente de la livebox, j'avais exactement le même problème.
La solution la plus radicale a été de mettre les DNS "en dur" dans /etc/resolv.conf.

#9 Le 20/09/2008, à 19:16

MaMieMando

Re : internet lent - livebox-dns

Dans /etc/dhcp3/dhclient.conf

sudo nano /etc/dhcp3/dhclient.conf

... rajoutez au choix (pour écraser 192.168.1.1) :

supersede domain-name-servers 80.10.246.130, 81.253.149.10;

ou encore (pour mettre à la suite de 192.168.1.1) :

append domain-name-servers 80.10.246.130, 81.253.149;

sauvez et quittez (ctrl x)

Bonne chance

#10 Le 24/09/2008, à 11:08

larotule

Re : internet lent - livebox-dns

Merci pour la solution

A noter que je viens d'installer Intrepid en alpha6 et j'ai pas eu besoin de faire la manip, tout marche a merveille d'entrée niveau dns de la livebox ! et j'ai pourtant ceci dans mons resolv.conf :

# Generated by NetworkManager
domain home
search home
nameserver 192.168.1.1

neutral

enfin tant que ca marche je cherche pas a comprendre smile

Hors ligne

#11 Le 25/10/2009, à 11:47

Henri MICHEL

Re : internet lent - livebox-dns

Désolé de rajouter mon grain de sel à un sujet déjà ancien

Un utilisateur chez lequel j'ai installé ubuntu il y a bien longtemps
il tourne toujours 7.04, va falloir que je le mette à niveau smile ) se
plaignait de "problème réseaux"

Il est connecté en Ethernet sur une LiveBox, dhcp

J'ai constaté que la livebox (IP adress: 192.168.1.1) ne répondait pas
aux  requêtes DNS

$ host www.google.com
;; connection timed out; no servers could be reached

Je me suis dit "pas de problème" je modifie /etc/resolv.conf ou
(plutôt /etc/dhcp3/dhclient.conf pour que le changement soit
permanent) et je lui indique d'utiliser les serveurs DNS d'opendns
(208.67.222.222 208.67.220.220) puisque la LiveBox n'est pas capable de
"forwarder" les requêtes DNS.

Et là surprise, la connection réseau est OK

$ ping -c 1 208.67.222.222
PING 208.67.222.222 (208.67.222.222) 56(84) bytes of data.
64 bytes from 208.67.222.222: icmp_seq=1 ttl=55 time=54.4 ms

Mais apparemment les réponses DNS sont filtrées, même si l'on demande
de contacter un serveur opendns directement on n'obtient pas de réponse

$ host -t A yahoo.fr 208.67.222.222
;; connection timed out; no servers could be reached


INCROYABLE! non seulement la LiveBox ne remplit par correctement sa
fonction de serveur DNS mais en plus elle barre la route quand on
essaie de s'adresser à quelqu'un d'autre.

Évidemment après quelques minutes le problème s'est résolu tout seul
(sans même faire un reboot de la LiveBox)

Avant de retourner chez cet ami, pour vérifier
  .) quelle version de Firmware tourne sa LiveBox
  .) comment elle est configurée
  .) si j'avais mis ipv6 dans /etc/modprobe.d/blacklist sur le système
     ubuntu
  .) lancer quelques requêtes DNS avec host ou dig
  .) ramasser quelques traces avec tcpdump
  ....
quelques questions à ceux qui ont aussi tenté de solutionner ce problème.
Tout particulièrement à yvan78
Il dit:

Mais en fait, on s'aperçoit que seul cela ne résoud rien. on reste
obligé de modifier les DNS car la libc est conforme au rec et pile
réseau IPV6 => requêtes DNS AAAA d'abord, puis, si timeout, A.

Je ne suis pas sûr de ce point, sur un ubuntu hardy sur lequel le
modules "ipv6" n'est pas chargé si l'on appelle simplement gethostbyname
cf programme C simpliste plus bas. Si on le lance

./gethost yahoo.fr

et que l'on trace l'interface réseau dans un autre terminal

sudo tcpdump  -n -i eth0 port 53

On ne voit que des requêtes de type "A" pour adresses IPv4 et non des
requêtes de type "AAAA"(adresses IPv6):

13:17:22.620627 IP 192.168.1.52.46107 > 208.67.222.222.53: 40318+ A? yahoo.fr. (26)
13:17:22.674483 IP 208.67.222.222.53 > 192.168.1.52.46107: 40318 2/0/0 A 217.146.186.221, A[|domain]


J'ai raté quelque chose ?

Appendice: code de gethost (programme tout bête appellant gethostbyname())

/* compile with gcc -Wall -o gethost gethost.c */
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>

#include <netdb.h>

#include <stdlib.h>
#include <stdio.h>

int main(int argc, char **argv) {
  if (argc < 2) {
    fprintf(stderr,"Usage: %s hostname\n", argv[0]);
    exit(1);
  }

  struct hostent *hp = gethostbyname(argv[1]);

  if (hp == NULL) {
    fprintf(stderr,"gethostbyname() failed\n");
    exit(1);
  } else {
    printf("%s = ", hp->h_name);
    unsigned int i=0;
    while ( hp -> h_addr_list[i] != NULL) {
      printf( "%s ", inet_ntoa( *( struct in_addr*)( hp -> h_addr_list[i])));
      i++;
    }
    printf("\n");
    exit(0);
  }
}

Dernière modification par Henri MICHEL (Le 25/10/2009, à 14:19)

Hors ligne