Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/05/2008, à 17:47

hugsy

Check drive au demarrage

Bonjour a tous,

J'ai intallé hardy sur un portable Compaq presario X1000 il y a une semaine tout s'est bien passé.
Je ne sais pas si c'est normal ou pas, mais un demarrage sur deux si ce n'est pas tous, j'ai une verification des disques , voila le message:

" routine check of drives "

Le faite que ce check se fasse ça ralenti vachement le demarrage de la machine.

Est ce que c'est normal sur hardy??? Comment peu t'on faire pour le desactiver ???

Avant j'avais gutsy sur cette machine, e je n'avais pas ce petit desagrement.

Merci de vos reponses


" In a world with  Linux, who needs Windows and Gates"

Hors ligne

#2 Le 14/06/2008, à 08:58

nico_h

Re : Check drive au demarrage

avant il faisait une vérification aussi régulièrement. là, c'est un peu trop souvent à mon goût par contre... j'aimerais aussi savoir comment on fait pour en réduire la fréquence.


Config. actuelle : bodhilinux 3.0 | ubuntu 14.04 | freebsd 10.1
Des exercices d'entraînement en maths (niveau 4e/3e) : http://mr.hainaux.net/
Festival vintage à soutenir : http://fr.ulule.com/marvellous-pop-festival/

Hors ligne

#3 Le 14/06/2008, à 15:01

gl25.it

Re : Check drive au demarrage

Oui, on peut enlever la vérification des disques et c'est même intéligent de le faire. Pour cela, il faut éditer en root le fichier /etc/fstab et changer à "0 0" la fin des lignes concernant tes partitions en FAT32 (vfat).
Tu peux t'aider de la page http://doc.ubuntu-fr.org/installation/mount_fstab (c'est un peu compliqué).
Si tu as des problèmes, donne nous le contenu de ton fichier /etc/fstab.
Voici le mien si tu veux t'en inspirer :

# /etc/fstab: static file system information.
#
# Partition system: /dev/hda4 <=> UUID=45e73095-ec0b-4e84-a067-d20f7403ca7d
UUID=45e73095-ec0b-4e84-a067-d20f7403ca7d /    ext3    defaults,errors=remount-ro  0  1
#
# <file system> <mount point> <type> <options>   <dump><pass>
proc       /proc         proc        defaults    0     0
/dev/sda2  none          swap        sw          0     0
/dev/cdrom   /media/cdrom0 udf,iso9660 user,noauto 0     0
/dev/sda5  /mnt/data     vfat        rw,user,auto,exec,gid=100,uid=1000,umask=077,iocharset=utf8,codepage=850  0  0
/dev/sda1  /mnt/windows  vfat        rw,user,auto,exec,gid=100,uid=1000,umask=077,iocharset=utf8,codepage=850  0  0

# partitions liees
/mnt/data/Musique /home/toto/musique none bind 0     0
/mnt/data/mail/Profile_toto/ /home/toto/courriels none bind 0 0

Ubuntist depuis Noël 2006.

Hors ligne

#4 Le 15/06/2008, à 18:04

nico_h

Re : Check drive au demarrage

merci pour ta réponse !

de mon côté, je n'ai aucune partition en vfat ; il vérifie sda2 (qui est en ext3).

nico@xochipilli:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda2
UUID=7ba72f6d-925c-4973-a7f4-23f8c8c02cee /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=b690bb4e-69ce-4f5a-8370-fbbc37c5e9c8 none            swap    sw              0       0
#/dev/scd0       /media/cdrom0   udf,iso9660 user,auto,exec,utf8 0       0
nico@xochipilli:~$

d'après la doc, une valeur de 0 1 pour ma partition racine est normale, pour le swap 0 0 aussi. apparemment ça indique dans quel ordre les vérifs sont effectuées au démarrage... et pas la fréquence... y'a pas de réglage pour ça ??


Config. actuelle : bodhilinux 3.0 | ubuntu 14.04 | freebsd 10.1
Des exercices d'entraînement en maths (niveau 4e/3e) : http://mr.hainaux.net/
Festival vintage à soutenir : http://fr.ulule.com/marvellous-pop-festival/

Hors ligne

#5 Le 16/06/2008, à 10:05

carton69

Re : Check drive au demarrage

tu peux taper ça dans un terminal :

sudo tune2fs -i 90d -c 500 /dev/sda2

Ca te permet de déclencher une vérif de ton disque tous les 90 jours (90d) ou tous les 500 démarrages.

#6 Le 16/06/2008, à 10:15

gl25.it

Re : Check drive au demarrage

Ton fstab me parait bon. Il est important que la partition racine soit en "1", et je ne sais pas s'il vérifie à chaque démarrage ou pas ni comment changer la fréquence (ni si c'est intélligent de le faire).
Par contre, tu n'as pas de partition de données. J'en conclu que ta partition racine est énorme et que tu as toutes tes données dessus. Pour accélérer le temps de démarrage et pour plus de sécurité, je t'invite à réduire ta partition racine (à 10Gio par exemple) et mettre tes données sur une autre partition.

C'est quoi cette option "relatime" pour sda2 ? C'est toi qui l'a mise ?
Essaie donc de la remplacer par "defaults", comme dans mon fstab.


Ubuntist depuis Noël 2006.

Hors ligne

#7 Le 16/06/2008, à 10:37

cep

Re : Check drive au demarrage

gl25.it a écrit :

C'est quoi cette option "relatime" pour sda2 ? C'est toi qui l'a mise ?
Essaie donc de la remplacer par "defaults", comme dans mon fstab.

Non. Pourquoi veux-tu la modifier ? voir les évolutions des options de mount avec les nouveaux noyaux.

Ceci dit, si le fsck est lancé à chaque démarrage, c'est qu'il y a un problème sur le fs ou, pire, sur le disque.

Donc, soit faire un fsck avec l'option -f -y pour réparer les éventuels problèmes après avoir pris les précautioons d'usage, soit vérifier ce qui justifie ces fsck.

Il est aussi possible de voir les réglages par défaut du nombre de mounts avec la commande :

tune2fs -l /dev/sda2 |grep Max

Hors ligne

#8 Le 16/06/2008, à 11:05

gl25.it

Re : Check drive au demarrage

cep a écrit :
gl25.it a écrit :

C'est quoi cette option "relatime" pour sda2 ? C'est toi qui l'a mise ?
Essaie donc de la remplacer par "defaults", comme dans mon fstab.

Non. Pourquoi veux-tu la modifier ? voir les évolutions des options de mount avec les nouveaux noyaux.

Désolé. Après un man mount, je me rend en effet compte que ce n'est pas relatime qui gène.


Ubuntist depuis Noël 2006.

Hors ligne

#9 Le 16/06/2008, à 11:11

carton69

Re : Check drive au demarrage

cep a écrit :

tune2fs -l /dev/sda2 |grep Max

Argh ! Merci pour ta commande, mais pour un de mes disques, elle me renvoie ce message d'erreur :

tune2fs: Bad magic number in super-block lors de la tentative d'ouverture de /dev/sda2
Impossible de trouver un superbloc de système de fichiers valide.

sda2 correspond à mon disque de sauvegarde (500 Go en ext3), si quelqu'un a une piste pour corriger le problème, merci d'avance wink

#10 Le 16/06/2008, à 11:21

cep

Re : Check drive au demarrage

tune2fs s'applique à des systèmes de fichiers ext2/ext3.

Donc, soit ton fs n'est pas en ext2/3, soit il est détériore.

Hors ligne

#11 Le 16/06/2008, à 11:43

carton69

Re : Check drive au demarrage

cep a écrit :

tune2fs s'applique à des systèmes de fichiers ext2/ext3.

Donc, soit ton fs n'est pas en ext2/3, soit il est détériore.

En effet, j'ai été un peu trop rapide, sda2 correspond à un disque ntfs et pas à mon disque de sauvegarde en ext3.

Ouf ! Tout est normal donc, je retourne bosser tongue Merci bien pour la réponse rapide.

#12 Le 16/06/2008, à 19:54

nico_h

Re : Check drive au demarrage

merci pour les réponses !! c'est nickel !


Config. actuelle : bodhilinux 3.0 | ubuntu 14.04 | freebsd 10.1
Des exercices d'entraînement en maths (niveau 4e/3e) : http://mr.hainaux.net/
Festival vintage à soutenir : http://fr.ulule.com/marvellous-pop-festival/

Hors ligne

#13 Le 15/08/2008, à 20:59

romano8401

Re : Check drive au demarrage

salut j'ai le meme probleme a tous les demmarage j'ai un checking drive sauf que au bout de 8% il s'arrete et l'écran devien comme un terminal avec pleins de trucs ecrient

root@romain-desktop:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config -- 
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=0d1aa2ea-85eb-4423-9be3-4dd1d42ddaa8 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=67cf3365-63b3-4b99-b849-2ced68fe3a71 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

#14 Le 31/08/2008, à 20:51

nico_h

Re : Check drive au demarrage

ton message manque d'indications : est-ce que tu arrives quand même à démarrer ? sur quel disque le check drive s'effectue-t-il ? as-tu essayé la commande tune2fs pour modifier le nombre de démarrages au bout duquel le check drive se déclenche ? que retourne la commande proposée par cep (tune2fs -l /dev/sda2 |grep Max) (dans ton cas, mettre sda1 au lieu de sda2 apparemment) ? peux-tu indiquer quelles sortes de messages sont renvoyés par le check drive "raté" ?

EDIT: dans la doc, l'explication sur la vérification des disques c'était ici : http://doc.ubuntu-fr.org/verification_de_fichiers

Dernière modification par nico_h (Le 12/01/2009, à 19:20)


Config. actuelle : bodhilinux 3.0 | ubuntu 14.04 | freebsd 10.1
Des exercices d'entraînement en maths (niveau 4e/3e) : http://mr.hainaux.net/
Festival vintage à soutenir : http://fr.ulule.com/marvellous-pop-festival/

Hors ligne

#15 Le 02/03/2009, à 03:31

big

Re : Check drive au demarrage

carton69 a écrit :

tu peux taper ça dans un terminal :

sudo tune2fs -i 90d -c 500 /dev/sda2

Ca te permet de déclencher une vérif de ton disque tous les 90 jours (90d) ou tous les 500 démarrages.

bonjour
j'ai tapé cette commande dans mon terminal et voila se que ca me répond  :   
yann@Constant:~$ sudo tune2fs -i 90d -c 500 /dev/sda2
[sudo] password for yann:
tune2fs 1.40.8 (13-Mar-2008)
tune2fs: Attempt to read block from filesystem resulted in short read lors de la tentative d'ouverture de /dev/sda2
Impossible de trouver un superbloc de système de fichiers valide.
yann@Constant:~$

si quelqu' un pouvait me dire pk cela me fait ca je lui en serait reconnaissant

#16 Le 02/03/2009, à 20:26

nico_h

Re : Check drive au demarrage

tu es sûr que sda2 chez toi c'est bien une partition linux "standard" ext3 (et pas la partition swap, par exemple ?). tu peux nous renvoyer une copie de ce que donne

yann@Constant:~$ cat /etc/fstab

EDIT: la même question a été posée un peu plus haut dans ce sujet !!!

Dernière modification par nico_h (Le 02/03/2009, à 20:28)


Config. actuelle : bodhilinux 3.0 | ubuntu 14.04 | freebsd 10.1
Des exercices d'entraînement en maths (niveau 4e/3e) : http://mr.hainaux.net/
Festival vintage à soutenir : http://fr.ulule.com/marvellous-pop-festival/

Hors ligne