Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 08/06/2008, à 11:02

gmano

[RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonjour,

Je viens d'installer hardy sur mon pc et j'essaie de configurer fstab
Ci-après le résultat de fdisk -l
Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1        2550    20482843+  83  Linux
/dev/sda2            2551        3825    10241437+  83  Linux
/dev/sda3            3826        4867     8369865    b  W95 FAT32
/dev/sda4            4868        4998     1052257+   5  Extended
/dev/sda5            4868        4998     1052226   82  Linux swap / Solaris

Disque /dev/sdb: 40.0 Go, 40027029504 octets
255 heads, 63 sectors/track, 4866 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xcc07cc07

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1   *           1        2550    20482843+   c  W95 FAT32 (LBA)
/dev/sdb2            2551        4866    18603270    f  W95 Etendu (LBA)
/dev/sdb5            2551        3060     4096543+   b  W95 FAT32
/dev/sdb6            3061        3952     7164958+  83  Linux
/dev/sdb7            3953        4083     1052226   82  Linux swap / Solaris
/dev/sdb8            4084        4866     6289416   83  Linux

Voici le contenu que j'ai ajouté dans fstab
/dev/sdb1       /mnt/WindowsC     vfat rw,user,auto,exec,gid=100,uid=1000,umask=002,iocharset=utf8,codepage=850,shortname=mixed 0 0
/dev/sdb5       /mnt/WindowsD     vfat        defaults,umask=0           0    0

Les partitions  /mnt/WindowsD et  /mnt/WindowsC existent et j'y ai fait un chmod 777
un mount que ce soit par gparted ou par la commande mount, j'ai le message suivant:
mount: périphérique spécial /dev/sdb1 n'existe pas
J'ai le même message pour /dev/sdb5

Ou est mon erreur please

Remarque lorsque j'affiche les fichiers cachés, dans /dev, les références a sda1 à 5 existent mais pour sdb, je n'ai que sdb, pas sdb1 a 5 le disque n'était pas présent lors de l'installation.
question subsidiaire : est-il possible de recharger les pointeur de partition?

Dernière modification par gmano (Le 29/11/2008, à 16:17)

Hors ligne

#2 Le 09/06/2008, à 13:28

sebtx

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonjour,

Essaye de poster le résultat de cette commande:

dmesg | grep sdb

Hors ligne

#3 Le 10/06/2008, à 20:49

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonsoir,

Voila le resultat de la commande  "dmsg | grep sdb" mais ce disque était monté tel que sous Ubuntu 7.10 il possède windows xp et une partition ext3 depuis 2 ans au moins

[   30.116053] sd 1:0:0:0: [sdb] 78177792 512-byte hardware sectors (40027 MB)
[   30.116075] sd 1:0:0:0: [sdb] Write Protect is off
[   30.116079] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[   30.116110] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   30.116338] sd 1:0:0:0: [sdb] 78177792 512-byte hardware sectors (40027 MB)
[   30.116356] sd 1:0:0:0: [sdb] Write Protect is off
[   30.116359] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[   30.116387] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   30.116394]  sdb:sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray
[   33.407859] sd 1:0:0:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[   33.407865] sd 1:0:0:0: [sdb] Sense Key : Aborted Command [current] [descriptor]
[   33.407895] sd 1:0:0:0: [sdb] Add. Sense: Scsi parity error
[   33.407904] end_request: I/O error, dev sdb, sector 0
[   33.407910] Buffer I/O error on device sdb, logical block 0
[   34.510487] Dev sdb: unable to read RDB block 0
[   34.510583] sd 1:0:0:0: [sdb] 78177792 512-byte hardware sectors (40027 MB)
[   34.510851] sd 1:0:0:0: [sdb] Write Protect is off
[   34.510855] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[   34.510888] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   34.510921] sd 1:0:0:0: [sdb] 78177792 512-byte hardware sectors (40027 MB)
[   34.510937] sd 1:0:0:0: [sdb] Write Protect is off
[   34.510940] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[   34.510967] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   34.511061] sd 1:0:0:0: [sdb] Attached SCSI disk

Hors ligne

#4 Le 12/06/2008, à 19:12

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonsoir,

Pas de solutions alors.

J'ai refait une mise a jour du systeme et rien!!!

Hors ligne

#5 Le 12/06/2008, à 19:52

aragami

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

j'ai le meme probleme avec mon disque dur externe!!

Hors ligne

#6 Le 12/06/2008, à 20:48

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Salut,

J'ai /dev/sdb qui existe mais je ne sais comment se crée ni comment forcer la "recréation" au boot des sdb1
et les autres.

Il s'agit de disque ide je ne comprends pas pourquoi on a changé la gestion des disques. C'est absurde.

Hors ligne

#7 Le 18/06/2008, à 21:10

blahnotblahblah

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

si les deux disques durs sont branchés, que donnes la commande
sudo fdisk /dev/sd*


proverbe ashanti: "Quand la maison brûle, on ne perd pas de temps à pérorer".

Hors ligne

#8 Le 19/06/2008, à 21:05

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonsoir,

la comande ne donne rien car il n'y a pas d'options.
en tête de mon post il y a le resultat de fdisk -l

voici le resultat de  sudo fdisk -s /dev/sd*

/dev/sda: 13260240
/dev/sda1: 7164958
/dev/sda2: 1052257
/dev/sda3: 5036377
/dev/sdb: 39088896

mais les partitions de sdb ne sont pas indiquées.

ici le resultat de la commande sudo fdisk -l /dev/sd*

Disque /dev/sda: 13.5 Go, 13578485760 octets
255 heads, 63 sectors/track, 1650 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x18ad18ac

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1         892     7164958+  83  Linux
/dev/sda2             893        1023     1052257+  82  Linux swap / Solaris
/dev/sda3            1024        1650     5036377+  83  Linux

Disque /dev/sda1: 7336 Mo, 7336917504 octets
255 heads, 63 sectors/track, 891 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x00000000

Disque /dev/sda1 ne contient pas une table de partition valide

Disque /dev/sda2: 1077 Mo, 1077511680 octets
255 heads, 63 sectors/track, 131 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x00000000

Disque /dev/sda2 ne contient pas une table de partition valide

Disque /dev/sda3: 5157 Mo, 5157250560 octets
255 heads, 63 sectors/track, 627 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x00000000

Disque /dev/sda3 ne contient pas une table de partition valide

Disque /dev/sdb: 40.0 Go, 40027029504 octets
255 heads, 63 sectors/track, 4866 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xcc07cc07

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1   *           1        2550    20482843+   c  W95 FAT32 (LBA)
/dev/sdb2            2551        4866    18603270    f  W95 Etendu (LBA)
/dev/sdb5            2551        3060     4096543+   b  W95 FAT32
/dev/sdb6            3061        3952     7164958+  83  Linux
/dev/sdb7            3953        4083     1052226   82  Linux swap / Solaris
/dev/sdb8            4084        4866     6289416   83  Linux

Hors ligne

#9 Le 24/06/2008, à 21:04

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonsoir,

N'y a-t-il pas moyen de forcer la ré exécution ( à la mano si nécessaire) du module de détection de partitions ou périphériques pour faire reconnaitre les partitions ou les nouveau périphériques?

Dernière modification par gmano (Le 25/06/2008, à 14:19)

Hors ligne

#10 Le 04/08/2008, à 11:19

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonjour,

J'ai fait une mise ajour de Hardy hier mais le problème persiste.

Qui pourrait m'aider a définir une règle UDEV pour que ces partition du disque soit reconnues?
Je pensais pourvoir recopier la définition de de la 7.10, mais on est passé de hd à sd!.

Merci

Hors ligne

#11 Le 04/08/2008, à 11:29

jeanjd63

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Salut

Peux-tu donner les résultats de :
sudo  ls  -l /dev/?db?

puis de :
sudo  ls -l /dev/disk/by-uuid/

@+

Hors ligne

#12 Le 05/08/2008, à 21:13

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonsoir,

Voici le résulta de sudo  ls  -l /dev/?db?

ls: ne peut accéder /dev/?db?: Aucun fichier ou dossier de ce type

et le resultat de sudo  ls -l /dev/disk/by-uuid/

total 0
lrwxrwxrwx 1 root root 10 2008-08-05 21:07 6216fab9-236c-48f1-ade0-b7fc5b0ee6f9 -> ../../sda2
lrwxrwxrwx 1 root root 10 2008-08-05 21:07 9091fcc6-0c9e-48a0-8625-e64d50f630bb -> ../../sda3
lrwxrwxrwx 1 root root 10 2008-08-05 21:07 bd567c57-9456-430d-a563-a65d14efb7a1 -> ../../sda1

Pensz-vous qu'installer gutsy mettre à jour puis faire un upgrate vers hardy serait une bonne soluition?

Dernière modification par gmano (Le 05/08/2008, à 21:15)

Hors ligne

#13 Le 07/08/2008, à 00:21

_clem

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

J'ai exactement le même problème.

Install de Ubuntu 7.04 sur un disque dur IDE formaté
ajout d'un disque IDE (contenant déjà des données) en fat32 => erreur

sudo mount -t vfat /dev/sdb5 /media/storage

mount: périphérique spécial /dev/sdb5 n'existe pas

sudo fdisk -l /dev/sd*

Disque /dev/sda: 81.9 Go, 81964302336 octets
255 heads, 63 sectors/track, 9964 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x8844a5db

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1        9587    77007546   83  Linux
/dev/sda2            9588        9964     3028252+   5  Extended
/dev/sda5            9588        9964     3028221   82  Linux swap / Solaris

Disque /dev/sda1: 78.8 Go, 78855727104 octets
255 heads, 63 sectors/track, 9586 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x00000000

Disque /dev/sda1 ne contient pas une table de partition valide

Disque /dev/sda5: 3100 Mo, 3100898304 octets
255 heads, 63 sectors/track, 376 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x00000000

Disque /dev/sda5 ne contient pas une table de partition valide

Disque /dev/sdb: 122.9 Go, 122942324736 octets
255 heads, 63 sectors/track, 14946 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x000d2300

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1            5028       14946    79674367+   5  Extended
/dev/sdb2   *           1        5027    40379346   83  Linux
/dev/sdb5            5222       14946    78116062+   b  W95 FAT32
/dev/sdb6            5028        5220     1550209+  82  Linux swap / Solaris

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Help !

#14 Le 07/08/2008, à 06:45

jeanjd63

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Salut

Dans les 2 cas il s'agit d'un ajout de disque.

Il faudrait vérifier comment sont branchés ces disques et surtout que la position des cavaliers (switch) à l'arrière du disque (slave, master etc...) est bien en phase avec la présence d'un autre périf sur la mappe IDE (disque, cdron etc...)
@+

Hors ligne

#15 Le 07/08/2008, à 17:05

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonjour,

Oui il s'agit d'un ajout de disque, le problème que je ne comprends pas c'est pourquoi cela fonctionne sous Gutsy et non sous hardy. car comme ce disque possède mes données sensibles, je peux l'enlever facilement lorsque j'installe un nouvel OS. les cavaliers sont correctement positionnés puisque je peux démarrer (avec le MBR car j'ai XP dessus) sur ce disque en enlevant celui sur lequel j'ai grub et Ubuntu.

Comment faire pour recréer les règles de UDEV en automatique en laissant ce disque branché? ou comment devrais je écrire les règles de UDEV pour que ce disque soit pris en comptes sous Hardy?

A+

Dernière modification par gmano (Le 07/08/2008, à 17:07)

Hors ligne

#16 Le 12/08/2008, à 15:55

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonjour,

Toujours pas de solution en vue?

Que pensez vous du fait de recopier les règle UDEV de gutsy après avoir changer hd par sd?

Comment remonter ce bug chez canonical?

Hors ligne

#17 Le 10/09/2008, à 06:07

stickiste

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Hello,
je venais de rencontrer le problème et je pense avoir trouvé la solution.
Je suis en ubuntu studio 7.04.
Ma partition en FAT32 était soudain devenue inaccessible depuis Windows, j'ai été obligé de formater depuis windows puis de recopier les données.
De retour sur Ubuntu, le montage automatique de la partition ne fonctionnait plus.
Voici les opérations que j'ai faites:

1. lancement depuis Applicatoins/Outils systèmes/Outil de configuration NTFS (ntfs-config), et valider l'accès en lecture et en écriture. Cela a pour effet de mettre à jour le fichier /etc/fstab

2. ouvrir une fenêtre terminal et passer en mode root
su -

3. essayer un montage général
mount -a
Ici, j'ai pu voir le nouvel UUID attribué par le système à ma nouvelle partition /sda2

root@amd3000:~# mount -a
fusermount: mount failed: Device or resource busy
FUSE mount point creation failed
Unmounting /dev/disk/by-uuid/465029305029285F (HDC1_NTFS)
fusermount: mount failed: Device or resource busy
FUSE mount point creation failed
Unmounting /dev/disk/by-uuid/54781334781313F8 (HDC2_NTFS)
fusermount: mount failed: Device or resource busy
FUSE mount point creation failed
Unmounting /dev/disk/by-uuid/CE047CCB047CB7D3 (SDA1_NTFS)
mount: périphérique spécial /dev/disk/by-uuid/B4B3-D135 n'existe pas

4.Editer la liste courante des liens disques:
root@amd3000:~# ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2008-09-10 05:39 465029305029285F -> ../../hdc1
lrwxrwxrwx 1 root root 10 2008-09-10 05:39 54781334781313F8 -> ../../hdc2
lrwxrwxrwx 1 root root 10 2008-09-10 07:38 85831466-838f-4af2-858f-85c506c7c5f8 -> ../../sda4
lrwxrwxrwx 1 root root 10 2008-09-10 07:38 B4AA-BA88 -> ../../sda2
lrwxrwxrwx 1 root root 10 2008-09-10 07:38 CE047CCB047CB7D3 -> ../../sda1
lrwxrwxrwx 1 root root 10 2008-09-10 07:38 f44aade7-2a6e-454d-a82a-9a2a34348dbc -> ../../sda3

5.Il suffit alors de se positionner dans le répertoire /dev/disk/by-uuid, et pour mon cas renommer l'ancien UUID de sda2 vers le nouveau
mv B4AA-BA88 B4B3-D135

6. refaire un mount -a, puis regarder de nouveau le bureau d'ubuntu pour voir apparaître le bel icône smile

J'espère que cela vous aidera
++

#18 Le 29/11/2008, à 16:16

gmano

Re : [RESOLU] spécial /dev/sdb1 n'existe pas (Hardy) /dev/sdb exite!

Bonjour,

Resolu avec sudo partprobe qui met a jour le inode mais ne mémorise pas son action.

Dans quel script, lancé au démarrage de mon pc, je dois mettre cette commande?

Merci

Dernière modification par gmano (Le 29/11/2008, à 17:37)

Hors ligne

Haut de page ↑