Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 08/01/2006, à 15:43

Constantin

[RESOLU]Pb avec GTK

Bonjour à  tous,
je cherche à  installer gbuscan afin de pouvoir gérer mon caméscope numérique sous ubuntu.
Lorsque je tape ./configure j'ai un message d'erreur concernant GTK. Je vous en livre une partie :

checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.2.0... no
*** Could not run GTK test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GTK or finding the wrong
*** version of GTK. If it is not finding GTK, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
***
*** If you have a RedHat 5.0 system, you should remove the GTK package that
*** came with the system with the command
***
***    rpm --erase --nodeps gtk gtk-devel
configure: error: gscanbus needs GTK

Pourtant j'ai installé avec Synaptic les packages concernant gtk1.2 et libgtk1.2 (ainsi que les dev correspondant).
SI une à¢me charitable a une idée je suis preneur.
Merci d'avance.

Dernière modification par Constantin (Le 06/12/2007, à 21:26)

Hors ligne

#2 Le 08/01/2006, à 18:51

Bzh

Re : [RESOLU]Pb avec GTK

et GTK 2 ??? Il demande une version > ou = à la 1.2 !!! Enfin je parle des paquets -dev.

Hors ligne

#3 Le 08/01/2006, à 20:28

requiem

Re : [RESOLU]Pb avec GTK

Non, c'est bien gtk-1.2 qu'il demande.
Sinon, il aurait demandé explicitement gtk-2.0 et plus.


Le problème avec Linux, ce n'est pas Linux, c'est le linuxien

Hors ligne

#4 Le 08/01/2006, à 20:48

Bzh

Re : [RESOLU]Pb avec GTK

checking for GTK - version >= 1.2.0... no

Cela veut bien dite qu'il demande une version >= à 1.2 de Gtk !

Il demande une version > ou = à la 1.2

Il me semble que c'est bien ce que j'ai dis smile

Ce qui veut dire que Gtk 2.0 est sencé suffire ! Tu n'as qu'a installer le dev de Gtk 2.0 !!!

Hors ligne

#5 Le 08/01/2006, à 20:56

Desintegr

Re : [RESOLU]Pb avec GTK

Non, son programme utilise GTK+ 1.2 sinon il aurait vérifi& une version supérieure ou égale à la 2.0.

De plus le ./configure utise gtk-config pour vérifier la version de GTK+. Or gtk-config n'est plus utilisé et a été remplacé par pkg-config pour GTK+ 2.0.

Es-tu certain d'avoir installé le paquet « libgtk1.2-dev » ?
Que renvoie la commande « gtk-config --version gtk » ?

Dernière modification par Desintegr (Le 08/01/2006, à 21:03)


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#6 Le 09/01/2006, à 10:33

Constantin

Re : [RESOLU]Pb avec GTK

Avec la commande gtk-config --version gtk, le système répond : 1.2.10
En fait je commence à me demander si je n'ai pas deux versions d'installé : quand je vais voir dans le gestionnaire de paquets synaptic j'ai libgtk1.2-dev et libgtk2.0-dev d'installé (à moins que GTK et GTK+ puissent cohabiter sereinement).
En tout cas merci pour vos réponses.

Hors ligne

#7 Le 09/01/2006, à 10:47

Desintegr

Re : [RESOLU]Pb avec GTK

Pourquoi compiles-tu ce logiciel ?
Il est déjà présent dans les dépôts (universe)
.

Sinon, Il n'y a pas de conflit entre la « libgtk1.2-dev » et la « libgtk2.0-dev », sinon tu n'aurais pas pu installer les deux paquets en même temps.

Dernière modification par Desintegr (Le 09/01/2006, à 10:49)


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#8 Le 09/01/2006, à 15:51

alain_72

Re : [RESOLU]Pb avec GTK

Desintegr a écrit :

Non, son programme utilise GTK+ 1.2 sinon il aurait vérifi& une version supérieure ou égale à la 2.0.

Ca veut dire que son programme ne fonctionnera pas avec une version inférieure à la 1.2, mais fonctionnera avec la 1.2 ou supérieure. La 2.0 étant une version supérieure à la 1.2, ça devrait fonctionner.


ubuntu Breezy Badger 5.10 - kernel linux-K7
AMD Athlon XP 2600 - 512 Mo DDR - HD 80 Go (/) HD 160 Go (/home)
Nvidia Geforce FX 5200 128 Mo
adresse jabber : linux.ubuntu@jabber.org

Hors ligne

#9 Le 09/01/2006, à 16:02

dawar

Re : [RESOLU]Pb avec GTK

GTK1 et GTK2 sont des branches totalement  différentes, un programme pour GTK1 ne fonctionne pas avec GTK2 et inversement.

Enfin, si le paquet est diponible dans les dépots, pourquoi s'embeter ?


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#10 Le 10/01/2006, à 14:56

Constantin

Re : [RESOLU]Pb avec GTK

Desintegr a écrit :

Pourquoi compiles-tu ce logiciel ?
Il est déjà présent dans les dépôts (universe)
.

Sinon, Il n'y a pas de conflit entre la « libgtk1.2-dev » et la « libgtk2.0-dev », sinon tu n'aurais pas pu installer les deux paquets en même temps.

Oups, désolé, j'avais fait la recherche alors que ma liste de dépots n'était pas complètete je ne l'avais donc pas remarqué.
Encore désolé pour le dérangement inutile, je l'installe à partir de synaptic.
Merci pour l'aide!

Hors ligne

Haut de page ↑