Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 08/01/2006, à 19:10

remyremy

[Résolu] Souris USB non détectée ?

Bonjour à tous.

Je viens d'installer Ubuntu (Breezy), sur un Compaq Presario 3300 (proc AMD 64) et je ne peux pas utiliser ma souris USB.
J'ai pensé au début que ça venait d'un problème de ports USB, mais mes autres périphériques USB fonctionnent sans problème...

J'ai regardé différents tutos, FAQs, etc. qui, pour la plupart,  proposent de modifier le fichier /etc/X11/xorg.conf (mais pas toujours de la même manière), mais rien n'y fait...:(

J'avais antérieurement installé une distribution Kubuntu, et là, la souris fonctionnait si elle était branchée avant le démarrage, mais alors, le Touchpad ne fonctionnait plus (mais bon, c'est peut-être une autre histoire).

Si quelqu'un a une solution, c'est pas de refus.
Merci.

#2 Le 08/01/2006, à 21:23

ron

Re : [Résolu] Souris USB non détectée ?

essaye un adaptateur ps/2...

Hors ligne

#3 Le 09/01/2006, à 12:04

remyremy

Re : [Résolu] Souris USB non détectée ?

Un adaptateur ???
J'ai que des ports USB et ma souris est USB...
Donc je ne vois pas ce que je ferais avec un adaptateur...

#4 Le 09/01/2006, à 12:28

bernez

Re : [Résolu] Souris USB non détectée ?

lsusb ne donne rien ?


vyé kanari ka fè bonsoup.
Kenavo. A galon !

Hors ligne

#5 Le 09/01/2006, à 12:32

remyremy

Re : [Résolu] Souris USB non détectée ?

Heuuu...
Connaissais pas cette commande, je vais voir wink

#6 Le 09/01/2006, à 13:01

remyremy

Re : [Résolu] Souris USB non détectée ?

Alors voilà le résultat de lsusb :

Bus 001 Device 001: ID 0000:0000

Ca me paraît un peu cours, non ???

Je viens de voir qu'au démarrage, il y a une erreur (que je n'ai pas le temps de lire) sur USB liée à huci_hcd (enfin, un truc comme ça...).

Au début, je pensais que les ports USB n'étaient pas reconnus, mais en fait mes périphériques de stockages (clé et DD externe en USB) fonctionnent sans problèmes sur n'importe quel port.

A savoir aussi que lors de l'installe, ma souris USB était branchée, je ne sais pas si ça a son importance...

Une idée  sad  ?

#7 Le 09/01/2006, à 13:09

Desintegr

Re : [Résolu] Souris USB non détectée ?

« dmesg » pour voir ce que raconte le noyau. Tu verras sans doute le message lié à huci_hcd.

Ton « lsusb » nous dit qu'aucun périphérique USB n'a été trouvé, à part le contrôlleur USB.


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#8 Le 09/01/2006, à 13:43

remyremy

Re : [Résolu] Souris USB non détectée ?

Alors, voilà ce que j'ai trouvé avec dmesg qui semble avoir un rapport avec l'USB :

[   12.216551] USB0 USB1 USB2 PS2K PS2M MAC0

Apparemment, il voit mes 3 ports USB, c'est déjà ça. Puis, plus loin :

[   18.655080] ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
[   18.655813] ACPI: PCI Interrupt Link [LUS0] enabled at IRQ 21
[   18.655824] ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LUS0] -> GSI 21 (level, low) -> IRQ 21
[   18.655863] PCI: Setting latency timer of device 0000:00:02.0 to 64
[   18.655869] ohci_hcd 0000:00:02.0: nVidia Corporation nForce3 USB 1.1
[   24.157985] ohci_hcd 0000:00:02.0: USB HC takeover failed!  (BIOS/SMM bug)
[   24.157992] ohci_hcd 0000:00:02.0: can't reset
[   24.158007] ACPI: PCI interrupt for device 0000:00:02.0 disabled
[   24.158012] ohci_hcd 0000:00:02.0: init 0000:00:02.0 fail, -16
[   24.158019] ohci_hcd: probe of 0000:00:02.0 failed with error -16
[   24.158607] ACPI: PCI Interrupt Link [LUS1] enabled at IRQ 20
[   24.158616] ACPI: PCI Interrupt 0000:00:02.1[b] -> Link [LUS1] -> GSI 20 (level, low) -> IRQ 20
[   24.158631] PCI: Setting latency timer of device 0000:00:02.1 to 64
[   24.158637] ohci_hcd 0000:00:02.1: nVidia Corporation nForce3 USB 1.1 (#2)
[   29.714159] ohci_hcd 0000:00:02.1: USB HC takeover failed!  (BIOS/SMM bug)
[   29.714460] ohci_hcd 0000:00:02.1: can't reset
[   29.714694] ACPI: PCI interrupt for device 0000:00:02.1 disabled
[   29.714700] ohci_hcd 0000:00:02.1: init 0000:00:02.1 fail, -16
[   29.714968] ohci_hcd: probe of 0000:00:02.1 failed with error -16
[   29.735112] ACPI: PCI Interrupt Link [LUS2] enabled at IRQ 22
[   29.735120] ACPI: PCI Interrupt 0000:00:02.2[C] -> Link [LUS2] -> GSI 22 (level, low) -> IRQ 22
[   29.735144] PCI: Setting latency timer of device 0000:00:02.2 to 64
[   29.735150] ehci_hcd 0000:00:02.2: nVidia Corporation nForce3 USB 2.0

Déjà, je suis sensé avoir 3 ports USB 2.0, et j'avais déjà remarqué sur une ancienne install de Kubuntu qu'il n'identifie qu'1 ports 2.0 et 2 ports 1.1...(cela dit, je me suis peut-être fait arnaquer par le constructeur ...:/ ). Je trouve ça bizard, d'autant qu'il n'a pas l'air de les aimer ces ports 1.1.

2ème chose : comme je le disais, malgrès ça, ma clé USB et mon DD externe passent sans problème sur n'importe lequel de ces ports.
Peut-être que ma souris est en USB 1.1 et que ça ne plait pas au noyau ???

Ces infos vous parlent plus qu'à moi ?

#9 Le 09/01/2006, à 13:53

Desintegr

Re : [Résolu] Souris USB non détectée ?

Problème similaire à http://forum.ubuntu-fr.org/viewtopic.php?pid=158927

Tes périphériques USB2 fonctionnent sans problème (clef/disque USB) avec le module « ehci_hcd ».

Le problème est lié au module « ohci_hcd » donc à l'USB 1.
Après une petite recherche, la raison que l'USB ne fonctionne pas surement est un bug du BIOS et causé par le driver ACPI.

Premièrement, essaye de mettre à jour ton BIOS.
Ensuite, on avisera. (par exemple, désactivation de l'ACPI)

EDIT IMPORTANT :
J'ai trouvé ceci aussi http://prinsig.se/weekee/index.php/USB_(hw)

Après avoir fait la mise à jour de BIOS, mais que ça ne fonctionne toujours pas. Suis les instructions suivantes.

Désactive le module ohci : sudo rmmod ohci_hcd
Puis réactive le avec une option spéciale : sudo modprobe ohci-hcd no_handshake=1

Branche ta souris USB et ensuite vérifie si tout se déroule bien grâce au « dmesg » (les dernières lignes) et au « lsusb ».

Si ça fonctionne, on verra pour automatiser tout ça.

Dernière modification par Desintegr (Le 09/01/2006, à 13:58)


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#10 Le 09/01/2006, à 15:23

remyremy

Re : [Résolu] Souris USB non détectée ?

YES !!!!!!

Une petite MAJ du Bios et ça marche (ce qui n'a pas été de tout repos, vu le bordel pour trouver le bon fichier cher HP/Comaq roll ) !!!!! big_smile

Merci Desintegr pour tes liens. cool

Adieu le TouchPad !!!!

PS : heuu, comment je fais pour mettre [Résolu] en tant qu'invité ???

#11 Le 09/01/2006, à 15:26

Desintegr

Re : [Résolu] Souris USB non détectée ?

En tant qu'invité, il faut demander à un admin pour mettre en [Résolu].

Dernière modification par Desintegr (Le 09/01/2006, à 15:26)


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#12 Le 09/01/2006, à 15:35

remyremy

Re : [Résolu] Souris USB non détectée ?

OK, je leur fais signe.

Et encor merci, ça faisait 1 semaine que je me galérais tongue

++

#13 Le 15/02/2006, à 03:28

le_nogre

Re : [Résolu] Souris USB non détectée ?

Desintegr a écrit :

Problème similaire à http://forum.ubuntu-fr.org/viewtopic.php?pid=158927

Tes périphériques USB2 fonctionnent sans problème (clef/disque USB) avec le module « ehci_hcd ».

Le problème est lié au module « ohci_hcd » donc à l'USB 1.
Après une petite recherche, la raison que l'USB ne fonctionne pas surement est un bug du BIOS et causé par le driver ACPI.

Premièrement, essaye de mettre à jour ton BIOS.
Ensuite, on avisera. (par exemple, désactivation de l'ACPI)

EDIT IMPORTANT :
J'ai trouvé ceci aussi http://prinsig.se/weekee/index.php/USB_(hw)

Après avoir fait la mise à jour de BIOS, mais que ça ne fonctionne toujours pas. Suis les instructions suivantes.

Désactive le module ohci : sudo rmmod ohci_hcd
Puis réactive le avec une option spéciale : sudo modprobe ohci-hcd no_handshake=1

Branche ta souris USB et ensuite vérifie si tout se déroule bien grâce au « dmesg » (les dernières lignes) et au « lsusb ».

Si ça fonctionne, on verra pour automatiser tout ça.

Salut j'ai le meme probleme sauf que je trouve pas de mise a jour pour mon bios ( portbale compaq presario 3332EA).
J'ai donc essayé de desactiver et reactiver ohci_hcd avec l'option en question et ca marche big_smile.
Pourrais-tu me dire comment automatiser tout ca?
merci d'avance smile

#14 Le 15/02/2006, à 04:39

le_nogre

Re : [Résolu] Souris USB non détectée ?

Nan en fait c bon on m'a aidé a automatiser ca smile
il faut lancer ces commandes au demarrage et pour cela il faut creer un script.

faire un script dans le dossier /etc/init.d/  en donnant n'importe quel nom au fichier:

vi /etc/init.d/nom_fic

et mettre ce qui suit dans ce fichier :

#!/bin/sh
sudo rmmod ohci_hcd
sudo modprobe ohci-hcd no_handshake=1

ensuite accorder les autorisations necessaires...

chmod 755 nom_fic

puis creer lien logique pour que le script soit lancé au demarrage:

sudo ln -s /etc/init.d/nom_fic /etc/rcS.d/S99nom_fic

S99 pour que ce soit lancé en dernier.

Ca a marché pour moi...à defaut de pouvoir flasher mon bios.

#15 Le 20/01/2007, à 21:10

Baptiste

Re : [Résolu] Souris USB non détectée ?

Merci pour cette astuce! Je dois avouer que ça m'a gâché la vie pendant pas mal de temps sous dapper avec mon ancien hp zv5421ea (on me l'a volé!)! Désormais j'ai un asus A6tc et surprise, et le même problème sous edgy cette fois-ci (uniquement avec le noyau ubuntu).

Serait-il possible d'ouvrir un bug sur launchpad ou c'est déjà fait. La solution est bonne et ça éviterait pas mal de problèmes aux nouveaux utilisateurs!

Merci encore!

Hors ligne

Haut de page ↑