Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 01/11/2008, à 14:36

simdax

[RESOLU] probleme OGRE & BOOTSTRAP

Bonjour,

j'ai un problème pour compiler les sources d'OGRE avec Intrepid Ibex (enfin je crois que c'est la nouvelle version de libtool qui pose problème). Lorsque je fais le ./bootstrap de ogre, le terminal me dit "Libtool 1.4 or above is required".

En cherchant j'ai trouvé une réponse sur les forums d'OGRE, je pense que l'idée est de modifier le fichier bootstrap

Index: bootstrap
===================================================================
--- bootstrap   (revision 8054)
+++ bootstrap   (working copy)
@@ -22,7 +22,7 @@
        exit 1;
 fi

-if test -z "`libtool --version 2>&1|head -n 1|egrep '1.[4-5]'`"; then
+if test 140 -gt "`libtool --version|head -n 1|awk '{print $4;}'|sed "s/\.//g"`"; then
        echo "Libtool 1.4 or above is required. Aborting build...";
        exit 1;
 fi

mais je ne sais pas commment modifier mon bootstrap de manière adéquate, toutes les modifications que je fais amènent des erreurs de syntaxe (normal, j'y connais pas grand chose)

Merci de votre aide

Dernière modification par simdax (Le 02/11/2008, à 08:56)

Hors ligne

#2 Le 01/11/2008, à 14:46

Link31

Re : [RESOLU] probleme OGRE & BOOTSTRAP

C'est un fichier patch. Tu pourrais patcher les sources de la manière habituelle, mais pour une ligne autant le faire à la main.

Donc, enlève la ligne du fichier bootstrap qui commence par un - dans le patch que tu as posté (le - n'est pas présent dans le fichier bootstrap), et remplace-la par la ligne qui commence par un + (sans écrire le + wink).

Au fait, je croyais que Ogre était dans les dépôts ?

Dernière modification par Link31 (Le 01/11/2008, à 14:46)

Hors ligne

#3 Le 02/11/2008, à 08:56

simdax

Re : [RESOLU] probleme OGRE & BOOTSTRAP

OK génial ça marche big_smile
Je savais pas que Ogre était dans les dépôts, en fait c'est trop simple linux ...
J'essaye quand même d'installer la 1.6 et si ça marche pas je verrais
merci

Hors ligne

Haut de page ↑