Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 04/02/2006, à 11:09

appopson

[Résolu] Clavier allemand

Bjr,

Comment mettre les accents avec un clavier allemand  sur les "e", les "a"  ?


Merci

Dernière modification par appopson (Le 05/02/2006, à 09:25)


Ubuntu inside ...

Hors ligne

#2 Le 04/02/2006, à 11:19

sbrunner

Re : [Résolu] Clavier allemand

Ton clavier est-t-il bien configurer dans le fichier '/etc/X11/xorg.conf' ?

Pour un clavier suisse français j'ai :

    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "ch"
    Option "XkbOptions" "fr"
    Option "XkbVariant" "fr"

Pour un clavier allemand tu doit certainement avoir :

    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "de"

Dernière modification par sbrunner (Le 04/02/2006, à 16:46)

Hors ligne

#3 Le 04/02/2006, à 11:58

appopson

Re : [Résolu] Clavier allemand

Voici tout le contenu de '/etc/X11/xorg.conf'


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection


Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "de"
        Option          "XkbVariant"    "nodeadkeys"
EndSection



Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "CB773F-EJ"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
        Monitor         "CB773F-EJ"
        DefaultDepth    24
        SubSection "Display"
                Depth           2
                Modes           "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection


Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection


Ubuntu inside ...

Hors ligne

#4 Le 04/02/2006, à 12:43

sbrunner

Re : [Résolu] Clavier allemand

Et si tu essaye de supprimer la ligne

        Option          "XkbVariant"    "nodeadkeys"

CU
Stéph

Dernière modification par sbrunner (Le 04/02/2006, à 16:45)

Hors ligne

#5 Le 04/02/2006, à 13:21

appopson

Re : [Résolu] Clavier allemand

Ca marche super bien.
J'ai mis un # devant la ligne 'Option          "XkbVariant"    "nodeadkeys"  '.

Je peux maintenant utiliser mon clavier coe avant.

Merci pour le coup de main.

Dis parviens tu  à monter les cles usb chez toi?

Merci


Ubuntu inside ...

Hors ligne

#6 Le 04/02/2006, à 14:38

sbrunner

Re : [Résolu] Clavier allemand

Peut-tu mettre [résolu] dans le titre du premier message ?

Pour ton problème de clés chez moi ça marche (continue dans ton autre post wink ).

CU
Stéph

Hors ligne

#7 Le 04/02/2006, à 15:37

HoPHP

Re : [Résolu] Clavier allemand

Deux petite choses : Le [Résolu], ce serait bien et il serait agréable d'éditer vos posts pour mettre tout ce qui n'est pas français (donc, le code) entre les balises [code ][/code ] (sans espaces) appropriées. C'est clairement plus facile pour la lecture.

Merci d'avance,

HoPHP


Merci de ne pas jeter d'arguments aux trolls qui se trouvent dans la fosse.
HoPHP est mort, vive OdyX

Hors ligne

#8 Le 04/02/2006, à 16:46

sbrunner

Re : [Résolu] Clavier allemand

C'est fais pour ma part ;-)

Hors ligne

Haut de page ↑