Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 01/12/2008, à 15:21

olep

Soucis Kino

Bonjour,
Dans un grand élan de générosité avec moi-même, j'ai voulu me simplifier ma propre vie de monteur de video familiale, et j'ai donc essayé Kino.
Déjà installé avant ma migration vers Intrepid, c'est la version 1.3.0.

Chapitre1:
Petite video de 3 minutes, acquisition, montage, export simple et facile, ca marche, c'est cool! tongue
Chapitre2:
Je remarque qu'à chaque fois que je démarre mon PC, avant de lancer Kino, il faut systématiquement faire "sudo modprobe raw1394" & "sudo chmod 777 /dev/raw1394"....:/
Chapitre3:
Bon c'est parti - Je charge 1 heure de vidéo depuis mon camescope. je me retrouve avec une bonne vingtaine de fichiers DV dans le storyboard.... et là, craque le drame: dés que j'appuie sur lecture puis arrêt, tout se fige, le driver de son explose dans mes oreilles, et Kino se gèle sur place....:(
Je suis obligé de rebooter le PC sans quoi je deviendrais sourd en 30 secondes!

D'où mes innocentes questions:
Y-a-t-il un moyen que ce fichu module I-3-E soit toujours chargé, et les droits donnés à l'utilisateur?
Kino accepte-t-il un grand nb de videos ds le storyboard?

J'ai essayé de bouger quelques options comme indiqué dans http://doc.ubuntu-fr.org/kino et dans lprod, notamment en décochant l'option "Abandonner les images vidéo si nécessaire", mais là c'est encore pire, la video défile à toute allure et sans son....
J'ai aussi changé l'option audio en mettant à tout hasard "pulseaudio" au lieu de "default", et manifestement, ca marche pas non plus....

Une idée?

merci!
wink


Asrock Extreme4 990FX, AthlonX4-640, CG RADEON HD 6570
Ubuntu64 13.04 depuis le 15/05/2013 à 16h30 environ....

Hors ligne

#2 Le 21/12/2008, à 17:00

lol25

Re : Soucis Kino

Ajoutes dans le fichier /etc/modules les lignes suivantes :
raw1394
dv1394
ohci1394
ieee1394
comme ça ils se chargeront automatiquement au démarrage.
Tu peux avoir un paquet de fichiers .dv sans que cela pose pb. J'ai des répertoire avec plus d'une centaine de ceux-ci et Kino marche.
Pour le reste pas d'idée.

Hors ligne

#3 Le 23/12/2008, à 01:25

olep

Re : Soucis Kino

lol25 a écrit :

Ajoutes dans le fichier /etc/modules les lignes suivantes :
raw1394
dv1394
ohci1394
ieee1394
comme ça ils se chargeront automatiquement au démarrage.
Tu peux avoir un paquet de fichiers .dv sans que cela pose pb. J'ai des répertoire avec plus d'une centaine de ceux-ci et Kino marche.
Pour le reste pas d'idée.

Merci pour le tuyau!
wink


Asrock Extreme4 990FX, AthlonX4-640, CG RADEON HD 6570
Ubuntu64 13.04 depuis le 15/05/2013 à 16h30 environ....

Hors ligne

#4 Le 29/12/2008, à 18:49

mdu

Re : Soucis Kino

olep a écrit :
lol25 a écrit :

Ajoutes dans le fichier /etc/modules les lignes suivantes :
raw1394
dv1394
ohci1394
ieee1394
comme ça ils se chargeront automatiquement au démarrage.
Tu peux avoir un paquet de fichiers .dv sans que cela pose pb. J'ai des répertoire avec plus d'une centaine de ceux-ci et Kino marche.
Pour le reste pas d'idée.

Merci pour le tuyau!
wink

Bonjour,
J' ai les mêmes problêmes.
Où doit-on insérer les 4 lignes dans le fichier "modules" (qui est vide chez moi pour l'instant)?
(Copie d' écran S.V.P)
Merci
mdu

#5 Le 31/12/2008, à 00:47

Tyim

Re : Soucis Kino

J'ai le même problème : il arrive un moment ou kino se fige et le son se met à tirailler fortement et sans s'arrêter.
Même après avoir forcer kino à s'arrêter.

Il faut redémarrer le PC.

J'ai ajouter les lignes dans /etc/modules, mais il n'y a pas de changement pour moi.


Pour MDU :

sudo gedit /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp

# Generated by sensors-detect on Sat Dec 27 10:32:35 2008
# Chip drivers
w83627ehf
k8temp


raw1394
dv1394
ohci1394
ieee1394

Dernière modification par Tyim (Le 31/12/2008, à 00:47)


Les rêveurs créent le monde, les réalistes le font fonctionner (Tyim)

Hors ligne

#6 Le 31/12/2008, à 14:37

mdu

Re : Soucis Kino

Tyim a écrit :

J'ai le même problème : il arrive un moment ou kino se fige et le son se met à tirailler fortement et sans s'arrêter.
Même après avoir forcer kino à s'arrêter.

Il faut redémarrer le PC.

J'ai ajouter les lignes dans /etc/modules, mais il n'y a pas de changement pour moi.


Pour MDU :

sudo gedit /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp

# Generated by sensors-detect on Sat Dec 27 10:32:35 2008
# Chip drivers
w83627ehf
k8temp


raw1394
dv1394
ohci1394
ieee1394

Pour Tyim,
Ci-dessous mon fichier "modules" :
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp

raw1394
dv1394
ohci1394
ieee1394

Est-ce OK?
Merci
mdu

#7 Le 01/01/2009, à 14:38

Tyim

Re : Soucis Kino

Je n'y vois pas d'erreur.


Je n'ai plus le problème avec kino. Mais ce n'est pas du à cette modification.

J'ai fait plusieurs manipulations avant de m'apercevoir que ça fonctionner (essai d'installation de la dernière version sans succès avec installation de packets complémentaires)

Mais je pense en fait que la solution est de modifier les préférences de kino comme suit :
(accéder à éditer/préférences)
- D'abord dans l'onglet Défauts, choisir PAL (rien à voir avec le problème mais c'est mieux en france)
- dans l'onglet affichage cocher 'GDK'
- dans l'onglet audio cocher 'Actver l'audio lors de la navigation'

Si vous essayer, dites moi si ça fonctionne pour vous. Bonne chance

Dernière modification par Tyim (Le 01/01/2009, à 14:39)


Les rêveurs créent le monde, les réalistes le font fonctionner (Tyim)

Hors ligne

#8 Le 02/01/2009, à 19:50

mdu

Re : Soucis Kino

Tyim a écrit :

Je n'y vois pas d'erreur.


Je n'ai plus le problème avec kino. Mais ce n'est pas du à cette modification.

J'ai fait plusieurs manipulations avant de m'apercevoir que ça fonctionner (essai d'installation de la dernière version sans succès avec installation de packets complémentaires)

Mais je pense en fait que la solution est de modifier les préférences de kino comme suit :
(accéder à éditer/préférences)
- D'abord dans l'onglet Défauts, choisir PAL (rien à voir avec le problème mais c'est mieux en france)
- dans l'onglet affichage cocher 'GDK'
- dans l'onglet audio cocher 'Actver l'audio lors de la navigation'

Si vous essayer, dites moi si ça fonctionne pour vous. Bonne chance

Bonsoir Tyim,
J' ai suivi tous vos conseils, hélas cela ne foctionne.
Mon camescope sony DCR -HC51E n' est pas détecté par KINO.
Que puis-je faire de plus?
mdu

#9 Le 02/01/2009, à 21:12

Tyim

Re : Soucis Kino

J' ai suivi tous vos conseils, hélas cela ne foctionne.

Je parlais pour le problème de blocage de kino avec le son strident en  continu.

Est ce que tu as suivi ce lien ?
http://fr.lprod.org/wiki/doku.php?id=vi … camescopes


Les rêveurs créent le monde, les réalistes le font fonctionner (Tyim)

Hors ligne

#10 Le 02/01/2009, à 22:07

mdu

Re : Soucis Kino

Tyim a écrit :

J' ai suivi tous vos conseils, hélas cela ne foctionne.

Je parlais pour le problème de blocage de kino avec le son strident en  continu.

Est ce que tu as suivi ce lien ?
http://fr.lprod.org/wiki/doku.php?id=vi … camescopes

Je suis bien allé sur le lien.
Mon souci c' est que malgré :
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp

#load 1394 modules for 1394 acquisition DV card - lprod.org, licence GNU/GPL 2008, L.Bellegarde
raw1394
dv1394.

je suis obligé de taper à la console :

sudo modprobe raw1394

sudo modprobe dv1394
pour pouvoir acquérir une vidéo du camescope.
mdu

#11 Le 05/01/2009, à 14:30

olep

Re : Soucis Kino

mdu a écrit :
Tyim a écrit :

Je n'y vois pas d'erreur.


Je n'ai plus le problème avec kino. Mais ce n'est pas du à cette modification.

J'ai fait plusieurs manipulations avant de m'apercevoir que ça fonctionner (essai d'installation de la dernière version sans succès avec installation de packets complémentaires)

Mais je pense en fait que la solution est de modifier les préférences de kino comme suit :
(accéder à éditer/préférences)
- D'abord dans l'onglet Défauts, choisir PAL (rien à voir avec le problème mais c'est mieux en france)
- dans l'onglet affichage cocher 'GDK'
- dans l'onglet audio cocher 'Actver l'audio lors de la navigation'

Si vous essayer, dites moi si ça fonctionne pour vous. Bonne chance

Bonsoir Tyim,
J' ai suivi tous vos conseils, hélas cela ne foctionne.
Mon camescope sony DCR -HC51E n' est pas détecté par KINO.
Que puis-je faire de plus?
mdu

Bonjour
Concernant l'audio, si j'active les 2 dernières de ta liste, Tyim, ça ne se passe pas vraiment bien... mais il faut que je ré-essaie, de plus, j'ai noté au démarrage du PC une erreur alsa/pulseaudio: en fait on a l'impression que pulseaudio cherche une connection sur alsa, et ça plante. Ca pourrait être lié?
roll


Asrock Extreme4 990FX, AthlonX4-640, CG RADEON HD 6570
Ubuntu64 13.04 depuis le 15/05/2013 à 16h30 environ....

Hors ligne

#12 Le 26/01/2009, à 15:21

olep

Re : Soucis Kino

Petit up-and-news...
L'option Affichage "GDK", par défaut, pas bon.... j'ai toujours ces "freeze" hasardeux qui arrivent lorsqu'en lecture video j'appuie sur stop ou pause, avec le son qui se bloque, m'obligeant de tout redemarrer.
Je vais essayer l'option Xvideo et voir si j'ai toujours ces plantages...
En parallele, qui dit son dit pulseaudio.... et dans le site de Kino, voici ce qui a été communiqué par l'auteur:

PulseAudio got you down?
.... Because Kino frequently opens and closes the audio device, it will frequently connect and disconnect with the pulseaudio service. Therefore, routing Kino's audio through PulseAudio might not be so convenient. The default configuration of Kino uses the ALSA "default" PCM, which distros hook into to route to PulseAudio. Therefore, to bypass PulseAudio, you can try setting the Audio Device to "plughw:0,0" (or some other PCM that you know you prefer) in Kino's Preferences.

If you really do want to send Kino's audio to PulseAudio, then I found the OSS emulation does not create an audio/video synchronization issue. Simply set the Audio Device to "/dev/dsp" in Kino's Preferences and then run Kino using the "padsp kino" command.....

wink

Dernière modification par olep (Le 26/01/2009, à 15:21)


Asrock Extreme4 990FX, AthlonX4-640, CG RADEON HD 6570
Ubuntu64 13.04 depuis le 15/05/2013 à 16h30 environ....

Hors ligne

#13 Le 01/02/2009, à 18:57

marc31

Re : Soucis Kino

moi aussi je souffre de ces plantages ; c'est aussi référencé sur launchpad ; sur google : kino pulseaudio sound loop. Des liens :
- http://ubuntuforums.org/showthread.php?t=980308
- http://ubuntuforums.org/archive/index.php/t-1014084.html,
- http://www.kinodv.org/dcforum/dcforum?az=show_topic&forum=101&topic_id=3097
- https://bugs.launchpad.net/ubuntu/+source/kino/+bug/286723

concerne :
- pulseaudio,
- ubuntu, opensuse (et certainement d'autres distribs)

pour régler ces problèmes :
- récuperer sur http://getdeb.net, le dernier kino 1.3.3 (intrepid) et l'installer ; mettre /dev/dsp comme device audio et relancer kino ; just enjoy :-)
- pour hardy heron, ce n'est pas la version 1.3.3 mais la 1.3.2 et qui ne corrige pas le bug, mais le contournement est expliqué ici : http://www.kinodv.org/article/view/173/1/13/ :
   - mettre /dev/dsp pour audio device et
   - lancer kino en le préfixant de "padsp" : padsp kino ; c'est un wrapper pulseaudio OSS et ca devrait regler nos problèmes.

Dernière modification par marc31 (Le 01/02/2009, à 19:43)


ubuntu-gutsy / ATI RC410 [Radeon Xpress 200] + Nvidia GeForce 7300 SE / wireless RaLink RT2500 / toulouse-ouest / xmpp://marc.quinton@jabber.org

Hors ligne

#14 Le 02/02/2009, à 16:35

olep

Re : Soucis Kino

marc31 a écrit :

moi aussi je souffre de ces plantages ; c'est aussi référencé sur launchpad ; sur google : kino pulseaudio sound loop. Des liens :
- http://ubuntuforums.org/showthread.php?t=980308
- http://ubuntuforums.org/archive/index.php/t-1014084.html,
- http://www.kinodv.org/dcforum/dcforum?az=show_topic&forum=101&topic_id=3097
- https://bugs.launchpad.net/ubuntu/+source/kino/+bug/286723

concerne :
- pulseaudio,
- ubuntu, opensuse (et certainement d'autres distribs)

pour régler ces problèmes :
- récuperer sur http://getdeb.net, le dernier kino 1.3.3 (intrepid) et l'installer ; mettre /dev/dsp comme device audio et relancer kino ; just enjoy :-)
- pour hardy heron, ce n'est pas la version 1.3.3 mais la 1.3.2 et qui ne corrige pas le bug, mais le contournement est expliqué ici : http://www.kinodv.org/article/view/173/1/13/ :
   - mettre /dev/dsp pour audio device et
   - lancer kino en le préfixant de "padsp" : padsp kino ; c'est un wrapper pulseaudio OSS et ca devrait regler nos problèmes.

C'est donc la 2ième méthode expliquée sur le site de Kino qui est préconisée, à priori...
Pour ma part, sans changer de version, j'ai changé l'option audio, en mettant "plughw:0,0", et ça a l'air de fonctionner aussi. A voir l'usage.....
j'utilise Kino 1.3.2 sur Intrepid.


Asrock Extreme4 990FX, AthlonX4-640, CG RADEON HD 6570
Ubuntu64 13.04 depuis le 15/05/2013 à 16h30 environ....

Hors ligne

#15 Le 02/02/2009, à 18:28

marc31

Re : Soucis Kino

olep a écrit :

C'est donc la 2ième méthode expliquée sur le site de Kino qui est préconisée, à priori...
Pour ma part, sans changer de version, j'ai changé l'option audio, en mettant "plughw:0,0", et ça a l'air de fonctionner aussi. A voir l'usage.....
j'utilise Kino 1.3.2 sur Intrepid.

merci pour l'info. Je dois dire que j'ai un peu galéré a ce sujet, mais c'est comme cela qu'on progresse :-)


ubuntu-gutsy / ATI RC410 [Radeon Xpress 200] + Nvidia GeForce 7300 SE / wireless RaLink RT2500 / toulouse-ouest / xmpp://marc.quinton@jabber.org

Hors ligne

#16 Le 07/04/2009, à 20:16

JeanAdrien

Re : Soucis Kino

J'ai le même souci de son que celui décrit dans ce forum, donc j'ai installé la derniere version 1.3.3, (je suis sur Intrepid) ça a l'air de fonctionner de ce côté là, mais quand, dans le montage, je fais une lecture de fichiers .avi (capturés avec une ancienne version) la lecture se fait à vitesse rapide .... pas moyen de lire à vitesse normale ...
Est-ce un bug de la nouvelle version ?

Dernière modification par JeanAdrien (Le 07/04/2009, à 20:17)

Hors ligne

#17 Le 15/04/2009, à 17:55

marc31

Re : Soucis Kino

JeanAdrien, je ne sais pas tres bien ; ce que je peux te dire, c'est que s'il y a des soucis dans l'afficache de la vidéo, c'est souvent ce qu'il se produit (ou du son). Il te faut donc vérifier d'abord la video ; essaie les différents parametres d'affichage. Apres tu fais de meme avec la vidéo. Eventuellement tu repasses en serveur Xorg de base (non propriétaire).


ubuntu-gutsy / ATI RC410 [Radeon Xpress 200] + Nvidia GeForce 7300 SE / wireless RaLink RT2500 / toulouse-ouest / xmpp://marc.quinton@jabber.org

Hors ligne

#18 Le 10/05/2009, à 20:43

Jonnypark

Re : Soucis Kino

Hello,

j'ai aussi un problème de son, qui est récurrent. En suivant vos conseils ça n'a pas résolu. Avec "plughw:0,0" je n'ai tout simplement pas de son, avec "/dev/dsp" le son est toujours saccadé et scratch.

J'ai kino 1.3.3 et Jaunty...

Hors ligne

#19 Le 07/06/2010, à 23:22

6-ril

Re : Soucis Kino

Même problème version Lucid :
Réponse trouvé sur le site   http://www.kinodv.org/

Dans la console, il faut taper :

gksu gedit /etc/modprobe.d/blacklist-firewire.conf

Enlever les commentaires ( # ) pour les ligne :
ohci1394
sbp2
dv1394
raw1394
video1394

Ajouter un commentaire pour les lignes :
firewire-ohci
firewire-sbp2

Enregistrer et quitter

Puis tapez la commande suivante :

sudo update-initramfs -k all -u

et enfin rebootez

Cyril

Hors ligne

#20 Le 02/01/2011, à 20:51

truffy

Re : Soucis Kino

bonjour,
j'ai des soucis avec kino que je voulais utiliser pour la premiere fois.
j'ai ubuntu 10.10 et une camera sony DCR-HC20E-PAL
Dès que je clique sur Acquisition j'ai le message"le module raw1394 n'est pas chargé ou échec lecr/écrit sur /dev/raw1394"
Comme indiqué sur le forum, j'ai fait
sudo modprob raw1394, ainsi que dev1394,ohci1394,ieee1394
puis lsmod | grep 1394 , tout y est
puis sudo chmod 777 /dev/raw1394
rien n'y fait, même msg et la zone des touches de défilement qui reste en grisé.
Quelqu'un a-t-il une idée ? ( je précise que je ne suis pas un grand fortiche en Linux...)

Hors ligne

#21 Le 07/08/2011, à 02:32

tevezed

Re : Soucis Kino

Pour truffy

Et alors, depuis ça  fonctionne ?
Car moi aussi j'ai le même problème

Hors ligne