Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/02/2006, à 19:49

teolemon

Tutoriel pour installer Xgl sur kde ou gnome

NB : Ce TUTO EST TRADUIT MAIS PAS A JOUR. LA PROCEDURE A ETE SIMPLIFIEE.VOIR LES REPONSES

Tutoriel sur l'installation de Xgl pour kde ou gnome. Je ne montre que comment installer la gfx nividia la plus récente,mais ATI devrait également pouvoir faire tourner Xgl.


Ok, donc voilà comment je m'y suis pris, et un listing de ma config matérielle:

Matos:
Amd64 3200+
Nvidia Geforce 6800LE
carte mère MSI Neo2 deluxe.

Logiciels:
Une installation toute fraîche de  Dapper flight 3 (kubuntu)
http://cdimage.ubuntu.com/cdimage/kubuntu/releases/dapper/flight-3/dapper-install-i386.iso

J'ai fait une installation par défaut.

La première chose que j'ai fait après l'installation a été de désinstaller
nvidia-glx and nvidia-kernel-common <-- Les utilisateurs de cartes Ati peuvent ignorer ceci.

J'ai ensuite activé les dépôts universe dans Dapper et j'ai fait:

sudo apt-get update 
sudo apt-get upgrade

Regardons maintenant les upgrade, et gardons bien à l'esprit que le paquetage xorg has been locked for upgrade. Nous pouvons régler cela en tapant:

sudo apt-get remove xorg-common 
sudo apt-get install xserver-xorg

Cette commande installera Xorg 7.0, qui est compatible avec Xgl.

Maintenant nous devons installer et paramétrer la carte graphique nvidia. A cet effet,

sudo apt-get install nvidia-kernel-common nvidia-glx <-- [color=#FF0000]Les utilisateurs de cartes Ati peuvent ignorer ceci.[/color]

-------------------------------------------------------------------------
Modifions ensuite le fichier xorg.conf de cette manière:

sudo nano -w /etc/X11/xorg.conf

Dans la Section "Module"
ajoutez # au début de la ligne:

# Load "GLcore" 
# Load "dri"<-- [color=#FF0000]Les utilisateurs de cartes Ati ne doivent pas ajouter le # pour cette ligne.[/color]

et ajoutez la ligne suivante

Load glx

Une fois que c'est fait, ça devrait ressembler à ça:

Section "Module" 
# Load "GLcore" 
Load "i2c" 
Load "bitmap" 
Load "ddc" 
[color=#FF0000]#[/color] Load "dri" [color=#FF0000]le # n'est à ajouter que pour les possesseurs de cartes nvidia[/color]
Load "extmod" 
Load "freetype" 
Load "glx" 
Load "int10" 
Load "type1" 
Load "vbe" 
EndSection

Modifiez la Section "Device" pour qu'elle ressemble à celà:

Section "Device" 
Identifier "NVIDIA Corporation NV40 [GeForce 6800 LE]" 
Driver "nvidia" <--- [color=#FF0000]les utilisateurs de cartes ATI doivent utiliser le driver fglrx[/color] 
BusID "PCI:1:0:0" 
Option "NvAGP" "1" <-- [color=#FF0000]Les utilisateurs de cartes Ati peuvent ignorer ceci.[/color]
Option "RenderAccel" "true" <-- [color=#FF0000]Les utilisateurs de cartes Ati peuvent probablement ignorer ceci.Je ne pense pas que les driver le supportent[/color]
Option "AllowGLXWithComposite" "true" EndSection<-- [color=#FF0000]Les utilisateurs de cartes Ati peuvent probablement ignorer ceci.Je ne pense pas que les driver le supportent[/color]

L'option Option "NvAGP" "1" est optionnelle. Je pense que ça ameliore les performances du système, mais vous devez désactiver le module agpgart pour l'utiliser.

Et enfin si vous possedez une carte nvidia card, ajoutez ceci à la fin du fichier.  Utilisateurs de cartes Ati, ne l'ajoutez pas!

Section "Extensions" 
                         Option "Composite" "Enable" 
EndSection

-------------------------------------------------------------------------------------

Redémarrez le serveur-x, et tout devrait démarrer normalement. Si votre carte gfx ne marche pas dès maintenant avec x, elle ne marchera pas avec  Xgl.

NOTE: Si vous le pouvez pas lancer le serveur-x, vous devez faire ceci:

sudo apt-get install linux-image-2.6.15-14- [color=blue]k7[/color] 
sudo apt-get install linux-restricted-modules-2.6.15-14- [color=blue]k7[/color]

J'ai utilisé le  k7 pour mon processeur amd64. Vous devrez probablement utiliser le kernel pour 386 à la place.

Reinstallez alors à nouveau histoire d'être sur nvidia-glx et nvidia-kernel-common.

Rebootez , et tentez de démarrer à nouveau x.

--------------------------------------------------------------------------------------

Si vous êtes ici ,c'est déjà bien ;-) . Maintenant vous devez installer ces paquetages:

sudo apt-get install libx11-6 libx11-dev libxau-dev libxau6 libxcomposite-dev libxcomposite1 libxcursor-dev libxcursor1 libxdamage-dev libxdamage1 libxdmcp-dev libxdmcp6 libxext-dev libxext6 libxfixes-dev libxfixes3 libxfont-dev libxfont1 libxft-dev libxft2 libxi-dev libxi6 libxinerama-dev libxinerama1 libxkbfile-dev libxkbfile1 libxklavier10 libxmu-dev libxmu-headers libxmu6 libxmuu-dev libxmuu1 libxp6 libxpm-dev libxpm4 libxrandr-dev libxrandr2 libxrender-dev libxrender1 libxres1 libxss1 libxt-dev libxt6 libxtrap-dev libxtrap6 libxtst-dev libxtst6 libxv-dev libxv1 libxvmc1 libxxf86dga1 libxxf86misc1 libxxf86vm1 x11proto-bigreqs-dev x11proto-composite-dev x11proto-core-dev x11proto-damage-dev x11proto-fixes-dev x11proto-fonts-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-resource-dev x11proto-scrnsaver-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-resource-dev x11proto-scrnsaver-dev x11proto-trap-dev x11proto-video-dev x11proto-xcmisc-dev x11proto-xext-dev x11proto-xinerama-dev libpng12-dev build-essential gcc gcc-3.4 libncurses5 libncurses5-dev libqt3-mt-dev m4 autoconf automake1.7 autotools-dev libtool libxfont-dev xtrans-dev libfreetype6-dev zlib1g-dev libgl1-mesa-dev gconf libgconf-dev gconf-editor cvs libgconf2-dev

Maintenant placez vous dans votre home/ à l'aide de l'instruction cd et entrez la commande:

cd ~ wget http://freedesktop.org/%7edavidr/xgl-svn_100.tar.bz2 tar -xjvf xgl-svn_100.tar.bz2

EDIT:
Le lien ci dessus est peut-être mort,donc voici un nouveau lien grâce à zasf. Le lien contient Xgl,glxcompmgr et les glitz dep files. Si vous les installez ,vous n'avez pas à les compiler vous-mêmes.Si vous les installez , skip the
howto down to the two choices (When you are about to run Xgl):
http://battlehorse.homelinux.net/JSPWiki/Wiki.jsp?page=Xgl

Voici d'autres sites qui hébergent ces fichiers au cas où le premier lien ne marche pas bien:
http://www.compsoc.man.ac.uk/%7Elewiz/xgl/
http://www.xs4all.nl/%7Esbkg0002/ubuntu/dapper/glxcompmgr_0.0.1-1_i386.deb
http://www.xs4all.nl/%7Esbkg0002/ubuntu/dapper/glitz_0.5.2-1_i386.deb
http://www.xs4all.nl/%7Esbkg0002/ubuntu/dapper/xserver_6.6.1-1_i386.deb
http://rapidshare.de/files/12904204/glitz_0.5.2-1_i386.deb.htm
http://rapidshare.de/files/12904366/glxcompmgr_0.0.1-1_i386.deb.html
http://rapidshare.de/files/12905554/xserver_6.6.1-1_i386.deb.html


Merci à tous d'heberger les fichiers sur vos serveurs.

Pour installer un paquetage .deb, entrez une commande du genre :

sudo dpkg -i NomDuPaquetage.deb

NOTE:

Maintenant nous allons compiler, si vous avez choisi de ne pas installer les paquetages en .deb. Si vous avez des problèmes avec automake, essayer d'installer automake1.9 au lieu d'automake1.7.
J'ai mis automake1.7 dans la liste des paquetages, parce que j'ai eu des problèmes avec la version 1.9. Mais pour certains,ça ne marchera qu'avec automake1.9.

Si vous voulez plutôt essayer avec Automake1.9:

sudo apt-get remove automake1.7 
sudo apt-get install automake1.9 
sudo update-alternatives --set automake /usr/bin/automake-1.9

Sinon sautez cette étape et utilisez plutôt la config par défaut qui est "automake1.7

Maintenant tapez dans un terminal:

cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/xorg login 
cvs -z3 -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/xorg co app 
cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/cairo login 
cvs -z3 -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/cairo co glitz 
cd glitz ./autogen.sh --prefix=/opt/fdo 
make 
sudo make install

Puis entrez la commande:

cd ../app/glxcompmgr 
./autogen.sh --prefix=/opt/fdo 
make 
sudo make install 
export PKG_CONFIG_PATH=/opt/fdo/lib/pkgconfig

puis celle-ci

cd ../../Xserver-6.6.1 
./configure --enable-xglserver --enable-glx --enable-xkb --disable-kdriveserver 
make 
sudo make install

Deux choix se présentent maintenant à vous. 1. Lancer le serveur Xgl en standalone, ou 2. le lancer dans ce serveur-X. Le second choix n'était pas très stable sur mon ordi,mais c'est bon si vous voulez juste le tester.

1.
Stoppez maintenant tout serveur-x en fonctionnement en tapant:
PUSH ALT + CTRL + F1

ouvrez une console en root et tapez

sudo /etc/init.d/ [color=blue]kdm[/color] stop

Remplacez  kdm par gdm si vous utilisez gnome.

Passez maintenant au petit 2.

2.

Connectez vous en root et tapez:

Xgl :1 -fullscreen -ac -accel xv -accel glx:pbuffer & DISPLAY=:1 xterm

Maintenant ça va normalement vous ouvrir un serveur Xgl avec xterm ouvert.

Maintenant tapez dans xterm:

pour les utilisateurs de kde:

su "nom de votre utilisateur" 
startkde

pour les utilisateurs de gnome:

su "nom de votre utilisateur" 
nautilus & metacity & gnome-panel & gnome-settings-daemon ou essayez peut-être sinon avec "gnome-session" à la place. Je n'ai pas vraiment bien testé la chose pour le moment.

Ceci démarrera kde ou gnome dans le serveur Xgl. Vous devez ouvrir votre répertoire home dans gnome pour lancer des applications en arrière plan. Gnome ne marchera pas tès bien.

Maintenant ouvrez un nouveau terminal et tapez ce qui suit:

sudo mkdir /opt/mesalibs 
cd /opt/mesalibs 
sudo cp /usr/lib/[color=blue]nvidia[/color]/libGL.so.1.2.xlibmesa libGL.so.1.2 
sudo ln -s libGL.so.1.2 libGL.so sudo ln -s libGL.so.1.2 libGL.so.1

Si vous avez une carte ATI, remplacez  nvidia par
fglrx

Dans le même terminal,tapez ceci:

LD_LIBRARY_PATH=/opt/mesalibs DISPLAY=:1 konsole

Cette commande ouvrira un nouveau terminal, où vous pourrez entrer la commande suivante:

/opt/fdo/bin/glxcompmgr shadow wobbly

Sinon vous pouvez plus simplement entrer la commande suivante:

LD_LIBRARY_PATH=/opt/mesalibs /opt/fdo/bin/glxcompmgr shadow wobbly

Mais je pense que c'est plus facile d'avoir un terminal ouvert ,ne serait-ce que pour glxcompmgr.

Pour voir les plugins disponibles, allez dans le dossier /opt/fdo/lib/glxcomp/

Le plugin fade ne marche pas très bien sur ma machine.

Suivez les étapes suivantes pour changer les touches que vous utilisez pour bouger le cube,etc:

1. Entrez la commande

/opt/fdo/bin/glxcompmgr gconf cube expose fade rotate shadow wobbly zoom

- le plugin gconf vous permet d'utiliser gconf pour changer the defaults
2. Lancez gconf-editor et trouvez le dossier /apps/gnome-composite/plugins/
3. Changez les raccourcis pour chaque plugin, par exemple changez zoom/screen0/options/initiate/value en [Control]Button3
4. Utilisez votre nouveau raccourci dans Xgl (relancer Xgl ou glxcompmgr n'est pas necessaire)

Attention: Quand j'ai utilisé le plugin fade, tout est devenu flou. Si celà vous arrive,faites ctrl + c.

Maintenant,invitez tous vos potes,et rendez jaloux vos amis qui ont encore windows

EDIT:
gconftool-2 peut aussi être utilisé pour configurer the glxcompmgr controls. Just do:

gconftool-2 --spawn glxcompmgr gconf cube rotate zoom wobbly shadow fade gconftool-2 --type=string --set /apps/gnome-composite/plugins/zoom/screen0/options/initiate/value '[Control]Button3'

8/02/06 EDIT:
Have now made a NOTE, about automake1.7/1.9, for compiling problems, in the howto.

9/02/06 EDIT:
Thiese fixes and updates will be fixed soon (Today if possible)

There is a new server release? I will try checking it out and add it to the howto
Compiz is released. Lets get it testet and included in the howto. Anyone got a dependencylist yet? Any help would be appreciated <-- Got It compiled now. I will update the howto tomorrow. Don't have time today. Sry.
- I need to update the driver section for Ati. Problems related. <- FIXED. With help from zasf.
- The xserver link is down I see.  <- FIXED thx to zasf
- Added more links to xserver, glxcompmgr and glitz

Dernière modification par teolemon (Le 19/02/2006, à 13:51)


I'm a bun, but you bun too!
Aidez-nous à traduire Ubuntu Trusty Tahr (doc, applis, descriptions d'applis, pages web) en français  >> http://doc.ubuntu-fr.org/ubuntu-l10n-fr

Hors ligne

#2 Le 09/02/2006, à 21:16

neni

Re : Tutoriel pour installer Xgl sur kde ou gnome

Le petit soucis est que le fichier xgl-svn_100.tar.bz2 n'est plus disponible à l'adresse http://freedesktop.org/~edavidr et que je ne trouve pas où me le procurer.
Avec le CVS de xorg, cela ne fonctionne pas.

Hors ligne

#3 Le 10/02/2006, à 06:02

Valère

Re : Tutoriel pour installer Xgl sur kde ou gnome

Des .deb ont été mis à dispositions sur le topic original, il n'y a meme plus besoin de compiler.


1984 was not supposed to be an instruction manual
hostux.net serveur mail/jabber + hébergement d'images.

Hors ligne

#4 Le 10/02/2006, à 06:11

Valère

Re : Tutoriel pour installer Xgl sur kde ou gnome

teolemon a écrit :

Maintenant ouvrez un nouveau terminal et tapez ce qui suit:

sudo mkdir /opt/mesalibs cd /opt/mesalibs sudo cp /usr/lib/nvidia/libGL.so.1.2.xlibmesa libGL.so.1.2 sudo ln -s libGL.so.1.2 libGL.so sudo ln -s libGL.so.1.2 libGL.so.1

If you are an ATI user, replace the nvidia with
fglrx

Pour les possesseurs de cartes ATI, téléchargezlibgl1-mesa.deb, décompressez l'archive.
Puis copiez libGL.so.1.2 (libgl1-mesa_6.4.1-0ubuntu3_i386.deb_FILES/usr/lib) dans /opt/mesalibs
N'oubliez pas :

sudo ln -s libGL.so.1.2 libGL.so
sudo ln -s libGL.so.1.2 libGL.so.1

1984 was not supposed to be an instruction manual
hostux.net serveur mail/jabber + hébergement d'images.

Hors ligne

#5 Le 10/02/2006, à 07:43

zafx

Re : Tutoriel pour installer Xgl sur kde ou gnome

J'ai une carte ati. Je crois que je vais me tenter XGL Merci pour la traduction, j'avoue que j'ai encore un peu de mal avec l'anglais technique. Et merci aussi pour les info sur les cartes ATI. J'ai plus aucune excuse maintenant!:D

Hors ligne

#6 Le 10/02/2006, à 12:14

Jonas

Re : Tutoriel pour installer Xgl sur kde ou gnome

Dapper Drake est tout a fait fonctionnel ou pas ???

J'ai super envie de tester XGL mais je veux avoir un ordi fonctionnel ...

Mega super idée de traduire cette article wink

Dernière modification par Jonas (Le 10/02/2006, à 12:15)


Pour poster facilement des images et fichiers sur un forum jetez un coup d'oeil ici

Hors ligne

#7 Le 10/02/2006, à 20:37

nidaime

Re : Tutoriel pour installer Xgl sur kde ou gnome

Je viens de faire l'install xgl en suivant le tuto !
Tout marche très bien tongue, mais je souhaiterais maintenant faire de xgl mon serveur x par défaut pour pas me retaper la manip à chaque foids.

J'ai trouvé ce script sur le forum du tutorial anglais :

#!/bin/sh
export DISPLAY=:1
export LD_LIBRARY_PATH=/opt/mesalibs:$LD_LIBRARY_PATH

sudo Xgl $DISPLAY -fullscreen -ac -accel xv -accel glx:pbuffer &

/opt/fdo/bin/glxcompmgr shadow wobbly &

exec gnome-session

Quelqu'un peut il me dire comment l'utiliser ?
Dans quel fichier dois-l'insérer ?

Merci

#8 Le 10/02/2006, à 20:42

mars

Re : Tutoriel pour installer Xgl sur kde ou gnome

et avec du i915 comment qu'on fait? d'apres ce que j'ai vue on peut espérer quelques perfs valable! faut espérer que l'utilisation soit un peu simplifié pour la finale ....

Hors ligne

#9 Le 11/02/2006, à 18:59

tshirtman

Re : Tutoriel pour installer Xgl sur kde ou gnome

moi ça fait 2 jours que je suis su xgl et franchement je veux aussi en faire mon bureau par défault ... pour le script ça m'interresse aussi!

prochain défi: mettre e17 par dessus ça tongue!

Hors ligne

#10 Le 11/02/2006, à 19:45

jjgan

Re : Tutoriel pour installer Xgl sur kde ou gnome

Au niveau des possesseurs de cartes ATI ça posse des problèmes ?
Je vois notamment l'utilisation de composite ... qui ne marche pas sous ATI
des effets disparaissent ? (transparence, fade... ) ?

J'hésite a passer sous Dapper tout de suite, c'est "stable" ?

Merci


http://jerome.phplister2.org/

Hors ligne

#11 Le 11/02/2006, à 21:15

teolemon

Re : Tutoriel pour installer Xgl sur kde ou gnome

Je continue la traduc mais j'ai de plus en plus de mal à voire les modifs de l'original.Pourriez vous me les signaler ?
D'autre part, Yann, est-il possible d'activer les balises de couleur dans le code,et ce même si ce n'est pas très en accord avec la charte graphique?
Toute aide ou correction est la bienvenue.

Dernière modification par teolemon (Le 12/02/2006, à 16:25)


I'm a bun, but you bun too!
Aidez-nous à traduire Ubuntu Trusty Tahr (doc, applis, descriptions d'applis, pages web) en français  >> http://doc.ubuntu-fr.org/ubuntu-l10n-fr

Hors ligne

#12 Le 12/02/2006, à 17:18

grozeille

Re : Tutoriel pour installer Xgl sur kde ou gnome

>Valère, t'as l'air doué, tu peux ptêtre m'aider...
j'ai une ATI 9000pro + Ubuntu Dapper + toutes les maj (xorg7 par exemple)
quand je lance Xorg + glxinfo j'obtiens :
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9000 DDR Generic
OpenGL version string: 1.3.1041 (X4.3.0-8.21.7)
Donc à priori tout est OK.

Je lance cette fois Xgl (grâce aux debs de http://battlehorse.homelinux.net/w/Wiki.jsp?page=Xgl)
et la glxinfo me donne :
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.5 Mesa 6.5

hmm moi pas content...
m'enfin bon, je test quand même "glxcompmgr" et il marche plutôt bien...

puis je souhaite tester "compiz", mais lui m'indique qu'il me manque l'extension "GL_EXT_texture_from_pixmap".
Si on regarde la procédure de compilation, on voit qu'on a besoin d'un patch pour activer cette extension... et on supose que mesa_20060212-1_i386.deb contient cette modification...
Pour infos, ni les drivers MESA ni même ceux d'ATI n'ont cette extension quand on regarde glxinfo...

quand j'install ce DEB (qui contient des libGL.so.*), je ne vois pas de changement à ceux de /usr/lib... donc ou s'installent ils ?
si je les remplace à la main.. BROK.. plus de X qui se lance...

dans la manip, on a besoin de copier d'autre libGL dans /opt/mesalib et de préciser LD_LIBRARY_PATH=/opt/mesalibs avant de lancer compiz ou glxcompmgr... pourquoi 2 libGL ? qu'ont-ils de différent ? Celui de mesa doit-il être dans /usr/lib ? lequel a besoin de l'extension GL_EXT_texture_from_pixmap ? pourquoi avec XGL j'ai MESA alors que j'ai installé le deb xorg-driver-fglrx et que je n'ai pas touché aux libGL par la suite ?

tout ça est confu pour moi... j'ai l'impression que OPENGL c'est le gros bordel sous linux...

EDIT : j'ai oublié de dire que j'utilise les paquets xorg-driver-fglrx car je n'arrive pas à installer les paquets/.run d'ATI... l'installation se passe, je configure xorg.conf avec fglrx mais j'obtient toujours glxinfo => MESA... sad il manque sans doute une étape à la procédure ? dois-je remplacer manuellement des libGL.so quelque part ?


EDIT : bon... après avoir essayé plusieurs fois, je n'ai plus l'erreur "missing GL_EXT_texture_from_pixmap" (car j'ai pas lu l'infos sur le paquet deb à décompresser dans /opt/mesalibs)... donc compiz ce lance... mais j'obtient un écran NOIR sad
de plus, mes raccourcis ne marchent plus (pour lancer expose ou cube)

Dernière modification par grozeille (Le 13/02/2006, à 01:18)

Hors ligne

#13 Le 14/02/2006, à 00:20

skateinmars

Re : Tutoriel pour installer Xgl sur kde ou gnome

quelqun aurait-il deja essaye de le compiler sur une archi 64 bits ?

Hors ligne

#14 Le 14/02/2006, à 11:29

general alcazar

Re : Tutoriel pour installer Xgl sur kde ou gnome

nidaime a écrit :

Je viens de faire l'install xgl en suivant le tuto !
Tout marche très bien tongue

Pourrais tu m'expliquer  comment tu parviens à faire fonctionner le cube et le zoom ?

dans gconf-editor j'ai toutes les entrées qu'il faut.
Par exemple pour => cube=> next-slide=> type =>   binding
                                                                     value => <Alt>space

Mais si je fais alt space il ne se passe rien.

Hors ligne

#15 Le 14/02/2006, à 14:10

tshirtman

Re : Tutoriel pour installer Xgl sur kde ou gnome

gconftool-2 --type=String --set /apps/gnome-composite/plugins/rotate/screen0/options/initiate/value '<ModeSwitch>Button2'
gconftool-2 --type=String --set /apps/gnome-composite/plugins/rotate/screen0/options/terminate/value '<Release>Button2'
gconftool-2 --type=String --set /apps/gnome-composite/plugins/zoom/screen0/options/zoom_in/value '<ModeSwitch>Button4'
gconftool-2 --type=String --set /apps/gnome-composite/plugins/zoom/screen0/options/zoom_out/value '<ModeSwitch>Button5'
trouvé sur un forum gentoo ...
pour moi ça marche pour la rotation du cube (alt-gr + clic molette) par contre pas le zoom (qui devrait etre alt-gr + molette)... j'ai toujours pas compris
note que tu peut bien sur mettre les valeurs toi même avec gconf-editor mais ces commandes le font pour toi! cool:D en espérant que ça marche pour toi!:D

quelqu'un a fait marcher expose?

Dernière modification par tshirtman (Le 14/02/2006, à 14:12)

Hors ligne

#16 Le 14/02/2006, à 17:17

nidaime

Re : Tutoriel pour installer Xgl sur kde ou gnome

En réponse à general alcazar et tshirtman :

Tout dépend du conpositor que vous utilisez, avec xglcompmgr pas testé ...

par contre, avec compiz, tout fonctionne sans rien paramétrer !

Voici les commandes :

-Switch windows = Alt + Tab
-Arrange and View All Windows = F12 turns on or off; clicking a window will zoom it to the front
-Switch desktops on cube = Ctrl + Alt + Left/Right Arrow
-Switch desktops on cube - with active window following = Ctrl + Shift + Alt + Left/Right Arrow
-Make window translucent/opaque = right-click the window's title bar and select Opacity
-Zoom-in once = Super-key right-click
-Zoom-in manually = Super-key + wheel mouse up
-Zoom-out manually = Super-key + wheel mouse down
-Move window = Alt + left-click
-Snap Move window (will stick to borders) = Ctrl + Alt + left-click
-Resize window = Alt + right-click


Un petit lien pour les deb de Mesa + compiz + libsvg-cairo + glitz + Xgl
http://z.narutochaos.com/ubuntu/xgl/

Ca à l'air de marcher, mais le mieux reste la compilation...

#17 Le 14/02/2006, à 19:38

LpBv

Re : Tutoriel pour installer Xgl sur kde ou gnome

Bonjour,

Est il possible d'installer XGL sur Breezy ?

Hors ligne

#18 Le 14/02/2006, à 19:57

general alcazar

Re : Tutoriel pour installer Xgl sur kde ou gnome

nidaime a écrit :

En réponse à general alcazar et tshirtman :

Tout dépend du conpositor que vous utilisez, avec xglcompmgr pas testé ...

par contre, avec compiz, tout fonctionne sans rien paramétrer !

J'en suis encore à xglcompmgr et pour le cube et le zoom il n'y a rien à faire,, ça ne marche pas.
J'ai seulement les fenêtres molles et les ombrages.
Je tourne avec les deb trouvés ici :
http://battlehorse.homelinux.net/w/Wiki.jsp?page=Xgl

J'ai essayé de lancer compiz (version deb) mais ça plante.
Va falloir compiler roll

Hors ligne

#19 Le 14/02/2006, à 20:40

Nidaime

Re : Tutoriel pour installer Xgl sur kde ou gnome

general alcazar a écrit :

J'ai essayé de lancer compiz (version deb) mais ça plante.

un segfault ??

Pour lancer compiz utilises ce script :

#!/bin/bash
sudo killall gdm
sudo killall Xgl &
sudo killall Xorg &
wait
sleep 2
sudo Xgl :1 -ac -accel xv -accel glx:pbuffer &
sleep 4
DISPLAY=:1 LD_LIBRARY_PATH=/opt/mesa/lib/ /opt/fdo/bin/gnome-window-decorator &
DISPLAY=:1 LD_LIBRARY_PATH=/opt/mesa/lib/ /opt/fdo/bin/compiz decoration wobbly fade minimize cube rotate zoom scale move resize place menu &
sleep 4
DISPLAY=:1 gnome-settings-daemon &
DISPLAY=:1 gnome-panel &
DISPLAY=:1 nautilus &
sleep 8

Hors ligne

#20 Le 14/02/2006, à 20:41

Djspit

Re : Tutoriel pour installer Xgl sur kde ou gnome

J'ai essayé avec xglcompmgr et je suis dans le même cas que alcazar : fenêtre molle seulement (amuzant d'ailleur) !
Je suis sur que cube et rotate sont lancées correctement, et je pense que c'est juste la touche "windows" qui n'est pas reconnue...
J'ai essayé Compiz, plus difficile faire fonctionner, mais une fois executer gnome-windows-decoration, rien ne se passe, gnome ne démarre pas ?
Je suis très impatient de voir sortir les .deb stables et de nouvelles extentions !

Merci beaucoup au traducteur, cela m'a pas mal aidé ! au passage, sans doute un oubli, je suis étonné de ne pas voir de lien vers la version originale du how to !

Hors ligne

#21 Le 14/02/2006, à 22:18

tshirtman

Re : Tutoriel pour installer Xgl sur kde ou gnome

pour cube et rotate avec xcompmgr il faut metre cube et rotate dans les extentions a charger sinon ça risque pas de marcher (voir le script donné plus haut qui est bon a pars ça) idem pour le zoom et expose sauf que eux ça marche toujours pas pour moi!

Hors ligne

#22 Le 14/02/2006, à 22:47

Azuriel

Re : Tutoriel pour installer Xgl sur kde ou gnome

Tout marche, sauf gnome-window-decoration que je ne parviens pas à installer.
Je compile compiz mais il refuse me compiler gnome-window-decorator hmm

Hors ligne

#23 Le 14/02/2006, à 22:49

general alcazar

Re : Tutoriel pour installer Xgl sur kde ou gnome

Nidaime a écrit :
general alcazar a écrit :

J'ai essayé de lancer compiz (version deb) mais ça plante.

un segfault ??

Merci pour le script mais ce n'est pas mieux, gnome se lance mais avec des fenêtres sans bordure.
Puisque tu as l'air d'avoir réussi à faire fonctionner le bouzin.
Pourrais tu nous faire un petit howto?
En fait je n'y pige pas grand chose.
Qu'est ce qu'il faut compiler et installer exactement.
Xgl, compiz et quoi d'autre  ?

Merci d'avance.

Hors ligne

#24 Le 14/02/2006, à 23:20

tshirtman

Re : Tutoriel pour installer Xgl sur kde ou gnome

dans le script j'ai remplacé

DISPLAY=:1 gnome-settings-daemon &
DISPLAY=:1 gnome-panel &
DISPLAY=:1 nautilus &

par

DISPLAY=:1 gnome-session &

ça évite le problème rencontré par notre general (que j'ai eu aussi)
ensuite j'ai changé le chemin de compiz et gnome-window-decoration pour que çà corresponde a la réalité (/usr/lib/) j'ai peut etre tors sur ce point...
et j'ai l'erreur rencontré plus haut par grozeille

mais lui m'indique qu'il me manque l'extension "GL_EXT_texture_from_pixmap".

j'en suis a chercher la solution à ça... je vais essayer de suivre la voie qu'il indique.

edit installer les paquets xserver et mesa diso a l'addresse donné par grozeil permet de lancer compiz comme il faut ...

expose (F12) et le cube marchent pour la transparence par contre j'utilise toujours transset : je n'ai pas le menu. zoom marche po sad, sad les icones ne sont plus moles quand on les déplace:(

mais vraiment bien quand même compiz ... je suis fan des fentres collant au bords (ctrl plus déplacement).

Dernière modification par tshirtman (Le 14/02/2006, à 23:48)

Hors ligne

#25 Le 15/02/2006, à 01:36

Nidaime

Re : Tutoriel pour installer Xgl sur kde ou gnome

Alors,
Nous allons voir coment installer compiz correctement. Pour cela vous devez avoir suivi le tuto et fait tourner Xgl + glxcompmgr.

1) Installons les librairies nécessaires à la compilation :

sudo apt-get install libgtk2.0-dev libgnome-desktop-dev libwnck-dev libpango1.0-dev libxxf86vm-dev makedepend

2) Nous allons récupérer la dernière version de mesa :

cd ~
cvs -d:pserver:anonymous@pdx.freedesktop.org:/cvs/mesa login
cvs -d:pserver:anonymous@pdx.freedesktop.org:/cvs/mesa co -r mesa_6_4_2 Mesa

Télécharger ce patch  et placez le dans le dossier Mesa (~/Mesa)
On se place dans le dossier et on applique le patch :

cd Mesa
tar -xvzf patches.tar.gz
patch -p0 < ./mesa-glx-x11-get-drawable-attribs-fix-1.diff
patch -p0 < ./mesa-glx-x11-texture-from-pixmap-1.patch

Nous patchons maintenant glxproto.h :

cd /usr/include/GL/
sudo cp glxproto.h glxproto.bak
sudo patch -p0 <~/Mesa/glxproto.patch

On compile ensuite mesa (afin de na pas tout casser, on va installer mesa dans /opt/mesa à la place de /usr/locale) :

cd ~/Mesa
sudo ln -s /usr/bin/makedepend /usr/X11R6/bin/makedepend
make linux-dri-x86 
sudo mkdir /opt/mesa
sudo make install

On va vous demander ou de spécifier certains dossiers, indiquez :
/opt/mesa/include/   pour include
/opt/mesa/lib/   pour lib

On va maitenant télécharger la dernière version de compiz, et l'installer :

cd ~
cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/xorg co app/compiz
cd app/compiz
./autogen.sh --prefix=/opt/fdo/
make
sudo make install

Voila smile l'installation de compiz est terminée  !!
Vous devez obtenir ceci :

the following optional plugins will be compiled:
  gconf: yes
  place: yes
  menu:  yes
  svg:   no

and the following optional features will be compiled:
  gnome: yes
  kde:   no

Pour finir, utilisez le script que je cite plus haut et ca devrait rouler.
Il se peut que l'orsque vous lancez le script gnome-windows-manager ne se lance pas.
Relancez le une seconde fois après un Ctrl+Alt+backspace , il se chargera correctement.

Dernière modification par Nidaime (Le 15/02/2006, à 02:57)

Hors ligne