Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 25/12/2008, à 19:37

JujuLand

Pb install Ubuntu sur iMac M5521

Bonjour,

Lors de l'install, alors que je boote sur le CD, l'install bloque sur la détection du lecteur de CD :

Aucun lecteur de CD-Rom n'a été détecté

Il peut être nécessaire ce charger des pilotes additionnels de lecteurs de
CD-Rom depuis une disquette de pilotes. Si vous une telle disquette,
placez-la dans le lecteur puis continuez. Dans le cas contraire, vous
aurez la possibilité de choisir vous-même le module de pilote de lecteur de
CD-Rom.

Faut-il choisir le pilote de lecteur de CD-Rom depuis une disquette de pilotes?

                  Oui                       Non

Le problème, c'est que :

1) je n'ai pas de lecteur de disquette.
2) je n'ai pas la disquette en question.

Y-a-t-il une solution ?

Merci

A+

Hors ligne

#2 Le 26/12/2008, à 00:59

samou

Re : Pb install Ubuntu sur iMac M5521

J'ai exactement le même problème lors de l'installation d'ubuntu 8.10 sur un power-mac G4

A +

Hors ligne

#3 Le 26/12/2008, à 19:27

gagoune

Re : Pb install Ubuntu sur iMac M5521

Salut !
Idem pour moi, j'ai dû passer pas la 7.10 pour mettre Xubuntu sur mon iBook G3, puis migrer vers 8.04... quant-à la migration vers Intrepid Ibex, j'ai dû lancer une mise-à-jour partielle à partir du CD (alternate) téléchargé sur le site...
C'est en cours... pourvu que ça passe ! lol


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#4 Le 31/12/2008, à 10:47

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Je viens d'essayer la 7.10

Cà semble fonctionner (par contre, il faut nécessairement le CD alternate).

La mise à jour vers l'alternate 8.04 ne devrait pas, à priori, poser de problème.

On verra ensuite pour la 8.10

A+

Hors ligne

#5 Le 31/12/2008, à 20:41

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Je disais que ça semblait fonctionner, mais je parlais alors juste de l'install.

Par contre, l'install viens de se finir, et après ejection du CD, le redémarrage est laborieux. Je ne sasi pas si j'ai mal fait le partitionnement, mais il semble ne pas trouver de boot.

J'ai pourtant créé une partition NewWorld (enfin le nom ressemble à ça).

Voici le partitionnement utilisé:

Partition primaire >>> NewWorld  1 Go
Partition primaire >>> /              8 Go
Partiution secondaire >>> home  10 Go
Partiton de swap                      1 Go

Mémoire : 512 Mo

L'iMac attends quelque chose pour booter. (icone de dossier au milieu de l'écran)

Si quelqu'un voit ou j'ai raté quelque chose, et comment y remédier ...

A+

Hors ligne

#6 Le 01/01/2009, à 18:59

gagoune

Re : Pb install Ubuntu sur iMac M5521

Salut ET BONNE ANNEE A TOUS ! big_smile
Alors, après maintes tentatives de mettre 8.10 sur les différents G3 qui m'entourent, ça bug constamment ! mad

D'après ce que j'ai lu sur les sites anglophones, c'est le cas pour tous les PPC... (n'hésitez pas à donner votre avis ! wink )...
Pour ma part, je me contente de 8.04.1 tongue qui marche très bien sur ma palourde...

Il faut encore que je rajoute quelques sources de logiciels (histoire de ne manquer de rien... ), mais tout baigne...

Sur un iMac DV SE (400MHz avec lecteur DVD 'mange-disque'), je n'arrive pas à éjecter les CD audio... les logiciels 'standards' qui les lisent n'offrent pas d'option éjecter qui s'activent lors de l'insertion d'un CD Audio...

Et sur PowerMac G3 (B&B), tout à l'air opérationnel.

Pour le moment, je bloque sur un PowerMac G5 (2x2,3 GHz, si je ne me trompe) car le HD à l'air d'avoir des clusters défectueux... donc le formatage est LONG !

(pour info, seul la palourde est ma propriété... les autres appartiennent à d'autres membres de ma famille qui voient leur Macs chéris abandonnés par Apple et veulent un OS qui suivent un peu !)

PS : @JujuLand
Pour ton partitionnement, je suis surpris que tu aies créé une partition Bootstrap d'un GIGA alors qu'il n'est demandé qu'un Méga-Octet... Si tu peux juste confirmé qu'il n'y a pas d'erreur dans ton énoncé ! wink

Dernière modification par gagoune (Le 01/01/2009, à 19:01)


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#7 Le 02/01/2009, à 10:30

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Salut, et meilleurs voeux

Effectivement, je ne devais pas avoir les yeux en face des trous lorsque j'ai fait l'install. J'ai bien créé une partition de boot de 1 Go.

Hormis le fait que je doive retailler les partitions (mais est-ce possible, vu que le live CD ne fonctionne pas), le boot ne se fait pas sur cette partition, que j'ai du déclarer comme partition de boot.

Ai-je raté quelque chose, et comment y remédier ?

Je précise de plus, que je n'ai aucun système mac, vu que je ne vois pas l'intérêt de conserver un Mac OS 9.1,mais peut-être que mon problème vient de là ...

A+

Dernière modification par JujuLand (Le 02/01/2009, à 10:31)

Hors ligne

#8 Le 04/01/2009, à 21:34

gagoune

Re : Pb install Ubuntu sur iMac M5521

Salut !
J'ai tâché de trouvé ton modèle d'iMac pour ne pas te dire de bêtises...
Donc, pour être sûr, tu as bien :
un iMac G3 à 600 ou 700 MHz
avec au 512 Mo de RAM si j'ai bien compris... et
au 20 Go de HD
si tu veux (comme moi durant ces dernières vacances) mettre ubuntu SEUL dessus, je peux te donner quelques liens ou même si ça te chante, j'avais fais un tuto pour un dual boot avec Mac OS X, si on retire la partie concernant Mac OS X, tout devrait se simplifier !
bref, si ça t'intéresse, je te recommande de partir sur l'installation de Xubuntu 7.10 que tu trouveras ici :
http://cdimage.ubuntu.com/xubuntu/ports/releases/7.10/release/ (prends bien la version alternate !)
et en te servant du tuto (qui m'a beaucoup aider) qui se trouve là :
http://chamblandes.tuxfamily.org/installationMac/preparatifs1.html
Voilà de quoi commencer !
Pour le partitionnement, je te conseille :
- 1 Mo - bootstrap (newworld)
- 8 Go - racine ( / )
- 1 Go - swap
- le reste - données ( /Home )

Commence avec ça et reviens au premier problème rencontré... (ça ne devrait pas tarder... wink )

P.S. : Si je te recommande Xubuntu au lieu de Ubuntu, c'est parce que Xfce (utilisé dans Xubuntu) est plus léger que Gnome (utilisé dans Ubuntu) ou que KDE (utilisé dans Kubuntu) !


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#9 Le 04/01/2009, à 22:23

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Pour tout dire, je ne sais pas si c'est un G3, je n'ai pas vu de truc de ce type, j'ai juste trouvé sous la bête, une reférence modèle M5521.

Pour la mémoire, je l'ai upgradé à 512 Mo et j'ai changé le DD de 8 Go (si mes souvenirs sont bons) pour un 20 Go

Je voudrais bien rester sous gnome, mais le problème principal pour moi en ce moment, c'est de savoir pourquoi et comment booter sur cette putain de partition newworld.

Cà me parait bizarre que ça ait foiré, le flag de boot serait parti sans que je m'en aperçoive ? Et même, dans ce cas, n'y a-t-il pas un moyen de le forcer ??

A+

Dernière modification par JujuLand (Le 04/01/2009, à 22:24)

Hors ligne

#10 Le 05/01/2009, à 13:36

gagoune

Re : Pb install Ubuntu sur iMac M5521

Salut !
Alors pour connaître les spécifications de ton mac, (sous OSX) va dans le "menu pomme" (en haut à gauche) et clique sur "A propos de ce Mac".
Dans la fenêtre qui s'ouvre, clique sur "Plus d'infos..." pour avoir... plus d'infos (CQFD tongue ) !
Quand à ton install, je me demande si ce n'est pas justement la taille de ta partition bootstrap qui pose problème... mais, à vrai dire, je n'y connais pas grand chose dans ce domaine...
Le plus sûr serait encore de ré-installer 'proprement' ubuntu sur ton iMac...
Si tu as un G3 qui tourne à plus de 600MHz, tu peux tenter de garder Gnome (donc Ubuntu au lieu de Xubuntu comme je te le disais plus haut).
Voilà... je ne peux pas t'en dire plus ! Désolé !


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#11 Le 05/01/2009, à 15:20

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Je n'ai plus d'os, le disque a juste les partitions que je t'ai donné.

Je vais essayer de diminuer la partition newworld en faisant une session console, pour voir si ça permet de booter, ensuite il faudra que je déplace les partitions et que je retaille le home.

C'est simple à faire sur un pc, car nombre d'outils permettent de le faire, et même le cd live de ubuntu, malheureusement, ça semble difficile depuis un mac, à moins que la partition newworld me permette le boot sur le live cd, mais je doute.

Merci

A+

Hors ligne

#12 Le 10/01/2009, à 12:09

JujuLand

Re : Pb install Ubuntu sur iMac M5521

J'ai essayé de partitionner comme tu me l'avais indiqué, et j'avais un message d'erreur, m'indiquant l'impossibilité de partitionner home.

J'ai donc change le disque, pensant que le problème se situait sur la fin du disque, et que l'erreur ne pouvait peut-être pas se voir à l'install, vu qu'il n'y a pas de formattage de la partition swap.

Je viens donc de recommencer avec un nouveau disque, et je me suis aperçu d'un détail qui aurait peut-être pû poser un problème.

Lors du partitionnement, il me proposait par défaut home, ce que j'acceptais, et non /home comme il aurait dû. J'ai corrigé en choisissant /home, et cette fois c'est passé. Coïncidence ?

Bon, je laisse l'install se finir, et je vois si je boote cette fois sur Ubuntu.

A+

Dernière modification par JujuLand (Le 10/01/2009, à 12:10)

Hors ligne

#13 Le 10/01/2009, à 16:35

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Hum, l'install est finie, mais pas de boot, j'ai un petit dossier au milieu de l'écran, et impossible de faire quelque chose.

Il me vient une idée, j'ai laissé le boot par défaut sur la partition newworld, mais comme je n'ai pas de system mac, c'est peut-être normal que ça ne boote pas, grub a probablement été installé sur la partition contenant /, il il faudrait dans ce cas déclarer cette partition comme partition de boot ?

Merci de me confirmer ma probable erreur, et s'il y a un moyen d'éviter une autre install, en changeant la partition bootable ???

A+

Hors ligne

#14 Le 20/01/2009, à 19:12

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Bon, y'a pas ici de spécialiste de Mac qui ait installé Ubuntu sur son ordi ?

Je suppose que c'est un problème simple pour des afficionados Mac, non ??

sad

A+

Hors ligne

#15 Le 21/01/2009, à 16:43

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Bon, en fouinant partout ou je pouvais, j'ai trouvé quelques infos.

J'ai notamment trouvé le type exact de mon iMac, mais je ne sais pas s'il utilise old World ou NewWorld:

Product MPN       MPN     M5521
Form Factor         All-in-one
Processor            PowerPC 750 (G3) 400 MHz
Display          15 in. CRT Display
Processor Type   PowerPC 750 (G3)
Processor Speed  400 MHz
Processor Manufacturer     Motorola
Installed Qty.     1
Max Qty.     1
Display Type     CRT Display
Display Size     15 in.
Installed RAM  64 MB
Supported RAM speeds     100 MHz
Installed Video Memory     16 MB
Installed Cache Memory     512 KB
Integrated Input/Output Ports     USB 1.1 x 2 • FireWire (IEEE1394a) x 2 • RJ45 Lan Port x 1 • RJ11 Phone Jack x 1 (Input)
CD / DVD Type      CD-ROM
Optical Drive Read Speed     24x (CD)
On Board Graphic Processor     ATI Rage 128GL
Modem Type     Fax / Modem
Networking Type     Integrated 10/100 Network Card
Data Link Protocol     Ethernet • Fast Ethernet
OS Certified     Apple MacOS 9.2

Cà, c'est pour la bestiole, avec de plus, un truc curieux, c'est que le système que j'ai trouvé dessus est le 9.1, et non le 9.2, mais c'est probablement un détail, Mais de toute façon, çà ne me dit pas si c'est un oldWorld ou un New World.

J'espère que ce n'est pas un OldWorld, car je ne voudrais pas avoir OSx 9.1, mais seulement Ubuntu.

Je viens de trouver çà sur une page sur doc ubuntu :

All G4s and later machines are NewWorld. Almost all G3s are NewWorld, including all iMacs and iBooks. However, the "beige" G3 desktop and some early G3 servers are OldWorld.

Ca voudrait donc dire que mon G3 est NewWorld, non?

Mais vu que ça ne boote pas alors que j'ai une partition NewWorld, j'ai bien peur que ça ne soit malheureusement le cas ... à moins qu'il ne faille y mettre des choses à la main, dans cette partition.
Mais comment alors ?

Si quelqu'un peut m'indiquer ...

A+

Dernière modification par JujuLand (Le 21/01/2009, à 16:51)

Hors ligne

#16 Le 22/01/2009, à 20:06

JujuLand

Re : Pb install Ubuntu sur iMac M5521

Je viens d'avoir des infos sur ubuntuforums (j'ai ouvert un fil dans le forum Mac), et il y a des solutions:

Pour 8.04.1 :

sous yaboot:

install modprobe ide-core

ou, si ça continuait malgré tout, ouvrir une session avec Alt-Pomme-F2

# modprobe ide-core
# exit

passer en session 1 avec Alt-Pomme-F1, et continuer l'install

pour 8.10 :

remplacer ide-core par ide-scsi
- ne fonctionne pas depuis yaboot, faut donc le faire en session.

Tout ceci va permettre l'install, mais ce n'est pas tout à fait fini, et c'est peut-être une des raisons du non lancement que j'avais après 7.10, il faut ajouter le lancement de ide-core ou ide-scsi (selon la version)

Donc il faut faire des modifs, avant de quitter l'install

Il faut ajouter ide-core ou ide-scsi (suivant version) à
/etc/initramfs-tools/modules

et mettre à jour sur le disque par la commande:

sudo update-initramfs -u

Un redémarrage ensuite devrait être correct.

Mais je n'en suis pas encore là, et j'espère confirmer tout çà.

A+

Hors ligne

Haut de page ↑