Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 25/12/2008, à 19:52

Sylvain Boily

Paquet flightgear 1.9.0 pour Hardy

Salut,

Je suis entrain de terminer le packaging complet pour la version 1.9.0 smile. Je vais l'uploader au même endroit de suite. Par contre comme c'est méga long (compilation super longue ...) à faire c'est pas encore parfait. Mais ça lance le jeu et ça semble marcher smile.

C'est un peu cracra mais bon pour les impatients comme moi c'est parfait wink
Donc petite procédure rapide :

cd ~
mkdir fgfs-deb
cd fgfs-deb
wget http://www.proformatique.org/deb/fgfs-base_1.9.0-1ubuntu1_all.deb
wget http://www.proformatique.org/deb/flightgear_1.9.0-0ubuntu0_i386.deb
wget http://www.proformatique.org/deb/libopenscenegraph8_2.7.8-1ubuntu0_i386.deb
wget http://www.proformatique.org/deb/libopenthreads8_2.7.8-1ubuntu0_i386.deb
wget http://www.proformatique.org/deb/openscenegraph_2.7.8-1ubuntu0_i386.deb
wget http://www.proformatique.org/deb/plib1.8.5_1.8.5-0ubuntu1_i386.deb
wget http://www.proformatique.org/deb/simgear1.9.0_1.9.0-0ubuntu0_i386.deb
sudo apt-get install libpng3
sudo dpkg -i --force-all *.deb

Puis lancer votre jeu smile, j'ai pas encore eu le temps de faire fgrun 1.5 mais à suivre.

Dès que j'ai le temps je ferai pour la 8.10 aussi mais ça doit peut-être marcher avec ces packages.

Bon jeu.
Sylvain

#2 Le 26/12/2008, à 11:11

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Salut,

J'ai aussi uploadé pour intrepid. Elle est vraiment symap cette nouvelle version wink

Du coup j'ai réorganisé les répertoires.

Bon jeu.
Sylvain

#3 Le 28/12/2008, à 18:30

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Voilà pour simplifier j'ai fait un repo pour intrepid :

Ajouter dans votre /etc/apt/sources.list la ligne suivante :

deb http://proformatique.org/deb intrepid main

Puis faire :

sudo apt-get update
sudo apt-get install flightgear fgrun

N'hésitez pas à me remonter les soucis.

A+

#4 Le 29/12/2008, à 18:31

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

Bonjour Sylvain,

Quand j'essaie à l' apt-get install j'ai

Les paquets suivants contiennent des dépendances non satisfaites :
fgrun: Dépend: libopenscenegraph8 (>= 2.7.8) mais il n'est pas installable
Dépend: libopenthreads8 (>= 2.7.8) mais il n'est pas installable
Dépend: simgear1.9.0 (>= 1.9.0) mais il n'est pas installable
E: Paquets défectueux

«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#5 Le 29/12/2008, à 20:14

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Ah j'ai pas ce souci, si tu essaies d'installer juste openscenegraph tu as quoi comme erreur ?
Je vais installer une intrepid tout fraiche et faire le test voir si j'arrive à le reproduire.

#6 Le 29/12/2008, à 20:56

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Ah oui en effet il manque les packages ... Bon je regarde ça et j'update :-].

#7 Le 29/12/2008, à 22:29

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

Merci pour le mal que tu te donnes.


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#8 Le 30/12/2008, à 08:34

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Bon voilà pour fgrun c'est corrigé, je fini de refaire le package de flightgear dans la journée.
J'ai testé avec une installation toute neuve d'intrepid avec les dernières mise à jour et ça s'installe sans souci.

#9 Le 30/12/2008, à 09:14

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

Bonjour, cela fonctionne, j'ai bien flightgear et fgrun d'installé, merci beaucoup pour ton aide et ton dépôt. Mais maintenant il faut que je comprenne deux bizarreries, tout d'abord quand j'arrive sur un nouvel aéroport, je suis à quelques mètres au dessus du sol et l'avion se plante et mon joystick ne fonctionne plus. Je vais aller faire un tour sur le site de Flightgear voir si je ne trouve pas quelques éléments de réponses. En tout cas merci encore.

Edit : J'ai résolu le premier souci en spécifiant explicitement dans fgrun la piste où je souhaite me trouver. Concernant le joystick en fait, il est reconnu mais pas calibré correctement. Le palonnier est absent et la manette des gaz ne fonctionne pas.

Dernière modification par Bud78 (Le 30/12/2008, à 09:33)


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#10 Le 30/12/2008, à 10:13

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Moi j'ai eu aucun souci pour le faire tourner, ma config est carte nvidia 9600GT avec joystick Saitek Cyborg Evo en usb.
Par contre attention car dans le repo j'ai pas refait encore flightgear en 1.9.0, mais il est dispo en download ici en attendant que je refasse ce package.

http://proformatique.org/deb/pool/main/f/flightgear/

A+

#11 Le 30/12/2008, à 10:29

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

C'est très sympa, mais je vais attendre sagement que tu mettes ça dans le dépôt...:D...ça fonctionne et j'ai pas envie de mettre le souk.
Pour le Joystick, en fait il est bien reconnu comme un Sidewinder Forcefeedback 2, mais flighgear semble ne pas aller chercher le bon fichier xml de configuration, pour une raison mystérieuse il va chercher celui par défaut alors que dans les fichiers de data il y a un xml conçu pour ce device....:/...bizarre....


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#12 Le 30/12/2008, à 12:09

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

Le Joystick fonctionne maintenant parfaitement, j'ai trouvé la solution sur cette page
http://wiki.flightgear.org/index.php/Joystick
Dans mon cas, il s'agissait juste d'une petite différence entre le nom du Joystick attribué par le système et le nom spécifié entre les tags <name> du fichier xml de configuration de mon Joystick.
Dans un cas "Microsoft SideWinder Force Feedback 2" et dans l'autre "Microsoft SideWinder Force Feedback 2 Joystick". Heureusement qu'il y a un bon Wiki parce que j'étais pas prêt de la trouver en bidouillant celle-là...:D
Toute ma gratitude à Sylvain qui m'a bien aidé avoir un simulateur opérationnel. Sous Windows, j'ai passé des heures là-dessus, je vais pouvoir en faire autant maintenant sous Linux...:D:D....c'est Madame qui va être contente...:lol::lol::lol:


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#13 Le 30/12/2008, à 18:43

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Voilà j'ai tout réparé et ça devrait marcher sans souci maintenant smile. J'ai testé depuis une installation intrepid tout neuve et pas de souci.
N'hésitez pas à me remonter les soucis.
Je vais essayer de refaire marcher atlas et packager fgcom aussi. Si vous avez des idées d'addons pour flightgear à packager je suis preneur.

A+

#14 Le 30/12/2008, à 20:11

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

@Sylvain : J'ai bien pu faire une mise à jour de fgfs et de fgfs-base à partir de ton dépôt, donc ça fonctionne bien pour moi. Ceci dit, il y a un truc bizarre concernant fgrun, il est bien en version 1.5 donc installé à partir de ton dépôt mais il n'apparait pas dans Synaptic contrairement à fgfs et fgfs-base qui apparaissent parfaitement. C'est pas vraiment gênant mais c'est surprenant.
Dans cette version FlightGear n'a plus besoin de Simgear ?


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#15 Le 30/12/2008, à 23:31

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Si si simgear est en dépendance, c'est la version 1.9.0. Si tu fais un dpkg -l simgear1.9.0 tu devrais l'avoir. Pour fgrun dans synaptic, aucune idée, je n'ai jamais utilisé ce soft :-].
En tout cas la version 1.9 est vraiment sympa sinon smile.

#16 Le 31/12/2008, à 03:57

Blakesnake

Re : Paquet flightgear 1.9.0 pour Hardy

J'ai essayé d'installer FlightGear en utilisant le dépot http://proformatique.org/deb intrepid main

Erreur 404 qu'il me dit... problème de serveur ? Bon je remettrais ça à plus tard...

merci quand même pour ton boulot de compilation Sylvain, je n'ai malheureusement pas encore le niveau pour compiler les softs moi-même.

c'est pas trop compliqué à faire ?


Les manchots ça roxxe (dixit le gars qui a habité un an à moins d'un kilomètre d'une colonie de manchots royaux)

Hors ligne

#17 Le 31/12/2008, à 05:53

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

Sylvain Boily a écrit :

Si si simgear est en dépendance, c'est la version 1.9.0. Si tu fais un dpkg -l simgear1.9.0 tu devrais l'avoir. Pour fgrun dans synaptic, aucune idée, je n'ai jamais utilisé ce soft :-].

Effectivement, j'ai bien simgear1.9.0 d'installé mais comme pour fgrun le paquet n'apparaît pas dans Synaptic. C'est bizarre parce que sur l'ensemble des paquets pris sur ton dépôts, j'en ai qui s'affiche et pas d'autres....:/...en tout cas encore merci pour ton boulot.


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#18 Le 31/12/2008, à 08:18

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Blakesnake a écrit :

J'ai essayé d'installer FlightGear en utilisant le dépot http://proformatique.org/deb intrepid main

Erreur 404 qu'il me dit... problème de serveur ? Bon je remettrais ça à plus tard...

merci quand même pour ton boulot de compilation Sylvain, je n'ai malheureusement pas encore le niveau pour compiler les softs moi-même.

c'est pas trop compliqué à faire ?

Ah pourquoi 404 ? Si tu vas sur cette page http://proformatique.org/deb tu vois les répertoires ? Y a pas de raison que tu es un 404 :-].

Sinon pour faire les packages, c'était surtout super long car openscenegraph mets une nuit à compiler sur ma machine ... J'ai du patcher quelques Makefile aussi, ça m'a pris quelques jours à les faire mais si ça peut servir tant mieux smile. Normalement vous pouvez aussi rajouter :

deb-src http://proformatique.org/deb intrepid main

Puis faire un apt-get source des packages pour les recompiler vous même si ça intéresse.

Pour synaptic j'ai lancé le soft et j'ai fait recherché dans recherche rapide et j'ai bien trouvé fgrun. Donc je ne sais pas pourquoi tu ne le vois pas :-].

#19 Le 31/12/2008, à 14:44

Blakesnake

Re : Paquet flightgear 1.9.0 pour Hardy

Voila ce que m'affiche le logiciel de gestion des sources:

Impossible de récupérer http://proformatique.org/deb/dists/intrepid/main/binary-amd64/Packages.gz  404 Not Found
Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Aucun problème pour les autres sites

je vais essayer en téléchargant les paquets manuellement alors...


Les manchots ça roxxe (dixit le gars qui a habité un an à moins d'un kilomètre d'une colonie de manchots royaux)

Hors ligne

#20 Le 01/01/2009, à 11:09

Bud78

Re : Paquet flightgear 1.9.0 pour Hardy

Sylvain Boily a écrit :

Je vais essayer de refaire marcher atlas et packager fgcom aussi. Si vous avez des idées d'addons pour flightgear à packager je suis preneur.

Je me casse les dents sur :

- Atlas
- TaxiDraw
- TerraGear

Donc si ta proposition marche toujours, tu auras au moins un utilisateur pour ceux là ...:D


«Tout ce qui a son prix est de peu de valeur.»
[ Friedrich Nietzsche ] - Extrait de Ainsi parlait Zarathoustra

Hors ligne

#21 Le 01/01/2009, à 11:18

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Blakesnake a écrit :

Voila ce que m'affiche le logiciel de gestion des sources:

Impossible de récupérer http://proformatique.org/deb/dists/intrepid/main/binary-amd64/Packages.gz  404 Not Found
Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Aucun problème pour les autres sites

je vais essayer en téléchargant les paquets manuellement alors...

Ah oui zut, c'est pas packagé pour amd64, juste pour i386 :-(

#22 Le 01/01/2009, à 11:20

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Bud78 a écrit :

Je me casse les dents sur :

- Atlas
- TaxiDraw
- TerraGear

Donc si ta proposition marche toujours, tu auras au moins un utilisateur pour ceux là ...:D

Hum Altlas je suis aussi entrain de regarder mais ça ne se compile plus avec simgear 1.9.0 apparemment, donc ça va prendre un peu plus de temps :-(;

Les deux autres je mets ça dans ma todo :-).

#23 Le 01/01/2009, à 11:35

Blakesnake

Re : Paquet flightgear 1.9.0 pour Hardy

Sylvain Boily a écrit :

Ah oui zut, c'est pas packagé pour amd64, juste pour i386 :-(

Bon il ne me reste plus qu'a apprendre à compiler...


Les manchots ça roxxe (dixit le gars qui a habité un an à moins d'un kilomètre d'une colonie de manchots royaux)

Hors ligne

#24 Le 05/01/2009, à 01:26

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Salut,

Pour taxidraw ça va arriver sous peu (ça compile puis upload), pour atlas, je suis entrain de voir avec un gars de flightgear qui aurai fait un patch pour que ça marche avec simgear 1.9.
Pour les packages amd64 j'ai trouvé comment cross-compiler donc y a peut-être moyen. J'essaie d'en faire un pour voir wink.
Je vais regarder terragear aussi.

A+

#25 Le 05/01/2009, à 01:55

Sylvain Boily

Re : Paquet flightgear 1.9.0 pour Hardy

Bon taxidraw semble fonctionnel, je l'ai lancé, il marche mais je ne connais pas, donc faites moi un retour si jamais y a un souci wink.

$ sudo apt-get update
$ sudo apt-get install taxidraw

En rajoutant mon repo bien sûr.

A+

Haut de page ↑