Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 14/02/2006, à 00:59

PierreAd

[Résolu] Utilisation de wxWidgets : problème d'include

Salut tout le monde,

Bon voilà, je suis en galère ce soir... j'ai commencé à m'amuser avec les wxWidgets depuis une semaine ou deux sous windows (je sais c'est pas bien !!!), et j'avais bien envie de passer ces développements sous linux... j'ai donc récupéré les sources sur le site de wxWidgets, fait les traditionnels :

./configure
make
sudo make install

Mais j'ai un "gros" soucis, lorsque je veux inclure le header "wx/wx.h" dans un de mes fichiers, j'ai une erreur comme quoi le fichier est introuvable... bon qu'à cela ne tienne, un ptit tour dans le usr/include, hop je repère la lib, c'est en fait "wx-2.6/wx/wx.h"....

Probleme, maintenant le compilo me trouve bien wx.h mais ne trouve pas les includes qui sont faits a l'intérieur de ce fichier :

/usr/local/include/wx-2.6/wx/wx.h:15:21: wx/defs.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:16:23: wx/object.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:17:25: wx/dynarray.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:18:21: wx/list.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:19:21: wx/hash.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:20:23: wx/string.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:21:21: wx/intl.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:22:20: wx/log.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:23:22: wx/event.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:24:20: wx/app.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:25:22: wx/utils.h : Aucun fichier ou répertoire de ce type
/usr/local/include/wx-2.6/wx/wx.h:26:23: wx/stream.h : Aucun fichier ou répertoire de ce type
main.cpp:2:19: wx/wx.h : Aucun fichier ou répertoire de ce type

Est-ce que ça vient d'une mauvaise manip de ma part ??
Quelqu'un sait comment je devrais procéder pour installer correctement les wxwidgets ?

Merci de votre aide, bonne nuit a tous les geeks big_smile


PierreAd

Dernière modification par PierreAd (Le 15/02/2006, à 10:07)

Hors ligne

#2 Le 15/02/2006, à 09:54

thx1138

Re : [Résolu] Utilisation de wxWidgets : problème d'include

PierreAd a écrit :

[...]
Quelqu'un sait comment je devrais procéder pour installer correctement les wxwidgets ?
[...]

apt-get install libwxgtk2.6-dev

En espérant avoir pu t'aider.

Note : je rappelle que lorsqu'on utilise une distribution qui a un système de packages qui gère les dépendances, il vaut mieux utiliser ce dernier plutôt que d'installer «à la main» des programmes/bibliothèque. Cela permet de ne pas perturber le système ...


They did not know it was impossible, so they did it - Mark Twain

Hors ligne

#3 Le 15/02/2006, à 10:07

PierreAd

Re : [Résolu] Utilisation de wxWidgets : problème d'include

Salut,

Merci de ton aide, en fait j'avais déjà fait ça pour réinstaller correctement... En revanche, si ce soucis arrive à d'autres personnes, aller voir ce topic :

http://forum.ubuntu-fr.org/viewtopic.php?id=26539

Merci,

PierreAd

Hors ligne

Haut de page ↑