Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/02/2006, à 23:30

neu9

GeForce 5200 (nvidia) - 3D KO

bon, ca fait 2 heures que je rame

j'ai pourtant trouvé ce botuto :
http://doc.ubuntu-fr.org/materiel/nvidia

mais les pingouins glacés, ils ne sont meme plus lents, il ne démarrent plus du tout !

neu9@aldorande:~$ slune
* Slune * Slune lives in /usr/share/games
Erreur de segmentation

sad any clue ?

Hors ligne

#2 Le 17/02/2006, à 22:04

neu9

Re : GeForce 5200 (nvidia) - 3D KO

bon je reformule comme 18 personnes ont lu, j'ai pas du etre clair

j'ai un AMD Athlon 1800+ avec un GeForce5200

l'affichage normal ca va, mais quand je lance "slune" (un pingouin sur une luge de vitesse) c'est tres tres saccadé (genre 1 image par seconde)
j'en déduis que la 3D ne fonctionne pas.

j'ai suivi le tuto http://doc.ubuntu-fr.org/materiel/nvidia
mais quand je mets "nvidia" au lieu de "nv" dans le xorg.conf, le serveur X ne veut plus démarrer.

Hors ligne

#3 Le 17/02/2006, à 23:01

Express

Re : GeForce 5200 (nvidia) - 3D KO

Mets une copie de xorg.conf !

Hors ligne

#4 Le 18/02/2006, à 09:23

neu9

Re : GeForce 5200 (nvidia) - 3D KO

voila

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Driver          "nv"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "\uffffcran g\uffffn\uffffrique"
        Option          "DPMS"
        HorizSync       28-64
        VertRefresh     43-60
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Monitor         "\uffffcran g\uffffn\uffffrique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

Hors ligne

#5 Le 22/02/2006, à 22:34

Link31

Re : GeForce 5200 (nvidia) - 3D KO

Quel est le message d'erreur de X quand tu mets "nvidia" ?

Tu peux aussi tenter :

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo dpkg-reconfigure xserver-xorg

en choisissant "nvidia" comme driver quand il le demande.

Hors ligne

#6 Le 22/02/2006, à 22:44

Achille

Re : GeForce 5200 (nvidia) - 3D KO

Effectivement, la 3D n'est pas activée. As-tu bien tapé en terminal la commande:

sudo nvidia-glx-config enable

Tu devrais avoir

Section "Module"
#       Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
#       Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV34 [GeForce FX 5200]"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
EndSection

Hors ligne

#7 Le 22/02/2006, à 23:04

neu9

Re : GeForce 5200 (nvidia) - 3D KO

hello,

heu, j'ai essayé tellement de chose le 17/18 que je ne me souviens plus... roll

je sais que j'ai tenté le sudo dpkg-reconfigure xserver-xorg avec nvidia au bon moment.
ca m'a fait la meme chose qu'en mettant nvidia à la place de nv à la main :
écran bleu avec écrit au milieu des jolis hyéroglyphes, m'expliquant que le server X ne démarre plus. il m'indique quand meme ou est le kick et le starter => je remets l'ancien xorg.conf et je reviens à la case départ,
sauf que tant que les libs glx (ou restricted, je ne sais pas exactement) son installées, j'ai les erreurs de segmentation au lancement de xmms ou slune

quelqu'un a déjà essayé avec les drivers qu'on peut télécharger sur le site nvidia ?

Hors ligne

#8 Le 22/02/2006, à 23:33

Link31

Re : GeForce 5200 (nvidia) - 3D KO

As-tu vraiment installé tous les paquets ? Parce que dans le tuto on ne peut pas dire que c'est bien mis en évidence... Pour en être sûr, tape :

dpkg -l | grep nvidia

puis

dpkg -l | grep linux-restricted

Tu dois avoir nvidia-glx, nvidia-kernel-common (et nvidia-settings qui est je crois facultatif).
Tu dois aussi avoir linux-restricted-modules-[ta version de linux] d'après le tuto.

Si rien ne s'affiche pour l'une ou l'autre de ces commandes ou si il te manque des paquets, fais :

sudo apt-get install linux-restricted-modules-`uname -r`
sudo apt-get install nvidia-glx nvidia-kernel-common nvidia-settings
sudo nvidia-glx-config enable

Puis retente avec "nvidia" dans le xorg.conf.

Sinon les pilotes du site de nvidia j'ai jamais réussi à les installer sur Ubuntu.

PS : attention aux apostrophes spéciales : il faut taper ` et pas ' !

Hors ligne

#9 Le 23/02/2006, à 21:56

neu9

Re : GeForce 5200 (nvidia) - 3D KO

voici l'état actuel

 dpkg -l | grep nvidia
rc  nvidia-glx-legacy                         1.0.7174-0ubuntu25.1                 NVIDIA binary XFree86 4.x/X.Org 'legacy' dri
ii  nvidia-kernel-common                      1.0.7667+1                           NVIDIA binary kernel module common files
ii  nvidia-settings                           1.0-3ubuntu6                         Tool of configuring the NVIDIA graphics driv

et

dpkg -l | grep linux-restricted
ii  linux-restricted-modules-2.6.12-10-k7-smp 2.6.12.4-11.1                        Non-free Linux 2.6.12 modules on AMD K7 SMP
ii  linux-restricted-modules-common           2.6.12.4-11.1                        Non-free Linux 2.6.12 modules helper script

bon... prochaine étape : je vire TOUT
et je recommence comme c'est ecrit.
mais pas ce soir wink

Hors ligne

#10 Le 23/02/2006, à 23:59

Achille

Re : GeForce 5200 (nvidia) - 3D KO

Tu dois encore modifier ton fichier /etc/X11/xorg.conf (comme indiqué dans mon précédent message) en tapant en terminal:

sudo gedit /etc/X11/xorg.conf

ou sous Kubuntu

sudo kate /etc/X11/xorg.conf

Hors ligne

#11 Le 25/02/2006, à 17:11

Lestat the vampire

Re : GeForce 5200 (nvidia) - 3D KO

Je vois que tu as installé les nvidia-glx-legacy !! Ces paquets ne doivent etre installés que pour des anciennes cartes graphiques (style geforce, tnt2...) donc vire ce paquet et tous les autres paquets contenant du nvidia-legacy si tu en as installé d'autres. D'ailleurs, si tu regardes attentivement, tu vois bien que les paquets legacy sont en version 1.0.7174 alors que les autres sont en 1.0.7667...ils ne peuvent donc pas rester ensemble !!
Dans ton cas, tu dois avoir les "nvidia-glx" tout court.
Je vois que tu as aussi installé les linux-restricted-modules-2.6.12-10-k7-smp....or je doute que ce soit le paquet correspondant à ton noyau vu ton processeur. Tape "uname -r" pour voir quel noayu tu disposes et quel est donc le bon apquet à installer.

En résumé, pour une carte nvidia récente, seulement 4 paquets sont nécessaires à son fonctionnement :
nvidia-glx
nvidia-kernel-common
nvidia-settings
linux-restricted-modules-`uname -r` (ou uname -r correspond EXACTEMENT a la version de ton noyau).
Tout le reste, tu vires !!! et lis attentivement ce tuto pour le reste.

Dernière modification par Lestat the vampire (Le 25/02/2006, à 17:13)

Hors ligne

#12 Le 25/02/2006, à 19:18

neu9

Re : GeForce 5200 (nvidia) - 3D KO

merci pou r vos réponses ! smile

je viens seulement de me remettre sur le sujet
bon, je me demande comment virer "linux-restricted-modules-2.6.12-10-k7-smp" car dans synaptic il apparait comme non installé, pourtant dans mon boot grub je suis toujours sur "Ubuntu, kernel 2.6.12-10-k7-smp"

peut-etre avec les dpkg mais je ne maitrises pas tres bien.
de plus comme c'est des paquets de lib graphiques, je suppose qu'il faudrait se mettre en console pour tout virer ? roll

Hors ligne

#13 Le 25/02/2006, à 19:47

Lestat the vampire

Re : GeForce 5200 (nvidia) - 3D KO

Tu as 2 processeurs dans ton ordi ??? Sinon pourquoi tu as mis un noyau smp (pour multiprocesseurs) ??? Parce que pour un 1800+, un noyau K7 suffit, voir ce tuto.
Sinon, ce n'est pas obligatoire de se mettre en mode console pour les virer mais c'est mieux en effet....
tu fermes ta session, tu appuies sur Ctrl-Alt-F1 pour passer en mode console pure, tu te logge, tu tapes sudo /etc/init.d/gdm stop
puis apt-get remove --purge linux-restricted-modules-2.6.12-10-k7-smp
installe les bons linux-restricted-modules en tapant sudo apt-get install linux-restricted-modules-`uname -r` (comme indiqué plus haut).

Hors ligne

#14 Le 25/02/2006, à 20:13

zn23

Re : GeForce 5200 (nvidia) - 3D KO

même carte et même problemes que toi si t'a une solution je suis tout ouie ..
pour l'instant je vais surement reinstallé le systeme ce soir et m'y remettre demain plus serieusement
j'ai trouver cette page mais je n'y comprend mots
http://forum.ubuntu-fr.org/viewtopic.php?id=20762
si ca peut aider
a bientot


tu peux y mettre tout le fûmier que tu veux , pour un chêne centenaire, faut cent ans ...

Hors ligne

#15 Le 25/02/2006, à 21:26

neu9

Re : GeForce 5200 (nvidia) - 3D KO

Lestat a écrit :

Tu as 2 processeurs dans ton ordi ??? Sinon pourquoi tu as mis un noyau smp (pour multiprocesseurs) ???

non, en fait j'essaie npq en désepsoir de cause. je crois que quelqu'un me l'avais conseillé. j'ai pas réfléchi, je nettoyais le clavier et le coup est pari tout seul yikes

le pb c'est que maintenant que j'ai booté comme ca, uname -r me répond "2.6.12-10-k7-smp" pourtant je n'ai qu'un seul petit AMD Athlon 1800+ hmm

bon je vais rebooter avec le noyau "Ubuntu, kernel 2.6.12-9-386"
on verra ce que me dit uname -r
ma je suppose qu'il me dira "2.6.12-9-386"

Dernière modification par neu9 (Le 25/02/2006, à 21:40)

Hors ligne

#16 Le 25/02/2006, à 22:12

Lestat the vampire

Re : GeForce 5200 (nvidia) - 3D KO

Effectivement si tu boote sur le noyau 2.6.12-9-386, la commande uname -r te répondra 2.6.12-9-386....forcement.
De toute facon, tu dois reinstaller le driver quand tu changes de noyau... (c chiant mais on ne change pas de noyau tous les jours... une fois que c fait....hop).
Vu ta config, je te conseillerais :
1) de rebooter sur ton noyau de base...le 386
2) de virer le noyau k7-smp qui ne te sert strictement à rien
3) d'installer le noyau 2.6.12-10-k7 et tous les modules qui vont avec (linux-restricted-modules-2.6.12-10-k7 par exemple) et de booter dessus (tu peux aussi jeter un oeil sur ce tuto).

Le mieux étant d'installer les drivers nvidia la première fois, une fois qu'on a installé définitivement le bon noyau optimisé...ce qui évite de faire plusieurs fois la manip et surtout les problèmes quand on change de noyau.

Dernière modification par Lestat the vampire (Le 25/02/2006, à 23:32)

Hors ligne

#17 Le 25/02/2006, à 23:02

neu9

Re : GeForce 5200 (nvidia) - 3D KO

OK merci beaucoup smile
je vais essayer ca, peut-etre demain.

Hors ligne

Haut de page ↑