Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/01/2009, à 14:37

jeromeg

Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

J'ai ajouté sur mon PPA les paquets de Xfce 4.6 et quelques goodies. Pour les installer sur votre système, ajoutez ces lignes au fichier /etc/apt/sources.list :

Pour Intrepid :

deb http://ppa.launchpad.net/jerome-guelfucci/ppa/ubuntu intrepid main

Pour Hardy :

deb http://ppa.launchpad.net/jerome-guelfucci/ppa/ubuntu hardy main

Puis, lancez ces commandes dans un terminal pour ajouter la clé du dépot :

gpg --keyserver keyserver.ubuntu.com --recv 0E23917F5D9DCE6C
gpg --export --armor 0E23917F5D9DCE6C | sudo apt-key add -

Ensuite mettez à jour vos paquets, vérifiez que xfce4-mcs-manager est bien désinstallé et que xfce4-settings est bien installé. Puis relancez votre session et priez pour que ça marche.

Si vous rencontrez un problème avec Xfce 4.6, signalez le sur le bugzilla de Xfce : http://bugzilla.xfce.org/ .

Jérôme

Dernière modification par jeromeg (Le 07/03/2009, à 14:18)

Hors ligne

#2 Le 26/01/2009, à 16:58

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Merci pour ce dépot.

Aucun plantage à signaler à ce jour smile

Dans le planning de sortie de cette version il n'est fait mention que de la sortie finale, mais plus du planning de sortie de la rc.
Cela voudrait il dire qu'elle est déja sortie?

Hors ligne

#3 Le 26/01/2009, à 19:01

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

La rc1 devrait sortir avant la fin de la semaine, peut être même demain !

À +

Hors ligne

#4 Le 26/01/2009, à 20:40

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Je ne sais pas si c'est une vue de l'esprit, mais j'ai le sentiment que les fenetres et les menus des fenetres sont bien plus réactifs sous cette version

Le click droit sur le bureau est vraiment sympa avec le menu classique + le menu application

Certains menus sont bien plus ergonomiques tels que la config du bureau, menu "affichage" ...

Apres sur certaines fonctions il va falloir retrouver ses repères
- Comment alléger le menu "parametres"
- Comment "masquer" les bouton "hibernation" et "veille"
...

Hors ligne

#5 Le 28/01/2009, à 13:18

Wapush_HL

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

frenchy82 a écrit :

- Comment alléger le menu "parametres"

Copie les fichiers .desktop correspondants depuis /usr/share/applications vers ~/.local/share/applications tu l'édites et ajoutes cette ligne :

NoDisplay=true

Ensuite :
ALT+F2  -->  xfdesktop --reload  -->  Exécuter


frenchy82 a écrit :

- Comment "masquer" les bouton "hibernation" et "veille"

En deux commandes :

xfconf-query -c xfce4-session -np '/shutdown/ShowSuspend' -t 'bool' -s 'false'

et

xfconf-query -c xfce4-session -np '/shutdown/ShowHibernate' -t 'bool' -s 'false'

#6 Le 28/01/2009, à 14:23

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Merci beaucoup pour ce retour.

Concernant le menu paramètre, j'ai l'impression que c'est tout le menu systeme qui se trouve en doublon dans le menu parametre.

Je ne sais pas si d'autres constate aussi cela

Hors ligne

#7 Le 28/01/2009, à 21:07

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Re,

Pour les commandes pour masquer le suspend cela fonctionne nickel.

Concernant les menus en double dans systeme et parametre si on rajoute
NoDisplay=true

Le menu n'apparait plus ni dans systeme ni dans parametre

Donc la solution est de

1) copier le(s) .desktop en question sur ~/.local/share/applications

2) de remplacer

Categories=System;Settings;

par

Categories=System;

Si quelqu'un savait faire cela en script, ce serait la bienvenue smile

Hors ligne

#8 Le 03/02/2009, à 20:33

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Bonsoir,

Je vois que la version est passé de la beta à la rc.
Il est vrai qu'au niveau des traductions cela a bien avancé smile

J'ai juste un probleme avec le nouveau controleur de son. Il ne s'installe pas en fait.
Comme si il considerait que le paquet de la 4.4.3 etait plus a jour que celui de la 4.6

Sinon tout fonctionne nickel.

Thunar semble plus rapide notamment pour l'ouverture des dossiers comprenants beaucoup de fichiers smile

Hors ligne

#9 Le 08/02/2009, à 08:33

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Bonjour,


Pour information, les mises à de ce matin concernant xfce4- panel nécessitent la désinstallation du paquet xubuntu-desktop et de xubuntu-default-settings

Par la suite ont ne peut réinstaller xubuntu-desktop car xubuntu-default-settings ne peut pas être reinstallé

En espérant que ces infos puissent vous être utiles

Hors ligne

#10 Le 08/02/2009, à 10:58

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Salut,

Je suis au courant, ça sera réglé ce soir normalement. Désolé...

Jérôme

Hors ligne

#11 Le 08/02/2009, à 13:24

mr_pouit

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Pour info, tout ce bazar des fichiers de config entre Xubuntu et Xfce devrait être réglé plus proprement dans jaunty.


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#12 Le 08/02/2009, à 13:50

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Voila, normalement c'est réglé. Hésitez pas à signaler tout autre problème.

J'en ai profité pour ajouter les dernières versions de xfce4-notes-plugin, xfce4-xkb-plugin et xfce4-radio-plugin.

À +

Hors ligne

#13 Le 08/02/2009, à 14:03

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

J'espere n'etre pas le seul a tester sinon cela ne sera pas tres significatif et je vais finir par me sentir un peu envahissant  smile

Si je veux re installer xubuntu-desktop

cartes@cartes-desktop:~$ sudo apt-get install xubuntu-desktop
[sudo] password for cartes: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
  xubuntu-desktop: Dépend: xubuntu-default-settings mais ne sera pas installé
E: Paquets défectueux

donc j'essaye le paquets settings

cartes@cartes-desktop:~$ sudo apt-get install xubuntu-default-settings
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
  xubuntu-default-settings: Dépend: xfce4-utils (>= 4.5.99.1-0ubuntu2) mais 4.5.99.1-0ubuntu2~ppa1 devra être installé
E: Paquets défectueux

En sachant que xfce4-utils est installé et à jour

Hors ligne

#14 Le 08/02/2009, à 14:07

mr_pouit

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Oui, il est en train de corriger ça. tongue


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#15 Le 09/02/2009, à 18:26

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Bonjour,

On poste souvent pour signaler un problème ou une difficulté mais rarement pour faire part d'une satisfaction.

Alors, juste pour dire que tout fonctionne comme un charme. Merci à Jerome et a tous ceux qui y participent smile

J'adore cette version de xfce wink

Hors ligne

#16 Le 09/02/2009, à 18:51

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Content que ça te plaise !

Il faut aussi remercier mr_pouit et l'équipe de Debian Xfce à qui j'ai piqué tous les paquets wink

Hors ligne

#17 Le 19/02/2009, à 16:34

mavosaure

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Merci Jérôme!
Pour l'instant ça a l'air de tourner pas mal du tout.

J'ai vu aussi que tu avais même ajouté les dernières versions d'Abiword.... j'avais regardé ça avec envie il y a quelques semaines, mais je n'avais pas eu le courage de me lancer dans la compilation!
Par contre, j'ai eu un soucis pour imprimer à partir d'Abiword tout à l'heure (une lettre toute bête)... j'ai contourné en passant par un export PDF et l'impression a partir d'evince a, elle, bien fonctionné. Ça vient de chez moi ou bien?

Une autre question (rien à voir). A ma connaissance, il n'y a pas de gestionnaire graphique de connections réseau avec XFCE. J'ai lu (mais pas testé pour le moment) beaucoup de bien de WiCD... Est ce qu'il ne serait pas plus adapté à Xub, dans une optique de réduction des dépendances Gnomesques et de légèreté? Tous les avis et toutes les expériences sont les bienvenus...

Merci et à +++

mav


Xub'

Hors ligne

#18 Le 20/02/2009, à 14:26

frenchy82

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Bonjour,

WICD est tres efficace, c'est clair.
Mais le problème pour moi est qu'il ne gère pas le vpn PPTP. (sauf erreur de ma part)
C'est vraiment une fonction essentielle pour moi afin d'acceder au réseau de mon boulot et network-manager le gere tres bien

Hors ligne

#19 Le 27/02/2009, à 11:18

lordphoenix

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

@jéromeg : Je viens de lire que la version finale était sorti comptes tu mettre tes dépôts à jour?

Hors ligne

#20 Le 27/02/2009, à 11:53

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Bien sûr !

Dès que les paquets seront prêts dans Ubuntu Jaunty, je mettrai tout ça dans mon dépot. Je pense qu'il faut compter une semaine, voire deux.

Soyez patients wink

Jérôme

Hors ligne

#21 Le 27/02/2009, à 17:59

anekdoten

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

sinon j'ai un probleme de performances sur la beta : le composite est très lent. J'espère que ce problème sera reglé avec la finale...

Hors ligne

#22 Le 27/02/2009, à 18:02

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

anekdoten: il y a de grandes chances pour que ce soit un problème avec tes pilotes vidéos, le compositor de Xfce est très rapide.

Hors ligne

#23 Le 27/02/2009, à 18:09

anekdoten

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Et bien, j'ai un chipset intel de type gma965, depuis l'upgrade à 4.6beta la fluidité du compositeur est sacrément réduite.
Je tiens à préciser que j'ai le même problème avec la beta de Zenwalk 5.4 ( XFCE 4.6RC1 aussi )...

Hors ligne

#24 Le 27/02/2009, à 19:53

jeromeg

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Je te conseille d'attendre de tester avec la final et de signaler le problème sur le bugzilla de xfce si ça continue.

Hors ligne

#25 Le 27/02/2009, à 20:11

Wapush_HL

Re : Xfce 4.6 pour Ubuntu Intrepid et Ubuntu Hardy

Je n'éprouve aucun problème de fluidité avec le compositeur de Xfce 4.6 RC1 sur un vieux AMD Athlon K7 750Mhz avec 512 Mo de ram et une NVIDIA GeForce FX 5200 128 Mo sur Debian testing/unstable, ni avec Xfce 4.6 final sur un autre "ordinosaure" AMD Athlon K7 900Mhz avec 256 Mo de ram et une NVIDIA GeForce2 MX/MX 400 64Mo sur Arch. Je le trouve même plus stable et fluide.