Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 11/04/2005, à 15:20

ploum

Le son sous Warty et Hoary, à lire avant de poster

[edit] ATTENTION: les problèmes de son évoqués ici sont censés avoir trouvé solution avec la Breezy 5.10. Néanmoins, ce sujet contient des informations théoriques au sujet du fonctionnement du son sous linux.

Encore merci à Ploum

-----------------------------------------------------------------------------------------------------------------------------

Bon, je me rend compte que beaucoup de questions sont liées au son. Dans la majeure partie des cas, ce n'est pas dû à un problème matériel mais à une mauvaise compréhension de comment fonctionne le système.

Voici donc quelques explications techniques sur comment ça fonctionne. C'est un peu compliqué, si ça ne va vraiment pas, passez donc directement à la suite :


Explications Techniques
--------------------------------------

OSS
- C'est le noyau Linux qui fournit le son à la carte son en utilisant le driver approprié. Anciennement, le système qui permettait de faire ça était OSS.
Beaucoup de drivers ont été développés pour OSS. (Open Sound System)
Les applications utilisent donc l'interface OSS pour envoyer le son au driver.

ALSA
- OSS n'étant techniquement pas parfait, un remplaçant a été trouvé. Ce remplaçant est ALSA, pour Advanced Linux Sound Architecture.
Les programmes utilisant du son doivent donc être réécrit pour pouvoir utiliser ALSA à la place de OSS. (c'est pourquoi xmms a un plugin OSS et un plugin ALSA).

Cependant, afin que les anciennes applications continuent à fonctionner, il existe dans ALSA une couche de compatibilité qui permet aux applications OSS de croire qu'elles utilisent OSS au lieu de ALSA. (comme par exemple le plugin flash)

ESD
En théorie, un seul son peut être joué à la fois. Il n'y a en effet que un seul haut parleur. Pour pouvoir mixer plusieurs sons, on utilise un mixeur de son. C'est le rôle de ESD. Les applications envoient leurs sons à ESD, qui les mixe et envoie le résultat à OSS qui le passe à ALSA.


En cas de problème, avant de poster sur le forum

------------------------------------------------------------------------------
Il faut bien remarquer que, par défaut, une seule application à la fois peut accéder à la carte son. Et par défaut ESD, qui est une application comme une autre, est lancé et accède à la carte son.

Dans la majeure partie des cas, vous n'avez pas le son tout simplement car ESD "bouche" l'acccès à la carte son.

La première chose à faire est donc de tuer ESD (killall esd) puis de regarder ce qui accède à la carte son :
lsof /dev/dsp   vous indique les programmes qui utilisent OSS
lsof /dev/snd/* indique les programmes utilisant ALSA

Avant de poster, vérifiez bien que tout cela est vide et indiquez le dans votre post.


Comment configurer correctement le son ?
---------------------------------------------------------------------

Une bonne chose est de dire à ESD de se couper lorsqu'on a pas besoin de lui.

sudo gedit /etc/esound/esd.conf

et modifiez le fichier pour que ça ressemble à :

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

Relancez votre session, normalement vous ne devriez plus avoir de problème avec les jeux comme frozen-bubble. Il suffit de couper la musique deux secondes avant de lancer le jeu.



J'ai encore des problèmes !!!
--------------------------------------------------

1) Vérifiez vos hauts parleurs, branchements, etc.. (oui, dans environ 20% des posts sur le son, les enceintes n'étaient pas branchées)

2) vérifiez le volume !  Dans alsamixer, MASTER, PCM doivent être à fond et sans MM au dessus ou en dessous.

3) Si les musiques  semblent se jouer correctement mais que vous n'entendez rien, revérifiez les deux points précédents. Si Linux ne détecte pas de carte son, il ne joue JAMAIS le son ! et affiche TOUJOURS une erreur !
Vérifiez que votre ordinateur n'est pas équipé de deux cartes sons et branchez vos enceintes sur l'autre. (utiliser une carte son particulère est un autre problème)

4) Si vous avez un message d'erreur de type : "Not found or busy", vérifiez avec "lsof" (voir plus haut)

5) En désespoir de cause, postez sur le forum avec :
- le type d'erreur précis
- Le modèle précis de la carte son
- le résultat de "lsmod|grep snd"


Aller plus loin ! Ecouter plusieurs sons en même temps sans ESD !
-----------------------------------------------------------------------------------------------------
Ici ça devient plus technique et donc facultatif. Mais ça peut en intéresser plus d'un.
!!ATTENTION !!
Ne suivez ces instructions que si vous avez du son ALSA qui fonctionne correctement (par exemple xmms joue sans problème avec le plugin ALSA)
Ce n'est pas sûr que ceci marche avec toutes les cartes sons.
La première chose qu'on va faire, c'est dire à esd d'utiliser ALSA au lieu de OSS :

sudo apt-get install libesd-alsa0

ensuite on va créer le fichier asound :

sudo gedit /etc/asound.conf

dans lequel on met :

pcm.card0 {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "dmixer"

}


pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 4096
periods 128
rate 44100
}
bindings {
0 0
1 1
}
}

ensuite, on redémarre ALSA:

sudo /etc/init.d/alsa restart

Relancez votre session (pour ESD) et voilà, normalement vous devriez être capables d'entendre les clicks clicks de l'interface, écouter de la musique avec XMMS et jouer une vidéo avec totem, le tout en même temps. (il faut que les applications utilisent ESD ou ALSA,
préférablement ALSA)


Enfin, on va dire à Flash d'utiliser ESD et non OSS :

sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

On va aussi indiquer au jeux utilisant SDL d'utiliser ALSA au lieu d'OSS :

sudo apt-get install libsdl1.2debian-alsa

De cette manière, frozen-bubble utilisera alsa (et encore beaucoup d'autres jeux !)

Seul point noir : les applications OSS ne peuvent toujours accéder à la carte son que une par une. Il faut donc éteindre tous les sons **avant** de lancer l'application en question.
(par exemple des jeux comme Enemy Territory ou Quake)




*******
Ces explications techniques vous sont fournies par wip.png

Dernière modification par ploum (Le 23/04/2005, à 11:40)

Hors ligne

#2 Le 11/04/2005, à 15:53

laurent

Re : Le son sous Warty et Hoary, à lire avant de poster

Waaaaaaaaaaaaaaaaaaaaaaah! merci! enfin! big_smile


Laurent, petit belge explorant la banquise

Hors ligne

#3 Le 11/04/2005, à 16:08

endrylthalan

Re : Le son sous Warty et Hoary, à lire avant de poster

merci beaucoup pour l'explication smile c'était vraiment nécessaire !!
A épingler, non ?

Dernière modification par endrylthalan (Le 11/04/2005, à 16:09)


Et si tout n'était qu'illusion et que rien n'existait ? Dans ce cas, j'aurais vraiment payé mon tapis beaucoup trop cher.
Woody Allen

Hors ligne

#4 Le 11/04/2005, à 16:34

kilik

Re : Le son sous Warty et Hoary, à lire avant de poster

Excellent, je comprend mieux pourquoi il m'etait impossible d'utiliser ALSA avec gstreamer ....

Question subsidiaire : y'a t'il des inconvenients a ne pas utiliser ESD ?

Hors ligne

#5 Le 11/04/2005, à 16:38

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

kilik : si tu as plusieurs sons en même temps avec ALSA, alors ESD n'a aucun intérêt. Au contraire !
Il est juste nécessaire pour les sons systèmes "click click".

De toutes façons, avec la technique donnée dans ce post, esd se lance quand on a besoin de lui.

En gros, une fois configuré comme ça, ne te préoccupe plus de toutes ces histoires. Excepté pour les applications qui utilisent OSS et ça c'est chiant.

Je t'avoue que je ne comprend pas trop perso l'utilité d'ESD... à part pour introduire de la latence.

Hors ligne

#6 Le 11/04/2005, à 16:56

kilik

Re : Le son sous Warty et Hoary, à lire avant de poster

Je peux donc virer libesd0 sans problème ? ou dois-je le remplacer par libesd0-alsa (comme tu l'indiques dans ton tuto) ?..

Bon je test, si ça casse, c'est pas grave tongue

petit EDIT pour dire qu'au vu des dépendances, je le laisse !! hmm

Dernière modification par kilik (Le 11/04/2005, à 16:57)

Hors ligne

#7 Le 11/04/2005, à 17:05

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

met libesd0-alsa si alsa fonctionne bien chez toi.

Hors ligne

#8 Le 11/04/2005, à 17:21

kilik

Re : Le son sous Warty et Hoary, à lire avant de poster

big_smile Nikel, ca gazouille dans les oreilles !!

thx ploum

Hors ligne

#9 Le 11/04/2005, à 17:49

Bkssou

Re : Le son sous Warty et Hoary, à lire avant de poster

Je crois que cela était necessaire, je vais tester tout ca maintenant.....

Hors ligne

#10 Le 11/04/2005, à 18:00

Tom

Re : Le son sous Warty et Hoary, à lire avant de poster

sad:(:(
Bah moi ça marche pô

Alros voila les détails:
*Aucun son, dans "sélecteur de système multimédia", si je test avec ALSA, ESD, OSS, j'ai le message "La construction de la pipeline de test pour « ESD - Enlightenment Sound Daemon » a échoué". En plus en cas d'erreur, j'ai un bip du buzzer sad

*tom@UbuntuX:~$ lsmod|grep snd
snd_intel8x0           29984  1
snd_ac97_codec         64608  1 snd_intel8x0
snd_pcm_oss            47652  0
snd_mixer_oss          16768  2 snd_pcm_oss
snd_pcm                84872  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              23300  1 snd_pcm
snd                    50276  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9824  2 snd
snd_page_alloc          9604  2 snd_intel8x0,snd_pcm
tom@UbuntuX:~$ lsof /dev/dsp
tom@UbuntuX:~$ lsof /dev/snd*
tom@UbuntuX:~$

*Carte mère ASRock  K7S8XE pour plus d'infos sur la carte:
http://www.asrockfrance.com/k7s8x/

tom@UbuntuX:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SI7012 [SiS SI7012], device 0: Intel ICH [SiS SI7012]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

C'est grave docteur ? sad

Hors ligne

#11 Le 11/04/2005, à 18:48

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

Tom : oublie le sélecteur multimedia et renvoie le résultat de :

aplay /usr/share/sounds/gnomemeeting/gnomemeeting.wav
play /usr/share/sounds/gnomemeeting/gnomemeeting.wav


Le premier teste alsa, le second OSS

Hors ligne

#12 Le 11/04/2005, à 18:52

Tom

Re : Le son sous Warty et Hoary, à lire avant de poster

tom@UbuntuX:~$ aplay /usr/share/sounds/gnomemeeting/gnomemeeting.wav
Playing WAVE '/usr/share/sounds/gnomemeeting/gnomemeeting.wav' : Signed 16 bit L ittle Endian, Rate 11025 Hz, Mono

tom@UbuntuX:~$ play usr/share/sounds/gnomemeeting/gnomemeeting.wav
bash: play: command not found
tom@UbuntuX:~$

voila hmm

Hors ligne

#13 Le 11/04/2005, à 19:06

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

et tu n'as pas entendu de son avec le premier ?  Parce que là, sans erreur, on dirait qu'il a bel et bien marché !!!

Un conseil, utilise cette commande comme référence et continue à chercher. On dirait pourtant que tout semble correct chez toi. Note que j'ai eu des problèmes avec la même carte son que toi mais que sous Hoary, tout a marché nickel. Vérifie qu'un truc n'est pas "mutté" quelque part dans alsamixer.

Hors ligne

#14 Le 11/04/2005, à 20:15

Bkssou

Re : Le son sous Warty et Hoary, à lire avant de poster

J'aurais une question qui est en rapport avec mes problèmes de son sur hoary: connaissez vous un moyen d'envoyer le flux audio qui sort de l'émulation oss vers une sortie spécifique (la sortie SPDIF en occurence).

Je m'explique:

J'a le son, qui peut provenir de plusieur sources "alsa" en même temps sur la sortie SPDIF (par exemple XMMS Mplayer et le lecteur de musique) j'ai pour le moment désactivés le serveur de son au démarage car ils me sortent un sont pourris, mais quand je lance des application comme frozen-bubbles le son sort par la sortie analogique et non par la sortie numérique. Je cherche donc à corriger tout ca de manière à ce qu'il sorte vers la sortie numérique mais je ne sais pas comment faire

Pour plus d'info sur mes tribulations:
http://forum.ubuntu-fr.org/viewtopic.php?pid=19380#p19380

Merci

Hors ligne

#15 Le 11/04/2005, à 20:37

tquerne

Re : Le son sous Warty et Hoary, à lire avant de poster

Même carte mère: ASRock  K7S8X ; et pas de son non plus!

---------------------------------------------------------------------------------------------------
thierry@ubuntu:~$ lsmod|grep snd

snd_via82xx            25248  2
snd_ac97_codec         64608  1 snd_via82xx
snd_mpu401_uart         7168  1 snd_via82xx
snd_rawmidi            22944  1 snd_mpu401_uart
snd_seq_device          8332  1 snd_rawmidi
snd_bt87x              12612  0
snd_pcm_oss            47652  0
snd_mixer_oss          16768  3 snd_pcm_oss
snd_pcm                84872  4 snd_via82xx,snd_ac97_codec,snd_bt87x,snd_pcm_oss
snd_timer              23300  1 snd_pcm
snd                    50276  10 snd_via82xx,snd_ac97_codec,snd_mpu401_uart,snd_ rawmidi,snd_seq_device,snd_bt87x,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9824  3 snd
snd_page_alloc          9604  3 snd_via82xx,snd_bt87x,snd_pcm
gameport                4608  2 snd_via82xx,analog

------------------------------------------------------------------------------------------
thierry@ubuntu:~$ lspci

0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

--------------------------------------------------------------------------------------------
thierry@ubuntu:~$ play usr/share/sounds/gnomemeeting/gnomemeeting.wav
bash: play: command not found
-----------------------------------------------------------------------------------------------
thierry@ubuntu:~$ aplay /usr/share/sounds/gnomemeeting/gnomemeeting.wav
Playing WAVE '/usr/share/sounds/gnomemeeting/gnomemeeting.wav' : Signed 16 bit L ittle Endian, Rate 11025 Hz, Mono

Probléme spécifique à cette carte?

Hors ligne

#16 Le 11/04/2005, à 22:27

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

pour play, je crois qu'il est dans le package "sox", dispo en universe. Mais laissez tomber cette ligne en attendant.


Ce qui est bizarre pour tous les deux c'est que aplay joue le son !! (sinon il met une erreur ou cale)

Mais vous n'avez pas la même carte son : intel8x0 pour l'un, via pour l'autre. Bizarre bizarre

Hors ligne

#17 Le 11/04/2005, à 23:40

Bkssou

Re : Le son sous Warty et Hoary, à lire avant de poster

SI ca peut t'être utile Ploum pour les aider je vais essayer de relater exactement ce que j'ai fait avant d'avoir du son:

[*] j'ai d'abord cherché à determiner quelles étaient mes sorties pour mon systeme:

cat /proc/asound/devices

là j'ai obtenu ceci:

 
0: [0- 0]: ctl
 18: [0- 2]: digital audio playback
 25: [0- 1]: digital audio capture
 16: [0- 0]: digital audio playback
 24: [0- 0]: digital audio capture
 33:       : timer

On ne s'interresse qu'au truc només "playback" il y en a deux, il faut les tester pour voir si ca marche:

aplay -D hw:0,0 some.wav

et

aplay -D hw:0,2 some.wav

(où some.wave est un fichier que l'on a mis dans le répertoire home)
Je me suis alors rendu compte que j'obtenais du son sur les enceintes (reliés à la sortie SPDIF) avec hw: 0,2 et du son sur le casque(sortie analogique) en hw: 0,1.

(NB: à ce moment la si j'allais dans les options de XMMS ou de Mplayer et que je mettais comme sortie audio Alsa en forçant le périhérique sur hw: 0,2 au lieu de défaut cela fonctionnait mais pas simultanément)

[*] J'ai alors cherché à configurer mes fichiers de manière à ce qu'il sorte le son sur la sortie SPDIF par défaut

Pour cela j'ai créer le fichier asound: "sudo gedit /etc/asound.conf"
Je me suis alors renseigné pour ma carte mère (Asus A7N8X-deluxe) et j'ai trouver un script que j'ai copier coller en modifiant juste le hw:0,0 en hw:0,2

pcm.nforce-hw {
    type hw
    card 0
}
pcm.!default {
    type plug
    slave.pcm "nforce"
}
pcm.nforce {
    type dmix
    ipc_key 1234
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 32768
        rate 48000
    }
}
ctl.nforce-hw {
    type hw
    card 0
}

[*] ça ne marchait pas des masses: les applications comme Mplayer et XMMS marchait si je mettait en output Alsa avec comme périphérique audio (ou device): default mais pas en simultané, et en plus le serveur son de Ubuntu et toute les applications qui utilisaient OSS (exemple: frozen bubble NB: à ce moment là je ne savais pas qu'elles utilisaient OSS) ne fonctionnaient pas.
Alors j'ai lu attentivement et il y avait "dmix" que j'avais déja vu quelquepart. Je me suis renseigné et j'ai trouver quelquechose:

The Dmix Howto

Written in large parts by Frank Barknecht (feel free to use it any way you like). This howto describes how to set up dmix for OSS applications.
1. Install aoss, alsaplayer, mpg123

Note: If you use Debian, aoss comes with the alsa-oss package. Just type:

apt-get install alsa-oss alsaplayer \
 mpg123 alsaplayer-alsa

2. Test basic dmix on alsa with:

alsaplayer -o alsa -d plug:dmix some.mp3 &
aplay -D plug:dmix some.wav &
alsaplayer -o alsa -d plug:dmix some.mp3 &

This should work everywhere with ALSA 0.9.7. (It works also with ALSA 0.9.8 on a snd-intel8x0, eg. on nForce2 audio). If the second and/or third audiostream stutters, it might be the buffers-problem mentioned below 7). Don't give up yet.

En suivant ceci j'ai obtenu le son en simultané. (pour alsa)

La suite de ce how-to permet de configurer OSS (sans simultanéité):

3. configure .asoundrc for aoss-testing:

# cat ~/.asoundrc:

pcm.dsp0 {
    type plug
    slave.pcm "hw:0"
}
# or: 
#  pcm.dsp0 pcm.default
# if "default" hasn't been redefined

ctl.mixer0 {
    type hw
    card 0
}

4. Test aoss with mpg123 in oss mode:

aoss mpg123 some.mp3

Enfin on peut configurer pour avoir la simultanéité avec OSS (je l'ai fait mais pas testé)

5. The simple approach:

# cat ~/.asoundrc

pcm.dsp0 {
    type plug
    slave.pcm "dmix"
}
# mixer0 can stay unchanged, because 
# it isn't used anyway, I guess ;)
ctl.mixer0 {
    type hw
    card 0
}

Test this setup with mpg123 like under 4). This should enable dmix'd OSS playback, but it will not work on cards like the M-Audio Audiophile or other Delta cards, that need a certain audio data format for playback on hw:0 (which dmix uses by default). A fix is below.

6. The complex approach (defining dmix parameters)

If a card needs a certain format conversion we need to create a custom dmix device. Let's call it ossmix.

pcm.ossmix {
    type dmix
    ipc_key 1024          # must be unique!
    slave {
        pcm "hw:0,0"      # you cannot use a "plug" device here, darn.
        period_time 0
        period_size 1024  # must be power of 2
        buffer_size 8192  # dito. It
        #format "S32_LE"
        #periods 128      # dito.
        #rate 8000        # with rate 8000 you *will* hear, 
                          # if ossmix is used :)
    }

# bindings are cool. This says, that only the first
# two channels are to be used by dmix, which is enough for
# (most) oss apps and also lets multichannel chios work 
# much faster:

    bindings {
        0 0   # from 0 => to 0
        1 1   # from 1 => to 1
    }
}
pcm.dsp0 {
    type plug
    slave.pcm "ossmix"     # use our new PCM here
}
# mixer0 like above
ctl.mixer0 {
    type hw
    card 0
}

It is important, that this "ossmix" PCM works with your card in ALSA mode. That is, the following should produce sound:

alsaplayer -o alsa -d ossmix some.mp3

7. Dmixing the ICE1712 chip

The config above does still not work (well) with an Audiophile card (ICE1712 chip) or a VIA VT82xx (snd-via82xx). The error is:

$ alsaplayer -d ossmix
error on set_format SND_PCM_FORMAT_S16_LE
Unavailable hw params:
ACCESS:  RW_INTERLEAVED
FORMAT:  S32_LE
SUBFORMAT:  ALL
SAMPLE_BITS: ALL
FRAME_BITS: ALL
CHANNELS: 2
RATE: 48000
PERIOD_TIME: (21333 21334)
PERIOD_SIZE: 1024
PERIOD_BYTES: ALL
PERIODS: (6 7)
BUFFER_TIME: (136520 136521)
BUFFER_SIZE: 6553     <<<<====take a look here!!
BUFFER_BYTES: ALL
TICK_TIME: ALL

Jaroslav Kysela did know the reason: The max buffer size of the Delta card is "6553" as marked above. So we need to specify a buffer size in our dmix definition that is: a) a power of two and b) less than 6553. Here's the fixed OSS-dmix .asoundrc for a ICE1712 and VT82xx card:

# cat ~/.asoundrc

# our ICE1712 dmix:
pcm.ossmix {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 4096 # buffer size < 6653, but pow(x, 2)
        rate 44100       # we want to play CDs only
    }
    bindings {
        0 0
        1 1
    }
}
# Everything shall be dmixed, so redefine "default":
pcm.!default {
    type plug
    slave.pcm "ossmix"
}
# OSS via aoss should d(mix)stroyed:
pcm.dsp0 {
    type plug
    slave.pcm "ossmix"
}
ctl.mixer0 {
    type hw
    card 0
}

Dans le 7eme point on voit qu'il y a un problème avec les carte Via82.... ce qui est peut-être la raison du foirage de oss de tquerne....

Source:
http://alsa.opensrc.org/
en particulier:
pour intel8x0 ici
pour Dmix: ici

pour via82xxx (je ne l'ai pas lu je le met juste pour info.ici

Hors ligne

#18 Le 11/04/2005, à 23:58

tquerne

Re : Le son sous Warty et Hoary, à lire avant de poster

Petite ereur de ma part ma carte est une asrock K7VT4A.

Hors ligne

#19 Le 12/04/2005, à 01:24

coffee

Re : Le son sous Warty et Hoary, à lire avant de poster

Belle doc technique O_o

je l'epingle et crée un lien vers multimedia

S'il vous plait, ne posez plus de questions dans ce post, je nettoierai dans une semaine (soit le 19 avril au plus tot) ce thread pour qu'ils ne contiennent que des données utiles et aucune questions. Si vous avez un problèmes vous pouvez vous referez à cette doc http://forum.ubuntu-fr.org/viewtopic.php?id=2969 . Vous pouvez upper votre questions dans le forum.

Preparez vous à créer des posts pour votre problème de son. Ah oui j'effacerai aussi tous les posts qui contiennent une question dans les posts qui suivront le mien. Essayer de pas detruire la doc.
Pensez aussi au Wiki pour vos docs wink


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#20 Le 14/04/2005, à 11:51

Tonio

Re : Le son sous Warty et Hoary, à lire avant de poster

Par curiosité, qui s'inspire de l'autre? wink http://ubuntuforums.org/showthread.php?t=26567

Hors ligne

#21 Le 14/04/2005, à 14:55

vincebel

Re : Le son sous Warty et Hoary, à lire avant de poster

Très bon post, bonne chose qu'il soit épinglé. ça m'a évité de poster big_smile
Merci Ploum

Tonio >> c'est vrai que ça ressemble beaucoup!!!! wink

Dernière modification par vincebel (Le 14/04/2005, à 14:56)

En ligne

#22 Le 15/04/2005, à 00:38

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

dusu a très sympathiquement proposé de traduire ma doc pour le forum anglophone (ou je suis aussi présent).

Merci à lui.

Tonio : regarde la date des posts et surtout la première phrase
"The following howto has been posted by ploum on the French Ubuntu forums."

De toutes façons, je suis incapable de recopier un truc d'ailleurs. Je pond mes propres conneries à l'ancienne artisanalement ! ;-)

Hors ligne

#23 Le 15/04/2005, à 13:43

ploum

Re : Le son sous Warty et Hoary, à lire avant de poster

petit edit pour que Flash utilise ESD en lieu et place de OSS cool

Hors ligne

#24 Le 15/04/2005, à 15:27

Tonio

Re : Le son sous Warty et Hoary, à lire avant de poster

Ah oui, tiens faudra que j'apprenne à lire... smile

Ceci dis j'aime bien ce genre de conneries wink

Hors ligne

#25 Le 16/04/2005, à 13:44

pilou08

Re : Le son sous Warty et Hoary, à lire avant de poster

Bonjour à tous,

Pour pouvoir avoir du son sous xmms et les jeux ( applications non lancées simultanément) je dois faire killall esd, et tout fonctionne parfaitement. J'ai effectué les modif dans le fichier esd.conf mais rien ne change ... Auriez vous une explication ?

Merci d'avance !

Haut de page ↑