Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 08/03/2006, à 20:25

benardo

TILP TI-92 problème au lancement

Bonjour à tous !

J'ai un gros problème pour pouvoir relier ma TI-92 avec TILP
Depuis Synaptic j'ai installé TOUS les paquets... comme cela ne fonctionnait toujours pas j'ai  même installé les librairies de developpement concernant tilp.

Je desinstalle et j'essaye de tout compiler à l'ancienne !!!
Bon apparemment l'installation en mode compilation se déroule plutôt mal tout va bien pour les libraires mais  lorsque je fait :

./configure

pour tilp alors il bloque sur des librairies déjà présentes en dpkg_config : il ne les trouve pas !!! (fichiers .pc)

Je recommence donc avec synaptic... j'installe tous les paquets renvoyés via une recherche avec "texas instrument". Je précise que Univers et Multiverse sont activés.

Voilà ce qui se lance lorsque je lance TILP :
Je suis un newbie mais au vu de ce qui est écrit... et de ce que je constate sur l'application que se lance tout de même je crois que tous les boutons et les fonctions de l'interface graphique de TILP ne fonctionnent carrément pas.
Merci de votre aide précieuse : sans vous je ne pourrais pas installer fargo 2 sir ma ti92... un programme indispensable pour l'utilisation que j'en ai : consultation de textes et gestion de fichiers tableurs.

Merci de votre aide

root@ubuntu:~# tilp
tilp    : TiLP - Version 6.79, (C) 1999-2005 Romain Lievin
tilp    : THIS PROGRAM COMES WITH ABSOLUTELY NO WARRANTY
tilp    : PLEASE READ THE DOCUMENTATION FOR DETAILS
tilp    : built on Jun  2 2005 16:17:11
tilp    : initialized in command line mode.
tilp    : Configuration file not found, use default values. You can create one b y the 'File|Save config' command menu.
tilp    : err: msg_box: Information, Configuration file not found, use default v alues. You can create one by the 'File|Save config' command menu.

tilp    : setlocale: <fr_FR.UTF-8>
tilp    : bindtextdomain: </usr/share/locale/>
tilp    : textdomain: <tilp>
ticables: librairie ticables version 3.9.2
ticables: setlocale: <fr_FR.UTF-8>
ticables: bindtextdomain: </usr/share/locale>
ticables: textdomain: <libticables>
ticables: Compilé pour __LINUX__.
ticables: vérification des ressources :
ticables:   IO_API : trouvé lors de la compilation (HAVE_TERMIOS_H)
ticables:   IO_ASM :  trouvé lors de la compilation (HAVE_ASM_IO_H).
ticables:   IO_TIPAR :  trouvé lors de la compilation (HAVE_LINUX_TICABLE_H)
ticables:   IO_TISER :  trouvé lors de la compilation (HAVE_LINUX_TICABLE_H)
ticables:   IO_TIUSB: found at compile time (HAVE_LINUX_TICABLE_H)
ticables:   IO_LIBUSB :  trouvé lors de la compilation (HAVE_LIBUSB).
ticables: recherche rapide des ports série/parallèle :
ticables:   port série trouvé à l'adresse 0x3f8
ticables: recherche de tous les ports :
ticables:   /dev/ttyS0 at 0x3f8
ticables:   /dev/ttyS1 at 0x2f8
ticables:   /dev/ttyS2 at 0x3e8
ticables:   /dev/ttyS3 at 0x2e8
ticables: détermination de la méthode utilisée (automatique) :
ticables:   disponibilité de tty :
ticables:     le nœud /dev/ttyS0 existe
ticables:     permissions /user/group : -rw-rw---- root dialout
ticables:     l'utilisateur a le droit de lecture/écriture sur le périphérique :  oui
ticables: carte des E/S...
ticables: enregistrement du câble...
ticables: liste des réglages :
ticables:   câble : GrayLink
ticables:   port : serial port #2
ticables:   méthode : accès direct (api)
ticables:   nom du périphérique : /dev/ttyS1
ticables:   délai : 10
tifiles : librairie tifiles version 0.6.5
tifiles : setlocale: <fr_FR.UTF-8>
tifiles : bindtextdomain: </usr/share/locale>
tifiles : textdomain: <libtifiles>
tifiles : réglages :
tifiles :   type de calculatrice : TI92
ticalcs : librairie ticalcs version 4.5.9
ticalcs : setlocale: <fr_FR.UTF-8>
ticalcs : bindtextdomain: </usr/share/locale>
ticalcs : textdomain: <libticalcs>
tifiles : réglages :
tifiles :   type de calculatrice : TI92
ticalcs : réglages :
ticalcs :  Type de calculatrice: TI92
tilp    : Initialisé en mode GTK+.

(tilp:23563): libglade-WARNING **: could not find signal handler 'on_get_idlist1 _activate'.

(tilp:23563): libglade-WARNING **: could not find signal handler 'on_treev

Hors ligne

#2 Le 27/03/2006, à 14:47

smoof93

Re : TILP TI-92 problème au lancement

Salut !
Je tente de faire fonctionner une Ti89 relié par un câble serie (TI black link) à mon PIII sous breezy ( kernel 2.6.12-10-686 ).

J'ai aussi les messages d'erreur de type:

(tilp:XXXX): libglade-WARNING **: could not find signal handler "NOM_DU_SIGNAL".

Pour information, la libglade est une bibliothèque permettant le fonctionnement des applications dont l'interface graphique a été réalisée avec glade.
Apparament les messages d'erreur signifient que cette librairie n'arrive pas à faire le lien entre les boutons de l'interface de Tilp et les fonctions du logiciel, celles qui réalisent les actions à proprement dites.
Ceci peut être du par exemple à un mauvais portage du logiciel sous Ubuntu, ou à des évolutions des librairies depuis la compilation de l'executable.
Une solution pour que cela fonctionne est de recompiler l'application depuis les sources.
Ce problème concerne à priori tous les utilisateurs d'Ubuntu et mériterai, à mon avis une mise à jour du paquetage...avis aux amateurs !

De plus, pour  se connecter à la calculatrice, tilp se sert de pilotes de périphériques spécifiques aux câbles ( black-serial, USB, ou parallele ; le gray-serial fonctionnerai en natif). Ces pilotes ne semblent pas avoir été compilés pour les kernels Ubuntu. Il faut aussi les compiler à partir des sources qui se trouvent dans le paquetage  tidev-modules-source.

Cepandant, là aussi j'ai rencontré un problème. En suivant les instruction du fichier /usr/src/modules/tidev-modules/tiser/README, j'arrive à compiler les drivers USB et paralleles mais pas le pilote tiser qui me permetrai d'utiliser mon câble série.

Je ne suis pas un expert, mais voilà le compte rendu de ma tentative d'instalation.
Si quelqu'un réussit à faire fonctioner Tilp ou le module tiser, il serait bien aimable de nous dire comment.:D

Suite aux prochaines tentatives....
++

#3 Le 01/04/2006, à 19:50

onaka

Re : TILP TI-92 problème au lancement

I've had the same issue. See:

for a solution see:
https://wiki.ubuntu.com/tilp?highlight=%28tilp%29

#4 Le 01/05/2006, à 17:19

@l1nux

Re : TILP TI-92 problème au lancement

Bonjour,

J'ai tenté ausi de faire fonctionner une Ti92 relié par un câble serie (TI black link) à mon PIV sous breezy ( kernel 2.6.12-10-386) avec Tilp et Tilp2 (quelques soient les versions).. et rien à faire

J'ai tenté ...desespoir oblige...avec une ancienne version de tilp : TiLP v6.81: http://www.ticalc.org/archives/files/fileinfo/158/15898.html

Aprés compilation.....tout fonctionne !!

Allez comprendre!

al1

PS :
J'ai d'abord suivi ce tut : https://wiki.ubuntu.com/tilp?highlight=%28tilp%29
Puis j'ai  compilé ces packages ci-dessous :

obconf-1.5 : http://tr.openmonkey.com/pages/obconf

openbox-3.2 : http://icculus.org/openbox/download.php

http://sourceforge.net :
       libticables2-0.0.7
       libticalcs2-0.0.6
       libticonv-0.0.1
       libtifiles2-0.0.9

#5 Le 04/06/2006, à 10:45

Mirador57

Re : TILP TI-92 problème au lancement

Salut quand j'installe Tilp 2 tou se passe bien,puis j'installe gtk ,tout se passe bien et quand je veux lancer le logiciel un message d'erreur apparait "Le point d'entrée de procédure g_filename_to_utf8_utf8 est introuvable dans la bibliotheque de liaisons dynamique libglib-2.0-0.dll

Voila j'attend votre réponse
Merci

#6 Le 02/03/2007, à 12:49

hanet

Re : TILP TI-92 problème au lancement

Bonjour,

je fait remonter le post, car j'ai aussi ce problème de "point d'entrée" et je n'arrive pas à aller plus loin.

CONFIG : Win XP SP2

Haut de page ↑