Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 11/01/2005, à 17:57

laurent

[résolu]Problème lors de dist-upgrade

bonjour à tous,

voilà, je suis en train de faire le grand saut (bien préparé, quand meme: tout est sauvegardé bien au chaud) mais j'ai un problème:

Lorsque je fais apt-get dist-upgrade, tout ce passe bien, puis mon pc me retourne un message d'erreur. Là je refais apt-get dist-upgrade -f comme il me conseille et ça remarche pendant un moment.

En fait, on dirait que j'ai un problème avec kdelibs-data. J'ai tenté plusieures fois de désinstaller le paquet, etc. Mais mon pc ne veut rien savoir et ne juge que par apt-get -f install, qui redonne toujours le meme message d'erreur, lié à kdelibs-data. Je vous montre ce que ça donne ci-dessous:

laurent@ubuntu:~ $ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  kdelibs-data
Les paquets suivants seront mis à jour :
  kdelibs-data
1 mis à jour, 0 nouvellement installés, 0 à enlever et 141 non mis à jour.
355 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/7063ko dans les archives.
Après dépaquetage, 1610ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
WARNING: The following packages cannot be authenticated!
  kdelibs-data
Install these packages without verification? [y/N] y

Preconfiguring packages ...
(Lecture de la base de données... 120321 fichiers et répertoires déjà installés.)
Préparation du remplacement de kdelibs-data 4:3.2.3-2ubuntu1 (en utilisant .../kdelibs-data_4%3a3.3.2-1ubuntu3_all.deb) ...
Dépaquetage de la mise à jour de kdelibs-data ...
dpkg : erreur de traitement de /var/cache/apt/archives/kdelibs-data_4%3a3.3.2-1ubuntu3_all.deb (--unpack) :
tentative de remplacement de « /usr/share/mimelnk/application/vnd.stardivision.calc.desktop », qui appartient aussi au paquet openoffice.org-mimelnk
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/kdelibs-data_4%3a3.3.2-1ubuntu3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Quelqu'un a une idée (j'ose plus éteindre mon pc, en attendant, de peur de ce que ça pourrait donner au redémarrage)?

Au pire, je tenterai le "downgrade" comme expliqué sur le wiki, mais bon...

Merci d'avance

Dernière modification par laurent (Le 11/01/2005, à 18:59)


Laurent, petit belge explorant la banquise

Hors ligne

#2 Le 11/01/2005, à 18:02

multani

Re : [résolu]Problème lors de dist-upgrade

T'as qu'à l'enlever : dpgk -r kdelibs-data (je crois)
Et tu relances un apt-get dist-upgrade

Hors ligne

#3 Le 11/01/2005, à 18:33

laurent

Re : [résolu]Problème lors de dist-upgrade

ben la commande ne marchait pas, mais j'ai fait à peu près la meme chose:

J'ai retiré tous les paquet liés à celui-là, et celui là avec pour finir. Puis j'ai fait un apt-get dist-upgrade... et me voilà sous hoary (soit dit en passant, quelle rapidité de lancement... C'est plus un pc, c'est une fusée...)

Et tant pis pour k3b. Il était temps que j'essaie coaster, de toutes façons!

Bon, allons voir ce qu'il y a faire par ici........ wink

Tiens, au fait, où peut-on trouver les bugs déjà reportés pour la hoary... histoire de contribuer à l'avancement du bazar?

Dernière modification par laurent (Le 11/01/2005, à 18:35)


Laurent, petit belge explorant la banquise

Hors ligne

#4 Le 11/01/2005, à 18:57

multani

Re : [résolu]Problème lors de dist-upgrade

Les bugs pour ubuntu, c'est sur https://bugzilla.ubuntu.com/ wink

Hors ligne

#5 Le 11/01/2005, à 18:59

laurent

Re : [résolu]Problème lors de dist-upgrade

thx!!!


Laurent, petit belge explorant la banquise

Hors ligne

Haut de page ↑