Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/06/2009, à 16:53

Phendrax

Probleme d'affichage avec Kolourpaint

Bonjour à tous,

Alors voila, j'ai un petit problème depuis quelques jours avec Kolourpaint, l'affichage de la fenêtre déconne complètement alors qu'avant ça allait nickel.

Un petit screen : http://www2.noelshack.com/uploads/Capture003028.png

En fait je crois que l'affichage bug depuis que j'ai installé Compiz-Git et Cubethemer pourtant je ne sais pas si il y a vraiment un lien vu que lorsque je désactive Compiz, ben ça change rien pour Kolourpaint...

Sinon les autres applications en qt4 comme VLC ne buguent pas, ni les autres applications KDE comme Amarok.

Si je lance Kolourpaint en console, il me dit uniquement ça :

phendrax@phendrax-laptop:~$ kolourpaint
Starting KolourPaint on a 32-bit screen...
QPainter::setCompositionMode: PorterDuff modes not supported on device
QPainter::setCompositionMode: PorterDuff modes not supported on device

Je suis sous Jaunty avec GNOME.

Merci de votre aide ^^


HP Pavillon dv6800 - Ubuntu 10.10 - GNOME 2.32.0

Hors ligne

#2 Le 21/07/2009, à 18:24

alcidi2

Re : Probleme d'affichage avec Kolourpaint

J'ai exactement le même problème, désintallé et réinstallé kolourpaint , enlevé le répertoire .kde aussi , rien n'y fait.
Je pense que c'est soit ubuntu 9.04 qui ne gère pas correctement tout cela sans l'ajout d'une éventuelle librairie de kde qui ne se met pas lors de l'installation de kolourpaint, soit mythTV que j'avais installé et désinstallé aussi . Voilà les dernières modifs majeures sur mon pc .

#3 Le 25/07/2009, à 16:52

alcidi2

Re : Probleme d'affichage avec Kolourpaint

je pense en fait que cela est dû à la version de kolourpaint , ils sont passé en version 4 ce qui ne semble pas convenir à gnome. A vérifier avec une précédentre version si quelqu'un en possède une.

#4 Le 29/07/2009, à 07:54

alcidi2

Re : Probleme d'affichage avec Kolourpaint

En effet la version 4 n'aime pas gnome on dirait.
Il faut installer une ancienne version, par exemple celle-ci :
http://packages.debian.org/fr/etch/graphics/kolourpaint
Et pour le mettre en français : dans le synaptic installer le paquet kde-|10n-fr

#5 Le 20/08/2009, à 15:35

Phendrax

Re : Probleme d'affichage avec Kolourpaint

Hum oui la version précedente marche nickel sous Jaunty, mais elle est quand même moins bien que la version 4, qui elle, marchait très bien sous Intrepid T_T

(désolé du retard, j'avais complétement zappé ce topic /o/)


HP Pavillon dv6800 - Ubuntu 10.10 - GNOME 2.32.0

Hors ligne

#6 Le 05/09/2009, à 08:30

gawindx

Re : Probleme d'affichage avec Kolourpaint

Bonjour à tous

Un petit up sur ce post car j'ai été confronté au même probléme et je l'ai résolu.

La méthode est exactement la même que pour les problémes d'affichage liés a l'utilisation de cairo-dock Opengl + VirtualBox (et d'aprés la capture d'écran tu as bien cairo-dock OpenGL Phendrax).

Donc il faut éditer le menu gnome et afficher les propriétes de kolourpaint.
Devant la commande, rajouter : "env XLIB_SKIP_ARGB_VISUALS=1" (sans les guillemets)
ce qui devrait vous donner : env XLIB_SKIP_ARGB_VISUALS=1 kolourpaint %u

valider le tout et relancer kolourpaint, le résultat est flagrant^^

Bon samedi à tous, et je crois que l'on peut rajouter résolu^^

Dernière modification par gawindx (Le 05/09/2009, à 08:32)

Hors ligne

#7 Le 08/09/2009, à 18:58

Phendrax

Re : Probleme d'affichage avec Kolourpaint

Alors là je dis gg §§

Merci beaucoup gawindx, c'est nickel :3


HP Pavillon dv6800 - Ubuntu 10.10 - GNOME 2.32.0

Hors ligne

#8 Le 20/11/2010, à 10:37

yodhai

Re : Probleme d'affichage avec Kolourpaint

Bonjour,
j'ai le même problème cité ci-dessus: interface graphique déconne, et je pense que c'est du à l'utilisation de cairo-dock.
Visiblement, il y a une solution, mais je n'ai pas compris ce qu'a indiqué Gawindx plus haut:

gawindx a écrit :

Donc il faut éditer le menu gnome et afficher les propriétes de kolourpaint.
Devant la commande, rajouter : "env XLIB_SKIP_ARGB_VISUALS=1" (sans les guillemets)
ce qui devrait vous donner : env XLIB_SKIP_ARGB_VISUALS=1 kolourpaint %u

Comment fait-on pour "editer le menu gnome et afficher les propriété de kolourpaint" ??

PS: Je précise que je suis sur Ubuntu 10.04

Merci pour vos réponses.

Dernière modification par yodhai (Le 20/11/2010, à 10:38)

Hors ligne

#9 Le 01/01/2011, à 12:21

jerkam

Re : Probleme d'affichage avec Kolourpaint

salut...
j'ai trouvé le meme problem hmm, je ne sauvais pas comment editer le menu gnome comme gawindx avait dit sad

gawindx a écrit :

Donc il faut éditer le menu gnome et afficher les propriétes de kolourpaint.
Devant la commande, rajouter : "env XLIB_SKIP_ARGB_VISUALS=1" (sans les guillemets)
ce qui devrait vous donner : env XLIB_SKIP_ARGB_VISUALS=1 kolourpaint %u

...mais après une heure yikes ...j'ai trouvé la manière d'editer le menu gnome...C'est simple...click droite sur le coin superieur gauche de ton écran(sur le logo ubuntu)>editer les menus...il aparaitra une frenetre avec deux colonnes (1°)juste a gauche sur la colonne menu, choisi Graphisme et (2°)sur la colonne Elements, selectione kolourpaint...à coté choisi "propiétés" entre (-nouveau menu-nouvel element-nouveau separateur-monter-descendre-PROPIETES-suprimer)...et dans la partie comande... colle :

env XLIB_SKIP_ARGB_VISUALS=1 kolourpaint %u

J'espere que maintenant tu sache comment faire pour avoir un tres beau kolourpaint. Profite bien! big_smile

a la prochain et  merci gawindx

Dernière modification par jerkam (Le 01/01/2011, à 12:22)

Hors ligne

Haut de page ↑