Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/06/2009, à 15:13

bakrz

Pb son depuis une mise à jour

Salut, je suis ultra novice(je préfère prévenir). Depuis ma dernière mise à jour il y a deux jours sur mon portable ousk j'ai le ubuntu 8.04 LTS, ben bigre! je n'ai plus de son du tout il me dit, cet ordi tétu, que je n'ai pas de greffon ou un truce du genre :

"Le contrôleur de volume ne trouve aucun élément et/ou périphérique à contrôler. Cela signifie que soit vous n'avez pas les bons greffons GStreamer installés, soit vous n'avez pas de carte son configurée"

et  quand je vais sur système > son :

"gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Impossible d'utiliser le périphérique audio pour l'enregistrement."

Savez-vous ce que je dois faire?
Peut-on revenir à mon état ordinatique d'avant la fameuse mise à jour?
Mon ordi a été vendu avec ubuntu dessus diois-je réinstallé tout comme au départ?

Si vous pouviez me répondre je vous en serais vraiment reconnaissante parce que je ne comprends pas vraiment et avant d'utiliser la manière brutale(j'écrase tout!) je me demande s'il n'y a pas un truc simple à faire?

Bien à vous,
B

#2 Le 06/06/2009, à 15:43

pierre-antoine

Re : Pb son depuis une mise à jour

Salut,
tu as essayer de reinstaller alsa (c'est le driver son sous linux) ?
Pour plus d'info regarde ici, tu trouvera les dernieres version : http://www.alsa-project.org/main/index.php/Main_Page

Hors ligne

#3 Le 06/06/2009, à 15:59

jmsrt

Re : Pb son depuis une mise à jour

Salut
A priori tu a redémarré sur un nouveau noyau (ta mise à jour il y a 2 jours) : Pour connaître ta version de noyau actif, lance la commande est uname -r, qui va te renvoyer par exemple un 2.6.24-24-generic.
Redémarre ton portable, juste après le BIOS le lanceur GRUB va te proposer une liste de noyaux et démarrer sur le premier après un compte à rebours de quelques secondes. Avec les flèches Haut/bas, sélectionne un noyau précédent (2.6.24-23-generic par exemple), celui ci devrait avoir les bons modules pour le son. Si GRUB ne t'affiche pas la liste des noyaux disponibles, il faut appuyer sur la touche ECHAP pendant son compte à rebours pour sélectionner un noyau précédent.
Si le compte à rebours est trop rapide au point de ne pas avoir le temps d'appuyer sur ECHAP, modifie le fichier de GRUB en lançant la commande sudo gedit /boot/grub/menu.lst. Au début du fichier cherches la section "## timeout sec" et modifie le chiffre après timeout (ici il est sur 3, remplace le par 5 ou 8, il correspond au compte à rebours en secondes)

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout        3

A titre info j'ai aussi perdu le son hier suite à l'installation  de virtualbox qui m'a fait redémarrer sur le noyau   2.6.24-24-386 au lieu du  2.6.24-24-generic

Hors ligne

#4 Le 06/06/2009, à 16:56

bakrz

Re : Pb son depuis une mise à jour

Merci pour vos réponses!

Alors pierre-antoine oui j'ai déjà réinstallé mais sans succès

jmsrt, merci je viens de le faire et ça marche mais est-ce que cela veut dire que je dois faire sytématiquement la combine pour que ça marche? comment puis-je bloquer la dernière version défectueuse?

En tout cas ça me semble presque résolu si ce n'est qu'à la prochaine mise à jour je dois me méfier d'un module.

#5 Le 06/06/2009, à 17:27

jmsrt

Re : Pb son depuis une mise à jour

Content pour toi : Il suffit de demander à GRUB de démarrer par défaut sur l'avant dernier noyau et pas le dernier. relance l'édition de son fichier de configuration sudo gedit /boot/grub/menu.lst, et tout au début cherche ceci :

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default        0

j'ai mis en en gras l'OS (ou noyau) par défaut qui est lancé, c'est le numéro 0 (on commence la numérotation par zéro)
Tout en bas du fichier, dans la section ## ## End Default Options ##, tu as la liste des OS et noyaux, qui ressemble à ceci :

title        Ubuntu 8.04.2, kernel 2.6.24-24-386
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.24-24-386 root=UUID=7010355f-6e8f-47ae-8a64-e40d8e848122 ro quiet splash
initrd        /boot/initrd.img-2.6.24-24-386
quiet

title        Ubuntu 8.04.2, kernel 2.6.24-24-386 (recovery mode)
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.24-24-386 root=UUID=7010355f-6e8f-47ae-8a64-e40d8e848122 ro single
initrd        /boot/initrd.img-2.6.24-24-386

title        Ubuntu 8.04.2, kernel 2.6.24-24-generic
root        (hd0,4)
kernel        /boot/vmlinuz-2.6.24-24-generic root=UUID=7010355f-6e8f-47ae-8a64-e40d8e848122 ro quiet splash
initrd        /boot/initrd.img-2.6.24-24-generic
quiet

J'ai mis ici les 3 premiers (donc les numéro zéro, un et deux), comme je veux démarrer à chaque fois sur le noyau kernel 2.6.24-24-generic et pas sur le "kernel 2.6.24-24-386", je remplace en haut du fichier la ligne :

default        0
par
default        2

cela devrait aussi te convenir.
Sache que si tu installes un nouveau noyau (suite à une mise à jour), GRUB va le détecter et le mettre en premier dans sa liste (et en second il mettra ce nouveau noyau mais en mode recovery), donc tu démarreras sur un noyau non voulu. il te faudra de nouveau éditer ce fichier, ou lors des mises à jour, décocher celles concernant le noyau.

Hors ligne

#6 Le 06/06/2009, à 17:57

bakrz

Re : Pb son depuis une mise à jour

Merci beaucoup jmsrt! C'est résolu et je comprends mieux le fonctionnement de ce truc maintenant! Un pas de fourmis sur le Héron mais un grand pas dans ma compréhension!!

C'est donc [Résolu]

Hors ligne

#7 Le 06/06/2009, à 18:17

jmsrt

Re : Pb son depuis une mise à jour

Re
le mieux dans ce cas est d'éditer le message original et de rajouter [résolu] au début du titre.

Hors ligne

#8 Le 06/06/2009, à 18:40

bakrz

Re : Pb son depuis une mise à jour

Ben je sais mais je n'étais pas encore inscrite en envoyant ce message et alors je n'ai pas la main sur le titre. Mais bon La j'écris en très gros.

Résolu

Dernière modification par bakrz (Le 06/06/2009, à 18:42)

Hors ligne

#9 Le 07/06/2009, à 19:34

Floyd Pepper

Re : Pb son depuis une mise à jour

Bonsoir
@jmsrt
Je ne suis pas, à proprement parlé, concerné par ce PB.
Mais ta réponse concise est un modèle du genre.
bravo et merci


Vieux papy triste et Hétérocentriste (conditionné), en attente d'être complètement con×. J'aurais tendance à ne pas utiliser de smilleys.
Le plus tu t'fais chier, le plus t'es emmerdé.

Hors ligne

Haut de page ↑