Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/10/2009, à 05:26

David74

[résolu]Problème de langue

Bonjour,
j'avais jusqu'à présent un Xubuntu intrepid qui fonctionnait très bien. Histoire de toiletter un peu, j'ai fait une manip sur les fichiers "locales", que j'ai trouvé ici : http://doc.ubuntu-fr.org/nettoyer_ubuntu.
J'ai fait la commande : sudo apt-get install localepurge.
Dès lors, certaines traductions de mon environnement graphique ont disparu, et sont revenues en anglais, alors que tout était parfaitement francisé.
J'ai tenté la manip inverse, suis revenu vérifié l'installation des différents paquets "language", mais bernic.
Je me suis dit c'est l'occasion, je vais passer à Jaunty.
Je l'ai fait, mais rien n'a changé, les mêmes éléments restent en anglais.
Quelqu'un aurait-il une tentative d'explication?

Dernière modification par David74 (Le 17/10/2009, à 00:48)

Hors ligne

#2 Le 15/10/2009, à 09:07

marc_qui

Re : [résolu]Problème de langue

salut,
lorsque tu es passé à jaunty tu as fait une réinstallation avec formatage de la racine ou tu as fait une mise à niveau du système ?
as tu tenté de déinstaller puis réinstaller les programmes concernés en français ?

Hors ligne

#3 Le 15/10/2009, à 15:01

David74

Re : [résolu]Problème de langue

Pour passer à Jaunty, j'ai fait une mise à niveau.
Pour ce qui est du reste, je ne vois pas ce que je pourrais désinstaller puis réinstaller, vu que ce qui est en anglais, ce sont des trucs du style menu du clic droit sur les panneaux, dans le terminal, gestionnaire de fichiers, certains boutons ("close", "cancel",boite de dialogue de déconnexion,...). Je vais quand même essayer avec thunar, voir si ça fonctionne.
En revance, j'ai réinstaller les paquets "language-...-fr", mais ça n'a rien changé (j'ai fait réinstaller, et non pas désinstaller puis réinstaller).

Hors ligne

#4 Le 15/10/2009, à 18:48

philo

Re : [résolu]Problème de langue

Hug!

Et si tu vas dans Applications/Système/Prise en charge linguistique ; est-ce que french est bien coché?

Hors ligne

#5 Le 15/10/2009, à 18:57

David74

Re : [résolu]Problème de langue

Oui, et il n'y a que ça de coché.

Hors ligne

#6 Le 15/10/2009, à 19:50

David74

Re : [résolu]Problème de langue

Je viens de découvrir que des plus grosses appli comme quod libet sont aussi en english!... Ca craint

Hors ligne

#7 Le 15/10/2009, à 23:18

philo

Re : [résolu]Problème de langue

Bon ..je calle...vois pas.

J'ai eu 1 problème similaire il y a longtemps suite à l'installation de localpurge.
En fait j'ai tout viré puis réinstallé via synaptique je crois ...

Dernière modification par philo (Le 15/10/2009, à 23:19)

Hors ligne

#8 Le 16/10/2009, à 00:08

David74

Re : [résolu]Problème de langue

Quand tu dis "tout viré", c'est quoi tout?

Hors ligne

#9 Le 16/10/2009, à 01:14

Wapush

Re : [résolu]Problème de langue

Salut

Par curiosité, que contient ton fichier "/etc/locale.nopurge" ?

Utilise la balise CODE pour afficher son contenu sur le forum.

Hors ligne

#10 Le 16/10/2009, à 03:03

David74

Re : [résolu]Problème de langue

Je n'ai pas de fichier "/etc/locale.nopurge"!?... C'est normal ça?

Hors ligne

#11 Le 16/10/2009, à 11:56

philo

Re : [résolu]Problème de langue

J'ai viré localepurge , désinstallé aussi toutes les locales et réinstallé seulement fr.
J'y suis allé un peu à tâton mais ça a marché.

Dernière modification par philo (Le 16/10/2009, à 12:00)

Hors ligne

#12 Le 16/10/2009, à 14:06

David74

Re : [résolu]Problème de langue

Ben oui, j'ai un peu essayé tout ça aussi, mais moi, ça n'a pas fonctionné. J'ai fait des réinstal, des suppressions complètes  puis réinstall, je n'ai plus que des "-fr", mais rien n'y fait. Le pire, c'est que ça marchait avant localepurge. C'est vraiment pas une bonne idée ce truc, si pour gagner quelques Ko, tu te retrouve à devoir devenir bilingue...
Bon, cela dit, qu'on ne s'y trompe pas, je n'en veux pas du tout à quelque développeur que se soit, avec le boulot qu'ils font, ça serait mal venu, surtout de la part de quelqu'un qui ne fait qu'utiliser... Mais je ne sais pas comment on peut leur faire remonter ça, dans l'idée de rendre service, quoi... Et peut-être de trouver une solution.
Si quelqu'un sait...

Hors ligne

#13 Le 16/10/2009, à 17:34

Wapush

Re : [résolu]Problème de langue

David74 a écrit :

Je n'ai pas de fichier "/etc/locale.nopurge"!?... C'est normal ça?

Non, ce n'est pas normal que ce fichier ne soit pas présent si localepurge est encore installé. À l'installation de localepurge, il devrait normalement te demander de le configurer en sélectionnant les "locales" à ne pas purger. C'est dans ce fichier qu'il conserve cette information. Donc, soit tu as mal configuré localepurge lors de son installation, soit il ne t'a pas demandé de le configurer à l'installation.

Tu devrais pouvoir retrouver un système "presque" francisé en désinstallant localepurge et en réinstallant les paquets language-pack-fr, language-pack-fr-base, language-pack-gnome-fr et language-pack-gnome-fr-base. Je dis bien "presque", parce qu'un des problèmes (parmi tant d'autres) avec Ubuntu, c'est le bordel dans ses traductions... Par exemple, pour ton problème avec Quod Libet toujours en anglais, ses fichiers de traduction ne sont pas fournis dans un des paquets language-pack ni même par le paquet quodlibet, mais dans le paquet exfalso, une dépendance de Quod Libet... roll

Édit :
En fait, ça semble être la traduction de tout les paquets du dépôt "universe", non supportés officiellement par Ubuntu (dont Xfce), qui ne sont pas dans les language-pack. Donc tu ne retrouveras pas ton système francisé sans réinstaller tous les paquets de l'environnement de bureau Xfce.

Dernière modification par Wapush (Le 16/10/2009, à 17:38)

Hors ligne

#14 Le 16/10/2009, à 17:43

lsam

Re : [résolu]Problème de langue

J'ai aussi installé localepurge, et j'ai pas ton soucis.
T'es sûr que tu l'as bien paramétré et qu'il ne te purge pas justement toutes tes docs françaises ?

Hors ligne

#15 Le 16/10/2009, à 23:00

David74

Re : [résolu]Problème de langue

Bon, déjà, merci pour le tuyau concernant quod libet, j'ai réinstallé exfalso, et j'ai retrouvé du français. C'est toujours ça de pris...
Sinon, j'ai bien tenté de réinstaller les paquets "language-pack-...", mais sans succès.
Wapush, quand tu dis que je devrais réinstaller tous les paquets de l'environnement bureau xfce, ect-ce que tu peux préciser. Par exemple, pour les boites de dialogues type déconnexion, c'est quel paquet?
Je n'ai pas réinstallé localepurge, parceque je l'avais déjà fait en essayant de configurer autrement (je pense que je l'ai mal fait la première fois, en ne sélectionnant que "fr", sans fr-FR, fr-...@euro, ...), mais ça n'a rien changé. Actuellement, il n'est plus installé sur mon système.

Hors ligne

#16 Le 16/10/2009, à 23:34

David74

Re : [résolu]Problème de langue

Bon, merci Wapush, j'ai drôlement bien avancé. J'ai réinstallé thunar, il est français, xfce4-panel, le menu clic droit de mes panneaux sont français, xfce4-settings, ma boite de dialogue de paramétrage est en français.
Surtout, j'ai compris le principe : il n'y a pas une manip à faire pour que tout redevienne français, mais quand je vois quelque chose en anglais, il faut que je réinstalle le paquet correspondant qui se met alors en français, puisque c'est ce que j'ai paramétré.
A première vue, comme ça, il ne me reste plus que la boite de dialogue de déconnexion qui est en anglais (je sais c'est un détail, mais en bon obsessionnel, je m'attache aux détails...); Alors dites voir est-ce que quelqu'un connaitrait-il le paquet concerné??

Hors ligne

#17 Le 17/10/2009, à 00:36

Wapush

Re : [résolu]Problème de langue

Je n'utilise plus Xubuntu, mais ces paquets devraient normalement être installés par Xubuntu :

gtk2-engines-xfce (moteur de thème Xfce)
libxfce4menu-0.1-0 (gestion du menu)
libxfce4util4
libxfcegui4-4
xfce4-appfinder
xfce4-mixer
xfce4-panel (panneau Xfce)
xfce4-places-plugin
xfce4-screenshooter
xfce4-session (c'est celui là pour le dialogue de déconnexion)
xfce4-settings (gestionnaire de configuration)
xfce4-terminal (le terminal Xfce)
xfdesktop4 (gestionnaire du bureau)
xfwm4 (gestionnaire de fenêtres)
thunar (gestionnaire de fichiers)
mousepad (éditeur de texte)
xfconf (démon de configuration)
thunar-data (contient les fichiers de traduction de thunar)
orage (calendrier Xfce)
xfce4-clipman-plugin (Gestion du presse-papier)
libexo-0.3-0
exo-utils
xfdesktop4-data (contient les fichiers de traduction de xfdesktop)
thunar-media-tags-plugin
thunar-archive-plugin
thunar-volman
thunar-thumbnailers

Dernière modification par Wapush (Le 17/10/2009, à 00:38)

Hors ligne

#18 Le 17/10/2009, à 00:47

David74

Re : [résolu]Problème de langue

Bon alors après quelques réinstallations de quelques uns de ce paquets, et un redémarrage, la dernière boite de dialogue résistate a cédé et se montre maintenant en français. Youpi, c'est gagné!...
A priori, il ne doit plus me rester quoique ce soit en anglais.
Merci Wapush, tu m'a bien aidé en me mettant sur la piste qui m'a fait pigé le truc.
A plus, je note en résolu.

Hors ligne