Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 18/10/2009, à 14:11

oowaka

[LaTeX] problème avec le package mbboard

Bonjour, dans mon document LaTeX, j'ai besoin de la lettre lambda en "double-barre" (comme le 1 de la fonction indicatrice ou les ensembles de nombre C, R, Q, (etc) en math). Or, en utilisant le package amsfonts, la commande \mathbb{\lambda} ne fonctionne pas. J'ai donc fait une petite recherche sur le net, et j'ai deux manières possibles de le faire :
   - la première, pas très belle, est de charger le package mathbbold avec l'option bbgreekl
   - la deuxième, plus jolie, est de charger le package mbboard.
J'ai donc mis, dans un premier temps, dans le dossier /usr/local/share/texmf/tex/latex/ les fichiers suivants :
  - mbboard.sty
  - mbboard.dcl
  - mbboard.tex
Voyant que cela ne fonctionnait toujours pas (même après le sudo texhash), j'ai trouvé une archive mbboard.zip que j'ai dézipper dans ce même dossier. Mais le document ne veut toujours pas se compiler !

Pouvez-vous me dire comment installer correctement ce package ?

Pour info, j'ai texlive-full et texmaker.
Je peux vous montrer, si vous le souhaitez, le message d'erreur que me renvoie texmaker, mais, je vous préviens, il est assez long... hmm

Merci d'avance pour votre aide !

Hors ligne

#2 Le 18/10/2009, à 15:11

ludovic889

Re : [LaTeX] problème avec le package mbboard

salut

tu ne nous as pas dit ton problème : est-ce que latex se plaint de ne pas trouver ton package ou alors est-ce que tu n'arrives pas à produire ton drôle de symbole ?


Ce n'est pas grave de ne pas avoir l'heure si on a le temps.

Hors ligne

#3 Le 18/10/2009, à 15:26

oowaka

Re : [LaTeX] problème avec le package mbboard

Latex arrive a trouvé mon package, mais l'erreur arrive avant de produire mon symbole.

Le plus simple, je pense, et de vous montrer le résultat que ça donne sur le code suivant :

\documentclass[a4paper, 10pt]{article}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[frenchb]{babel}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{bbm}
\usepackage{mbboard}

\begin{document}
$$\bblambda$$
\end{document}

Et voici le message que ça me retourne quand j'essaie de le compiler :

Process started

kpathsea: Running

mktextfm

mbb10

mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mbb10

This is METAFONT, Version 2.71828 (Web2C 7.5.6)

kpathsea: Running

mktexmf

mbb10

! I can't find file `mbb10'. <*> ...e:=ljfour; mag:=1; nonstopmode; input mbb10 Please type another input file name ! Emergency stop. <*> ...e:=ljfour; mag:=1; nonstopmode; input mbb10 Transcript written on mfput.log.

grep: mbb10.log

: Aucun fichier ou dossier de ce type

mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mbb10' failed to make mbb10.tfm.

kpathsea: Appending font creation commands to missfont.log. kpathsea: Running mktextfm mbb7

mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mbb7

This is METAFONT, Version 2.71828 (Web2C 7.5.6)

kpathsea: Running mktexmf mbb7

! I can't find file `mbb7'. <*> \mode:=ljfour; mag:=1; nonstopmode; input mbb7 Please type another input file name ! Emergency stop. <*> \mode:=ljfour; mag:=1; nonstopmode; input mbb7 Transcript written on mfput.log.

grep: mbb7.log: Aucun fichier ou dossier de ce type

mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mbb7' failed to make mbb7.tfm.

kpathsea: Running mktextfm mbb5

mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mbb5

This is METAFONT, Version 2.71828 (Web2C 7.5.6)

kpathsea: Running mktexmf mbb5

! I can't find file `mbb5'. <*> \mode:=ljfour; mag:=1; nonstopmode; input mbb5 Please type another input file name ! Emergency stop. <*> \mode:=ljfour; mag:=1; nonstopmode; input mbb5 Transcript written on mfput.log.

grep: mbb5.log

: Aucun fichier ou dossier de ce type

mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input mbb5' failed to make mbb5.tfm.

Process exited with error(s)

Désolé de ne pas avoir été très clair !

Hors ligne

#4 Le 18/10/2009, à 15:45

gigiair

Re : [LaTeX] problème avec le package mbboard

Bon, ce n'était pas vraiment une bonne idée de placer les fichiers là ou tu les as mis.
Le répertoire ~/texmf est fait pour ça. Autrement tu risques d'avoir une mauvaise surprise si les mainteneurs de texlive changent la configuration de leurs fichiers.
Il suffit de placer les fichiers décrits dans des endroits ou kpathsea pourra les trouver.

mkdir -p ~/texmf/fonts/source/public/mbboard 
mkdir -p ~/texmf/tex/generic/mbboard
mkdir -p ~/texmf/tex/latex/mbboard
cp /chemin/vers/mbboard/dézipé/source/*  ~/texmf/fonts/source/public/mbboard
cp /chemin/vers/mbboard/dézipé/texinputs/mbboard.tex ~/texmf/tex/generic/mbboard
cp /chemin/vers/mbboard/dézipé/texinputs/mbboard.dcl ~/texmf/tex/generic/mbboard
cp /chemin/vers/mbboard/dézipé/texinputs/mbboard.sty ~/texmf/tex/latex/mbboard

Et ça roule.
Tu peux vérifier en compilant le fichier

pdftex mbbtest

J'ai testé tout ce qui précède.

Le mode d'installation est décrit dans l'archive. Ce sont les utilitaires de kpathsea qui trouvent les fichiers metafont (.mf) tex ou latex. info kpathsea pour plus de détails, ou lire la doc de texlive dans /usr/share/doc/texlive-doc
la commande

texdoc live-fr

Doit aussi fournir les informations.

Dernière modification par gigiair (Le 18/10/2009, à 15:52)


--
JJR.

Hors ligne

#5 Le 18/10/2009, à 16:00

oowaka

Re : [LaTeX] problème avec le package mbboard

hmm

J'avais mis dans ce dossier en prenant exemple sur un lien que j'ai trouvé sur le net (je ne sais plus où ^^)...
Enfin, j'ai reessayé avec ta méthode, toujours la même erreur... hmm

"kpathsea", ne serait-ce pas pour KDE ? Je suis sur gnome... Peut être est-ce la raison pour laquelle ça fonctionne chez toi mais pas chez moi ? Même si, normalement, non... ^^

En tout cas, merci de vos réponses...

Hors ligne

#6 Le 18/10/2009, à 16:28

gigiair

Re : [LaTeX] problème avec le package mbboard

Ce n'est pas ma méthode qui provoque une erreur. Je l'ai testée chez moi, et j'ai même testé ton fichier.
kpathsea n'a rien à voir avec kde, si tu lis le message d'erreur qui t'es retourné tu verra qu'il est question de kpathsea (il faut les lire et essayer de les comprendre).
Que renvoie chez toi la commande

kpsewhich mbb10.mf

Le retour devrait être
/home/<ton home>/texmf/fonts/source/public/mbboard/mbb10.mf
Si ce n'est pas le cas, c'est que tu n'as pas appliqué correctement mes commandes (ou que j'ai fait une erreur de recopie) .
C'est évidemment pas /chemin/vers/.... qu'il faut recopier mais sa valeur. Si tu as téléchargé mbboard.zip dans ton $HOME, typiquement c'est ~/mbboard/

Dernière modification par gigiair (Le 18/10/2009, à 16:32)


--
JJR.

Hors ligne

#7 Le 18/10/2009, à 17:49

oowaka

Re : [LaTeX] problème avec le package mbboard

C'est bon, ça fonctionne, j'ai compris mon erreur : quand j'ai essayé ta méthode, je n'avais pas fermé un terminal où je venais de finir quelques manip en superutilisateur, et je suis resté en superutilisateur... (et oui, boulet !!! tongue)

En tout cas, merci beaucoup !!! big_smile

Hors ligne

#8 Le 18/10/2009, à 20:14

gigiair

Re : [LaTeX] problème avec le package mbboard

Ce n'est  pas ma méthode, c'est la méthode recommandée par  texlive. Il y a d'autres solutions plus ou moins bidouillées qui marchent également. C'est la garantie que les fichiers que tu aura installé ne seront jamais affectés par une mise à jour future de texlive.

Il est possible également de faire une installation personnelle sous root en
/usr/local/share/texmf en lieu et place de ~/texmf
Les fichiers seront visibles sur toute l'installation par tous les users.

Seulement, sous root, il faut mettre à jour la base de donnée de recherche par

#mktexlsr /usr/local/share/texmf

Tandis que ~/texmf ne nécessite pas cette mise à jour (on peut bien entendu faire un mktexlsr ~texmf, ça doit accélerer l'accès aux fichiers personnels, mais je n'ai jamais vu de différence notable).

Dernière modification par gigiair (Le 18/10/2009, à 20:17)


--
JJR.

Hors ligne

#9 Le 19/10/2009, à 07:59

gigiair

Re : [LaTeX] problème avec le package mbboard

On peut fignoler l'installation. L'archive contient un document mbbtest.tex qui  peut se compiler avec pdftex (pas pdflatex). Le résultat est un document qui contient tous les caractères que l'on peut obtenir avec mbboard (pas vérifié !).
Tu peux le copier dans un répertoire adéquate et le rendre visible par la commande texdoc (si tu n'as pas une version très récente de texdoc, il faudra peut-être le renommer mbboard.pdf).

$mkdir -p ~/texmf/doc/mbboard
$cp /chemin/vers/archive/texinputs/mbbtest.pdf ~/texmf/doc/mbboard/        (év. mbboard.pdf)

Et voilà, quand tu lances la commande

texdoc mbboard

C'est le document mbbtest qui s'affiche dans un visualisateur pdf

Dernière modification par gigiair (Le 19/10/2009, à 08:53)


--
JJR.

Hors ligne

Haut de page ↑