Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/11/2009, à 17:05

Medunta

[Résolu] ZSNES - son qui grésille - solution

Bonjour à tous,

Une fois n'est pas coutume, j'arrive avec une solution.

Le problème: son qui grésille / craque, plus particulièrement sur certains jeux.

Après avoir écumé Internet, il semble que ce problème puisse être lié au fait que ma carte son est intégrée à la carte mère.

La solution qui a fonctionné chez moi:

Dans la console, taper gedit ~/.zsnes/zsnesl.cfg pour éditer le fichier de configuration de ZSNES.
À l'entrée libAoDriver, remplacer "auto" (ou ce qui s'y trouvait) par "ass" (qui est le pilote Alsa - s'il est installé. Sinon, installer les paquets correspondants).

Normalement, il n'y a pas d'autre réglage à faire. Le taux d'échantillonnage est réglé à 44100 Hz sous ZSNES. Par exemple, sous Super Metroid qui était une catastrophe sonore, il n'y a presque plus aucun défaut: juste quelques micro-coupures très rares et pas gênantes du tout.

Voilà, en espérant que ça puisse en aider certains!

Merci de dire si ça vous a dépannés!

PS: je précise que ça marche sous Karmic Koala et que le problème existait déjà sous Jaunty Jackalope.

Edit: Si, ça grésille encore, il y a toujours moyen de passer en mode fenêtré puis remettre en plein écran. Bizarrement, ça semble marcher, mais je ne sais pas ce que ça change (des idées, quelqu'un?)

Dernière modification par Medunta (Le 01/11/2009, à 17:15)

Hors ligne

#2 Le 12/11/2009, à 11:10

superlag

Re : [Résolu] ZSNES - son qui grésille - solution

Salut

Je cherchai justement une solution (j'ai le même problème). Je peux donc ajouter qu'il faut tout d'abord faire

zsnes --help

, ce qui va donner la liste et le code des pilotes audio disponible (plus d'autres informations).


Dans mon cas par exemple :

Usage : zsnes [-d,-f #, ... ] <filename.sfc>
   Eg : zsnes -s -r 2 game.sfc

  -1 #/-2 #   Select Player 1/2 Input :
                0 = None       1 = Keyboard/Gamepad
  -ad <>  Select Audio Driver :
                  auto = Automatically select output
                  null = Null output
                   nas = NAS output
                   oss = OSS audio driver output
                  alsa = Advanced Linux Sound Architecture (ALSA) output
                   esd = ESounD output
                 pulse = PulseAudio Output
                   sdl = Simple DirectMedia Layer output

  -dd     Disable sound SPC700/DSP emulation which also disables sound output
  -ds     Disable sound output
  -dh     Disable ROM-specific hacks
  -f #    Enable fixed frame rate [0..9]
  -g #    Specify gamma correction value [0..15]
  -h      Force HiROM
  -j      Disable mouse (Automatically turns off right mouse click)
  -js #   Set joystick sensitivity [0..32767]
  ../..

Il suffit ensuite comme tu le dis d'entrer

gedit ~/.zsnes/zsnesl.cfg

pour forcer tel ou tel pilote audio. Dans ce cas aucun driver en particulier, il faut les tester les un après les autres pour trouver le meilleur.
Merci pour la piste smile

ps: c'est oss tongue

Dernière modification par superlag (Le 12/11/2009, à 11:12)

Hors ligne

#3 Le 15/11/2009, à 19:32

projy

Re : [Résolu] ZSNES - son qui grésille - solution

Salut!
J'ai un peu le meme souci, grésillement des musique que ce soit avec totem ou vlc, j'ai essayer de regler un peu les préferences son en enlevent déja la carte mere et en mettant juste ma SB audigy en choisissant 5.1 output mais ca grésille toujours . En tout cas j'aurais pas besoin d'enlever le ";" car le 5.1 marche déja ^^

gedit znes renvoie a rien chez moi

Ps j'ai garder mon home de la 9.04....

Dernière modification par projy (Le 15/11/2009, à 19:33)

Hors ligne

#4 Le 15/11/2009, à 19:43

projy

Re : [Résolu] ZSNES - son qui grésille - solution

C bon j'ai trouver  dans sortie fallait mettre caisson de basse a fond il etait au mini....:(

Hors ligne