Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 21/04/2005, à 16:13

laurent

[résolu]je veux utiliser mon mpio dmk (lecteur mp3)

Bonjour,

voici mon prob:

J'ai un mpio DMK 128mb, seulement, cette gentille chose fonctionne avec un programme dédié sous l'os de mon ami bill que j'aime. (ancien lecteur mp3 de ma copine, elle aussi sous ubuntu maintenant, mais bon...)

Il existe un projet qui me tient fort à coeur:

http://mpio.sourceforge.net/

Pour faire bref, ces gens développe un moyen d'utiliser mon lecteur mp3.

Je retrousse mes manches et je m'y met.

Pour commencer, je télécharge la version 0.70.

./configure  = ok après installation de 2-3 biblios
make = foireux à mort.

un tour sur leurs archives mails m'indique que c'est déjà arrivé à une autre personne. On lui a conseillé la version instable: 0.7.1, qui utilise libusb.

N'étant pas d'humeur contraire, je recommence.

et là, (zinquiétez pas, on arrive là ou vous pouvez m'aider)

./configure:

*** You need at least version 0.1.7 of the libusb library for USB support
*** http://sourceforge.net/projects/libusb/
*** If you cannot find the appropriate version, try CVS

Bon bon. La version d'ubuntu est:

libusb 0.1-4 (il me semble, parce que le 1:0.1.8-17ubuntu2 m'intrigue...)

Bref, soit:

- la version d'ubuntu est bien inférieure à 0.1.7 (et là ça me broute parce qu'ils sont déjà en 0.1.10 sur le site de sourceforge et qu'ubuntu est censée être une distib quand meme pas mal à jour)
- la version d'ubuntu est supérieure et je comprends pas.

Dans le premier cas, je me suis dit: allons sur la page du projet libusb (voir msg d'erreur).

Mais bon, vu le nombre de dépendance de ce machin, j'ai pas vraiment envie de tout désinstaller...

Quelqu'un pourrait m'aider? puis-je compiler libusb sans trop de prob (sans virer tout ubuntu ou presque;))? ou alors est-ce le ./configure qui se plante? ou encore mieux, quelqu'un connait un dépot ou je peux trouver mpio?

Merci de vos idées et conseils wink

Dernière modification par laurent (Le 21/04/2005, à 16:26)


Laurent, petit belge explorant la banquise

Hors ligne

#2 Le 21/04/2005, à 16:25

laurent

Re : [résolu]je veux utiliser mon mpio dmk (lecteur mp3)

réinstallation de libusb et ça fonctionne (enfin, la compilation a marché, pour le reste, on verra...)

Ok, la prochaine fois je me tais...


Laurent, petit belge explorant la banquise

Hors ligne

#3 Le 21/04/2005, à 17:04

laurent

Re : [résolu]je veux utiliser mon mpio dmk (lecteur mp3)

Bon, après 1000 autres problèmes dont je vous passerai l'explication, j'ai trouvé les dépots pour ceux que ça intéresse:

deb http://www.le-seb.org/unofficial-debs/ ./
deb-src http://www.le-seb.org/unofficial-debs/ ./

Haaaaa ça va tout de suite mieux smile smile

attention une fois tout installé, et lors de l'utilisation de kmpio (pour ceux que ça intéresse) (surement parce que l'interface est pourrie sinon):

il faut synchroniser 1X avant d'uploader / downloader des fichiers...


Laurent, petit belge explorant la banquise

Hors ligne

#4 Le 21/04/2005, à 17:18

laurent

Re : [résolu]je veux utiliser mon mpio dmk (lecteur mp3)

marche po

bon, je vais en parler aux dev....

en tout cas, leur prog est pas top au point...


Laurent, petit belge explorant la banquise

Hors ligne

Haut de page ↑