Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 11/11/2009, à 18:51

Laonics

Problème Google Earth 5.0

Après avoir installé les paquets Google Earth de Medibuntu et directe avec le fichier en .bin téléchargé depuis google, quand je lance G-E il ne démarre pas (juste la page avec marqué en gros Google Earth dessus). En console j'ai obtenu cette erreur, qu'il semble être différent de que ce trouve dans la doc :

/usr/lib/gio/modules/libgiogconf.so: mauvaise classe ELF: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgvfsdbus.so: mauvaise classe ELF: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: mauvaise classe ELF: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/shaman/.googleearth/crashlogs/crashlog-4afae567.txt

Please include this file if you submit a bug report will to Google.

J'ai cru lire que c'était sans doute un problème lié au fait que je sois en 64 bits. En tout cas j'ai installé (je pense avoir installé tous les paquets qu'il faut : ia32-libs, linux32, ia32-libs-gtk, et lib32nss-mdns).

Je suis sous la 9.10, ma carte graphique une : ATI Technologies Inc RV770 [Radeon HD 4870]. Je précise bien sur que G-E fonctionnait chez moi sous Jaunty en 32 bits.
Merci pour votre aide.

Dernière modification par Laonics (Le 11/11/2009, à 18:52)

Hors ligne

#2 Le 22/12/2009, à 15:38

chat2gouttieres

Re : Problème Google Earth 5.0

Je dis ça comme ça, mais ça vient pas du fait que tu ais installé les tous les paquets qu'il faut, mais en 32 bits ? C'est ce que semble dire le nom des paquets en tout cas. Après, peut-être ce que je dis est une grosse bêtise aussi.


Il y a 3 grands mensonges en informatique : ça fonctionne, c'est compatible, ça sort bientôt :p

Hors ligne

#3 Le 22/12/2009, à 19:38

Laonics

Re : Problème Google Earth 5.0

Bah d'après la doc, on peut installer google Earth sur 64bits en installer entre autre lib32nss-mdns. De toute façon, google Earth depuis quelque temps arrive à se lancer ! Je ne sais pas pourquoi... Je n'ai rien d'installé d'autre en tout cas pour que ça fonctionne. Comme j'ouvre une console j'ai juste maintenant que ces erreurs :

/usr/lib/gio/modules/libgiogconf.so: mauvaise classe ELF: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgvfsdbus.so: mauvaise classe ELF: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: mauvaise classe ELF: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so

Mais il se lance sans problème et fonctionne impeccablement. Donc je ne comprends pas ce qui c'est passé...

Hors ligne

#4 Le 11/03/2010, à 11:54

Lifesaver

Re : Problème Google Earth 5.0

Bon je poste ici car le message est plus récent que celui-ci : http://forum.ubuntu-fr.org/viewtopic.php?id=291304&p=3
Donc, je résume :
L'installation en mode root via le bin transformé en deb ne fonctionne pas, j'ai une erreur au lancement de google-earth :
$ googleearth
/usr/lib/googleearth/googleearth-bin: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory
J'ai tenté, en suivant divers conseils, de renommer des librairies, à ne pas faire, ça m'a foutu en l'air mes connections réseau. Je suis donc revenu en arrière...
J'ai tenté l'installation via les dépôts Medibuntu, sans succès :


Re: [périmer]google-earth 5.0

Via Medibuntu, pas plus de succès... sad

$ sudo apt-get install googleearth
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fakeroot python-urwid g++-4.4 g++ build-essential dpkg-dev patch
  libstdc++6-4.4-dev
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  googleearth-data
Les NOUVEAUX paquets suivants seront installés :
  googleearth googleearth-data
0 mis à jour, 2 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 21,8Mo dans les archives.
Après cette opération, 68,4Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Err http://fr.packages.medibuntu.org karmic/non-free googleearth-data 5.1.3509.4636-0medibuntu1
  503  Service Unavailable
Err http://fr.packages.medibuntu.org karmic/non-free googleearth 5.1.3509.4636-0medibuntu1
  503  Service Unavailable
Impossible de récupérer http://fr.packages.medibuntu.org/pool/n … u1_all.deb  503  Service Unavailable
Impossible de récupérer http://fr.packages.medibuntu.org/pool/n … _amd64.deb  503  Service Unavailable
E: Impossible de récupérer quelques archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?


Que faire ??? Installer en root via le bin transformé en deb et attendre qu'une mise à jour éventuelle de Ubuntu débloque la situation comme pour Laonics, ou y-a-t-il une autre solution aujourd'hui ?


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#5 Le 25/03/2010, à 19:29

brakbabord

Re : Problème Google Earth 5.0

Pour ta deuxième erreur, c'est visiblement un problème de dépots.
Essaie un apt-get update (pour resynchroniser) ou recommence plus tard.

Perso j'ai toujours fait l'installation avec le paquet .bin fournit chez Google. Il faut installer aussi les ia32-libs et lib32nss-mdns.

Hors ligne

Haut de page ↑