Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 22/04/2005, à 09:12

gcxd

Problème son sur Hoary avec jeux

Bien le bonjour à tous !!!

Voila, je me suis mis pour la première fois à Linux la semaine dernière et j'ai choisi la Ubuntu Hoary 5.04 pour commencer (kernel 2.6.10-5-386).

J'ai découvert chaque jour quelques nouveaux trucs... Mais je bloque sur le fonctionnement de Quake 3 qui a quelques problèmes visiblement avec Alsa Oss et Esd. J m'explique.

Le son marche très bien avec Gnome etc. Mais quand je lance Quake 3 (ca pourrait être un autre jeu, ou une autre appli, pour ca que je poste ici), le jeu se bloque à la phase "sound initialization". Problème qui se resout tres vite si je lance un 'killall esd' juste avant.

Le problème ? ben après, le son ne marche plus dans aucune application, sauf dans les jeu lol. Alors si vous avez une idée, plz help, je voudrais que le jeu se lance sans faire de 'killall esd' et que le son marche encore apres; c'est peut-etre possible de faire un script qui fait un 'killall esd, lance q3 et relance le son a la fin du jeu...

Sinon le chose suivante pourrait etre utile; quand je lance 'lsof /dev/dsp', rien ne s'affiche, mais avec lsof '/dev/snd/*' voila ce qui s'affiche :

gcxd@ubuntu:~$ sudo lsof /dev/snd/*
Password:
COMMAND    PID USER   FD   TYPE DEVICE SIZE NODE NAME
mixer_app 8827 gcxd   35u   CHR  116,0      7777 /dev/snd/controlC0

C'est grave docteur ? C'est quoi cette application ? Ou ce matos ? Ou trouver ce qui correspond à ces données ? Pour information j'ai modifié esd.conf pour qu'il s'éteigne quand on a pas besoin de lui.

Mon matos : Athlon XP 3200+, 1Go Samsung CH5, Asus A7N8X Deluxe, Geforce FX 5200 et frigo Whirlpool.

D'avance merci, et si c'est pas l'endroit idéal pour ce post, merci de me dire ou reposter !

#2 Le 22/04/2005, à 10:05

Manu0086

Re : Problème son sur Hoary avec jeux

Bonjour,

J'ai exactement le même problème. J'ai la même carete mère.

Sauf qu'au lieu de faire un killall esd, je vais tout simplement dans Système > Préférences > Son et je désactive le serveur de son pour avoir du son dans les jeux. Mais alors, je n'en ai plus sous Ubuntu.

Je le réactive pour l'avoir de nouveau ensuite...

Un autre problème est que le son est de très mauvaise qualité quand je veux écouter de la musique ou même regarder une vidéo.

Dons si qq1 avait une solution, je suis également preneur.

#3 Le 22/04/2005, à 11:34

Yann

Re : Problème son sur Hoary avec jeux

J'ai une A7V8X-X , et depuis que je suis passé sous hoary j'ai un son lamentable avec skype. Désactiver le serveur de son résoud ce problème, merci beaucoup Manu. Mais j'ai plus de son avec les autres programmes smile


Et pourtant moi, jsuis pas du genre délicat,
Dans un coin de la musse, j'ai posé mon matelas
- Paulo Anarkao

Hors ligne

#4 Le 22/04/2005, à 12:37

dawar

Re : Problème son sur Hoary avec jeux

Pour le son, il y'a l'excellent topic de ploum : http://forum.ubuntu-fr.org/viewtopic.php?id=2969

Utiliser dmix et alsa est a mon avis une assez bonne solution, voir dans le topic de ploum. Perso ca fonctionne bien, sauf qu'alsa se vaute parfois (très rare tout de même) et je n'ai plus de son, un sudo /etc/init.d/alsa restart permtant de régler cela (ca ne m'est arrivé qu'une fois)


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#5 Le 22/04/2005, à 13:40

Manu0086

Re : Problème son sur Hoary avec jeux

Merci beaucouuuuuuuuuup !!

Cela a rêglé mon problème et le son est maintenant parfait big_smile

Je peux enfin écouter mes mp3 !!

#6 Le 22/04/2005, à 15:33

gnucoder

Re : Problème son sur Hoary avec jeux

Le howto de ploom fonctionne sauf que la qualité du son sous xmms avec la sortie ESD est trés movaise, quand je choisis la sortie OSS le son est parfait mais plus de multiplexage... j'ai ESD dans le sélécteur multimedia ?????


Because code matters more than commercials
http://blog.syscraft.net

Hors ligne

#7 Le 23/04/2005, à 13:36

gcxd

Re : Problème son sur Hoary avec jeux

Chez moi pareil, la methode de Ploum a marche sans probleme, merci infiniment. Je recommande donc cette methode aux utilisateurs de carte-mere Asus A7N8X et derives ! big_smile

Haut de page ↑