Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 16/04/2006, à 19:20

célineange

Installer lyx avec qt4

Bonjour,

J'utilise lyx et une dernière version de celui ci est sortie stable récemment utilisant qt4.


J'ai installé qt4 par synaptic (la totale y compris la doc pour le développement car j'ai envie d'essayer).

J'ai d'abord utilisé lyx avec qt3. Pour cela, il a fallu compiler avec un ./configure --with-frontend=qt --with qt-dir="nom_du_rep_racine_de_qt3"

Ca a marché pour qt3.

Mais j'aimerais le tester sous qt4 (vu qu'il parait qu'il y a des fonctionnalités supplémentaires).

J'ai essayé les mêmes commandes, mais pb:

A la compilation, il ne trouve jamais ma librairie qt.

Ma question est:

Comment savoir quel est le nom du répertoire à indiquer pour qt4 ?

Merci smile

#2 Le 22/04/2006, à 21:56

rubens

Re : Installer lyx avec qt4

Il s'agit de la version 1.4.0 ?

Est-ce que ceci ne suffit pas à ton bonheur ?
ftp://ftp.lyx.org/pub/lyx/bin/1.4.0/ubuntu/

Perso, je l'ai installé grâce à ces *.deb et ça fonctionne très bien.

Cordialement,
Rubens

Hors ligne

#3 Le 22/04/2006, à 22:00

rubens

Re : Installer lyx avec qt4

Et il y même la dernière 1.4.1 qui corrige quelques bugs critiques ici :
ftp://ftp.lyx.org/pub/lyx/bin/1.4.1/ubuntu/
que je vais installer maintenant...

Hors ligne

#4 Le 22/04/2006, à 22:15

rubens

Re : Installer lyx avec qt4

Pour moi, c'est OK avec la 1.4.1: il faut juste désinstaller la version précédente avant d'installer la nouvelle : cf. README.Ubuntu1.4.1.

Hors ligne

#5 Le 08/06/2006, à 17:53

Sebos

Re : Installer lyx avec qt4

Bonjour Rubens,

j'ai lu vos derniers messages et je veux exactement fairela meme chose: càs upgrader la version 1.3.3 de LyX en 1.4.1...
Seul problème, je suis absolument nul en LaTeX et LyX, du coup, je nsais absolument pas comment faire pour faire l'upgrade?
J'ai téléchargé le répertoire Ubundu du lien ftp donné dans tes précédents messages mais une fois le fichier Readme ouvert, je suis bloqué car je ne sais pas comment compiler?
Et oui... roll désolé, d'etre un petit nouveau...;)
Cordialement,

Sébastien

#6 Le 11/06/2006, à 19:40

mouvf

Re : Installer lyx avec qt4

'soir,

En restant dans la même lignée... g installer lyx1.3.7 via synaptique => pas de blem.

Maintenant je voudrais installer lyx 1.4.1 ; je vais bien sur le liens de rubens, je vois tout les fichiers et les télécharges... je lis le readme (jsuis nul en anglais mais un pote me traduit.... =>

1. désintaller lyx, lyx-common,lyx-qt et lyx-xforms ... tout cela via synaptique... je suppose.

2. ensuite installer libforms1 ... tjs via synaptique... je suppose.

3. avoir telecharge les 5 fichiers sur le repertoire : .../desktop (par ex.) => lien de rubens... tjs d'accord ?

4. taper la cde : sudo dpkg -i etc...  et cela devrait fonctionner !!!

... bon... qd je fais cette manip... le pc rale un peu :

- la désintallation ne me semble pas si simple... on dirait qu'il laisse qué chose qd même.
- la lib qui manque ps de blem.
- par contre qd je fais le : sudo dpkg etc... on dirait qu'ilme manque 4 à 5 lib....

vous pouvez m'aider ?

Ubuntu depuis 31 h. big_smile

Hors ligne

#7 Le 20/06/2006, à 16:23

Minet

Re : Installer lyx avec qt4

rubens a écrit :

Pour moi, c'est OK avec la 1.4.1: il faut juste désinstaller la version précédente avant d'installer la nouvelle : cf. README.Ubuntu1.4.1.

Mais, je ne parviens pas à installer la version 1.4.1 (ni la 1.4.0 d'ailleurs) sous Dapper
vous y arrivez vous?

Hors ligne

#8 Le 01/07/2006, à 23:20

mouvf

Re : Installer lyx avec qt4

'jour,

idem pour moi... pas de possibilité pour le 1.4 et encore moins la 1.4.1...

Tidju !!! ;-)

Hors ligne

#9 Le 04/07/2006, à 09:03

Minet

Re : Installer lyx avec qt4

mouvf a écrit :

'jour,

idem pour moi... pas de possibilité pour le 1.4 et encore moins la 1.4.1...

Tidju !!! ;-)

par contre j'y arrivai super bien sous breezy mordji

Hors ligne

#10 Le 23/07/2006, à 15:09

Minet

Re : Installer lyx avec qt4

par contre, si on installe Dapper par la mise à jour de Breezy la version 1.4.1 installée sous Breezy reste opérationnelle
Youpi. lol

Hors ligne

#11 Le 29/07/2006, à 08:23

Béryl

Re : Installer lyx avec qt4

Pour Qt4, je n'ai pas essayé, mais las d'attendre un paquet lyx1.4 pour Dapper je l'ai compilé.
Aucun problème ! J'ai même la dernière version (1.4.2).
Le seul bug est inhérent à Lyx : pas de gestion de l'UTF-8. Le dictionnaire français ne fonctionne pas.
Il suffit de rajouter un petit script du genre :

#!/bin/sh

LANG=fr_FR
lyx -geometry 1300x768
exit 0

Par contre, l'interface passe en anglais. Mais le dictionnaire français fonctionne.

Hors ligne

Haut de page ↑