Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 30/01/2010, à 13:18

BrunoL

[Résolu] root n'a pas la permission de copier !

Je copie un répertoire d'un disque sur un autre.

root@laptop:/home#cp -r moi/.gvfs /media/SaveMoi/Save_2010_01_29/

Tout se passe bien jusqu'à : cp: ne peut évaluer `moi/.gvfs': Permission non accordée

Le fichier en question est :
dr-x------  2 moi moi       0 2010-01-30 12:05 .gvfs

Nautilus et Gnome-commander se plantent également avec un message type "erreur interne" ...

Jusqu'à la dernière sauvegarde (5 jours) tout fonctionnait bien !

Voyez-vous le pb ?

Merci.

Dernière modification par BrunoL (Le 30/01/2010, à 17:17)

Hors ligne

#2 Le 30/01/2010, à 13:24

Qid

Re : [Résolu] root n'a pas la permission de copier !

en meme temp pourquoi tu recopie ce truc ?
il est en cours d'utilisation d'ou le fait que tu puisse pas le copier !
mais sais tu seulement à quoi il sert !?


"GNU/Linux c'est que du bon mais M$ Windows c'est pas si mal"
1 Portable Gigabyte P35G avec un multiboot de 9 os : pour moi : W$ & UBUNTU
et pour le GUL dont je suis le dépanneur de référence : en LTS : Ubuntu-gnome & KLXUbuntu + mint mate & cinnamon
1 Tablette ASUS rootée : Android 4.4.2 | doc.ubuntu-fr/Qid

En ligne

#3 Le 30/01/2010, à 13:27

BrunoL

Re : [Résolu] root n'a pas la permission de copier !

Je veux juste faire une sauvegarde du home.

J'ignore totalement ce que peux faire gvfs mais cela bloque mes save ...
Le pire est qu'effectivement comme il est utilisé, impossible de modifier les propriété.

Put... pourquoi ça marchait avant ? j'ai fait pas mal de truc (passé sur un ssd) mais là je vois pas le rapport ...

Hors ligne

#4 Le 30/01/2010, à 13:32

Qid

Re : [Résolu] root n'a pas la permission de copier !

BrunoL a écrit :

Je veux juste faire une sauvegarde du home.

si c'est faire une sauvegarde pour faire une sauvegarde franchement c'est innutil
ça sert a rien de garder des truc qui ne servent pas !
essaye un peu de capter ce qu'il se passe dans ton home
plutot que de recopier betement ... d'ailleur en passant
non il n'a jamasi été possible de recopier des fichiers qui sont en ours d'utilisation :
ce que ut dis n'a jamais pu marcher


"GNU/Linux c'est que du bon mais M$ Windows c'est pas si mal"
1 Portable Gigabyte P35G avec un multiboot de 9 os : pour moi : W$ & UBUNTU
et pour le GUL dont je suis le dépanneur de référence : en LTS : Ubuntu-gnome & KLXUbuntu + mint mate & cinnamon
1 Tablette ASUS rootée : Android 4.4.2 | doc.ubuntu-fr/Qid

En ligne

#5 Le 30/01/2010, à 13:40

snapshot

Re : [Résolu] root n'a pas la permission de copier !

Qid a écrit :

non il n'a jamasi été possible de recopier des fichiers qui sont en ours d'utilisation

C'est uniquement vrai sous windows. Sous Linux, non seulement on peut ouvrir des fichiers en cours d'utilisation, mais en plus, on peut les effacer ! C'est la raison pour laquelle linux n'a pas besoin de rebooter à chaque mise à jour. Les fichiers systèmes sont remplacés alors qu'ils sont ouverts. Ça ne plante pas car les applications qui les utilisent continue d'accéder aux anciennes données qui ne seront détruites qu'à la fermeture du dernier fichier les référençant.

gvfs est le Gnome Volume File System. Il l'utilise dès qu'on utilise « Se connecter à un serveur » du menu « Raccourcis ». Le serveurs distants sont montés dans le répertoire .gvfs avec un système spécial, sans que l'utilisateur n'ait besoin de passer par la commande mount qui demande les droits root.

Tu n'as donc vraiment pas besoin de sauvegarder ce répertoire, à moins que tu veuilles sauvegarder les disques des machines distantes... Fais une exclusion pour ce répertoire.

Dernière modification par snapshot (Le 30/01/2010, à 13:42)


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#6 Le 30/01/2010, à 13:48

Qid

Re : [Résolu] root n'a pas la permission de copier !

snapshot a écrit :
Qid a écrit :

non il n'a jamasi été possible de recopier des fichiers qui sont en ours d'utilisation

C'est uniquement vrai sous windows. Sous Linux, non seulement on peut ouvrir des fichiers en cours d'utilisation, mais en plus, on peut les effacer ! C'est la raison pour laquelle linux n'a pas besoin de rebooter à chaque mise à jour. Les fichiers systèmes sont remplacés alors qu'ils sont ouverts. Ça ne plante pas car les applications qui les utilisent continue d'accéder aux anciennes données qui ne seront détruites qu'à la fermeture du dernier fichier les référençant.

gvfs est le Gnome Volume File System. Il l'utilise dès qu'on utilise « Se connecter à un serveur » du menu « Raccourcis ». Le serveurs distants sont montés dans le répertoire .gvfs avec un système spécial, sans que l'utilisateur n'ait besoin de passer par la commande mount qui demande les droits root.

je me disais aussi ... mais bon ça depend des quelles quand meme wink

par contre merci pour cette deffinition de gvfs parce que j'avoue que je savais pas vraiment non plus à quoi il servait :
je connais de nom parce qu'il apparait dans les point de montage avec je sais plus quelle commande
mais sinon c'est tout ... d'aiileur etant un point de montage c'est surtout pour ça en faite qu'il peu pas etre sauvé


"GNU/Linux c'est que du bon mais M$ Windows c'est pas si mal"
1 Portable Gigabyte P35G avec un multiboot de 9 os : pour moi : W$ & UBUNTU
et pour le GUL dont je suis le dépanneur de référence : en LTS : Ubuntu-gnome & KLXUbuntu + mint mate & cinnamon
1 Tablette ASUS rootée : Android 4.4.2 | doc.ubuntu-fr/Qid

En ligne

#7 Le 30/01/2010, à 13:53

BrunoL

Re : [Résolu] root n'a pas la permission de copier !

Mes sauvegardes n'ont pour seule finalité que de me permettre de ne rien perdre et de pouvoir restaurer ce qui me sera nécessaire pour redémarrer dans des conditions les plus proches de celles que j'utilisais lors du dernière utilisation et sans me prendre la tête ...

Jusqu'à maintenant elles ont répondu à mon attente donc l'utilité est très relative ...
Et l'appréciation qualitative pour le moins arbitraire wink

Je note l'impossibilité que tu évoques et qui est totalement exacte (manip aisément reproductible ). Après vérification, précédemment le .gvfs était bien dans le home et pourtant mon DD externe démontre que les saves s'exécutaient mais elles ne contiennent aucun fichier caché.

Donc je pense qu'une option a dû changée lors de ma réinstallation.

Merci pour ces éléments qui m'ont permis d'avancer.

Dernière modification par BrunoL (Le 30/01/2010, à 13:55)

Hors ligne

#8 Le 30/01/2010, à 13:59

BrunoL

Re : [Résolu] root n'a pas la permission de copier !

QLD peux tu m'indiquer si je peux virer gvfs ? je ne me connecte pas à des serveurs.

Comment expliques-tu le plantage du cp si linux ne verrouille pas ?

Comme indiqué précédemment le cp évoqué peut être reproduit aisément et sans risque. Chez moi il plante ... chez toi ça marche ?

Dernière modification par BrunoL (Le 30/01/2010, à 14:00)

Hors ligne

#9 Le 30/01/2010, à 15:01

snapshot

Re : [Résolu] root n'a pas la permission de copier !

non, tu ne peux pas virer gvfs, ou du moins, la solution est ailleurs.

J'ai essayé ceci :

sudo cp -r .gvfs  /tmp

et ça plante de la même manière que toi !

Ce que contient le point de montage .gvfs est géré dynamiquement et lié à l'utilisateur à qui il appartient. Il est possible qu'une récente mise à jour ait interdit ce qui était possible avant pour combler une faille de sécurité par exemple (aller voir les fichiers d'un autre utilisateur). Ou alors, gvfs est planté et tu devrais essayer de redémarrer...

Je pense que la solution consiste à ne pas sauvegarder ce répertoire : ce sont des serveurs distants !

Exemple : Raccourcis → Se connecter à un serveur, Type=FTP public, serveur=ftp.free.fr.
Un fenêtre apparait, et aussi un nouveau répertoire dans .gvfs :

$  ls -al .gvfs
total 16
dr-x------   3 xxx xxx      0 2010-01-30 14:39 .
drwxrwx--- 179 xxx xxx 16640 2010-01-30 14:54 ..
drwx------   1 xxx xxx      0 1970-01-01 01:00 ftp sur ftp.free.fr

Si je relance le cp :
- avec sudo : toujours la même erreur de permission refusée
- sans sudo : je lance une sauvegarde du serveur FTP de free...

Dans les deux cas, ce n'est pas ce que l'on veut...


Pensez à mettre [Résolu] dans le titre une fois votre problème réglé !

Hors ligne

#10 Le 30/01/2010, à 17:16

BrunoL

Re : [Résolu] root n'a pas la permission de copier !

Bon, rsync est plus adapté aux sauvegardes que mon cp.

Un peu laborieux en ligne de commande mais un petit script aide bien.

Voila, j'ai fait un pas vers la sauvegarde intelligente. roll

Merci.

Hors ligne

#11 Le 30/01/2010, à 17:41

Elzen

Re : [Résolu] root n'a pas la permission de copier !

snapshot a écrit :

gvfs est le Gnome Volume File System. Il l'utilise dès qu'on utilise « Se connecter à un serveur » du menu « Raccourcis ». Le serveurs distants sont montés dans le répertoire .gvfs avec un système spécial, sans que l'utilisateur n'ait besoin de passer par la commande mount qui demande les droits root.

Note que quand tu accèdes à des données distantes, c'est ton compte utilisateur, qui est connecté à la machine distante, pas ton compte root. Et même si c'était le cas, le compte auquel tu te connectes sur la machine n'est certainement pas le compte root de cette machine. Passer par ton compte root à toi ne peut donc pas augmenter tes droits sur les fichiers distants, et risque même plutôt de te les diminuer.

Sinon, pour la sauvegarde de données, personnellement je démarre sur un live-cd et je fais une image de la partition sur un disque externe avec dd. C'est pas mal.


Elzen : polisson, polémiste, polymathe ! (ex-ArkSeth)
Un script pour améliorer quelques trucs du forum.
La joie de t'avoir connu surpasse la peine de t'avoir perdu…
J'ai pour qualité de ne jamais attaquer les gens. J'ai pour défaut de souvent avoir l'air de le faire.

Hors ligne

Haut de page ↑