Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 12/05/2010, à 22:34

sam7

mon multiboot & Debian Sid E17

bonjour, pour faire suite à http://forum.ubuntu-fr.org/viewtopic.php?id=387219 (installation d'un nouveau multiboot)
je vais maintenant installer Debian Sid E17.
cf.  http://forum.ubuntu-fr.org/viewtopic.php?id=262357  & http://forum.ubuntu-fr.org/viewtopic.php?id=389980
& plus particulièrement http://forum.ubuntu-fr.org/viewtopic.ph … 4#p3470704

sam7 a écrit :

toutes les infos "pratiques" sont là :
http://forum.ubuntu-fr.org/viewtopic.ph … 4#p3435494
(lors de mes tests en machine virtuelle)

1) installation de lenny, sans interface graphique, avec un CD
2) modification du sources.list en squeeze
3) migration vers squeeze
4) modif du sources.list en sid
5) migration vers sid
6) install e17

quelques extraits des liens donnés dans le fil d'origine :

Si tu veux passer en Sid, c'est la première chose à faire. Connecte-toi en root, ouvre le sources.list avec nano, et change (ou ajoute) les dépôts en unstable (il n'y a pas de dépôt unstable/updates).
Ensuite ouvre Aptitude, CTRL+T et Options > Préférences
Fais défiler les options, et décoche (avec ESPACE) 'Installer automatiquement les paquets recommandés'
Tu sors d'aptitude, puis :
aptitude update
aptitude full-upgrade

(...)

Au tout début de l'installation, tu choisis l'encodage clavier. Choisis fr-latin9

(...)

Bon, tu en es où, là, avec ton installation ? Pourquoi ne te fais-tu pas une petite partition pour tester "en vrai" ?

Pour passer de Lenny à Squeeze, et de Squeeze à Sid, c'est pareil qu'avec Ubuntu : on remplace le sources.list par celui de la nouvelle version, et on fait un aptitude full-upgrade (plusieurs fois si nécessaire).

Tu risques de garder pas mal de paquets obsolètes. C'est pas très gênant en soi ...

(...)

Rien de plus simple : ajoute les dépôts Sid à ton sources.list (c'est les mêmes que squeeze, mais avec sid ou unstable à la place ; il n'y a pas de dépôt "updates" pour Sid)
aptitude update
aptitude full-upgrade

Avant d'utiliser aptitude, désactive l'installation automatique des paquets recommandés (c'est dans les options ; il suffit de lancer aptitude, puis CTRL+T pour accéder au menu Préférences, ESPACE pour activer/désactiver, et Q pour quitter)

(...)

aptitude install sudo

(...)

Editeur de texte en console : nano
CTRL+O pour sauver, CTRL+X pour quitter

Quelques pistes pour la suite de ton aventure :
http://forum.ubuntu-fr.org/viewtopic.php?pid=669091

Ça ne sert à rien d'installer un environnement graphique si tu n'as pas de serveur graphique, ni de pilotes pour ta carte.

après avoir "commenter" mon installation, je vais donc livrer dans ce topic mes observations & modifications personnelles au fil du temps...
... à commencer par exemple par la modif du fstab ou encore la gestion du double écran, pour commencer... smile
( http://forum.ubuntu-fr.org/viewtopic.php?id=395834  &  http://forum.ubuntu-fr.org/viewtopic.ph … 3#p3466113 )

Dernière modification par sam7 (Le 21/02/2011, à 23:49)

Hors ligne

#2 Le 12/05/2010, à 23:59

sam7

Re : mon multiboot & Debian Sid E17

j'ai pourtant procédé comme l'autre jours dans ma machine virtuelle pour effectuer l'installation de lenny, puis migration en squeeze, puis migration en sid, puis installation e17 ((mais pas par le svn, tans pis) ...
... et la c'est la "mouise" ... après reboot, je n'ai ni grub2 (pourtant, il s'était bien installé), ni d'interface graphique !
... & en prime, grub1 ne reconnais pas les distributions installées sur l'ordinateur ... sauf Windows sad (nb : pas d'ext4 lors de l'install, format inconnu & non détecté)
résultat des courses, je me retrouve à vous écrire à partir d'un livecd d'ubuntu !

que dois-je faire pour retrouver l'accès à mes autres systèmes ?
comment réinstaller grub2 sur le MBR simplement ?

dois-je :
1) retenter une install (en mode "expert" cette fois) ?
ou
2) installer (à nouveau, par exemple) crunchbang statler que je sidiserais ? puis, je remplacerais xfce par e17 wink

allez, je tente le 1), on verra bien ... mais je ne vais pas y passer la nuit !

Hors ligne

#3 Le 13/05/2010, à 00:58

sam7

Re : mon multiboot & Debian Sid E17

je poste depuis debian lenny installée en mode "expert" ... avec grub2 qui ne voit pas les autres systèmes installés ...

pas d'ubuntu 10.04 ni de gnome-voyager, pas de kubuntu 10.04, pas de crunchbang statler xfce ...
seulement winxp sad
que faire ?

déjà avec un interface (gnome), c'est un peu plus "facile", mais ça n'est pas gagné...
... je crois bien que je vais m'arrêter là pour cette nuit... à suivre demain matin,
en espérant réussir à résoudre le problème de multiboot invisible
... ensuite, on verra pour sidiser lenny, puis metttre e17, puis personnaliser le fstab & gérer le dualscreen...


je suis preneur de tous conseils utiles, d'avance, merci.

Dernière modification par sam7 (Le 13/05/2010, à 01:04)

Hors ligne

#4 Le 13/05/2010, à 19:16

misaine

Re : mon multiboot & Debian Sid E17

pourquoi ne pas installer directement squeeze a jour
http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/i386/iso-cd/


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#5 Le 13/05/2010, à 20:05

Kookaburra

Re : mon multiboot & Debian Sid E17

c'est pas faux ...


Portable17p : CrunchBangLinux // EeePC : ArchLinux
Openbox Addict : http://kookadimi.deviantart.com
Mes photos : http://www.fluidr.com/photos/kookadimi/sets
Votre téléphone mobile dispose de plus de puissance que l'ensemble des ordinateurs de la NASA en 1969. La NASA a lancé un homme sur la Lune. Vous lancez un oiseau sur des cochons...

Hors ligne

#6 Le 13/05/2010, à 21:58

sam7

Re : mon multiboot & Debian Sid E17

lors de mes essais en machine virtuelle, j'ai eu droit à des plantages avec  debian-testing-i386-businesscard.iso lors de mes tentatives d'installation ... c'est vrai que l'avantage avec ceci, en mode expert, c'est de pouvoir installer directement sid ...
... mais celà vas-t'il résoudre mon soucis de grub2 qui ne reconnais pas mes autres distributions installées ? là est la question
maintenant que je suis sous lenny avec gnome comme "interface", je devrais pouvoir passer facilement à squeeze, puis à sid ... enfin théoriquement, mais celà résoudra-t'il mon soucis ?

Edit :

misaine a écrit :

dois-je tenter d'installer Burg dans lenny

non ça ne fonctionnera pas , les dépendances sont trop vieilles sur lenny

Grub2  est "aveugle"

pour lui donner des yeux installe os-prober

je vais donc tenter la manip, & passer à squeeze, puis à sid afin d'installer burg sans soucis, si os-prober ne résouds pas mon problème
cf. http://forum.ubuntu-fr.org/viewtopic.php?pid=3475692#p3475692

debian:/home/sam7# update-grub
Updating /boot/grub/grub.cfg ...
Found Debian background: moreblue-orbit-grub.png
Found linux image: /boot/vmlinuz-2.6.26-2-686
Found initrd image: /boot/initrd.img-2.6.26-2-686
Found linux image: /boot/vmlinuz-2.6.26-1-686
Found initrd image: /boot/initrd.img-2.6.26-1-686
Found Microsoft Windows XP �dition familiale on /dev/sdc1
done
debian:/home/sam7#

j'ai malheureusement peu d'espoir ... tout ceci, c'est lenny + winxp ... où sont passés les boot de mes autres systèmes ?

Dernière modification par sam7 (Le 13/05/2010, à 22:16)

Hors ligne

#7 Le 13/05/2010, à 22:23

sam7

Re : mon multiboot & Debian Sid E17

sad mince, ça ne marche pas sad
... problème à suivre ici : http://forum.ubuntu-fr.org/viewtopic.php?pid=3475744#p3475744
avec cette aide peut-être ? http://doc.ubuntu-fr.org/grub-pc?s[]=r%C3%A9installer&s[]=grub

Dernière modification par sam7 (Le 13/05/2010, à 22:52)

Hors ligne

#8 Le 13/05/2010, à 23:10

sam7

Re : mon multiboot & Debian Sid E17

au final, je crois bien que vous avez raison ... à la réflexion
http://forum.ubuntu-fr.org/viewtopic.php?pid=3475857#p3475857

reste à refaire mon install debian avec debian-testing-i386-businesscard.iso & de faire l'install en ext4 & non en ext3 comme c'est le cas actuellement

si vraiment, ça plante encore après cette tentative, et bien j'installe à nouveau crunchbang que je sidiserais & dans lequel j'ajouterais e17, puis je supprimerais xfce neutral ... ça sera quazi pareil après ... (bien sûr, je modifierais en conséquence le sources.list smile

j'ai du installer brasero pour graver le cd tongue

Dernière modification par sam7 (Le 13/05/2010, à 23:19)

Hors ligne

#9 Le 13/05/2010, à 23:25

sam7

Re : mon multiboot & Debian Sid E17

maintenant, je reboot sur le cd debian-testing-i386-businesscard.iso pour refaire une ultime tentative d'installation ... en espérant pouvoir retrouver mon multiboot perdu !

si la manip de ce soir échoue, demain j'installe à nouveau crunchbang statler  neutral

Dernière modification par sam7 (Le 13/05/2010, à 23:30)

Hors ligne

#10 Le 14/05/2010, à 01:18

sam7

Re : mon multiboot & Debian Sid E17

debian sid installé (avec environnement gnome ... ce fut long ... très long ...), mais il y a encore des soucis... sad
1) l'affichage est foireux... mais ça n'est pas le plus important
2) bien que lors de l'install Grub2 ai bien détecté tous les systèmes installés ...
3) dans le grub de démarrage, il n'y a que debian sid, & même pas Windows !
résultat des courses, je suis en train de poster en livecd ubuntu

je crois que je vais essayer la manip indiquée ici :
http://forum.ubuntu-fr.org/viewtopic.php?pid=3475744#p3475744

documentation a écrit :

Si vous n'avez plus Grub2 suite, par exemple, à l'installation d'un autre système d'exploitation, voici les étapes à suivre pour le remettre en place :

   1.      Munissez-vous d'un CD d'installation (ou clé USB d'installation) d'Ubuntu 9.10 ou ultérieure1) ;
   2.      Amorcez votre ordinateur avec ce CD-ROM ou cette clé USB en choisissant l'option, si besoin, Essayer Ubuntu sans rien changer sur votre ordinateur ;
   3.      Montez la partition qui contenait GRUB 2 auparavant. Cette partition est généralement la même qui contient tout le système Ubuntu. Dans une session d'essai d'Ubuntu, rendez-vous dans le menu Raccourcis et sélectionnez la partition à monter dans la liste des partitions existantes ;
   4.      Allez dans Système → Administration → Utilitaire de disques et notez : Notez l'identifiant de périphérique de votre disque dur
         1.            l'identifiant de périphérique de votre disque dur primaire (généralement /dev/sda),
         2.            et le nom de montage de la partition que l'on vient juste de monter (par exemple /media/disk).

   5.      Dans un terminal (Applications → Accessoires → Terminal), lancez la commande suivante en remplaçant "/media/disk" et /dev/sda par votre point de montage et le disque primaire notés précédemment :

      sudo grub-install --root-directory=/media/disk /dev/sda

   6.      Redémarrez en enlevant votre live-cd ou votre clé-usb.

... ou alors, si je peux démarrer debian en "mode sans échec" ...
... je verrais ça demain vu l'heure tardive

en cas d'échec de ces 2 possibilités, j'installe crunchbang demain !

Hors ligne

#11 Le 14/05/2010, à 06:47

misaine

Re : mon multiboot & Debian Sid E17

c'est normal au premier demarrage , fait os-prober puis update-grub2


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#12 Le 14/05/2010, à 12:46

sam7

Re : mon multiboot & Debian Sid E17

cette nuit, avant de me coucher, j'ai effectué un "update-grub" avec debian sid en "mode sans échecs" ... et j'ai retrouvé enfin un multiboot dans le grub2 ... tous mes systèmes y sont bien ...
... mais là encore, j'ai quelques soucis...

> ubuntu 10.04 : http://forum.ubuntu-fr.org/viewtopic.php?pid=3465544#p3465544 pour y mettre http://modern-os.projects.servhome.org/topic.php?id=73 le moment venu
>> démarre sans soucis

> Gnome-voyager : http://forum.ubuntu-fr.org/viewtopic.php?id=395911
>> ne veut pas démarrer autrement qu'en mode "sans échecs"/root (interface graphique possible)

> CrunchBang : http://forum.ubuntu-fr.org/viewtopic.php?id=396118
>> ne veut pas démarrer autrement qu'en mode "sans échecs"/root (interface graphique possible)

> Kubuntu : http://forum.ubuntu-fr.org/viewtopic.php?id=396164
>> démarre sans soucis

> Debian Sid
>> ne veut pas démarrer autrement qu'en mode "sans échecs"/root ("startx" donne le même résultat)
lorsque l'on démarre normalement, au lieu d'avoir le GDM, j'ai une vague image floutée & illisible ...
... & quand je saisi identifiant & mot de passe, rien ne se passe sad ... cf. 1) ici http://forum.ubuntu-fr.org/viewtopic.php?pid=3476164#p3476164

comment remédier à ces problèmes ?

dois-je donc tenter de faire os-prober puis update-grub2 ? ... à partir de debian sid ?
(je poste ici à partir de kubuntu)


je me demande s'il n'y a pas eu (peut-être) des modifs dans les UUID ? ... mais j'en doutes cf. http://forum.ubuntu-fr.org/viewtopic.php?pid=3478674#p3478674

Dernière modification par sam7 (Le 15/05/2010, à 10:11)

Hors ligne

#13 Le 14/05/2010, à 22:23

sam7

Re : mon multiboot & Debian Sid E17

comment résoudre ce problème ? je crois bien que je vais installer e17 en plus de gnome dans ma sid ... ça marchera peut-être mieux ?

Edit : j'ai enfin ouvert un topic sur le forum debian a sujet de ces problèmes...
... ici : http://forum.debian-fr.org/viewtopic.php?f=3&t=27742

Dernière modification par sam7 (Le 15/05/2010, à 00:03)

Hors ligne

#14 Le 15/05/2010, à 09:38

sam7

Re : mon multiboot & Debian Sid E17

sur le forum debian,  Clem_ufo  m'y propose de tenter un

#Xorg -configure

je vais donc voir ce que ça donne wink

Edit :

#Xorg -configure
me retourne le message suivant :
"command not found"
je ne sais plus que faire... :-?

Dernière modification par sam7 (Le 15/05/2010, à 21:23)

Hors ligne

#15 Le 16/05/2010, à 21:29

sam7

Re : mon multiboot & Debian Sid E17

j'ai peut-être une piste ici pour la solution de ce problème :
http://forum.debian-fr.org/viewtopic.php?f=8&t=13604
il faut que je regarde ça de prêt tongue

Hors ligne

#16 Le 25/05/2010, à 23:35

sam7

Re : mon multiboot & Debian Sid E17

il faudrait sans doute que je regarde ceci également : http://doc.ubuntu-fr.org/carte_graphique
& peut-être même ici également : http://doc.ubuntu-fr.org/interface_3d

Hors ligne

#17 Le 30/05/2010, à 11:37

sam7

Re : mon multiboot & Debian Sid E17

& j'espère aussi que ceci m'aidera http://forum.ubuntu-fr.org/viewtopic.php?pid=3509256#p3509256 tongue
... ainsi que ceci peut-être ?
http://nouveau.freedesktop.org/wiki/

Dernière modification par sam7 (Le 30/05/2010, à 12:09)

Hors ligne

#18 Le 04/06/2010, à 23:08

sam7

Re : mon multiboot & Debian Sid E17

il faudra que je regarde également ici à tout hazard : http://doc.ubuntu-fr.org/nvidia?s[]=installer&s[]=driver&s[]=nvidia ... par précaution d'abord sur ma debian sid ... mais entièrement en ligne de commande, faute d'avoir un interface graphique fonctionnel...

...mais aussi ceci bien sûr :
http://forum.debian-fr.org/viewtopic.php?t=1682 => http://forum.debian-fr.org/viewtopic.php?f=8&t=1682&p=279590#p279590
http://memoire-grise-liberee.fr.eu.org/nVidia/install/debian/
http://michauko.org/blog/2007/05/16/installer-les-vrais-pilotes-nvidia-sous-debian/

Dernière modification par sam7 (Le 04/06/2010, à 23:20)

Hors ligne

#19 Le 05/06/2010, à 12:09

Baspar

Re : mon multiboot & Debian Sid E17

Sinon pour les driver, tu peux aussi essayer avec envyng, il les installe automatiquement.
http://doc.ubuntu-fr.org/envyng
( Idem, lien Ubuntu, désolé)

Hors ligne

#20 Le 06/06/2010, à 14:35

sam7

Re : mon multiboot & Debian Sid E17

merci ... il va faloir que je regarde comment gere tout ça en ligne de commande sans interface graphique ... pas facile de travailler à l'aveuglette tongue

Hors ligne

#21 Le 06/06/2010, à 16:00

Baspar

Re : mon multiboot & Debian Sid E17

Avec aptitude c'est asssez facile wink
[PUB]
Sous arch, yaourt te propose une interface en ligne de commande qui te permet les recherche de paquets.. Je dis ça, je dis rien
[/PUB]

Hors ligne

#22 Le 06/06/2010, à 23:52

sam7

Re : mon multiboot & Debian Sid E17

il me faudra regarder ceci également : http://forum.debian-fr.org/viewtopic.php?f=8&t=1682&p=279965#p279965

Hors ligne

#23 Le 13/06/2010, à 12:07

sam7

Re : mon multiboot & Debian Sid E17

bon, je crois que je ne vais pas tarder à enfin me lancer sur ce problème ...
je viens d'éditer "papier" quelques unes des pages dans les liens donnés plus haut...

pour "mémo", voici ma "config graphique" :

sam7@debian:~$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT] (rev a1)
sam7@debian:~$

NB : & si ça marche pour debian, je ferais de même pour ma crunchbang afin d'avoir la 3D en plus
cf. http://forum.ubuntu-fr.org/viewtopic.php?pid=3527135#p3527135

Dernière modification par sam7 (Le 13/06/2010, à 12:10)

Hors ligne

#24 Le 13/06/2010, à 20:18

Baspar

Re : mon multiboot & Debian Sid E17

Tiens nous au courant wink

Hors ligne

#25 Le 13/06/2010, à 21:00

sam7

Re : mon multiboot & Debian Sid E17

a tout hasard, je rajoute ce fichier xorg.conf dans ma debian qui n'en avait pas ...

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "NUL M17W"
    HorizSync       31.0 - 60.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600 GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1440+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

... on verra bien, puis je tenterais quelques manips du genre :

apt-get install module-assistant nvidia-kernel-common
suivi d'un apt-get update & apt-get upgrade...
si ça ne donne rien, je tenterais un :
apt-get install nvidia-glx nvidia-kernel-source
puis
apt-get install module-assistant
m-a update
m-a prepare
m-a build nvidia-kernel-source
... enfin on verra bien... croisons les doigts

Hors ligne

Haut de page ↑