Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/07/2010, à 16:33

lovasoa

Linux et Xorg sur un vieux powermac G4

Bonjour,
Je ne viens pas vraiment pour poser une question, mais plutôt pour donner une réponse.
J'ai eu beaucoup de mal pour installer linux sur un vieux powermac g4, ou plus exactement pour configurer Xorg.
La machine est un vieux powermac PPC G4 graphite. La carte graphique est une ATI Rage 128 Pro, et l'écran (c'est principalement lui qui a posé problème) un Apple studio display 17" (M7649).
  Tout d'abord, le livecd reste avec un écran noir. Pour contourner cela, il faut passer au noyau l'option video=ofonly, ou video=aty128fb:1280x1024-24@60. La première option marchera (normalement) sur tous les mac ppc avec un openfirmware. La deuxième, comme on peut s'en douter, est spécifique aux cartes graphiques ati 128, et à un écran de1280x1024, avec 2^24 couleurs, à 60 images par seconde.
  Ensuite, ce qui m'a le plus embetêté, ça a été de démarrer X. J'ai enfin réussi, avec le xorg.conf suivant :

Section "Device"
    Identifier "Configured Video Device"
    BusID   "PCI:0:16:0"
    Driver  "r128"
    EndSection

    Section "Monitor"
        Identifier    "StudioDisplay17"
        Option "DPMS"
        HorizSync   30-80
        VertRefresh   50-100
       # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
       Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

       # 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
       Modeline "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync

       # 800x600 59.86 Hz (CVT 0.48M3) hsync: 37.35 kHz; pclk: 38.25 MHz
       Modeline "800x600_60.00" 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync

       # 640x480 59.38 Hz (CVT 0.31M3) hsync: 29.69 kHz; pclk: 23.75 MHz
       Modeline "640x480_60.00" 23.75 640 664 720 800 480 483 487 500 -hsync +vsync
EndSection

    Section "Screen"
        Identifier    "Default Screen"
        Monitor        "StudioDisplay17"
        Device        "Configured Video Device"
            DefaultDepth    24
               SubSection       "Display"
                 Depth            24
                 Modes             "1280x1024_60.00" "1024x768" "800x600" "640x480"
               EndSubSection
               SubSection        "Display"
                 Depth            16
                 Modes             "1280x1024" "1024x768""800x600" "640x480"
               EndSubSection
    SubSection "Display"
          Depth      15
          Modes      "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
    SubSection "Display"
          Depth      8
          Modes      "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
    SubSection "Display"
          Depth      4
          Modes      "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
    SubSection "Display"
          Depth      1
          Modes      "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
    EndSection

    Section "ServerLayout"
       Identifier   "Default Layout"
       Screen      "Default Screen"
    EndSection

    Section "DRI"
       Mode   0666
    EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"macintosh"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"nodeadkeys"
	Option		"XkbOptions"	"lv3:ralt_switch"
EndSection

Voilà. J'espère que comme ça, d'autres personnes galéreront moins que moi...


Pour les pauvres idiots, il y a Windows. Pour les riches Idiots, il y a mac os. Pour moi, il y a Ubuntu.

Hors ligne

#2 Le 04/07/2010, à 20:49

marc_qui

Re : Linux et Xorg sur un vieux powermac G4

salut,
il y a une rubrique trucs et astuces wink

Hors ligne

#3 Le 05/07/2010, à 09:28

nesthib

Re : Linux et Xorg sur un vieux powermac G4

tu peux aussi mettre un lien vers ce fil dans la documentation, ce sera plus utile et visible.
merci smile


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne

#4 Le 05/07/2010, à 21:47

lovasoa

Re : Linux et Xorg sur un vieux powermac G4

J'ai mis un lien depuis la doc sur ppc.


Pour les pauvres idiots, il y a Windows. Pour les riches Idiots, il y a mac os. Pour moi, il y a Ubuntu.

Hors ligne

#5 Le 02/03/2012, à 19:28

maxwello

Re : Linux et Xorg sur un vieux powermac G4

merci je crois que ça va me servir car je viens d,installer ubuntu sur un g4 avec l'ecran apple. j'ai d'ailleurs utiliser la version 10.04 alternate.
encore merci!

Hors ligne

Haut de page ↑