Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 19/07/2010, à 18:09

kurtosis

[RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Bonjour,

Je cherche à pouvoir jouer à Heroes of Might and Magic 3 (version native linux) sur Ubuntu 10.4 (Lucid).

Le jeu se lance, mais impossible d'avoir du son :

$heroes3
Couldn't open audio: Couldn't open audio device or ESD connection

car il est configuré pour utiliser ALSA/ESD : en 1999, personne ne prévoyait que Pulseaudio débarquerait un jour.

J'aimerais savoir si quelqu'un a réussi à avoir le son, et comment.
Du Googlage intensif ne donne pas grand chose...
Je vois les possibilités suivantes :

1. La doc pulseaudio sur ubuntu-fr préconise :

sudo apt-get install libsdl1.2debian-esd
export SDL_AUDIODRIVER=”esd”

pour redirigier les flux des applis qui utilisent SDL vers Pulse. Aucun effet pour moi hmm Alors je teste les autres possibilités :

2. padsp est aussi censé convertir les flux oss en flux pulseaudio. Bah mon jeu ne reconnaît quand même pas qu'il peut émettre du son hmm

3. Désinstaller Pulse et revenir à Alsa. J'ai déjà fait, à chaque mise à jour d'ubuntu il faut lutter, et skype ne fonctionne plus qu'avec Pulse désormais, donc j'aimerais éviter.

4. Désactiver temporairement Pulse, mettre à disposition une couche ESD pour permettre au jeu de l'utiliser. C'est ce que j'essaye de faire mais je ne sais pas comment. Installer le paquet esound désinstalle le paquet pulseaudio-esound-compat, ca ne me plaît pas (et ne résout pas le problème non plus).


Bref, je patine. Un autre joueur a-t-il déjà été confronté ? J'ai lu que pulse gênait aussi certains émulateurs.

Merci et bonne journée
Nicolas

Dernière modification par kurtosis (Le 19/07/2010, à 23:04)

Hors ligne

#2 Le 19/07/2010, à 20:18

Gatsu

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Salut,

T'as essayé aoss ?

Hors ligne

#3 Le 19/07/2010, à 20:49

alej

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

kurtosis a écrit :

4. Désactiver temporairement Pulse, mettre à disposition une couche ESD pour permettre au jeu de l'utiliser. C'est ce que j'essaye de faire mais je ne sais pas comment. Installer le paquet esound désinstalle le paquet pulseaudio-esound-compat, ca ne me plaît pas (et ne résout pas le problème non plus)

Y'a pasuspender pour ça. C'est d'ailleurs avec ça que RTCW fonctionne au poil chez moi.  J'ai mis ça dans /etc/rc.local...

echo 'wolfsp.x86 0 0 direct' >> /proc/asound/card0/pcm0p/oss

... mais bon, c'est pas indispensable que ce soit là, hein. Faut juste vérifier que ce soit bien pris en compte...

$ cat /proc/asound/card0/pcm0p/oss 
wolfsp.x86 0 0 direct

... et si c'est fait en ligne de commande, faut le faire comme ça...

$ sudo sh -c "echo 'wolfsp.x86 0 0 direct' >> /proc/asound/card0/pcm0p/oss"

"wolfsp.x86", c'est le nom de l'exécutable (faudrait juste transposer avec le nom de ton exécutable) et je lance le jeu comme ça...

$ pasuspender le_jeu

Ça ne coûte rien d'essayer...

Hors ligne

#4 Le 19/07/2010, à 23:03

kurtosis

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Merci, vous êtes sympa big_smile

C'est résolu grâce à alej !

J'ai tout suivi, comme je n'avais pas oss dans mon répertoire /proc/asound/card0/pcm0p, j'ai installé le paquet libsdl1.2debian-all.
Il avait été supprimé lors d'une de mes tentatives précédentes, mais je pense que Ubuntu l'a dans l'install de base.

Ensuite :

$ sudo sh -c "echo '/usr/local/games/Heroes3/heroes3 0 0 direct' >> /proc/asound/card0/pcm0p/oss"
$ cat /proc/asound/card0/pcm0p/oss
/usr/local/games/Heroes3/heroes 3 0 direct

Là j'ai un peu grogné parce qu'au lieu d'avoir 0 0 je me retrouve avec 3 0 et un nom de fichier foireux (le vrai exécutable s'appelle heroes3). Avant de bidouiller les noms de fichiers, j'ai testé de lancer heroes3 juste comme ca : ca marche même sans pasuspender (avec aussi). Donc le "3" a une cause inconnue mais pas de conséquence.

$ heroes3

big_smile:D:D:D
Je vais mettre tout ca dans un batch et profiter de ce super jeu smile
Ca me réconcilie avec Pulse !

Merci à vous deux. RESOLU ! big_smile

Dernière modification par kurtosis (Le 19/07/2010, à 23:10)

Hors ligne

#5 Le 19/07/2010, à 23:13

alej

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

kurtosis a écrit :
$ sudo sh -c "echo '/usr/local/games/Heroes3/heroes3 0 0 direct' >> /proc/asound/card0/pcm0p/oss"

Normalement, y'a pas besoin du chemin ; le nom de l'exécutable suffit...

Hors ligne

#6 Le 20/07/2010, à 11:55

kurtosis

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Addendum :
Ca ne fonctionnait plus après un redémarrage. Voilà j'ai réglé tout ca.

* Si vous n'avez pas de répertoire /proc/asound/card0/pcm0p/oss

1. vous n'avez pas /proc/asound : c'est que Alsa est mal installé/configuré
2. vous n'avez pas le oss tout au bout : il faut installer le paquet alsa-oss et ajouter dans votre /etc/modules : snd-pcm-oss et snd-mixer-oss, qui semblent donner l'accès au /oss du bout. N'installez surtout pas oss4-base.

Hors ligne

#7 Le 11/11/2010, à 23:29

lenidupingouin

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Bonjour.

Je cherche moi aussi  à avoir le son avec cet anthologie jeu !
Mais débutant que je suis, je galère et n'arrive à rien hmm

J'en suis bloqué à ça :
cat: /proc/asound/cardo/pcmop/oss: Aucun fichier ou dossier de ce type

J'ai pourtant installé les paquets alsa-oss et libsdl1.2debian-all, de même que j'ai suivi le conseil quant à "ajouter dans votre /etc/modules : snd-pcm-oss et snd-mixer-oss, qui semblent donner l'accès au /oss du bout. N'installez surtout pas oss4-base."

Bref, je rame.
Si une âme charitable et savante était de passage ... tongue

Merci d'avance smile

Hors ligne

#8 Le 14/04/2011, à 08:44

drumspirit

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Bonjour ou bonsoir, tout dépend de votre fuseau horaire lol

Je me permets de ré-ouvrir le sujet car l'aide fournie n'est pas suffisante pour régler le petit souci que je rencontre, à savoir, pas de son dans ce fantastique jeu qu'est Heroes of Might & Magic. D'ailleurs je salue bien bas l'auteur du post car en plus d'apprécier la même chose, nous portons le même prénom lol
Je détail un peu mes actions.
Après avoir installé les librairies adéquates, je rencontre une erreur retournée lors de l'utilisation de cette ligne :
sudo sh -c "echo '/usr/local/games/Heroes3/heroes3 0 0 direct' >> /proc/asound/card0/pcm0p/oss"

L'erreur est la suivante :
sh: cannot create /proc/asound/card0/pcm0p/oss: Directory nonexistent

J'ai donc édité comme suit le fichier /etc/modules  en ajoutant les lignes suivantes :
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-3 snd-pcm-oss

Difficile de se dépatouiller seul, j'ai tenté de créer "moi-même" le dit fichier oss (hein, tant qu'à faire, autant tenter le tout pour le tout roll).

La commande pasuspender mon_jeu ne m'apporte guère plus, cela retourne toujours et encore la même histoire comme cité par l'auteur du post : Couldn't open audio: Couldn't open audio device or ESD connection.

Pulseaudio -k n'arrange pas plus mon affaire, l'erreur retournée au lancement du jeu reste la même !
J'ai aussi tenté avec aoss, rien n'y fait, le bougre il s'entête à vouloir me laisser un silence des plus complets.
Qui plus est, Google me fait la tête en ce moment...
Me manque-t-il une étape ? Aurais-je omis quelque chose ?
Merci de votre support et d'avoir pris le temps de me lire.

Linuxement votre,
Drumspirit.

Hors ligne

#9 Le 15/04/2011, à 00:53

casselinux

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Je connais une solution qui à fortement bien fonctionné chez moi...

Fusiller PulseAudio! Lui déchirer les tripes! Et arracher son maudit coeur avec Synaptics et lui faire montrer juste avant qu'ils creve!!!

MWAHAHAHAHAHHAHAHAHA !!!

Euh, qui à dit "bourrin" ? Désolé, PainKiller à fait des ravages chez moi... lol


Utilisateur d'Ubuntu depuis 2008, partisan du libre mais anti-extrémiste... Bein quoi? Je n'aime pas les sectes... :paf:
Blog de Claqueur - Le blog qui donne des claques! :3

Hors ligne

#10 Le 15/04/2011, à 06:57

drumspirit

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Non je comprends que Pulse puisse rebuter certains sauf  que depuis l'étranger j'en ai besoin pour utiliser Skype correctement et garder contact avec la France. Tant pis, je suis un puriste, je joue sans son:rolleyes:

Hors ligne

#11 Le 29/10/2011, à 14:02

askrym

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Goodmorning , first off , sorry for writing english . I can't write french and google-translating does not seem a brilliant idea in my opinion.
Anyway , i have the same problem on my netbook with ubuntu 10.10 maverick i386
when i'm launching the game from the terminal it says :
"Couldn't open audio:"
--
I've already tried posting on http://ubuntuforums.org & http://forum.ubuntu-it.org and while google-ing for a solution I've found this thread; alas i cannot understand french language and i haven't clearly got what kind solution you used to make it work (provided you did make it work, it sounds to me so) , i tried google-translating the whole page but it carries out a quite confusing translation.

could you please help me out?

i thank you in advance.
bye smile

Hors ligne

#12 Le 22/02/2012, à 23:51

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Bonjour,

J'en suis au même point que lenidupingouin...
Quelqu'un aurait une idée ?

Merci smile

Hors ligne

#13 Le 23/02/2012, à 12:34

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Pour préciser un peu, je n'ai toujours pas le "oss" alors que j'ai suivi les manips qui normalement permettent de l'avoir. Je suis sous Natty.
Je n'y connais rien en son, je me débrouille à peine avec une console d'ailleurs smile Donc je ne peux vraiment pas proposer de solution ou de piste... Mais j'ai commencé à jouer hier soir, sans le son, vraiment c'est dommage !

Hors ligne

#14 Le 23/02/2012, à 20:29

abelthorne

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Une précision à tout hasard : les infos dans le premier message ne sont plus vraiment d'actualité. Théoriquement, plus besoin d'installer libsdl1.2debian-esound, la compatibilité avec ALSA est censée avoir été améliorée depuis le temps. D'ailleurs, je ne suis pas sûr que les paquets des différentes implémentations soient encore dans les dépôts.

Cela dit, si ça ne fonctionne pas "out of the box", utiliser padsp devrait fonctionner dans la plupart des cas. Après, il peut y avoir des cas particuliers...

Hors ligne

#15 Le 23/02/2012, à 21:59

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Effectivement, merci pour la précision !
Padsp ne fonctionne pas (il s'agit bien de le taper en console avant le nom de l'exécutable ? Le jeu se lance mais j'ai toujours le message d'erreur et pas de son.)

Hors ligne

#16 Le 24/02/2012, à 00:37

abelthorne

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Ouaip : padsp ./heroes3 par exemple (si tu es dans le dossier de Heroes 3 et que l'exécutable s'appelle "heroes3")
Si ce n'est pas un exécutable mais un script, il faudra peut-être modifier celui-ci (et donc analyser ce qu'il y a dedans).

Tu peux aussi essayer de tuer PulseAudio : killall pulseaudio avant de lancer ton jeu.

Hors ligne

#17 Le 24/02/2012, à 13:46

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

gnee@globulax:~$ killall pulseaudio
gnee@globulax:~$ padsp heroes3
Couldn't open audio: Couldn't open audio device or ESD connection

:'(

Hors ligne

#18 Le 24/02/2012, à 13:56

abelthorne

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Et avec export SDL_AUDIODRIVER=”esd” ou export SDL_AUDIODRIVER=”alsa” ou export SDL_AUDIODRIVER=”oss” avant de lancer le jeu (sans fermer le terminal entre, sinon le réglage de la variable est perdu) ? Sans installer de paquet en plus, bien sûr.

Accessoirement, si tu tues PulseAudio, pas besoin d'utiliser padsp.

Est-ce que tu sais quel système audio Heroes 3 utilise ? est-ce qu'il y a un fichier de config qui permet de modifier des options à ce niveau-là ?

Hors ligne

#19 Le 24/02/2012, à 14:16

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

gnee@globulax:~$ export SDL_AUDIODRIVER=”esd”
gnee@globulax:~$ heroes3
Couldn't open audio: Couldn't open audio device or ESD connection
gnee@globulax:~$ export SDL_AUDIODRIVER="alsa"
gnee@globulax:~$ heroes3
Couldn't open audio: Couldn't open audio device or ESD connection
gnee@globulax:~$ export SDL_AUDIODRIVER="oss"
gnee@globulax:~$ heroes3
Couldn't open audio: Couldn't open audio device or ESD connection

En ce qui concerne le système audio utilisé, je n'y connais rien, en parcourant Google dans tous les sens j'entends parler de OSS et d'Alsa... Comment puis-je le savoir ?
Pas de fichier de config à ma connaissance dans le dossier du jeu.

gnee@globulax:~$ ls /usr/local/games/Heroes3
data     Heroes_III_Tutorial.pdf  icon.xpm  mp3     uninstall
heroes3  icon.bmp                 maps      README

Hors ligne

#20 Le 24/02/2012, à 15:05

abelthorne

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Avant de faire les export de SDL_AUDIODRIVER, tu as bien relancé PulseAudio ?

Normalement, il devrait créer un dossier (caché) ~/.heroes3 ou un nom dans le genre, dans lequel il stocke ses paramètres, les sauvegardes, etc.

Dernière modification par abelthorne (Le 24/02/2012, à 15:06)

Hors ligne

#21 Le 24/02/2012, à 15:33

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Oui en effet, j'avais déjà regardé dans ce dossier caché mais il ne semble pas y avoir ce qu'on cherche...

gnee@globulax:~$ ls ~/.loki/heroes3
data  games  h3prefs  maps

(Le fichier "h3prefs" : je ne peux pas l'ouvrir, mais de toute façon je pense qu'il s'agit plutôt des préférences du jeu ?)

gnee@globulax:~$ pulseaudio
E: pid.c: Daemon already running.
E: main.c: Échec de pa_pid_file_create().

(J'ai supposé qu'on relançait pulseaudio en tapant "pulseaudio" dans le terminal, c'était bien ça ? Vu la réponse renvoyée je pense que oui, par contre je me demande ce qu'est ce message d'erreur)
J'ai retenté tous les "export SDL_AUDIODRIVER" sans résultat.

Hors ligne

#22 Le 24/02/2012, à 19:05

abelthorne

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

h3prefs, c'est un dossier ou un fichier ? Tu peux donner le résultat de ls -l ~/.loki/heroes3 ?

Pour PulseAudio, le message d'erreur dit apparemment qu'il est déjà lancé. Donc il a dû se relancer tout seul.

Hors ligne

#23 Le 24/02/2012, à 20:34

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

gnee@globulax:~$ ls -l ~/.loki/heroes3
total 16
drwx------ 2 gnee gnee 4096 2012-02-22 22:31 data
drwx------ 2 gnee gnee 4096 2012-02-22 23:19 games
-rw-r--r-- 1 gnee gnee  216 2012-02-22 23:02 h3prefs
drwx------ 2 gnee gnee 4096 2012-02-22 22:31 maps

h3prefs est un fichier.

Hors ligne

#24 Le 24/02/2012, à 22:07

abelthorne

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Ok. Et tu ne peux pas l'ouvrir avec un éditeur de texte ? gedit ~/.loki/heroes3/h3prefs si tu es sous Ubuntu normal (sinon, adapte la commande).

Hors ligne

#25 Le 25/02/2012, à 13:34

Gnée

Re : [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Non, il me dit "gedit n'a pas été capable de détecter le codage de caractères"...

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » [RESOLU]Avoir du son ALSA pour les vieux jeux, "malgré" pulse

Haut de page ↑