Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 30/05/2006, à 02:04

oniichan

Imprimante Lexmark x1100 Series (Z600)

Bonsoir

Je me suis aperçu que certains utilisateurs avaient eu quelques problèmes pour faire fonctionner leur imprimante Lexmark.
Ce tuto inspiré d'un HowTo vous permettra de faire fonctionner votre imprimante Lexmark (normalement) si c'est une:

Lexmark X1100, X1110, X1130, X1140, X1150, X1180, X1185
Lexmark Z25, Z55, Z513, Z515, Z600, Z605, Z615, Z705, Z715
Lexmark 5700 seulement en noir & blanc

"Mon imprimante est détectée, mais elle ne fonctionne pas..."
On va donc installer le driver Lexmark Z600 (v1.0-1 actuellement) disponible sur cette page:

http://downloads.lexmark.com/cgi-perl/d … ileID=1151

Vérifier si alien et libstdc++5 sont installés sinon dans le terminal:

sudo apt-get install alien libstdc++5

Toujours dans le terminal:

mkdir lexmark
mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark
cd lexmark

On a créer le repertoire lexmark auquel on a deplacé à l'intérieur, l'archive du driver.
Maintenant nous allons extraire l'archive:

tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

Préparation et installation du driver:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
tar -xvzf install.tar.gz
sudo alien -t z600cups-1.0-1.i386.rpm
sudo alien -t z600llpddk-2.0-1.i386.rpm
sudo tar xvzf  z600llpddk-2.0.tgz -C /
sudo tar xvzf z600cups-1.0.tgz -C /

On ne sait jamais un petit:

sudo ldconfig

Ensuite:

cd /usr/share/cups/model
sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz

Le driver est maintenant installé, il faut redémarrer CUPS,

/etc/rc2.d/S19cupsys restart

Pour savoir si le driver est correctement installé, faites:

cd /usr/lib/cups/backend
./z600

Vous devriez avoir un message ressembant à:

direct z600:/dev/usblp0 "Lexmark  Lexmark **** Series" "Lexmark Printer"

Si ce n'est pas le cas, il faudra peut-être monter l'USB :

gksudo "gedit /etc/fstab"
#ajouter la ligne suivante:
usbfs         /proc/bus/usb usbfs   devgid=14,devmode=0660 0 0
#enregistrer et quitter, puis dans le terminal:
sudo mount usbfs

Voilà maintenant, il suffit simplement d'ajouter l'imprimante (pour Gnome) dans Système > Administration > Impression. Choisir l'imprimante détectée "Lexmark  Lexmark **** Series"
Fabriquant: Lexmark
Modèle: Z600 v1.0-1
Appliquer.
Pour les utilisateurs de KDE ou de xfce, bah faut chercher ^^

Remarque: Petit souci pour les manchots en 64 bits, il semblerait que le fonctionnement de l'imprimante ne marche quand passant par un chroot 32bits.

Bonne chance ^^

Dernière modification par oniichan (Le 30/05/2006, à 02:07)

Hors ligne

#2 Le 30/05/2006, à 04:58

laurent

Re : Imprimante Lexmark x1100 Series (Z600)

Ce qui me permet de faire remonter mon topic avec, AMHA, un système plus simple wink

http://forum.ubuntu-fr.org/viewtopic.php?id=2962

copieur, va tongue

smile


Laurent, petit belge explorant la banquise

Hors ligne

#3 Le 12/06/2006, à 14:30

owai

Re : Imprimante Lexmark x1100 Series (Z600)

ca marche aussi pour les x1190 normalement smile
edit: c'est même sur, et vérifié!

pour le scanner, c'est pas encore bon, mais ca viendra avec la prochaine version de sane, j'imagine...

Dernière modification par owai (Le 15/06/2006, à 11:40)

Hors ligne

#4 Le 14/06/2006, à 17:04

madmax

Re : Imprimante Lexmark x1100 Series (Z600)

J'ai une Lexmark z705, j'ai fait comme indiqué dans la procedure, il n'y a aucun message d'erreur, j'ai pus installer l'imprimante mais elle n'imprime pas. L'icone de l'imprimante se met en pause, je fait redémarrer mais elle se remet en pause.

Est-ce que quelqu'un a une idée ?

sad

Hors ligne

#5 Le 26/06/2006, à 20:43

anik

Re : Imprimante Lexmark x1100 Series (Z600)

bonjour smile

j'ai tout suivi et j'ai plein de messages d'erreurs, ça ne marche donc pas sad

ça c'est bien passé pour:

sudo apt-get install alien libstdc++5

et

sudo mount usbfs

il m'a répondu que:

mount: selon mtab procbususb est déjà monté sur /proc/bus/usb

au début avec

mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark

ensuite, il me dit qu'il ne trouve pas ce fichier

voilà, est-il possible que ce soit parce que j'utilise la nouvelle version de ubuntu???

merci pour votre aide

Hors ligne

#6 Le 27/06/2006, à 19:15

anik

Re : Imprimante Lexmark x1100 Series (Z600)

j'ai trouvé en lui ajoutant le chemin.

merci pour les explications claires malgré tout, mais sans le chemin je n'aurais pas réussi du tout !!

comme quoi une seule ligne fait buter wink

Hors ligne

#7 Le 02/10/2006, à 17:48

kristof

Re : Imprimante Lexmark x1100 Series (Z600)

Quelqu'un a t'il la solution pour le problème de marge du modèle Z705?

merci!

Hors ligne

#8 Le 21/11/2006, à 22:50

Azema

Re : Imprimante Lexmark x1100 Series (Z600)

Bonsoir,

je viens d'installer le pilote Lexmark-Z600-lxz600cj-cups.ppd sur kubuntu 6.06 Dapper Drake pour ma Lexmark z605 et j'ai rencontre quelques differences par rapport aux explications donnees par oniichan:

oniichan a écrit :

Code:
tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
tar -xvzf install.tar.gz
sudo alien -t z600cups-1.0-1.i386.rpm
sudo alien -t z600llpddk-2.0-1.i386.rpm
sudo tar xvzf  z600llpddk-2.0.tgz -C /
sudo tar xvzf z600cups-1.0.tgz -C /

Pour ma part, j'ai place le fichier dans le repertoire /usr/share/ppd/linuxprinting.org-gs-builtin/Lexmark/ qui contient deja les pilotes Lexmark existants.

sudo tar z600llpddk-2.0.tgz -C /usr/share/ppd/linuxprinting.org-gs-builtin/Lexmark/
sudo tar z600cups-1.0.tgz -C /usr/share/ppd/linuxprinting.org-gs-builtin/Lexmark/

Ensuite, le redemarrage de cupsys

sudo /etc/rc1.d/K19cupsys restart

Puis pour ajouter l'imprimante dans KDE : K > Parametres du systeme > imprimantes > ajouter une imprimante / une classe.... Lors du choix entre l'imprimante USB ou Autres, selectionnez Autres.

Le chemin du pilote de l'imprimante doit etre : nom_imprimante:/dev/usblp0, sinon ca ne marche pas.

Pour verifier qu'elle est bien installee, vous pouvez aller dans votre navigateur prefere et taper l'adresse : http://localhost:631/printers/ et demander une page de test.

Sinon, aucuns problemes, merci a oniichan pour le petit tuto. Tres pratique. wink

#9 Le 24/11/2006, à 22:07

Panda

Re : Imprimante Lexmark x1100 Series (Z600)

Bonsoir,

J'ai fait cette installation sous Debian Etch mais quand il me reste juste à choisir le model, z600 n'apparait pas dans la liste...

Donc je clique sur "installer le pilote" et retourne chercher le fichier .ppd en question : la réponse est "le pilote z600[...] est déja installé" sad !

Je cale là ! Si quelqu'un peut m'aider...


Debian Sid // Gnome // nVidia GeForce 6200       '^_^'

http://www.panda-tatau.net

Hors ligne

#10 Le 17/12/2006, à 16:36

borkmadjai

Re : Imprimante Lexmark x1100 Series (Z600)

Panda a écrit :

Bonsoir,

J'ai fait cette installation sous Debian Etch mais quand il me reste juste à choisir le model, z600 n'apparait pas dans la liste...

Je cale là ! Si quelqu'un peut m'aider...

idem pour moi.. 0_ö

quelqu'un à une idée .?

merci a vous..


Amilo SI1520 (Intel T2300 1,66Ghz, 100Go Sata, 2x512Mo DDR2 Samsung, Wifi, Bluetooth...)
Linux Ubuntu 6.10 Edgy
Noob Linuxien (Nouveau sur linux depuis le 19/11/2006)

Hors ligne

#11 Le 27/12/2006, à 16:52

joneall

Re : Imprimante Lexmark x1100 Series (Z600)

Je viens d'installer mon imprimante Dell 720 (déguisé en Lexmark Z600,
ou vice versa) sous Edgy et ça a marché parfaitement.  Le commande ./Z600
n'a rien affiché, mais ça marche quand même. 

Tout ce qui manque est le recto verso.  Impossible?

Encore merci.

(Je ne peux pas dire que j'ai compris toutes les étapes.)

Hors ligne

#12 Le 10/01/2007, à 15:18

mathieu973

Re : Imprimante Lexmark x1100 Series (Z600)

je viens de suivre à la lettre ce tuto (vive le copier coller avec konsole) tout marche nickel. Une question : l'imprimante c'est bien mais on fait comment pour le scanner maintenant ?

#13 Le 30/01/2007, à 01:43

7un5i

Re : Imprimante Lexmark x1100 Series (Z600)

De meme, j'ai suivi le tuto à la lettre, et tout fonctionne bien, le driver est installé. Mais, quand je vais pour imprimer, la tache est lancée dans la barre de notification, mais l'imprimante n'imprime rien du tout, et la tache fini par disparaitre de la fenetre des traveaux de l'imprimante, comme si l'impression avait bel et bien été effectuée.

D'ailleurs, lorsque je vais sur http://localhost:631/printers/PhotoPrinter720 et que je demande la tache des traveaux accomplis, il s'affiche toutes les tentatives que j'ai faites, comme si elles avaient abouties.

Qqn sait de quoi il retourne ? mon imprimante est une Dell Photo printer 720

#14 Le 30/01/2007, à 12:36

7un5i

Re : Imprimante Lexmark x1100 Series (Z600)

Personne ne peut m'aider ?:(

#15 Le 31/01/2007, à 03:03

7un5i

Re : Imprimante Lexmark x1100 Series (Z600)

7un5i a écrit :

Personne ne peut m'aider ?:(

sad:(:(:(:(:(:(:(

#16 Le 19/02/2007, à 18:54

Pierre72

Re : Imprimante Lexmark x1100 Series (Z600)

Bonjour,
J'ai effectué l'installation (thx copy/cut) mais quand il me reste juste à choisir le modele, z600 n'apparaît pas dans la liste.
Une petite idée pour résoudre ce problème ?
Merci d'avance pour l'aide

#17 Le 15/04/2007, à 10:18

wagner

Re : Imprimante Lexmark x1100 Series (Z600)

Pierre72 a écrit :

Bonjour,
J'ai effectué l'installation (thx copy/cut) mais quand il me reste juste à choisir le modele, z600 n'apparaît pas dans la liste.
Une petite idée pour résoudre ce problème ?
Merci d'avance pour l'aide

Il ne faut pas que tu choisisse le modele mais plutot rechercher ton fichier tar.gz quand tu es dans le menu de choix de la marque des imprimantes en bas normallement il te demande ton fichier tar.gz.
Aprés il te suffit de donner le  nom Z600(je crois ou peut -etre nimporte quoi...° a ton imprimente et c bon.
nico

#18 Le 26/04/2007, à 21:59

yanemail.g

Re : Imprimante Lexmark x1100 Series (Z600)

big_smile
Bonjour tout le monde,

j'ai fait et refait tous les tutos sur comment utiliser ma LEXMARK Z515. Je suis en réseau avec un ordi XP sur lequel est branché la lexmark. Sous Edgy, je commence l'installation de mon imprimante, tout va bien. Je lance une page de test : L'imprimante fait un bruit de chargment de feuille, puis refait le même bruit 2secondes après. Le problème : la page n'est pas chargée, rien ne s'est imprimé.

Si je suis les tutos en ligne de code, tout se passe correctement sauf pour ./z600 qui ne retourne rien. Mais comme l'imprimante n'est pas sur le pourt usb d'ubuntu... mais sur le réseau ....


Je ne sais pas comment faire : si je change sur XP le "processeur d'impression", j'ai de temps en temps une page de code qui sort.

Si je charge direct le PPD de z600 que j'ai chargé, rien de mieux : toujours ce bruit de chargement, mais pas d'impression.


Y'aurait-il une façon simple d'y arriver ? Il ne me manque plus que ça pour virer XP de chez moi !!!



merci

Hors ligne

#19 Le 07/09/2007, à 08:49

foufoune1

Re : Imprimante Lexmark x1100 Series (Z600)

bonjour a vous tous ..j ai un gros probleme avec mon imprimente lexmark x1100 series , tout est correctement bien installee mes cartouche son bonne on a fait le teste des couleur mes le gros probleme cet quand je lui demande d imprimer tous est bon sauf que ma feuilles reste blanche sur mon ecrant tout ce marque comme si elle imprime mais quand le feuilles sorts rien n as ete imprimer qui pourrais m aider si vous plait merci a vous j attend votre aide

Hors ligne

#20 Le 28/09/2007, à 17:10

foufoune1

Re : Imprimante Lexmark x1100 Series (Z600)

up

Hors ligne

#21 Le 20/12/2007, à 18:04

vigix

Re : Imprimante Lexmark x1100 Series (Z600)

Ce topic ne marche plus du tout; liens morts + fichiers téléchargés ne correspondent plus

Hors ligne

#22 Le 02/01/2008, à 11:56

karismatik

Re : Imprimante Lexmark x1100 Series (Z600)

Un grand MERCI pour ce tuto avec lequel je viens d'installer
Ma lexmark X1190 et ca marche j'en reviens pas ..................
MerCi

wink

Hors ligne

#23 Le 13/04/2008, à 13:09

Olivier76250

Re : Imprimante Lexmark x1100 Series (Z600)

Bravo pour ce tutoriel d'une grande limpidite.
Le seul soucis que j'aie c'est que lorsque je lance un test d'impression j'obtiens le message :
Erreur du serveur CUPS
Une erreur s'est produite lors de l'operation CUPS : "client-error-document-format-not-supported"
Lorsque je vais dans options de l'imprimante, je n'ai que le format de papier "Letter" qui est le format americain et aucune autre option de format A4.
J'ai rate une marche ou quoi ?
Si quelqu'un peut me tuyauter...
Merci

#24 Le 05/01/2010, à 10:22

pedrico

Re : Imprimante Lexmark x1100 Series (Z600)

Bonjour,

En suivant les tutos, avec le driver z600, j'avais fait fonctionner une lexmark x1100 sous xubuntu 9.04, chez une personne de ma famille. En changeant son ordi, j'ai essayé à nouveau de configurer cette imprimante, pour une ubuntu 9.10, mais là plus moyen. Imprimante reconnue, z600 installé, mais à l'impression : "CUPS Server error, internal error".

Désolé de déterrer un vieux topic, mais c'est assez désarmant, et cela oblige à utiliser windows pour imprimer, d'autant plus énervant que cela eût marché.

Merci de votre aide et ...
Bonne année 2010 !

Dernière modification par pedrico (Le 05/01/2010, à 10:23)


take it easy !

Hors ligne

#25 Le 07/01/2010, à 15:46

pedrico

Re : Imprimante Lexmark x1100 Series (Z600)

Bonjour,

Aucun utilisateur de Lexmark n'a de soucis sous Karmic, vraiment ?

++


take it easy !

Hors ligne

Haut de page ↑