Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 23/09/2010, à 03:35

Guimauve

Logiciel XFLR5 - Analyse aérodynamique

Bonjour à tous,

Apparemment le programme XFLR5 est disponible pour Linux (paquet de type *.rpm).

http://xflr5.sourceforge.net/xflr5.htm

J'ai converti le paquet *.rpm en *.deb à l'aide de alien et l'installation à fonctionné. J'ai lancé le programme avec succès mais je n'ai pas eu le temps de faire une analyse d'un profil d'aile.

http://doc.ubuntu-fr.org/Alien

Il faudrait peut-être l'ajouter dans la Logithèque Ubuntu dans la section Ingénierie

A+
Guimauve

Hors ligne

#2 Le 23/09/2010, à 05:26

Gemnoc

Re : Logiciel XFLR5 - Analyse aérodynamique

Bonjour Guillaume,

Très intéressant. Personnellement, je n'ai pas les connaissances pour le tester. Si tu as le temps de tester davantage le logiciel, crois-tu que tu pourrais créer une page dédiée dans la documentation sous XFLR5 ? wink

Par ailleurs, puisque le forum Ubuntu-fr est un forum d'utilisateurs, je ne crois pas que ta suggestion de l'ajouter dans la Logithèque soit lue par les gens concernés (ceux qui gèrent la distribution Ubuntu). Il faudrait qu'un mainteneur chez Canonical accepte de créer le paquet pour Ubuntu. Je ne sais pas trop où tu pourrais faire suivre cette suggestion...

P.S. La page SourceForge a un paquet deb 64 bits, mais de la version 5.00 de mai dernier plutôt que la v6.00 bêta sortie cette semaine.


Pensez à consulter la documentation ! :-)

Hors ligne

#3 Le 23/09/2010, à 21:15

Guimauve

Re : Logiciel XFLR5 - Analyse aérodynamique

Gemnoc a écrit :

Bonjour Guillaume,

Très intéressant. Personnellement, je n'ai pas les connaissances pour le tester. Si tu as le temps de tester davantage le logiciel, crois-tu que tu pourrais créer une page dédiée dans la documentation sous XFLR5 ? wink

Par ailleurs, puisque le forum Ubuntu-fr est un forum d'utilisateurs, je ne crois pas que ta suggestion de l'ajouter dans la Logithèque soit lue par les gens concernés (ceux qui gèrent la distribution Ubuntu). Il faudrait qu'un mainteneur chez Canonical accepte de créer le paquet pour Ubuntu. Je ne sais pas trop où tu pourrais faire suivre cette suggestion...

P.S. La page SourceForge a un paquet deb 64 bits, mais de la version 5.00 de mai dernier plutôt que la v6.00 bêta sortie cette semaine.

Je vais essayer de trouver du temps pour créer une page dédiée pour XFLR5 mais cet automne je fais mon dernier trimestre universitaire à temps plein et je n'ai pas beaucoup de temps libre pour le faire.

Peut-être pas avant janvier prochain.

Pour la version, moi j'ai bel et bien la version 6 bêta d'installée.

A+
Guimauve

Dernière modification par Guimauve (Le 23/09/2010, à 21:17)

Hors ligne

#4 Le 23/09/2010, à 23:38

Gemnoc

Re : Logiciel XFLR5 - Analyse aérodynamique

Pas de problème.

En attendant, j'ai listé l'application dans le portail Conception mécanique, mais elle aurait peut-être plus sa place dans calcul_numerique.


Pensez à consulter la documentation ! :-)

Hors ligne

#5 Le 24/09/2010, à 02:16

Guimauve

Re : Logiciel XFLR5 - Analyse aérodynamique

Gemnoc a écrit :

Pas de problème.

En attendant, j'ai listé l'application dans le portail Conception mécanique, mais elle aurait peut-être plus sa place dans calcul_numerique.

En fait, il serait plus approprié de la classer dans la section "Mécanique des fluides" puisque le logiciel en question simule l'écoulement de l'air autour des profils des ailes d'avions. Même si l'air est un gaz, son comportement dans un écoulement est typique d'un fluide. Il s'agit d'un écoulement externe.

A+
Guimauve

Hors ligne

#6 Le 24/09/2010, à 02:56

Gemnoc

Re : Logiciel XFLR5 - Analyse aérodynamique

D'accord, je fais le changement, merci pour la précision !


Pensez à consulter la documentation ! :-)

Hors ligne

#7 Le 14/11/2010, à 18:20

flodenhaut

Re : Logiciel XFLR5 - Analyse aérodynamique

bonjour,
J'ai essayé la même conversion .rpm -> .deb mais je n'ai pas réussi. Alien me renvoit l'erreur : error: incorrect format: unknown tag
Es ce que vous avez encore le .deb de XFLR5?
Merci

Hors ligne

#8 Le 14/11/2010, à 20:09

Gemnoc

Re : Logiciel XFLR5 - Analyse aérodynamique

Bonjour,

Le site propose un paquet .deb, mais pour architecture 64 bits.

https://sourceforge.net/projects/xflr5/files/

Si votre version d'Ubuntu est 32 bits, vous pourriez peut-être essayer la compilation, si la procédure ne vous fait pas peur...

Dernière modification par Gemnoc (Le 14/11/2010, à 20:10)


Pensez à consulter la documentation ! :-)

Hors ligne

#9 Le 14/11/2010, à 20:43

flodenhaut

Re : Logiciel XFLR5 - Analyse aérodynamique

Merci pour votre réponse rapide
En effet je suis sur 32 bits. j'arrive a faire lancer la version windows avec wine mais c'est dommage.
La compilation serait en effet la meilleur solution...

Hors ligne

#10 Le 14/11/2010, à 21:15

Gemnoc

Re : Logiciel XFLR5 - Analyse aérodynamique

Bonjour,

Je viens de tester la compilation. C'est somme toute assez simple (plus simple qu'en général).

Téléchargez l'archive xflr5_6.01-1.tar.gz du lien de mon message précédent. Ensuite, décompressez-la dans votre dossier personnel (clic droit > Extraire ici). Si votre nom d'usager est flodenhaut, donc sous /home/flodenhaut/ vous obtiendrez un dossier xflr5-6.01.

Ouvrez un terminal (menu Applications > Accessoires > Terminal), puis déplacez-vous dans le dossier xflr5-6.01 :

cd xflr5-6.01/

Petit truc : ne tapez que "cd x", puis la touche tabulation, le reste du nom sera complété.

Ensuite, vous copiez et collez cette commande, suivi de la touche Entrée :

dpkg-buildpackage -rfakeroot

Et vous attendez quelques minutes. Du texte défilera dans le terminal, quelques erreurs apparaitront, mais rien de grave.

Une fois la compilation terminée, quatre fichiers auront été générés dans votre dossier personnel : xflr5_6.01-1.dsc, xflr5_6.01-1.tar.gz, xflr5_6.01-1_i386.changes et xflr5_6.01-1_i386.deb. Il ne vous restera plus qu'à installer l'application à partir du fichier .deb généré (simplement en double-cliquant dessus, puis en cliquant sur «Installer le paquet».

Voilà, Xflr5 est installé, vous pouvez le lancer depuis le menu Applications > Graphisme > XFLR5.

À noter que sous Ubuntu 10.04 Lucid (donc peut-être sous 10.10 Maverick aussi), les sous-menus semblent invisibles avec le thème par défaut Ambiance ; c'est que le texte est noir sur fond noir. Il suffit de changer le thème.

Autre pépin : quand je sélectionne le menu File > Language... , j'obtiens cette erreur :

The directory /usr/share/xflr5/translations does not exist

C'est manifestement que les instructions du fichier de compilation sont incomplètes, parce que dans le dossier source téléchargé, il y a bien un dossier translations sous /xflr5-6.01, et ce dernier contient des fichiers de traduction, dont un pour le français. Il suffirait à mon avis de copier ce répertoire dans /usr/share/xflr5, avec les droits administrateur.

Dernière modification par Gemnoc (Le 14/11/2010, à 21:29)


Pensez à consulter la documentation ! :-)

Hors ligne

#11 Le 14/11/2010, à 21:28

Gemnoc

Re : Logiciel XFLR5 - Analyse aérodynamique

Je viens de tester la copie du répertoire translations et de son contenu : ça fonctionne.

La commande est la suivante, en prenant pour acquis que le dossier source est dans votre dossier personnel :

sudo cp -R ~/xflr5-6.01/translations/ /usr/share/xflr5/translations

Voilà, vous pouvez ensuite, si vous le désirez, faire le ménage dans votre dossier personnel, en ne conservant que le fichier .deb pour réinstallation future (et le dossier translations, au cas où).

En espérant que ça vous soit utile...


Pensez à consulter la documentation ! :-)

Hors ligne

#12 Le 14/11/2010, à 22:57

flodenhaut

Re : Logiciel XFLR5 - Analyse aérodynamique

Effectivement, d'après le Readme ça devrait être simple sous Ubuntu, mais j'ai un problème de dépendances qt4 sur ma machine.
la commande me donne :

dépendances de construction non trouvées : libqt4-opengl (>= 4:4.6.0) libqtcore4 (>= 4:4.6.0) libqtgui4 (>= 4:4.6.0)

Alors que j'ai les paquets bien installés avec des version supérieurs à celles demandées (si je comprends bien)


J'ai appliqué la méthode normalement destinée aux autres distributions que Debian/Ubuntu, sans faire l'étape 1:

        - To compile manually on any Linux distro, please follow the following steps:

        1. Get the libqt4-devel (OpenSuse) or qt-devel (Fedora), make, gcc-c++, and Mesa-devel packages

        2. cd into the xflr5-5.xx directory 

        3. type 

               - qmake

               - make

               - sudo make install 

-> ça a l'air de marcher!

Hors ligne

#13 Le 07/11/2013, à 17:52

maximelflu

Re : Logiciel XFLR5 - Analyse aérodynamique

Bonjour,
Je recherche à installer ce logiciel pour mes études, mais pas moyen de mettre la main sur un fichier installable dans ubuntu (ou alors je ne sais pas comment faire). Je suis allé sur le lien plus haut (http://sourceforge.net/projects/xflr5/files/) mais il n'y a que des versions Windows ou Mac.

Si quelqu'un a une idée sur un moyen d'installer ce logiciel, je suis preneur...
Merci smile
Maxime

Hors ligne

#14 Le 07/11/2013, à 18:19

lann

Re : Logiciel XFLR5 - Analyse aérodynamique

Je pense qu'il faut le compiler et donc récupérer les sources :

svn checkout svn://svn.code.sf.net/p/xflr5/code/trunk xflr5-code

ou par le lien "Download Snapshot" dans l'onglet code

Le .deb est dans Debian SID : http://packages.debian.org/unstable/science/xflr5

Dernière modification par lann (Le 07/11/2013, à 18:21)

Hors ligne

#15 Le 13/11/2013, à 17:36

maximelflu

Re : Logiciel XFLR5 - Analyse aérodynamique

Super, ça marche. Merci smile
Je vais pouvoir bien bosser maintenant smile

Hors ligne

Haut de page ↑