Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/10/2010, à 17:21

elmehd_10

[Résolu] Usb Wireless 54m Tp-link Tl-wn422g

bonjour
j'ai un clé wifi TP-LINK TL-WN422G mais elle marche pas dans ubuntu 9.10 j'ai cherché mais j'ai rien trouvé aidé moi svp
et merci

Dernière modification par elmehd_10 (Le 05/11/2010, à 23:54)

Hors ligne

#2 Le 10/10/2010, à 00:38

Climenole

Re : [Résolu] Usb Wireless 54m Tp-link Tl-wn422g

Salut elmehd  smile

Essaye d'utiliser les pilotes Windows de cette clé Usb avec l'application NDisWrapper

NDISWrapper Documentation Ubuntu-Fr

L'application te permet d'utiliser le fichier .inf du pilote.
Récupère celui-ci et copie-le dans un dossier Linux puis lance Ndiswrapper pour l'utiliser.
Pour installer Ndsiwrapper: Système -> Administration -> Gestionnaire de paquets Synaptic ...

Pour obtenir ces pilotes depuis le site du fabricant si tu ne les a pas déjà: TL-WN422G Drivers

Dis-nous si cela a résolu le problème. A+  smile


Claude LaFrenière  :-)
Profil & Contact: http://www.google.com/profiles/climenole

Hors ligne

#3 Le 10/10/2010, à 00:48

elmehd_10

Re : [Résolu] Usb Wireless 54m Tp-link Tl-wn422g

j'ai deja esséyé avec NDisWrapper et ndisgtk mais ça marche pas

Hors ligne

#4 Le 10/10/2010, à 00:50

elmehd_10

Re : [Résolu] Usb Wireless 54m Tp-link Tl-wn422g

et voila ce que j'ai dans ces commandes
cat /etc/lsb-release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"

lsusb

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0cf3:1006 Atheros Communications, Inc. 
Bus 001 Device 003: ID 1871:0d01 Aveo Technology Corp. 
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

lspci

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0cf3:1006 Atheros Communications, Inc. 
Bus 001 Device 003: ID 1871:0d01 Aveo Technology Corp. 
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@ubuntu:/home/ubuntu# lspci
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 12)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 12)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 12)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 12)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 12)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 12)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 12)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)
02:0a.0 Communication controller: Conexant Systems, Inc. HSF 56k HSFi Modem (rev 01)
02:0b.0 Ethernet controller: VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rev 86

lspci -nn | grep -i net

02:0b.0 Ethernet controller [0200]: VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] [1106:3106] (rev 86)

sudo lshw -C network

  *-network               
       description: Ethernet interface
       product: VT6105/VT6106S [Rhine-III]
       vendor: VIA Technologies, Inc.
       physical id: b
       bus info: pci@0000:02:0b.0
       logical name: eth0
       version: 86
       serial: 00:05:5d:82:64:64
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=via-rhine driverversion=1.4.3 duplex=half latency=32 link=no maxlatency=8 mingnt=3 multicast=yes port=MII speed=10MB/s
       resources: irq:11 ioport:c400(size=256) memory:ef010000-ef0100ff memory:38000000-3800ffff(prefetchable)

lsmod

Module                  Size  Used by
binfmt_misc             8356  1 
lp                      8964  0 
snd_intel8x0           30168  2 
snd_ac97_codec        101216  1 snd_intel8x0
ac97_bus                1532  1 snd_ac97_codec
snd_pcm_oss            37920  0 
snd_mixer_oss          16028  1 snd_pcm_oss
snd_pcm                75296  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy           2656  0 
snd_seq_oss            28576  0 
snd_seq_midi            6432  0 
snd_rawmidi            22208  1 snd_seq_midi
iptable_filter          3100  0 
snd_seq_midi_event      6940  2 snd_seq_oss,snd_seq_midi
ip_tables              11692  1 iptable_filter
snd_seq                50224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
x_tables               16544  1 ip_tables
snd_timer              22276  2 snd_pcm,snd_seq
snd_seq_device          6920  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
dm_crypt               12928  0 
snd                    59204  14 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ppdev                   6688  0 
uvcvideo               59080  0 
parport_pc             31940  1 
videodev               36736  1 uvcvideo
soundcore               7264  1 snd
ns558                   5404  0 
parport                35340  3 lp,ppdev,parport_pc
v4l1_compat            14496  2 uvcvideo,videodev
shpchp                 32272  0 
snd_page_alloc          9156  2 snd_intel8x0,snd_pcm
psmouse                56180  0 
gameport               11368  2 ns558
serio_raw               5280  0 
squashfs               22912  1 
aufs                  149420  1 
nls_cp437               5372  1 
isofs                  31620  1 
dm_raid45              84228  0 
xor                    15620  1 dm_raid45
via_rhine              22212  0 
mii                     5212  1 via_rhine
floppy                 54916  0 
intel_agp              27484  1 
agpgart                34988  1 intel_agp

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

ifconfig

eth0      Link encap:Ethernet  HWaddr 00:05:5d:82:64:64  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:11 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:4 erreurs:0 :0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:240 (240.0 B) Octets transmis:240 (240.0 B)

sudo iwlist scan

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

uname -r -m

2.6.31-14-generic i686

cat  /etc/network/interfaces

auto lo
iface lo inet loopback

nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            via-rhine
  State:             unavailable
  Default:           no
  HW Address:        00:05:5D:82:64:64

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off

Hors ligne

#5 Le 10/10/2010, à 01:21

Climenole

Re : [Résolu] Usb Wireless 54m Tp-link Tl-wn422g

Salut elmehd_10  smile

Voici peut-être une solution que j'ai trouvé sur le forum Ubuntu en anglais...

moviemaniac a écrit :

Re: TP-link TL-WN422G Problem
Okay, here's one thing to try:
Download this file to cour Desktop: http://git.kernel.org/?p=linux/kernel/g … b7;hb=HEAD

then open up a terminal and enter these commands one after the other (you will be asked for your password on the last step)

cd Desktop
sudo mv ar9271.fw /lib/firmware

reboot and see whether it works. Be sure to unplug your device and plug it in again after rebooting.

If it doesn't, follow these steps:

Download this file to your desktop: http://wireless.kernel.org/download/com … .6.tar.bz2
Then open a terminal and enter these commands one after the other (you will be asked for your password on the last step):
cd Desktop
tar xjvf compat-wireless-2.6.tar.bz2
cd compat-wireless-2.6
./scripts/driver-select ath9k_htc
make && sudo make install

after that reboot.

Ref.:
http://ubuntuforums.org/showthread.php?t=1473867
et
http://ubuntuforums.org/showthread.php?t=1473867&page=2

Voir les échanges entre disPlay et moviemaniac...

Ceci étant dit cela pourrait-il résoudre le problème ou pas? Vu que je ne l'ai pas essayé et que tu pourrais le faire à tes risque et périls préfères-tu attendre un autre avis (ce serait plus prudent je crois...) Mais au moins, selon disPlay la solution proposée par moviemaniac (le 2 ième lien en fait) est valable... (Au moins une solution a été utilisée avec succès au moins une fois....)

Si tu a besoin de la traduction en français fait le savoir. A+  smile

Dernière modification par Climenole (Le 10/10/2010, à 01:24)


Claude LaFrenière  :-)
Profil & Contact: http://www.google.com/profiles/climenole

Hors ligne

#6 Le 10/10/2010, à 16:39

elmehd_10

Re : [Résolu] Usb Wireless 54m Tp-link Tl-wn422g

j'ai trouvé la solution j'ai essayé le cd live de la dernier version d'ubuntu 10.10 et elle marche bien directement mais je l essayé dans un autre ordinateur puisque quand je lance le cd live dans mon pc a la fin du chargement il y a un écran noir avec des traits blanc même si je lance l'installation alors voila un nouveau problème et merci pour ton aide

Dernière modification par elmehd_10 (Le 10/10/2010, à 16:42)

Hors ligne

#7 Le 21/10/2010, à 01:20

Climenole

Re : [Résolu] Usb Wireless 54m Tp-link Tl-wn422g

Salut  elmehd_10  smile

Tu as trouvé: bravo!  n'oublie pas de mentionner [Résolu] dans le titre du fil de discussion...

smile


Claude LaFrenière  :-)
Profil & Contact: http://www.google.com/profiles/climenole

Hors ligne

Haut de page ↑