Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/10/2010, à 19:16

Chewbacca

Maverick et Compiz, Bug du Plugin Wallpaper

Bonjour !

Depuis la mise à jour a Maverick (RC) j'ai un bug avec compiz-fusion. J'utilise le plugin wallpaper pour afficher un wallpaper différent par bureau (en ayant désactivé la gestion du bureau dans nautilus). Or, depuis la dite mise à jour, j'ai un souci, les wallpapers ne s'affichent pas, et les fenêtres laissent une trainée qui ne disparait pas lors de leurs déplacements. Idem pour le panel. la seule solution pour revenir à la normale est de switcher sur un tty (Ctrl + Alt + F1 par exemple), et ensuite de revenir à l'affichage graphique (Ctrl + Alt + F7).  L'un d'entre vous a-t-il une solution pour éviter à avoir à switcher a chaque démarrage?

Merci d'avance wink

Config : Chipset intel GME 945, drivers à jour, Xorg également, Ubuntu Maverick RC GNOME

Dernière modification par Chewbacca (Le 08/10/2010, à 19:18)


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#2 Le 09/10/2010, à 06:47

benuch

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Même problème,

par contre il a été déposé sur launchpad. Apparemment un problème de x11. Plus qu'à attendre une mise à jour...

Merci pour la petite astuce.


Ubuntu+gnome2 sans panel et awn (maison) et Ubuntu+xmonad (travail)
Migration sous ubuntu à edgy eft 6.10, depuis W... est retourné aux cieux...

Hors ligne

#3 Le 12/10/2010, à 11:00

Yilduz

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Merci beaucoup pour l'astuce Ctrl Alt F1 / Ctrl Alt F7

J'ai tenté l'installation de wallpapoz, un gestionnaire de fonds d'écran, mais il y a un gros lag entre le moment où on change de bureau et le moment où le fond d'écran associé s'affiche. Donc je reviens vers wallpaper, avec la précieuse manip à base de Crtl Alt, et je vais aussi attendre patiemment une mise à jour smile

Hors ligne

#4 Le 12/10/2010, à 12:53

Raiduk

Re : Maverick et Compiz, Bug du Plugin Wallpaper

j'ai le même problème depuis le passage à la version 10.10

je conseil fortement de désactiver totalement la gestion des wall via compiz la meilleur solution étant de rendre à nautilus la gestion des walls en attendent un correctif

pensez à bien désactiver la gestion des wall de compiz en premier

tapez sa dans une console

gconf-editor

cherchez "aps/nautilus/preferences et dans cet onglet la ligne "show_desktop" et cochez la case correspondante.
sinon on peut enlever les effet de bureau et les réactiver sa enlève le problème mais au moins vous récupérez les icônes avec l'autre solution.

après on peut activer wallpapoz mais le beug du lag est connus depuis des années

Dernière modification par Raiduk (Le 12/10/2010, à 13:02)

Hors ligne

#5 Le 15/10/2010, à 01:01

Chewbacca

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Raiduk a écrit :

j'ai le même problème depuis le passage à la version 10.10

je conseil fortement de désactiver totalement la gestion des wall via compiz la meilleur solution étant de rendre à nautilus la gestion des walls en attendent un correctif

pensez à bien désactiver la gestion des wall de compiz en premier

tapez sa dans une console

gconf-editor

cherchez "aps/nautilus/preferences et dans cet onglet la ligne "show_desktop" et cochez la case correspondante.
sinon on peut enlever les effet de bureau et les réactiver sa enlève le problème mais au moins vous récupérez les icônes avec l'autre solution.

après on peut activer wallpapoz mais le beug du lag est connus depuis des années

Autre solution (que j'ai adoptée), retourner sur Lucid big_smile


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#6 Le 15/10/2010, à 23:20

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Salut,

même problème chez moi.
Nvidia 8400 GS Maverick 64 bits.
J'ai pas encore trop exploré (je reboot pas souvent), par contre, il y a peut-être moyen de démarrer compiz avec un retard. Faut voir s'il apparait dans les applis au démarrage ou s'il est démarré tout seul (ex: chez moi j'avais modifié la clé /desktop/gnome/applications/window_manager/default = /usr/bin/compiz, mais est-ce le cas chez vous et est-ce toujours utile ?)
Sinon essayer de recharger avec fusion-icon (pas réinstallé depuis Lucid) ou tester:

compiz --replace

Par contre je viens de voir dans les applis au démarrage que j'ai gsettings-data-convert. Peut-être il y a -t-il un lien, j'hésite à le désactiver
Après je reboot pas souvent donc ça me gène pas trop non plus mais hors de question que ce soit Nautilus qui gère mes walls et encore moins retourner sous Lucid (moi qui avait fait install neuve du lynx pour repartir sur une bonne base, j'ai ça et une merde avec le switch user qui me rappel gutsy  roll... )

Hors ligne

#7 Le 15/10/2010, à 23:30

Chewbacca

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Déja testé avec un compiz qui démarre en retard, ne fonctionne pas, même si je le démarre a la mano. Ai pas testé de désactiver le gsettings-data-convert.

Seule solution trouvée à ce jour, le switch tty->X


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#8 Le 15/10/2010, à 23:43

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Peut-être cocher /apps/gdm/simple-greeter/wm_use_compiz
Comme je ne sais pas trop l' incidence que ça pourrait avoir sur multi-user dont un avec, l'autre sans compiz, je laisse décoché pour le moment.

Hors ligne

#9 Le 16/10/2010, à 01:32

Chewbacca

Re : Maverick et Compiz, Bug du Plugin Wallpaper

A voir, si un user de maverick peut tester, je peux pas perso, je suis retourné sous lucid


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#10 Le 16/10/2010, à 01:51

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

je l'ai coché, je verrais bien au prochain reboot (quand ????)

Hors ligne

#11 Le 16/10/2010, à 02:50

Chewbacca

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Ok, tiens nous au courant wink


Portable : Core i5 Haswell 1600 - 2500Mhz, Intel HD 4600 + Nvidia GT 740M (optimus de m****), 6 Go DDR3 - Kubuntu 13.04 KDE 4.13
Media Center : Raspberry Pi - Openelec 4
DataServeur @Home : Raspberry Pi - Raspbian

Hors ligne

#12 Le 16/10/2010, à 14:09

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Finalement j'ai rebooté (je suis en test du Multiboot de frafa) : pas mieux sad

Hors ligne

#13 Le 17/10/2010, à 11:19

blackychan

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Salut a tous,
j'ai moi aussi le même bug depuis le passage à la 10.10.
La solution de Chewbacca marche bien chez moi, par-contre si il y avait moyen de l'automatiser ce serait pas plus mal en attendant le correctif (eh ben oui je suis un peu fénéant...lol)


dual boot ubuntu 10.10/ XP sp2 - carte mere gigabyte GA-K8NF-9 - proc AMD atlhon (64) 3000+ - carte video Nvidia GeForce 7800 GTX - 1 Go RAM

Hors ligne

#14 Le 17/10/2010, à 13:19

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Il y a peut-être moyen d'appeler un tty via getty ?
Par contre peut-être rien à voir mais

ps aux | grep getty

me montre que le tty1 est chargé en dernier, chez vous aussi? je viens de désactiver les autres, je verrais bien au prochain redémarrage.

Hors ligne

#15 Le 04/11/2010, à 11:37

lorped

Re : Maverick et Compiz, Bug du Plugin Wallpaper

I'm sorry for the english.
You may take a look at this self-made patch for this bug
https://bugs.launchpad.net/ubuntu/+sour … omments/14

Hors ligne

#16 Le 04/11/2010, à 13:45

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

J'ai redémarré hier: pas mieux avec moins de tty.

@lorped: sorry for my poor english but thanks for the patch, may be i'll try this later but recompile only for that...
(désolé pour mon anglais pourri mais merci pour le patch, j'essai peut-être de tester plus tard mais recompiler juste pour ça...)

Hors ligne

#17 Le 05/11/2010, à 09:44

lorped

Re : Maverick et Compiz, Bug du Plugin Wallpaper

fabux a écrit :

but recompile only for that...

lazy linuxer  big_smile

http://www.mediafire.com/?usji79x5yiu5d3z  ( wallpaper plugin - 64bit module - File Size: 96.69KB )

Hors ligne

#18 Le 19/12/2010, à 09:55

Raiduk

Re : Maverick et Compiz, Bug du Plugin Wallpaper

quelqu'un pourrait expliquer comment utiliser le patch ? j'y suis pas arrivé T_T 

HOP HOP edit : c'est bon j'y suis arrivé il fonctionne parfaitement.

Dernière modification par Raiduk (Le 19/12/2010, à 10:16)

Hors ligne

#19 Le 19/12/2010, à 11:27

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

J'avais oublié tiens roll
Du coup pas encore testé les fichiers de lorped. Je verrais au prochain reboot.
Normalement on décompresse le dossier et remplaces les fichiers.
Faire une save avant du dossier qui sera modifié et en admettant que l'archive téléchargée soit dans le dossier Téléchargements

#save
sudo cp -R /usr/lib/compiz/ /usr/lib/compiz.old/
#on se place dans le dossier de téléchargements
cd ~/Téléchargements
#décompression de l'archive
tar -xjvf wallpaper.tar.bz2
#remplacement des fichiers lié au plugin wallpaper
sudo cp ~/Téléchargements/usr/lib/compiz/* /usr/lib/compiz

et on relances ta machine.

Dernière modification par fabux (Le 19/12/2010, à 11:32)

Hors ligne

#20 Le 20/12/2010, à 21:20

nilux17

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Ca fait 15 jours que je bagarre avec ce truc !!!
du coup, j'était passez avec wallpapoz,
le coup d'aller sur tty1 et de revenir fonctionne tout pareil... ouf ça marche à peu près...

Hors ligne

#21 Le 21/12/2010, à 10:30

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Je n'ai pas encore rebooté pour tester le patch de lorped, mais chez moi passer par un tty et revenir marche bien chez moi.

Hors ligne

#22 Le 25/12/2010, à 15:04

Raiduk

Re : Maverick et Compiz, Bug du Plugin Wallpaper

moi j'ai tester le patch j'ai fait une sauvegarde de l'original puis j'ai ouvert en mode admin le dossier ou est l'original un bon copier coller, un reboot et c'était comme neuf !

Hors ligne

#23 Le 27/12/2010, à 18:38

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Impeccable chez moi aussi smile
Merci  à lorped pour avoir mâché le taf wink

ps: dans la doc il est indiqué un bug mais s'agit-il de celui-ci ? il est également question de launchpad mais point de lien vers celui-ci.
J'y mets le lien vers ce thread et j'en informe la liste wiki.

Hors ligne

#24 Le 27/12/2010, à 22:19

Raiduk

Re : Maverick et Compiz, Bug du Plugin Wallpaper

arf oui il s'agit de celui de ce tread c'est moi qui ai rajouté cette petite partie sur le wiki c'est bien le même beug je vais rajouter le lien vers le lunchpad comme demander par le mail d'un admin >_<

et expliquer rapidement comment l'appliquer

Dernière modification par Raiduk (Le 27/12/2010, à 22:23)

Hors ligne

#25 Le 28/12/2010, à 10:27

fabux

Re : Maverick et Compiz, Bug du Plugin Wallpaper

Merci pour le complément d'info.
J'ai reformulé un peu la note dans la doc et j'en informe la liste pour relecture.
A+

Hors ligne

Haut de page ↑